]> git.pld-linux.org Git - packages/mate-desktop.git/blob - mate-desktop.spec
drop unsupported locale jv
[packages/mate-desktop.git] / mate-desktop.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     gtk3            # use GTK+ 3.x instead of GTK+ 2.x
5
6 Summary:        Shared code for mate-panel, mate-session, mate-file-manager, etc.
7 Summary(pl.UTF-8):      Kod współdzielony przez pakiety mate-panel, mate-session, mate-file-manager itd.
8 Name:           mate-desktop
9 Version:        1.12.1
10 Release:        2
11 License:        LGPL v2+ with MIT parts (library), GPL v2+ (mate-about)
12 Group:          X11/Applications
13 Source0:        http://pub.mate-desktop.org/releases/1.12/%{name}-%{version}.tar.xz
14 # Source0-md5:  f5e1fb4f0b59b3d09b00a90cb07bc281
15 URL:            http://wiki.mate-desktop.org/mate-desktop
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  dconf-devel >= 0.13.4
19 BuildRequires:  desktop-file-utils
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
22 BuildRequires:  gettext-tools
23 BuildRequires:  glib2-devel >= 1:2.36.0
24 BuildRequires:  gobject-introspection-devel >= 0.9.7
25 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.24.0}
26 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
27 BuildRequires:  gtk-doc >= 1.4
28 BuildRequires:  intltool >= 0.50.1
29 BuildRequires:  libtool
30 %{!?with_gtk3:BuildRequires:    libunique-devel >= 1.0}
31 %{?with_gtk3:BuildRequires:     libunique3-devel >= 3.0}
32 BuildRequires:  mate-common
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpmbuild(find_lang) >= 1.36
35 BuildRequires:  startup-notification-devel >= 0.5
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xorg-lib-libX11-devel
38 BuildRequires:  xorg-lib-libXrandr-devel >= 1.3
39 BuildRequires:  xz
40 BuildRequires:  yelp-tools
41 Requires(post,postun):  gtk-update-icon-cache
42 Requires(post,postun):  hicolor-icon-theme
43 Requires:       %{name}-libs = %{version}-%{release}
44 # for identifying monitors from pnp.ids (libmate-desktop/display-name.c)
45 Requires:       hwdata >= 0.243-6
46 Requires:       xdg-user-dirs-gtk >= 0.10-2
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 The mate-desktop package contains an internal library (libmatedesktop)
51 used to implement some portions of the MATE desktop, and also some
52 data files and other shared components of the MATE user environment.
53
54 %description -l pl.UTF-8
55 Pakiet mate-desktop zawiera bibliotekę wewnętrzną (libmatedesktop)
56 służącą do implementacji niektórych elementów środowiska MATE, trochę
57 plików z danymi oraz inne współdzielone komponenty środowiska
58 użytkownika MATE.
59
60 %package libs
61 Summary:        Shared libmate-desktop library
62 Summary(pl.UTF-8):      Biblioteka współdzielona libmate-desktop
63 License:        LGPL v2+
64 Group:          Libraries
65 Requires:       dconf >= 0.13.4
66 Requires:       gdk-pixbuf2 >= 2.4.0
67 Requires:       glib2 >= 1:2.36.0
68 %{!?with_gtk3:Requires: gtk+2 >= 2:2.24.0}
69 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
70 Requires:       startup-notification >= 0.5
71 Requires:       xorg-lib-libXrandr >= 1.3
72
73 %description libs
74 Shared libmate-desktop library.
75
76 %description libs -l pl.UTF-8
77 Biblioteka współdzielona libmate-desktop.
78
79 %package devel
80 Summary:        Header files for libmate-desktop
81 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmate-desktop
82 License:        LGPL v2+
83 Group:          Development/Libraries
84 Requires:       %{name}-libs = %{version}-%{release}
85 Requires:       dconf-devel >= 0.13.4
86 Requires:       gdk-pixbuf2-devel >= 2.4.0
87 Requires:       glib2-devel >= 1:2.36.0
88 %{!?with_gtk3:Requires: gtk+2-devel >= 2:2.24.0}
89 %{?with_gtk3:Requires:  gtk+3-devel >= 3.0.0}
90 Requires:       startup-notification-devel >= 0.5
91
92 %description devel
93 Header files for the MATE-internal private library libmate-desktop.
94
95 %description devel -l pl.UTF-8
96 Pliki nagłówkowe prywatnej biblioteki wewnętrznej MATE
97 libmate-desktop.
98
99 %package apidocs
100 Summary:        mate-desktop API documentation
101 Summary(pl.UTF-8):      Dokumentacja API mate-desktop
102 Group:          Documentation
103 Requires:       gtk-doc-common
104 %if "%{_rpmversion}" >= "5"
105 BuildArch:      noarch
106 %endif
107
108 %description apidocs
109 mate-desktop API documentation.
110
111 %description apidocs -l pl.UTF-8
112 Dokumentacja API mate-desktop.
113
114 %prep
115 %setup -q
116
117 %build
118 %{__gtkdocize}
119 %{__libtoolize}
120 %{__aclocal} -I m4
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         %{?with_apidocs:--enable-gtk-doc --with-html-dir=%{_gtkdocdir}} \
126         --disable-schemas-compile \
127         --disable-silent-rules \
128         --disable-static \
129         --enable-unique \
130         --enable-mpaste \
131         %{?with_gtk3:--with-gtk=3.0} \
132         --with-pnp-ids-path=/lib/hwdata/pnp.ids
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libmate-desktop-2.la
142
143 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
144 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/mate-desktop.convert
145
146 desktop-file-install \
147         --remove-category="MATE" \
148         --add-category="X-Mate" \
149         --delete-original \
150         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
151         $RPM_BUILD_ROOT%{_desktopdir}/mate-about.desktop
152
153 # jv,ku_IQ not supported yet by glibc, ur_PK is empty version of ur
154 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{jv,ku_IQ,ur_PK}
155
156 %find_lang %{name} --with-mate
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post
162 %glib_compile_schemas
163 %update_icon_cache hicolor
164
165 %postun
166 %glib_compile_schemas
167 %update_icon_cache hicolor
168
169 %post   libs -p /sbin/ldconfig
170 %postun libs -p /sbin/ldconfig
171
172 %files -f %{name}.lang
173 %defattr(644,root,root,755)
174 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
175 %attr(755,root,root) %{_bindir}/mate-about
176 %attr(755,root,root) %{_bindir}/mate-color-select
177 %attr(755,root,root) %{_bindir}/mpaste
178 %{_mandir}/man1/mate-about.1*
179 %{_mandir}/man1/mate-color-select.1*
180 %{_mandir}/man1/mpaste.1*
181 %{_desktopdir}/mate-about.desktop
182 %{_desktopdir}/mate-color-select.desktop
183 %{_iconsdir}/hicolor/*/apps/mate.png
184 %{_iconsdir}/hicolor/scalable/apps/mate-symbolic.svg
185 %{_datadir}/mate-about
186 %{_datadir}/glib-2.0/schemas/org.mate.*.gschema.xml
187
188 %files libs
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libmate-desktop-2.so.17
192 %{_libdir}/girepository-1.0/MateDesktop-2.0.typelib
193
194 %files devel
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_libdir}/libmate-desktop-2.so
197 %{_includedir}/mate-desktop-2.0
198 %{_datadir}/gir-1.0/MateDesktop-2.0.gir
199 %{_pkgconfigdir}/mate-desktop-2.0.pc
200
201 %if %{with apidocs}
202 %files apidocs
203 %defattr(644,root,root,755)
204 %{_gtkdocdir}/mate-desktop
205 %endif
This page took 0.088646 seconds and 3 git commands to generate.