]> git.pld-linux.org Git - packages/mapnik.git/blob - mapnik.spec
- release 2
[packages/mapnik.git] / mapnik.spec
1 #
2 Summary:        Toolkit for developing GIS (Geographic Information Systems) applications
3 Name:           mapnik
4 Version:        0.7.1
5 Release:        2
6 License:        LGPL v2.1
7 Group:          Applications
8 Source0:        http://download.berlios.de/mapnik/%{name}-%{version}.tar.bz2
9 # Source0-md5:  8f65fda2a792518d6f6be8a85f62fc73
10 Patch0:         %{name}-boost_lib_names.patch
11 URL:            http://mapnik.org/
12 BuildRequires:  boost-devel
13 BuildRequires:  boost-python-devel
14 BuildRequires:  cairomm-devel
15 BuildRequires:  curl-devel
16 BuildRequires:  freetype-devel
17 BuildRequires:  gdal-devel
18 BuildRequires:  libicu-devel
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libltdl-devel
21 BuildRequires:  libpng-devel
22 BuildRequires:  libtiff-devel
23 BuildRequires:  libxml2-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  postgresql-devel
26 BuildRequires:  proj-devel
27 BuildRequires:  python-devel
28 BuildRequires:  python-pycairo-devel
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  scons
31 BuildRequires:  sqlite3-devel
32 BuildRequires:  zlib-devel
33 Suggests:       fonts-TTF-DejaVu
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Mapnik is a Free Toolkit for developing mapping applications. It's
38 written in C++ and there are Python bindings to facilitate fast-paced
39 agile development. It can comfortably be used for both desktop and web
40 development, which was something I wanted from the beginning.
41
42 Mapnik is about making beautiful maps. It uses the AGG library and
43 offers world class anti-aliasing rendering with subpixel accuracy for
44 geographic data. It is written from scratch in modern C++ and doesn't
45 suffer from design decisions made a decade ago.
46
47 %package -n python-%{name}
48 Summary:        Python bindings for Mapnik
49 Group:          Libraries/Python
50 Requires:       %{name} = %{version}-%{release}
51
52 %description -n python-%{name}
53 Python binding for Mapnik, the toolkit for developing GIS (Geographic
54 Information Systems) applications.
55
56 %package devel
57 Summary:        Header files for Mapnik
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Mapnik
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Header files for Mapnik.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki Mapnik.
67
68 %package static
69 Summary:        Static Mapnik library
70 Summary(pl.UTF-8):      Statyczna biblioteka Mapnik
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static Mapnik library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka Mapnik.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 %scons \
86         PREFIX=%{_prefix} \
87         BOOST_TOOLKIT=gcc43 \
88         INPUT_PLUGINS='raster,sqlite,osm,gdal,kismet,shape,postgis,ogr' \
89         SYSTEM_FONTS=%{_datadir}/fonts/TTF
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %scons install \
95         PREFIX=%{_prefix} \
96         DESTDIR=$RPM_BUILD_ROOT \
97         SYSTEM_FONTS=%{_datadir}/fonts/TTF
98
99 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
100 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
101 %py_postclean
102
103 ## DejaVu fonts are available in a separate package
104 #rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/fonts
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS CHANGELOG INSTALL README
115 %attr(755,root,root) %{_bindir}/*
116 %attr(755,root,root) %{_libdir}/lib*.so.*.*
117 %dir %{_libdir}/%{name}
118 %dir %{_libdir}/%{name}/input
119 %attr(755,root,root) %{_libdir}/%{name}/input/*.input
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/lib*.so
124 %{_includedir}/*
125
126 %files -n python-%{name}
127 %defattr(644,root,root,755)
128 %dir %{py_sitedir}/%{name}
129 %{py_sitedir}/%{name}/*.py[co]
130 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
131 %dir %{py_sitedir}/%{name}/ogcserver
132 %{py_sitedir}/%{name}/ogcserver/*.py[co]
This page took 0.19566 seconds and 4 git commands to generate.