]> git.pld-linux.org Git - packages/mapnik.git/blob - mapnik.spec
- release 10 (by relup.sh)
[packages/mapnik.git] / mapnik.spec
1 #
2 Summary:        Toolkit for developing GIS (Geographic Information Systems) applications
3 Name:           mapnik
4 Version:        2.0.0
5 Release:        10
6 License:        LGPL v2.1
7 Group:          Applications
8 Source0:        http://download.berlios.de/mapnik/%{name}-%{version}.tar.bz2
9 # Source0-md5:  499c6a61544014b9bc2a7c978f963ef3
10 Patch0:         %{name}-boost_lib_names.patch
11 URL:            http://mapnik.org/
12 BuildRequires:  boost-devel
13 BuildRequires:  boost-python-devel
14 BuildRequires:  cairomm-devel
15 BuildRequires:  curl-devel
16 BuildRequires:  freetype-devel
17 BuildRequires:  gdal-devel
18 BuildRequires:  libicu-devel
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libltdl-devel
21 BuildRequires:  libpng-devel
22 BuildRequires:  libtiff-devel
23 BuildRequires:  libxml2-devel
24 BuildRequires:  pkgconfig
25 BuildRequires:  postgresql-devel
26 BuildRequires:  proj-devel
27 BuildRequires:  python-devel
28 BuildRequires:  python-pycairo-devel
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  scons
31 BuildRequires:  sqlite3-devel
32 BuildRequires:  zlib-devel
33 Suggests:       fonts-TTF-DejaVu
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Mapnik is a Free Toolkit for developing mapping applications. It's
38 written in C++ and there are Python bindings to facilitate fast-paced
39 agile development. It can comfortably be used for both desktop and web
40 development, which was something I wanted from the beginning.
41
42 Mapnik is about making beautiful maps. It uses the AGG library and
43 offers world class anti-aliasing rendering with subpixel accuracy for
44 geographic data. It is written from scratch in modern C++ and doesn't
45 suffer from design decisions made a decade ago.
46
47 %package -n python-%{name}
48 Summary:        Python bindings for Mapnik
49 Group:          Libraries/Python
50 Requires:       %{name} = %{version}-%{release}
51
52 %description -n python-%{name}
53 Python binding for Mapnik, the toolkit for developing GIS (Geographic
54 Information Systems) applications.
55
56 %package devel
57 Summary:        Header files for Mapnik
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Mapnik
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Header files for Mapnik.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki Mapnik.
67
68 %package static
69 Summary:        Static Mapnik library
70 Summary(pl.UTF-8):      Statyczna biblioteka Mapnik
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static Mapnik library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka Mapnik.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 %scons \
86         PREFIX=%{_prefix} \
87         BOOST_TOOLKIT=gcc43 \
88         INPUT_PLUGINS='raster,rasterlite,sqlite,osm,gdal,kismet,shape,postgis,ogr,geos,occi' \
89         SYSTEM_FONTS=%{_datadir}/fonts/TTF
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %scons install \
95         PREFIX=%{_prefix} \
96         DESTDIR=$RPM_BUILD_ROOT \
97         SYSTEM_FONTS=%{_datadir}/fonts/TTF
98
99 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
100 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
101 %py_postclean
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS CHANGELOG INSTALL README
112 %attr(755,root,root) %{_bindir}/mapnik-config
113 %attr(755,root,root) %{_bindir}/mapnik-speed-check
114 %attr(755,root,root) %{_bindir}/shapeindex
115 %attr(755,root,root) %{_bindir}/upgrade_map_xml.py
116 %attr(755,root,root) %{_libdir}/libmapnik2.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libmapnik2.so.2.0
118 %dir %{_libdir}/mapnik2
119 %dir %{_libdir}/mapnik2/input
120 %attr(755,root,root) %{_libdir}/mapnik2/input/gdal.input
121 %attr(755,root,root) %{_libdir}/mapnik2/input/geos.input
122 %attr(755,root,root) %{_libdir}/mapnik2/input/kismet.input
123 %attr(755,root,root) %{_libdir}/mapnik2/input/ogr.input
124 %attr(755,root,root) %{_libdir}/mapnik2/input/osm.input
125 %attr(755,root,root) %{_libdir}/mapnik2/input/postgis.input
126 %attr(755,root,root) %{_libdir}/mapnik2/input/raster.input
127 %attr(755,root,root) %{_libdir}/mapnik2/input/shape.input
128 %attr(755,root,root) %{_libdir}/mapnik2/input/sqlite.input
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libmapnik2.so
133 %{_includedir}/mapnik
134
135 %files -n python-%{name}
136 %defattr(644,root,root,755)
137 %dir %{py_sitedir}/mapnik2
138 %{py_sitedir}/mapnik2/*.py[co]
139 %attr(755,root,root) %{py_sitedir}/mapnik2/_mapnik2.so
140 %dir %{py_sitedir}/mapnik2/ogcserver
141 %{py_sitedir}/mapnik2/ogcserver/*.py[co]
This page took 0.0391 seconds and 4 git commands to generate.