]> git.pld-linux.org Git - packages/mapnik.git/blob - mapnik.spec
- system TTF fonts path passed
[packages/mapnik.git] / mapnik.spec
1 #
2 Summary:        Toolkit for developing GIS (Geographic Information Systems) applications.
3 Name:           mapnik
4 Version:        0.6.0
5 Release:        1
6 License:        LGPL v2.1
7 Group:          Applications
8 Source0:        http://download.berlios.de/mapnik/%{name}-%{version}.tar.bz2
9 # Source0-md5:  981271ac1cd1432314a963809c245fe1
10 Patch0:         %{name}-boost_lib_names.patch
11 URL:            http://prdownload.berlios.de/
12 BuildRequires:  boost-devel
13 BuildRequires:  boost-python-devel
14 BuildRequires:  cairomm-devel
15 BuildRequires:  curl-devel
16 BuildRequires:  freetype-devel
17 BuildRequires:  libicu-devel
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libpng-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  libxml2-devel
22 BuildRequires:  ogdi-devel
23 BuildRequires:  postgresql-devel
24 BuildRequires:  proj-devel
25 BuildRequires:  python-devel
26 BuildRequires:  python-pycairo-devel
27 BuildRequires:  scons
28 BuildRequires:  sqlite3-devel
29 BuildRequires:  zlib-devel
30 Suggests:       fonts-TTF-DejaVu
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Mapnik is a Free Toolkit for developing mapping applications. It's written in
35 C++ and there are Python bindings to facilitate fast-paced agile development.
36 It can comfortably be used for both desktop and web development, which was
37 something I wanted from the beginning.
38
39 Mapnik is about making beautiful maps. It uses the AGG library and offers world
40 class anti-aliasing rendering with subpixel accuracy for geographic data. It is
41 written from scratch in modern C++ and doesn't suffer from design decisions
42 made a decade ago.
43
44 %package -n python-%{name}
45 Summary:        Python bindings for Mapnik
46 Group:          Libraries/Python
47 Requires:       %{name} = %{version}-%{release}
48
49 %description -n python-%{name}
50 Python binding for Mapnik, the toolkit for developing GIS (Geographic
51 Information Systems) applications.
52
53 %package devel
54 Summary:        Header files for Mapnik
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Mapnik
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description devel
60 Header files for Mapnik.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe biblioteki Mapnik.
64
65 %package static
66 Summary:        Static ... library
67 Summary(pl.UTF-8):      Statyczna biblioteka ...
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static ... library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka ....
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 %build
82 %scons \
83         PREFIX=%{_prefix} \
84         BOOST_TOOLKIT=gcc43 \
85         SYSTEM_FONTS=/usr/share/fonts/TTF
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %scons install \
91         PREFIX=%{_prefix} \
92         DESTDIR=$RPM_BUILD_ROOT \
93         SYSTEM_FONTS=/usr/share/fonts/TTF
94
95 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
96 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
97 %py_postclean
98
99 ## DejaVu fonts are available in a separate package
100 #rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/fonts
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS CHANGELOG INSTALL README
111 %attr(755,root,root) %{_bindir}/*
112 %attr(755,root,root) %{_libdir}/lib*.so.*.*
113 %dir %{_libdir}/%{name}
114 %dir %{_libdir}/%{name}/input
115 %attr(755,root,root) %{_libdir}/%{name}/input/*.input
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/lib*.so
120 %{_includedir}/*
121
122 %files -n python-%{name}
123 %defattr(644,root,root,755)
124 %dir %{py_sitedir}/%{name}
125 %{py_sitedir}/%{name}/*.py[co]
126 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
127 %dir %{py_sitedir}/%{name}/ogcserver
128 %{py_sitedir}/%{name}/ogcserver/*.py[co]
This page took 0.069659 seconds and 4 git commands to generate.