]> git.pld-linux.org Git - packages/mapnik.git/blob - mapnik.spec
- new package
[packages/mapnik.git] / mapnik.spec
1 #
2 Summary:        Toolkit for developing GIS (Geographic Information Systems) applications.
3 Name:           mapnik
4 Version:        0.6.0
5 Release:        1
6 License:        LGPL v2.1
7 Group:          Applications
8 Source0:        http://download.berlios.de/mapnik/%{name}-%{version}.tar.bz2
9 # Source0-md5:  981271ac1cd1432314a963809c245fe1
10 Patch0:         %{name}-boost_lib_names.patch
11 URL:            http://prdownload.berlios.de/
12 BuildRequires:  boost-devel
13 BuildRequires:  boost-python-devel
14 BuildRequires:  cairomm-devel
15 BuildRequires:  curl-devel
16 BuildRequires:  freetype-devel
17 BuildRequires:  libicu-devel
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libpng-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  libxml2-devel
22 BuildRequires:  ogdi-devel
23 BuildRequires:  postgresql-devel
24 BuildRequires:  proj-devel
25 BuildRequires:  python-devel
26 BuildRequires:  python-pycairo-devel
27 BuildRequires:  scons
28 BuildRequires:  sqlite3-devel
29 BuildRequires:  zlib-devel
30 Requires:       %{name}-libs = %{name}-%{release}
31 Suggests:       fonts-TTF-DejaVu
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Mapnik is a Free Toolkit for developing mapping applications. It's written in
36 C++ and there are Python bindings to facilitate fast-paced agile development.
37 It can comfortably be used for both desktop and web development, which was
38 something I wanted from the beginning.
39
40 Mapnik is about making beautiful maps. It uses the AGG library and offers world
41 class anti-aliasing rendering with subpixel accuracy for geographic data. It is
42 written from scratch in modern C++ and doesn't suffer from design decisions
43 made a decade ago.
44
45 %package -n python-%{name}
46 Summary:        Python bindings for Mapnik
47 Group:          Libraries/Python
48 Requires:       %{name} = %{name}-%{release}
49
50 %description -n python-%{name}
51 Python binding for Mapnik, the toolkit for developing GIS (Geographic
52 Information Systems) applications.
53
54 %package devel
55 Summary:        Header files for Mapnik
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Mapnik
57 Group:          Development/Libraries
58 Requires:       %{name} = %{name}-%{release}
59
60 %description devel
61 Header files for Mapnik.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki Mapnik.
65
66 %package static
67 Summary:        Static ... library
68 Summary(pl.UTF-8):      Statyczna biblioteka ...
69 Group:          Development/Libraries
70 Requires:       %{name}-devel = %{version}-%{release}
71
72 %description static
73 Static ... library.
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka ....
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 %build
83 %scons \
84         PREFIX=%{_prefix} \
85         BOOST_TOOLKIT=gcc43
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %scons install \
91         PREFIX=%{_prefix} \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
95 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
96 %py_postclean
97
98 # DejaVu fonts are available in a separate package
99 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/fonts
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc AUTHORS CHANGELOG INSTALL README
110 %attr(755,root,root) %{_bindir}/*
111 %attr(755,root,root) %{_libdir}/lib*.so.*.*
112 %dir %{_libdir}/%{name}
113 %dir %{_libdir}/%{name}/input
114 %attr(755,root,root) %{_libdir}/%{name}/input/*.input
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/lib*.so
119 %{_includedir}/*
120
121 %files -n python-%{name}
122 %defattr(644,root,root,755)
123 %dir %{py_sitedir}/%{name}
124 %{py_sitedir}/%{name}/*.py[co]
125 %attr(755,root,root) %{py_sitedir}/%{name}/*.so
126 %dir %{py_sitedir}/%{name}/ogcserver
127 %{py_sitedir}/%{name}/ogcserver/*.py[co]
This page took 0.055012 seconds and 4 git commands to generate.