]> git.pld-linux.org Git - packages/mana.git/blob - mana.spec
909c510abf3e68088931ea449689af376e7fd6dd
[packages/mana.git] / mana.spec
1 #
2 # TODO:
3 #       - subpackage for uim stuff?
4 #
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # don't require dictionary for package build
8 #
9 Summary:        A kana(romaji)-kanji conversion engine using ChaSen algorithm
10 #Summary(pl.UTF-8):     -
11 Name:           mana
12 Version:        0.2.1
13 Release:        4
14 License:        GPL v2
15 Group:          Applications
16 Source0:        http://dl.sourceforge.jp/shinji/20514/%{name}-%{version}.tar.bz2
17 # Source0-md5:  3a173e9c6047ed18ae8080cfcd38f3a4
18 Patch0:         %{name}-DESTDIR.patch
19 Patch1:         %{name}-change_scheme_dir.patch
20 Patch2:         %{name}-chasen.patch
21 URL:            http://sourceforge.jp/projects/shinji/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gdbm-devel
25 BuildRequires:  glib2-devel
26 BuildRequires:  iconv
27 BuildRequires:  libtool
28 BuildRequires:  ocaml
29 BuildRequires:  ocaml-camlp4
30 BuildRequires:  ocaml-findlib
31 Requires:       gdbm
32 %{!?with_bootstrap:Requires:    manadic}
33 %requires_eq    ocaml-runtime
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 A kana(romaji)-kanji conversion engine using ChaSen algorithm.
38
39 #%description -l pl.UTF-8
40
41 %package uim
42 Summary:        UIM support
43 Group:          Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       uim
46
47 %description uim
48 UIM support.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53 %patch1 -p0
54 %patch2 -p1
55
56 mv lib/{,mana-}chasen.h
57
58 %build
59 %{__libtoolize}
60 %{__aclocal}
61 %{__autoconf}
62 %{__automake}
63 %configure
64 %{__make} -j1
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{_datadir}/uim
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 # install mana-prelude.scm for uim
74 install -p mana/mana-prelude.scm $RPM_BUILD_ROOT%{_datadir}/uim
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README
82 %attr(755,root,root) %{_bindir}/*
83 %dir %{_libdir}/mana
84 %attr(755,root,root) %{_libdir}/mana/make*
85
86 %files uim
87 %defattr(644,root,root,755)
88 %{_datadir}/uim/mana-prelude.scm
This page took 0.047191 seconds and 2 git commands to generate.