]> git.pld-linux.org Git - packages/man-db.git/blob - man-db.spec
- updated to 2.8.6.1
[packages/man-db.git] / man-db.spec
1 # TODO: use man cache owner?
2 #
3 # Conditional build:
4 %bcond_without  tests   # "make check" call
5 #
6 Summary:        Tools for searching and reading man pages
7 Summary(pl.UTF-8):      Narzędzia do przeszukiwania i czytania stron podręcznika man
8 Name:           man-db
9 Version:        2.8.6.1
10 Release:        1
11 # project man-db  GPLv2+
12 # Gnulib part     GPLv3+
13 License:        GPL v2+ and GPL v3+
14 Group:          Base
15 Source0:        http://download.savannah.gnu.org/releases/man-db/%{name}-%{version}.tar.xz
16 # Source0-md5:  22e82fe1127f4ca95de7100168a927d1
17 Source1:        %{name}.daily
18 Source2:        %{name}.sysconfig
19 # Resolves: #655385 - use old format of nroff output
20 Patch0:         sgr.patch
21 # recent nroff uses times()
22 Patch1:         %{name}-sandbox.patch
23 URL:            http://www.nongnu.org/man-db/
24 BuildRequires:  gdbm-devel
25 BuildRequires:  gettext-tools >= 0.18.1
26 BuildRequires:  groff
27 BuildRequires:  less
28 BuildRequires:  libpipeline-devel >= 1.5.0
29 BuildRequires:  libseccomp-devel
30 BuildRequires:  pkgconfig
31 BuildRequires:  po4a >= 0.41
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRequires:  zlib-devel
35 Requires:       coreutils
36 Requires:       cronjobs
37 Requires:       grep
38 Requires:       groff
39 Requires:       gzip
40 Requires:       less
41 Requires:       libpipeline >= 1.5.0
42 Provides:       man-pages-reader = %{version}
43 Obsoletes:      man < 1.7
44 Obsoletes:      man-config
45 Obsoletes:      man-whatis
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define         pkgcachedir     /var/cache/man
49
50 %description
51 The man-db package includes five tools for browsing man-pages: man,
52 whatis, apropos, manpath and lexgrog:
53 - man preformats and displays manual pages.
54 - whatis searches the manual page names.
55 - apropos searches the manual page names and descriptions.
56 - manpath determines search path for manual pages.
57 - lexgrog directly reads header information in manual pages.
58
59 %description -l pl.UTF-8
60 Pakiet man-db zawiera pięć narzędzi do przeglądania stron podręcznika
61 man (nazywanych man-pages): man, whatis, apropos, manpath i lexgrog:
62 - man wstępnie formatuje i wyświetla strony podręcznika.
63 - whatis przeszukuje nazwy stron podręcznika.
64 - apropos przeszukuje nazwy stron podręcznika oraz opisy.
65 - manpath określa ścieżkę przeszukiwania dla stron podręcznika.
66 - lexgrog bezpośrednio odczytuje informacje z nagłówka stron
67   podręcznika.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73
74 %build
75 %configure \
76         --disable-cache-owner \
77         --disable-setuid \
78         --disable-silent-rules \
79         --with-browser=elinks \
80         --with-sections="1 1p 8 2 3 3p 4 5 6 7 9 0p n l p o 1x 2x 3x 4x 5x 6x 7x 8x" \
81         --with-systemdtmpfilesdir=%{systemdtmpfilesdir}
82
83 %{__make} \
84         CC="%{__cc} %{rpmcflags} %{rpmcppflags}"
85
86 %{?with_tests:%{__make} check}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 %{__make} install \
91         INSTALL='install -p' \
92         prefix=%{_prefix} \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 # move the documentation to relevant place
96 %{__mv} $RPM_BUILD_ROOT%{_docdir}/man-db/* ./
97
98 # remove libtool archives
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/man-db/*.la
100
101 # install cache directory
102 install -d $RPM_BUILD_ROOT%{pkgcachedir}
103
104 # install cron script for man-db creation/update
105 install -D -p %{SOURCE1} $RPM_BUILD_ROOT/etc/cron.daily/man-db.cron
106
107 # config for cron script
108 install -D -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/man-db
109
110 cat <<EOF > $RPM_BUILD_ROOT%{systemdtmpfilesdir}/man-db.conf
111 d %{pkgcachedir} 2755 root root 1w
112 EOF
113
114 %find_lang %{name}
115 %find_lang %{name}-gnulib
116 cat %{name}-gnulib.lang >> %{name}.lang
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %doc README man-db-manual.txt man-db-manual.ps docs/COPYING ChangeLog NEWS
124 %config(noreplace) %{_sysconfdir}/man_db.conf
125 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/man-db
126 %attr(750,root,root) /etc/cron.daily/man-db.cron
127 %attr(755,root,root) %{_sbindir}/accessdb
128 %attr(755,root,root) %{_bindir}/apropos
129 %attr(755,root,root) %{_bindir}/catman
130 %attr(755,root,root) %{_bindir}/lexgrog
131 %attr(755,root,root) %{_bindir}/man
132 %attr(755,root,root) %{_bindir}/mandb
133 %attr(755,root,root) %{_bindir}/manpath
134 %attr(755,root,root) %{_bindir}/whatis
135 %dir %{_libdir}/man-db
136 %attr(755,root,root) %{_libdir}/man-db/*.so
137 %if "%{_libexecdir}" != "%{_libdir}"
138 %dir %{_libexecdir}/man-db
139 %endif
140 %attr(755,root,root) %{_libexecdir}/man-db/zsoelim
141 %{_libexecdir}/man-db/globbing
142 %{_libexecdir}/man-db/manconv
143 %{systemdunitdir}/man-db.service
144 # TODO: as cron.daily replacement
145 #%{systemdunitdir}/man-db.timer
146 %{systemdtmpfilesdir}/man-db.conf
147 %dir %{pkgcachedir}
148 # documentation and translation
149 %{_mandir}/man1/apropos.1*
150 %{_mandir}/man1/lexgrog.1*
151 %{_mandir}/man1/man.1*
152 %{_mandir}/man1/manconv.1*
153 %{_mandir}/man1/manpath.1*
154 %{_mandir}/man1/whatis.1*
155 %{_mandir}/man1/zsoelim.1*
156 %{_mandir}/man5/manpath.5*
157 %{_mandir}/man8/accessdb.8*
158 %{_mandir}/man8/catman.8*
159 %{_mandir}/man8/mandb.8*
160 %lang(da) %{_mandir}/da/man*/*
161 %lang(de) %{_mandir}/de/man*/*
162 %lang(es) %{_mandir}/es/man*/*
163 %lang(fr) %{_mandir}/fr/man*/*
164 %lang(id) %{_mandir}/id/man*/*
165 %lang(it) %{_mandir}/it/man*/*
166 %lang(ja) %{_mandir}/ja/man*/*
167 %lang(nl) %{_mandir}/nl/man*/*
168 %lang(pl) %{_mandir}/pl/man*/*
169 %lang(pt) %{_mandir}/pt/man*/*
170 %lang(pt_BR) %{_mandir}/pt_BR/man*/*
171 %lang(ru) %{_mandir}/ru/man*/*
172 %lang(sr) %{_mandir}/sr/man*/*
173 %lang(sv) %{_mandir}/sv/man*/*
174 %lang(tr) %{_mandir}/tr/man*/*
175 %lang(zh_CN) %{_mandir}/zh_CN/man*/*
This page took 0.09817 seconds and 3 git commands to generate.