]> git.pld-linux.org Git - packages/make.git/blob - make.spec
- updated to 3.78.1,
[packages/make.git] / make.spec
1 Summary:        GNU Make
2 Summary(de):    GNU Make
3 Summary(fr):    L'utilitaire make de GNU
4 Summary(pl):    GNU Make
5 Summary(tr):    GNU Make
6 Name:           make
7 Version:        3.78.1
8 Release:        1
9 Serial:         1
10 Copyright:      GPL
11 Group:          Development/Building
12 Group(pl):      Programowanie/Budowanie
13 Source:         ftp://prep.ai.mit.edu/pub/gnu/make/%{name}-%{version}.tar.gz
14 Patch0:         make-info.patch
15 Prereq:         /usr/sbin/fix-info-dir
16 Buildroot:      /tmp/%{name}-%{version}-root
17
18 %description
19 A GNU tool for controlling the generation of executables and other
20 non-source files of a program from the program's source files.  Make allows
21 users to build and install packages without any significant knowledge about
22 the details of the build process.  The details about how the program should
23 be built are provided for make in the program's makefile.
24
25 The GNU make tool should be installed on your system because it is commonly
26 used to simplify the process of installing programs.
27
28 %description -l de
29 Das MAKE-Programm dient zur Koordination der Kompilierung und zum Linken
30 eines Satzes von Quellen in ein Programm, wobei nur die erforderlichen
31 Komponenten neu kompiliert werden, so daß der Entwickler eine Menge Zeit
32 spart. Aber damit sind die Fähigkeiten von MAKE noch lange nicht erschöpft -
33 lesen Sie die Info-Dokumente.
34
35 %description -l fr
36 make sert à coordonner la compilation et l'édition de liens d'un ensemble de
37 sources pour produire un programme, ne recompilant que ce qui est nécessaire
38 et économisant ainsi beaucoup de temps. En fait, make peut faire beaucoup
39 plus -- voir les docs info.
40
41 %description -l pl
42 Make jest u¿ywany do automatyzacji procesów kompilowania kodu ¼ród³owego i
43 konsolidacji kodu programów wykonuj±c tylko te czynno¶ci które s± potrzebne
44 w razie modyfikacji plików przetwarzanych przez make oszczêdzaj±c tym samym
45 czas. Make mo¿e wykonywaæ o wiele wiêcej ró¿nych typów operacji zwi±zanych z
46 przedtwarzaniem wsadowym. Pe³en opis make znale¼æ mo¿na na stronach info
47 ("info make").
48
49 %description -l tr
50 Bu program kaynak kodlarýnýn derlenmesini ve baðlanmasýný koordine etmek
51 için kullanýlýr. Sadece gerekli olan programlarý tekrar derleyerek zaman
52 yitirilmesini önler.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57
58 %build
59 LDFLAGS="-s"; export LDFLAGS
60 %configure
61 make 
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT%{_mandir}/man1
66
67 make install DESTDIR=$RPM_BUILD_ROOT
68
69 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/make.info*,%{_mandir}/man1/*} \
70         NEWS README
71
72 %post
73 /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
74
75 %postun
76 /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc {NEWS,README}.gz
84 %attr(755,root,root) %{_bindir}/*
85
86 %{_mandir}/man1/*
87 %{_infodir}/make.info*
This page took 0.035981 seconds and 3 git commands to generate.