]> git.pld-linux.org Git - packages/lzham.git/blob - lzham.spec
- new
[packages/lzham.git] / lzham.spec
1 Summary:        LZHAM - Lossless Data Compression Codec
2 Summary(pl.UTF-8):      LZHAM - kodek bezstratnej kompresji danych
3 Name:           lzham
4 Version:        1.0.stable1
5 %define tagver  %(echo %{version} | tr . _)
6 Release:        0.1
7 License:        MIT
8 Group:          Libraries
9 #Source0Download: https://github.com/richgel999/lzham_codec/releases
10 Source0:        https://github.com/richgel999/lzham_codec/archive/v%{tagver}/lzham_codec-%{tagver}.tar.gz
11 # Source0-md5:  68ec3db42d2263d7e79d0581293f946d
12 Patch0:         %{name}-includedir.patch
13 URL:            https://github.com/richgel999/lzham_codec
14 BuildRequires:  cmake >= 2.8
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  rpmbuild(macros) >= 1.605
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 LZHAM is a lossless data compression codec written in C/C++
21 (specifically C++03), with a compression ratio similar to LZMA but
22 with 1.5x-8x faster decompression speed.
23
24 %description -l pl.UTF-8
25 LZHAM to kodek bezstratnej kompresji danych, napisany w C/C++ (w
26 szczególności C++03). Współczynnik kompresji jest podobny do LZMA, ale
27 szybkość dekompresji jest 1.5-8 razy większa.
28
29 %package devel
30 Summary:        Header files for LZHAM libraries
31 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek LZHAM
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34 Requires:       libstdc++-devel
35
36 %description devel
37 Header files for LZHAM libraries.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe bibliotek LZHAM.
41
42 %prep
43 %setup -q -n lzham_codec-%{tagver}
44 %patch0 -p1
45
46 %build
47 install -d build
48 cd build
49 %cmake ..
50
51 %{__make}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} -C build install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post   -p /sbin/ldconfig
63 %postun -p /sbin/ldconfig
64
65 %files
66 %defattr(644,root,root,755)
67 %doc LICENSE README.md
68 %attr(755,root,root) %{_libdir}/liblzhamcomp.so
69 %attr(755,root,root) %{_libdir}/liblzhamdecomp.so
70 %attr(755,root,root) %{_libdir}/liblzhamdll.so
71
72 %files devel
73 %defattr(644,root,root,755)
74 %{_includedir}/lzham
This page took 0.067896 seconds and 3 git commands to generate.