]> git.pld-linux.org Git - packages/lyx.git/blob - lyx.spec
- up to 2.0.8
[packages/lyx.git] / lyx.spec
1 # TODO:
2 # - tex deps (tetex-tex-babel seems to be required, but I'm not sure)
3 #
4 # Conditional build:
5 %bcond_without  system_boost    # build with included boost-1.36
6 #
7 Summary:        A WYSIWYM frontend to LaTeX
8 Summary(pl.UTF-8):      Nakładka WYSIWYM na LaTeXa
9 Summary(pt_BR.UTF-8):   Editor de Textos para ambiente Desktop
10 Name:           lyx
11 Version:        2.0.8
12 Release:        1
13 Epoch:          1
14 License:        GPL v2+
15 Group:          Applications/Publishing/TeX
16 Source0:        http://ftp.lyx.org/pub/lyx/stable/2.0.x/%{name}-%{version}.tar.xz
17 # Source0-md5:  ea575447107a4c7511c06e082fbd2619
18 Source1:        %{name}.desktop
19 Source2:        %{name}.png
20 URL:            http://www.lyx.org/
21 BuildRequires:  QtGui-devel
22 BuildRequires:  aiksaurus-devel
23 BuildRequires:  aspell-devel
24 BuildRequires:  autoconf >= 2.59-9
25 BuildRequires:  automake
26 %{?with_system_boost:BuildRequires:     boost-devel >= 1.35.0}
27 BuildRequires:  gettext-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  pkgconfig
30 BuildRequires:  qt4-build
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  sed >= 4.0
33 BuildRequires:  xorg-lib-libX11-devel
34 Requires(post,postun):  tetex
35 Requires:       gv
36 Requires:       python-modules
37 Requires:       tetex-format-latex
38 Requires:       tetex-latex
39 Requires:       xdvi
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         texmfdir        %{_datadir}/texmf
43
44 %description
45 LyX is a modern approach of writing documents with a computer which
46 breaks with the tradition of the obsolete typewriter concept. It is
47 designed for people who want a professional output with a minimum of
48 time effort, without becoming specialists in typesetting. Compared to
49 common word processors LyX will increase the productivity a lot, since
50 most of the typesetting will be done by the computer, not the author.
51 With LyX the author can concentrate on the contents of his writing,
52 since the computer will take care of the look.
53
54 %description -l pl.UTF-8
55 LyX jest nowoczesnym narzędziem służącym do pisania dokumentów
56 łamiącym dotychczasową, przestarzałą tradycję maszyny do pisania. LyX
57 został zaprojektowany dla ludzi, którzy chcą tworzyć profesjonalne
58 dokumenty przy jak najmniejszym nakładzie czasowym bez konieczności
59 bycia specjalistą w składzie tekstów. LyX pozwala autorowi skupić się
60 na zawartości dokumentu podczas gdy komputer zajmie się całą resztą.
61
62 %description -l pt_BR.UTF-8
63 Lyx é uma forma moderna de escrever documentos com um computador sem
64 que isso quebre os conceitos de uso de uma máquina de escrever
65 tradicional. Ele é feito para pessoas que necessitam de um resultado
66 profissional com um mínimo de esforço, sem também ser um especialista
67 em fontes. Comparado com um editor de textos padrão, LyX é um editor
68 de textos que irá aumentar a produtividade visto que as fontes serão
69 selecionadas pelo editor, não pelo digitador.
70
71 %prep
72 %setup -q
73
74 %build
75 cat config/*.m4 > acinclude.m4
76 %{__aclocal} -I m4
77 %{__autoconf}
78 %{__autoheader}
79 %{__automake}
80 %configure \
81         --disable-silent-rules \
82         %{?debug:--enable-debug} \
83         --enable-nls \
84         %{?with_system_boost:--without-included-boost} \
85         --without-included-gettext \
86         --with-qt4-dir=%{_libdir}/qt4 \
87         --with-frontend=qt4
88
89 %{__make} all
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
94         $RPM_BUILD_ROOT%{texmfdir}/tex/latex
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
100 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
101
102 ln -sf %{_datadir}/lyx/tex $RPM_BUILD_ROOT%{texmfdir}/tex/latex/lyx
103
104 %{__sed} -i -e 's,#! /usr/bin/env python,#!/usr/bin/python,' $RPM_BUILD_ROOT%{_datadir}/lyx/configure.py
105
106 %find_lang %{name}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 umask 022
113 /usr/bin/texhash
114 cd %{_datadir}/lyx
115 ./configure.py > /dev/null || :
116 if [ -f lyxrc.defaults ]; then
117         cp -p lyxrc.defaults lyxrc
118 fi
119
120 %preun
121 if [ "$1" = "0" ]; then
122         %{__rm} -f %{_datadir}/lyx/{lyxrc.defaults,lyxrc*}
123         %{__rm} -f %{_datadir}/lyx/{doc/LaTeXConfig.lyx,packages.lst}
124 fi
125
126 %postun
127 umask 022
128 /usr/bin/texhash
129
130 %files -f %{name}.lang
131 %defattr(644,root,root,755)
132 %doc ANNOUNCE README NEWS
133 %attr(755,root,root) %{_bindir}/*
134 %dir %{texmfdir}/tex/latex/lyx
135 %dir %{_datadir}/lyx
136 %dir %{_datadir}/lyx/commands
137 %{_datadir}/lyx/CREDITS
138 %{_datadir}/lyx/bind
139 %{_datadir}/lyx/chkconfig.ltx
140 %{_datadir}/lyx/commands/default.def
141 %{_datadir}/lyx/doc/clipart
142 %attr(755,root,root) %{_datadir}/lyx/configure*
143 %dir %{_datadir}/lyx/doc
144 %{_datadir}/lyx/doc/[A-Z]*
145 %{_datadir}/lyx/doc/biblio
146 %lang(ca) %{_datadir}/lyx/doc/ca
147 %lang(cs) %{_datadir}/lyx/doc/cs
148 %lang(da) %{_datadir}/lyx/doc/da
149 %lang(de) %{_datadir}/lyx/doc/de
150 %lang(el) %{_datadir}/lyx/doc/el
151 %lang(es) %{_datadir}/lyx/doc/es
152 %lang(eu) %{_datadir}/lyx/doc/eu
153 %lang(fr) %{_datadir}/lyx/doc/fr
154 %lang(gl) %{_datadir}/lyx/doc/gl
155 %lang(he) %{_datadir}/lyx/doc/he
156 %lang(hu) %{_datadir}/lyx/doc/hu
157 %lang(id) %{_datadir}/lyx/doc/id
158 %lang(it) %{_datadir}/lyx/doc/it
159 %lang(ja) %{_datadir}/lyx/doc/ja
160 %lang(nb) %{_datadir}/lyx/doc/nb
161 %lang(nl) %{_datadir}/lyx/doc/nl
162 %lang(pl) %{_datadir}/lyx/doc/pl
163 %lang(pt) %{_datadir}/lyx/doc/pt
164 %lang(ro) %{_datadir}/lyx/doc/ro
165 %lang(ru) %{_datadir}/lyx/doc/ru
166 %lang(sk) %{_datadir}/lyx/doc/sk
167 %lang(sl) %{_datadir}/lyx/doc/sl
168 %lang(sv) %{_datadir}/lyx/doc/sv
169 %lang(uk) %{_datadir}/lyx/doc/uk
170 %lang(zh_CN) %{_datadir}/lyx/doc/zh_CN
171 %{_datadir}/lyx/autocorrect
172 %{_datadir}/lyx/encodings
173 %{_datadir}/lyx/examples
174 %{_datadir}/lyx/external_templates
175 %{_datadir}/lyx/fonts/
176 %{_datadir}/lyx/images
177 %{_datadir}/lyx/kbd
178 %{_datadir}/lyx/languages
179 %{_datadir}/lyx/layouts
180 %{_datadir}/lyx/layouttranslations
181 %attr(755,root,root) %{_datadir}/lyx/lyx2lyx
182 %attr(755,root,root) %{_datadir}/lyx/scripts
183 %{_datadir}/lyx/symbols
184 %{_datadir}/lyx/syntax.default
185 %{_datadir}/lyx/templates
186 %{_datadir}/lyx/tex
187 %{_datadir}/lyx/ui
188 %{_datadir}/lyx/unicodesymbols
189 %{_mandir}/man*/*
190 %{_desktopdir}/*.desktop
191 %{_pixmapsdir}/*
This page took 0.122232 seconds and 3 git commands to generate.