]> git.pld-linux.org Git - packages/lxterminal.git/blob - lxterminal.spec
automake fix
[packages/lxterminal.git] / lxterminal.spec
1 #
2 # Conditional build:
3 %bcond_with             gtk3            # build GTK+3 disables GTK+2
4 %bcond_without          gtk2    # build with GTK+2
5
6 %if %{with gtk3}
7 %undefine       with_gtk2
8 %endif
9
10 Summary:        LXTerminal is the standard terminal emulator of LXDE
11 Name:           lxterminal
12 Version:        0.1.11
13 Release:        5
14 License:        GPL v2
15 Group:          X11/Applications
16 Source0:        http://downloads.sourceforge.net/lxde/%{name}-%{version}.tar.gz
17 # Source0-md5:  fd9140b45c0f28d021253c4aeb8c4aea
18 Patch0:         wordseps.patch
19 URL:            http://wiki.lxde.org/en/LXTerminal
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  gettext-devel
23 BuildRequires:  gtk+2-devel
24 %{?with_gtk2:BuildRequires:     gtk+2-devel}
25 %{?with_gtk3:BuildRequires:     gtk+3-devel}
26 BuildRequires:  intltool
27 BuildRequires:  libtool
28 BuildRequires:  perl-XML-Parser
29 BuildRequires:  pkgconfig
30 %{?with_gtk3:BuildRequires:     vte-devel}
31 %{?with_gtk2:BuildRequires:     vte0-devel}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 LXTerminal is the standard terminal emulator of LXDE.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40
41 %{__sed} -i -e 's,AM_CONFIG_HEADER,AC_CONFIG_HEADERS,' configure.ac
42
43 %build
44 %{__libtoolize}
45 %{__aclocal}
46 %{__autoheader}
47 %{__autoconf}
48 %{__intltoolize}
49 %configure \
50         --disable-silent-rules \
51         %{?with_gtk3:--enable-gtk3}
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 # duplicate of ur
60 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ur_PK
61 # unsupported by glibc
62 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/frp
63
64 mv $RPM_BUILD_ROOT%{_localedir}/tt{_RU,}
65
66 %find_lang %{name}
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files -f %{name}.lang
72 %defattr(644,root,root,755)
73 %doc AUTHORS ChangeLog NEWS README
74 %attr(755,root,root) %{_bindir}/%{name}
75 %{_desktopdir}/%{name}.desktop
76 %{_mandir}/man1/%{name}*
77 %{_pixmapsdir}/%{name}.png
78 %{_datadir}/%{name}
This page took 0.097211 seconds and 3 git commands to generate.