]> git.pld-linux.org Git - packages/lvm2.git/blob - lvm2.spec
d55722e0d8dd3b1a878fd3ea2a6bea3b1773e22d
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - internal vs shared for cluster,snapshots,mirrors,thin,cache ?
4 #   note: dmeventd requires mirrors=internal)
5 #
6 # Conditional build:
7 # - initrd stuff
8 %bcond_with     initrd          # build initrd version
9 # - functionality
10 %bcond_without  cluster         # disable all cluster support (cmirrord)
11 %bcond_without  lvmdbusd        # lvmdbusd
12 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
13 %bcond_without  lvmlockd        # lvmlockd
14 %bcond_with     sanlock         # sanlock support in lvmlockd
15 # - additional features
16 %bcond_without  selinux         # SELinux support
17 # - bindings
18 %bcond_without  python          # Python bindings
19 %bcond_without  python2         # Python 2 binding
20 %bcond_without  python3         # Python 3 binding and lvmdbusd
21
22 # lvmlockd requires lvmpolld
23 %if %{without lvmpolld}
24 %undefine       with_lvmpolld
25 %endif
26
27 # for convenience
28 %if %{without python}
29 %undefine       with_python2
30 %undefine       with_python3
31 %endif
32 %if %{without python3}
33 %undefine       with_lvmdbusd
34 %endif
35
36 %if %{without cluster} && %{without sanlock}
37 %undefine       with_lvmlockd
38 %endif
39
40 Summary:        The new version of Logical Volume Manager for Linux
41 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
42 Name:           lvm2
43 Version:        2.03.08
44 Release:        1
45 License:        GPL v2 and LGPL v2.1
46 Group:          Applications/System
47 Source0:        ftp://sourceware.org/pub/lvm2/LVM2.%{version}.tgz
48 # Source0-md5:  92691c782db85150a05f2452ab10825c
49 Patch0:         device-mapper-dmsetup-export.patch
50 Patch1:         %{name}-pld_init.patch
51 Patch2:         device-mapper-dmsetup-deps-export.patch
52 Patch3:         %{name}-thin.patch
53 Patch4:         paths.patch
54 URL:            http://www.sourceware.org/lvm2/
55 BuildRequires:  autoconf >= 2.69
56 BuildRequires:  automake
57 # for /run detection
58 BuildRequires:  filesystem >= 3.0-43
59 BuildRequires:  libaio-devel
60 BuildRequires:  libblkid-devel >= 2.24
61 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
62 %{?with_selinux:BuildRequires:  libsepol-devel}
63 BuildRequires:  ncurses-devel
64 BuildRequires:  pkgconfig
65 %{?with_python2:BuildRequires:  python-devel >= 2}
66 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
67 %if %{with lvmdbusd}
68 BuildRequires:  python3-dbus
69 BuildRequires:  python3-pyudev
70 %endif
71 BuildRequires:  readline-devel
72 BuildRequires:  rpmbuild(macros) >= 1.647
73 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
74 BuildRequires:  systemd-devel >= 1:221
75 BuildRequires:  udev-devel >= 1:176
76 %if %{with initrd}
77 %{?with_selinux:BuildRequires:  libselinux-static}
78 %{?with_selinux:BuildRequires:  libsepol-static}
79 BuildRequires:  glibc-static
80 %else
81 Obsoletes:      lvm2-initrd
82 %endif
83 %if %{with cluster}
84 BuildRequires:  corosync-devel
85 BuildRequires:  dlm-devel >= 3.99.5
86 %endif
87 Requires(post,preun,postun):    systemd-units >= 38
88 Requires(post,postun):  /sbin/chkconfig
89 Requires:       device-mapper >= %{version}-%{release}
90 %{?with_selinux:Requires:       libselinux >= 1.10}
91 Requires:       systemd-units >= 38
92 # doesn't work with 2.4 kernels
93 Requires:       uname(release) >= 2.6
94 Suggests:       thin-provisioning-tools >= 0.5.4
95 Obsoletes:      lvm
96 Obsoletes:      lvm2-clvmd
97 Obsoletes:      lvm2-systemd
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _sbindir        /sbin
101 %define         _usrsbindir     /usr/sbin
102
103 # changing CFLAGS in the middle confuses confcache
104 %undefine       configure_cache
105
106 # borken on AC
107 %define         filterout_ld    -Wl,--as-needed
108
109 # causes: undefined reference to `__stack_chk_fail_local'
110 %define         filterout_c     -fstack-protector
111
112 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*' 'liblvm2cmd.so.*'
113
114 %description
115 This package includes a number of utilities for creating, checking,
116 and repairing logical volumes.
117
118 %description -l pl.UTF-8
119 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
120 logicznych wolumenów dyskowych (LVM2).
121
122 %package initrd
123 Summary:        The new version of Logical Volume Manager for Linux - initrd version
124 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
125 Group:          Base
126 Conflicts:      geninitrd < 10000.18
127
128 %description initrd
129 This package includes a number of utilities for creating, checking,
130 and repairing logical volumes - staticaly linked for initrd.
131
132 %description initrd -l pl.UTF-8
133 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
134 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
135 potrzeby initrd.
136
137 %package cmirrord
138 Summary:        Cluster mirror log daemon
139 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
140 Group:          Applications/System
141 Requires:       %{name} = %{version}-%{release}
142
143 %description cmirrord
144 cmirrord is the daemon that tracks mirror log information in a
145 cluster. It is specific to device-mapper based mirrors (and by
146 extension, LVM cluster mirrors). Cluster mirrors are not possible
147 without this daemon running.
148
149 This daemon relies on the cluster infrastructure provided by the
150 Cluster MANager (CMAN), which must be set up and running in order for
151 cmirrord to function.
152
153 %description cmirrord
154 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
155 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
156 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
157 lustrzanych ten demon jest niezbędny.
158
159 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
160 (Cluster MANager), który musi być skonfigurowany i działający, aby
161 działał cmirrord.
162
163 %package dbusd
164 Summary:        LVM2 D-Bus daemon
165 Summary(pl.UTF-8):      Demon LVM2 D-Bus
166 Group:          Daemons
167 Requires(post,preun,postun):    systemd-units >= 38
168 Requires:       %{name} = %{version}-%{release}
169 Requires:       python3-dbus
170 Requires:       python3-pygobject3 >= 3
171 Requires:       python3-pyudev
172
173 %description dbusd
174 Daemon for access to LVM2 functionality through a D-Bus interface.
175
176 %description dbusd -l pl.UTF-8
177 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
178 D-Bus.
179
180 %package lockd
181 Summary:        LVM2 locking daemon
182 Summary(pl.UTF-8):      Demon blokad LVM2
183 Group:          Daemons
184 Requires(post,preun,postun):    systemd-units >= 38
185 Requires:       %{name} = %{version}-%{release}
186 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
187 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
188
189 %description lockd
190 LVM commands use lvmlockd to coordinate access to shared storage.
191
192 %description lockd -l pl.UTF-8
193 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
194 współdzielonej pamięci masowej.
195
196 %package resource-agents
197 Summary:        OCF Resource Agents for LVM2 processes
198 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
199 Group:          Applications/System
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       resource-agents
202
203 %description resource-agents
204 OCF Resource Agents for LVM2 processes.
205
206 %description resource-agents -l pl.UTF-8
207 Agenci OCF do monitorowania procesów LVM2.
208
209 %package -n python-lvm
210 Summary:        Python 2 interface to LVM2
211 Summary(pl.UTF-8):      Interfejs Pythona 2 do LVM2
212 Group:          Libraries/Python
213 Requires:       device-mapper-libs = %{version}-%{release}
214
215 %description -n python-lvm
216 Python 2 interface to LVM2.
217
218 %description -n python-lvm -l pl.UTF-8
219 Interfejs Pythona 2 do LVM2.
220
221 %package -n python3-lvm
222 Summary:        Python 3 interface to LVM2
223 Summary(pl.UTF-8):      Interfejs Pythona 3 do LVM2
224 Group:          Libraries/Python
225 Requires:       device-mapper-libs = %{version}-%{release}
226
227 %description -n python3-lvm
228 Python 3 interface to LVM2.
229
230 %description -n python3-lvm -l pl.UTF-8
231 Interfejs Pythona 3 do LVM2.
232
233 %package -n device-mapper
234 Summary:        Userspace support for the device-mapper
235 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
236 Group:          Base
237 Requires(post,postun):  /sbin/ldconfig
238 Requires(post,preun,postun):    systemd-units >= 38
239 Requires:       device-mapper-libs = %{version}-%{release}
240 Requires:       systemd-units >= 38
241
242 %description -n device-mapper
243 The goal of this driver is to support volume management. The driver
244 enables the definition of new block devices composed of ranges of
245 sectors of existing devices. This can be used to define disk
246 partitions - or logical volumes. This light-weight kernel component
247 can support user-space tools for logical volume management.
248
249 %description -n device-mapper -l pl.UTF-8
250 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
251 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
252 sektorów na istniejących urządzeniach. Może to być wykorzystane do
253 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
254 składnik jądra może wspierać działające w przestrzeni użytkownika
255 narzędzia do zarządzania logicznymi wolumenami.
256
257 %package -n device-mapper-libs
258 Summary:        Device-mapper shared libraries
259 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
260 Group:          Libraries
261 Requires:       libblkid >= 2.24
262 Requires:       udev-libs >= 1:176
263 Conflicts:      device-mapper < 2.02.119-1
264
265 %description -n device-mapper-libs
266 Device-mapper shared libraries.
267
268 %description -n device-mapper-libs -l pl.UTF-8
269 Biblioteki współdzielone device-mappera.
270
271 %package -n device-mapper-devel
272 Summary:        Header files for device-mapper libraries
273 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
274 Group:          Development/Libraries
275 Requires:       device-mapper-libs = %{version}-%{release}
276 Requires:       libblkid-devel >= 2.24
277 %if %{with selinux}
278 Requires:       libselinux-devel
279 Requires:       libsepol-devel
280 %endif
281 Requires:       udev-devel >= 1:176
282
283 %description -n device-mapper-devel
284 Header files for device-mapper libraries.
285
286 %description -n device-mapper-devel -l pl.UTF-8
287 Pliki nagłówkowe bibliotek device-mappera.
288
289 %package -n device-mapper-static
290 Summary:        Static devmapper library
291 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
292 License:        LGPL v2.1
293 Group:          Development/Libraries
294 Requires:       device-mapper-devel = %{version}-%{release}
295
296 %description -n device-mapper-static
297 Static devmapper library.
298
299 %description -n device-mapper-static -l pl.UTF-8
300 Statyczna biblioteka devmapper.
301
302 %package -n device-mapper-initrd
303 Summary:        Userspace support for the device-mapper - initrd version
304 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
305 Group:          Base
306 Obsoletes:      device-mapper-initrd-devel
307 Conflicts:      geninitrd < 10000.10
308
309 %description -n device-mapper-initrd
310 The goal of this driver is to support volume management. The driver
311 enables the definition of new block devices composed of ranges of
312 sectors of existing devices. This can be used to define disk
313 partitions - or logical volumes. This light-weight kernel component
314 can support user-space tools for logical volume management.
315
316 This package contains dmsetup program linked staticaly for use in
317 initrd.
318
319 %description -n device-mapper-initrd -l pl.UTF-8
320 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
321 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
322 sektorów na istniejących urządzeniach. Może to być wykorzystane do
323 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
324 składnik jądra może wspierać działające w przestrzeni użytkownika
325 narzędzia do zarządzania logicznymi wolumenami.
326
327 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
328 potrzeby initrd.
329
330 %prep
331 %setup -q -n LVM2.%{version}
332 %patch0 -p1
333 %patch1 -p1
334 %patch2 -p1
335 %patch3 -p1
336 %patch4 -p1
337
338 %build
339 cp -f /usr/share/automake/config.sub autoconf
340 %{__aclocal}
341 %{__autoconf}
342
343 %if %{with initrd}
344
345 %configure \
346         %{?debug:--enable-debug} \
347         --disable-nls \
348         --disable-readline \
349         --enable-selinux \
350         --enable-static_link \
351         --with-optimisation="%{rpmcflags} -Os"
352
353 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
354 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
355
356 %{__make} -j1 -C include V=1
357 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB= V=1
358 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB= V=1
359 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB= V=1
360 %{__make} -j1 -C tools dmsetup.static lvm.static V=1
361 %{__mv} tools/lvm.static initrd-lvm
362 %{__mv} tools/dmsetup.static initrd-dmsetup
363
364 # check if tools works
365 for tool in initrd-lvm initrd-dmsetup; do
366         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
367         if [ $rc -gt 127 ]; then
368                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
369                 exit 1
370         fi
371 done
372
373 %{__make} clean
374
375 unset CC
376 %endif
377
378 %configure \
379         --enable-applib \
380         --enable-cache_check_needs_check \
381         --enable-cmdlib \
382         %{?with_lvmdbusd:--enable-dbus-service --enable-notify-dbus} \
383         %{?debug:--enable-debug} \
384         --enable-dmeventd \
385         --enable-dmfilemapd \
386         --enable-fsadm \
387         --with-default-locking-dir=/var/lock/lvm \
388 %if %{with lvmlockd}
389         %{?with_cluster:--enable-lvmlockd-dlm} \
390         %{?with_sanlock:--enable-lvmlockd-sanlock} \
391 %endif
392         --enable-lvmpolld \
393         --enable-ocf \
394         %{?with_python2:--enable-python2_bindings} \
395         %{?with_python3:--enable-python3_bindings} \
396         --enable-readline \
397         %{!?with_selinux:--disable-selinux} \
398         --enable-pkgconfig \
399         --enable-thin_check_needs_check \
400         --enable-udev_sync \
401         --enable-udev_rules \
402         --with-cache=internal \
403         --with-cache-check=/usr/sbin/cache_check \
404         --with-cache-dump=/usr/sbin/cache_dump \
405         --with-cache-repair=/usr/sbin/cache_repair \
406         --with-cache-restore=/usr/sbin/cache_restore \
407         --with-cluster=internal \
408 %if %{with cluster}
409         --enable-cmirrord \
410 %endif
411         --with-dmeventd-path=%{_sbindir}/dmeventd \
412         --with-interface=ioctl \
413         --with-lvm1=internal \
414         --with-mirrors=internal \
415         --with-optimisation="%{rpmcflags}" \
416         --with-snapshots=internal \
417         --with-systemdsystemunitdir=%{systemdunitdir} \
418         --with-tmpfilesdir=%{systemdtmpfilesdir} \
419         --with-thin=internal \
420         --with-thin-check=/usr/sbin/thin_check \
421         --with-thin-dump=/usr/sbin/thin_dump \
422         --with-thin-repair=/usr/sbin/thin_repair \
423         --with-thin-restore=/usr/sbin/thin_restore \
424         --with-udev-prefix=/ \
425         --with-vdo=internal --with-vdo-format=%{_bindir}/vdoformat \
426         --with-writecache=internal \
427         --with-usrlibdir=%{_libdir}
428
429 # use bash because of "set -o pipefail"
430 %{__make} -j1 \
431         SHELL=/bin/bash \
432         V=1
433 %{__make} -j1 -C libdm \
434         LIB_STATIC=libdevmapper.a \
435         V=1
436
437 %install
438 rm -rf $RPM_BUILD_ROOT
439 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig,/var/lock/lvm/subsys}
440
441 %{__make} install install_system_dirs install_systemd_units install_systemd_generators install_initscripts install_tmpfiles_configuration \
442         DESTDIR=$RPM_BUILD_ROOT \
443         OWNER="" \
444         GROUP="" \
445         V=1 \
446         python3dir=%{py3_sitescriptdir}
447
448 %{__make} -C scripts install_tmpfiles_configuration \
449         DESTDIR=$RPM_BUILD_ROOT \
450         V=1
451
452 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
453 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
454         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
455         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
456         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
457 done
458
459 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
460
461 %if %{with initrd}
462 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
463 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
464 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
465 %endif
466
467 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
468
469 %clean
470 rm -rf $RPM_BUILD_ROOT
471
472 %post
473 /sbin/chkconfig --add lvm2-monitor
474 %service lvm2-monitor restart
475 %systemd_post lvm2-monitor.service
476 /sbin/chkconfig --add blk-availability
477 # no service blk-availability restart
478 %systemd_post blk-availability.service
479 %if %{with lvmpolld}
480 %systemd_post lvm2-lvmpolld.socket
481 %endif
482
483 %preun
484 %systemd_preun lvm2-monitor.service
485 %systemd_preun blk-availability.service
486 %if %{with lvmpolld}
487 %systemd_preun lvm2-lvmpolld.socket
488 %endif
489
490 %postun
491 if [ "$1" = "0" ]; then
492         %service lvm2-monitor stop
493         /sbin/chkconfig --del lvm2-monitor
494         #no service blk-availability stop
495         /sbin/chkconfig --del blk-availability
496 fi
497 %systemd_reload
498
499 %triggerpostun -- %{name} < 2.02.94-1
500 %systemd_trigger lvm2-monitor.service
501
502 %post -n device-mapper
503 %systemd_post dm-event.socket
504
505 %preun -n device-mapper
506 %systemd_preun dm-event.socket dm-event.service
507
508 %postun -n device-mapper
509 %systemd_reload
510
511 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
512 %systemd_trigger dm-event.socket
513
514 %post   -n device-mapper-libs -p /sbin/ldconfig
515 %postun -n device-mapper-libs -p /sbin/ldconfig
516
517 %post dbusd
518 %systemd_post lvm2-lvmdbusd.service
519
520 %preun dbusd
521 %systemd_preun lvm2-lvmdbusd.service
522
523 %postun dbusd
524 %systemd_reload
525
526 %post lockd
527 %systemd_post lvm2-lvmlockd.service lvm2-lvmlocking.service
528
529 %preun lockd
530 %systemd_preun lvm2-lvmlockd.service lvm2-lvmlocking.service
531
532 %postun lockd
533 %systemd_reload
534
535 %files
536 %defattr(644,root,root,755)
537 %doc README WHATS_NEW doc/*
538 %attr(755,root,root) %{_sbindir}/blkdeactivate
539 %attr(755,root,root) %{_sbindir}/fsadm
540 %attr(755,root,root) %{_sbindir}/lvchange
541 %attr(755,root,root) %{_sbindir}/lvconvert
542 %attr(755,root,root) %{_sbindir}/lvcreate
543 %attr(755,root,root) %{_sbindir}/lvdisplay
544 %attr(755,root,root) %{_sbindir}/lvextend
545 %attr(755,root,root) %{_sbindir}/lvm
546 #%attr(755,root,root) %{_sbindir}/lvmconf
547 %attr(755,root,root) %{_sbindir}/lvmconfig
548 %attr(755,root,root) %{_sbindir}/lvmdiskscan
549 %attr(755,root,root) %{_sbindir}/lvmdump
550 %attr(755,root,root) %{_sbindir}/lvmsadc
551 %attr(755,root,root) %{_sbindir}/lvmsar
552 %attr(755,root,root) %{_sbindir}/lvreduce
553 %attr(755,root,root) %{_sbindir}/lvremove
554 %attr(755,root,root) %{_sbindir}/lvrename
555 %attr(755,root,root) %{_sbindir}/lvresize
556 %attr(755,root,root) %{_sbindir}/lvs
557 %attr(755,root,root) %{_sbindir}/lvscan
558 %attr(755,root,root) %{_sbindir}/pvchange
559 %attr(755,root,root) %{_sbindir}/pvck
560 %attr(755,root,root) %{_sbindir}/pvcreate
561 %attr(755,root,root) %{_sbindir}/pvdisplay
562 %attr(755,root,root) %{_sbindir}/pvmove
563 %attr(755,root,root) %{_sbindir}/pvremove
564 %attr(755,root,root) %{_sbindir}/pvresize
565 %attr(755,root,root) %{_sbindir}/pvs
566 %attr(755,root,root) %{_sbindir}/pvscan
567 %attr(755,root,root) %{_sbindir}/vgcfgbackup
568 %attr(755,root,root) %{_sbindir}/vgcfgrestore
569 %attr(755,root,root) %{_sbindir}/vgchange
570 %attr(755,root,root) %{_sbindir}/vgck
571 %attr(755,root,root) %{_sbindir}/vgconvert
572 %attr(755,root,root) %{_sbindir}/vgcreate
573 %attr(755,root,root) %{_sbindir}/vgdisplay
574 %attr(755,root,root) %{_sbindir}/vgexport
575 %attr(755,root,root) %{_sbindir}/vgextend
576 %attr(755,root,root) %{_sbindir}/vgimport
577 %attr(755,root,root) %{_sbindir}/vgimportclone
578 %attr(755,root,root) %{_sbindir}/vgmerge
579 %attr(755,root,root) %{_sbindir}/vgmknodes
580 %attr(755,root,root) %{_sbindir}/vgreduce
581 %attr(755,root,root) %{_sbindir}/vgremove
582 %attr(755,root,root) %{_sbindir}/vgrename
583 %attr(755,root,root) %{_sbindir}/vgs
584 %attr(755,root,root) %{_sbindir}/vgscan
585 %attr(755,root,root) %{_sbindir}/vgsplit
586 %{_mandir}/man5/lvm.conf.5*
587 %{_mandir}/man7/lvmcache.7*
588 %{_mandir}/man7/lvmraid.7*
589 %{_mandir}/man7/lvmreport.7*
590 %{_mandir}/man7/lvmsystemid.7*
591 %{_mandir}/man7/lvmthin.7*
592 %{_mandir}/man8/blkdeactivate.8*
593 %{_mandir}/man8/fsadm.8*
594 %{_mandir}/man8/lvchange.8*
595 %{_mandir}/man8/lvconvert.8*
596 %{_mandir}/man8/lvcreate.8*
597 %{_mandir}/man8/lvdisplay.8*
598 %{_mandir}/man8/lvextend.8*
599 %{_mandir}/man8/lvm2-activation-generator.8*
600 %{_mandir}/man8/lvm-config.8*
601 %{_mandir}/man8/lvm-dumpconfig.8*
602 %{_mandir}/man8/lvm-fullreport.8*
603 %{_mandir}/man8/lvm-lvpoll.8*
604 %{_mandir}/man8/lvm.8*
605 #%{_mandir}/man8/lvmconf.8*
606 %{_mandir}/man8/lvmconfig.8*
607 %{_mandir}/man8/lvmdiskscan.8*
608 %{_mandir}/man8/lvmdump.8*
609 %{_mandir}/man8/lvmsadc.8*
610 %{_mandir}/man8/lvmsar.8*
611 %{_mandir}/man8/lvreduce.8*
612 %{_mandir}/man8/lvremove.8*
613 %{_mandir}/man8/lvrename.8*
614 %{_mandir}/man8/lvresize.8*
615 %{_mandir}/man8/lvs.8*
616 %{_mandir}/man8/lvscan.8*
617 %{_mandir}/man8/pvchange.8*
618 %{_mandir}/man8/pvck.8*
619 %{_mandir}/man8/pvcreate.8*
620 %{_mandir}/man8/pvdisplay.8*
621 %{_mandir}/man8/pvmove.8*
622 %{_mandir}/man8/pvremove.8*
623 %{_mandir}/man8/pvresize.8*
624 %{_mandir}/man8/pvs.8*
625 %{_mandir}/man8/pvscan.8*
626 %{_mandir}/man8/vgcfgbackup.8*
627 %{_mandir}/man8/vgcfgrestore.8*
628 %{_mandir}/man8/vgchange.8*
629 %{_mandir}/man8/vgck.8*
630 %{_mandir}/man8/vgconvert.8*
631 %{_mandir}/man8/vgcreate.8*
632 %{_mandir}/man8/vgdisplay.8*
633 %{_mandir}/man8/vgexport.8*
634 %{_mandir}/man8/vgextend.8*
635 %{_mandir}/man8/vgimport.8*
636 %{_mandir}/man8/vgimportclone.8*
637 %{_mandir}/man8/vgmerge.8*
638 %{_mandir}/man8/vgmknodes.8*
639 %{_mandir}/man8/vgreduce.8*
640 %{_mandir}/man8/vgremove.8*
641 %{_mandir}/man8/vgrename.8*
642 %{_mandir}/man8/vgs.8*
643 %{_mandir}/man8/vgscan.8*
644 %{_mandir}/man8/vgsplit.8*
645 %attr(750,root,root) %dir %{_sysconfdir}/lvm
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
647 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
648 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
649 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
650 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
651 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
652 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
653 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
654 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
655 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/vdo-small.profile
656 %{systemdtmpfilesdir}/lvm2.conf
657 %{systemdunitdir}/blk-availability.service
658 %{systemdunitdir}/lvm2-monitor.service
659 %{systemdunitdir}/lvm2-pvscan@.service
660 %attr(755,root,root) /lib/systemd/system-generators/lvm2-activation-generator
661 %dir %{_sysconfdir}/lvm/cache
662 %ghost %{_sysconfdir}/lvm/cache/.cache
663 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
664 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
665 %attr(700,root,root) %dir /run/lvm
666 %attr(700,root,root) %dir /var/lock/lvm
667 %attr(700,root,root) %dir /var/lock/lvm/subsys
668 %if %{with lvmlockd}
669 %attr(755,root,root) %{_sbindir}/lvmlockctl
670 %attr(755,root,root) %{_sbindir}/lvmlockd
671 %{systemdunitdir}/lvmlockd.service
672 %{systemdunitdir}/lvmlocks.service
673 %{_mandir}/man8/lvmlockctl.8*
674 %{_mandir}/man8/lvmlockd.8*
675 %endif
676 %if %{with lvmpolld}
677 %attr(755,root,root) %{_sbindir}/lvmpolld
678 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
679 %{systemdunitdir}/lvm2-lvmpolld.service
680 %{systemdunitdir}/lvm2-lvmpolld.socket
681 %{_mandir}/man8/lvmpolld.8*
682 %endif
683
684 %if %{with cluster}
685 %files cmirrord
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_usrsbindir}/cmirrord
688 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
689 %{systemdunitdir}/lvm2-cmirrord.service
690 %{_mandir}/man8/cmirrord.8*
691 %endif
692
693 %if %{with lvmdbusd}
694 %files dbusd
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_sbindir}/lvmdbusd
697 %{py3_sitescriptdir}/lvmdbusd
698 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
699 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/com.redhat.lvmdbus1.conf
700 %{_datadir}/dbus-1/system-services/com.redhat.lvmdbus1.service
701 %{systemdunitdir}/lvm2-lvmdbusd.service
702 %{_mandir}/man8/lvmdbusd.8*
703 %endif
704
705 %files resource-agents
706 %defattr(644,root,root,755)
707 %dir %{_prefix}/lib/ocf/resource.d/lvm2
708 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
709
710 %if %{with python2}
711 %files -n python-lvm
712 %defattr(644,root,root,755)
713 #%attr(755,root,root) %{py_sitedir}/lvm.so
714 #%{py_sitedir}/lvm-%{version}_*-py*.egg-info
715 %endif
716
717 %if %{with python3}
718 %files -n python3-lvm
719 %defattr(644,root,root,755)
720 #%attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
721 #%{py3_sitedir}/lvm-%{version}_*-py*.egg-info
722 %endif
723
724 %files -n device-mapper
725 %defattr(644,root,root,755)
726 %doc *_DM
727 %{systemdunitdir}/dm-event.service
728 %{systemdunitdir}/dm-event.socket
729 /lib/udev/rules.d/10-dm.rules
730 /lib/udev/rules.d/11-dm-lvm.rules
731 /lib/udev/rules.d/13-dm-disk.rules
732 /lib/udev/rules.d/95-dm-notify.rules
733 /lib/udev/rules.d/69-dm-lvm-metad.rules
734 %attr(755,root,root) %{_sbindir}/dmeventd
735 %attr(755,root,root) %{_sbindir}/dmfilemapd
736 %attr(755,root,root) %{_sbindir}/dmsetup
737 %attr(755,root,root) %{_sbindir}/dmstats
738 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
739 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
740 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
741 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
742 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2vdo.so
743 %dir %{_libdir}/device-mapper
744 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
745 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
746 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
747 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
748 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
749 %{_mandir}/man7/lvmvdo.7*
750 %{_mandir}/man8/dmfilemapd.8*
751 %{_mandir}/man8/dmsetup.8*
752 %{_mandir}/man8/dmstats.8*
753 %{_mandir}/man8/dmeventd.8*
754
755 %files -n device-mapper-libs
756 %defattr(644,root,root,755)
757 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
758 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
759 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
760 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
761
762 %files -n device-mapper-devel
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{_libdir}/libdevmapper.so
765 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
766 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
767 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
768 %{_includedir}/libdevmapper.h
769 %{_includedir}/libdevmapper-event.h
770 %{_includedir}/lvm2cmd.h
771 %{_pkgconfigdir}/devmapper.pc
772 %{_pkgconfigdir}/devmapper-event.pc
773
774 %files -n device-mapper-static
775 %defattr(644,root,root,755)
776 %{_libdir}/libdevmapper.a
777
778 %if %{with initrd}
779 %files -n device-mapper-initrd
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/initrd/dmsetup
782
783 %files initrd
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_libdir}/initrd/lvm
786 %endif
This page took 0.071521 seconds and 2 git commands to generate.