]> git.pld-linux.org Git - packages/lvm2.git/blob - lvm2.spec
54d6222c7a443d88b8950a49aac929590b4ed145
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - internal vs shared for cluster,snapshots,mirrors,thin,cache ?
4 #   note: dmeventd requires mirrors=internal)
5 #
6 # Conditional build:
7 # - initrd stuff
8 %bcond_with     initrd          # build initrd version
9 # - functionality
10 %bcond_without  cluster         # disable all cluster support (cmirrord)
11 %bcond_without  lvmdbusd        # lvmdbusd
12 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
13 %bcond_without  lvmlockd        # lvmlockd
14 %bcond_with     sanlock         # sanlock support in lvmlockd
15 # - additional features
16 %bcond_without  selinux         # SELinux support
17 # - bindings
18 %bcond_without  python          # Python bindings
19 %bcond_without  python2         # Python 2 binding
20 %bcond_without  python3         # Python 3 binding and lvmdbusd
21
22 # lvmlockd requires lvmpolld
23 %if %{without lvmpolld}
24 %undefine       with_lvmpolld
25 %endif
26
27 # for convenience
28 %if %{without python}
29 %undefine       with_python2
30 %undefine       with_python3
31 %endif
32 %if %{without python3}
33 %undefine       with_lvmdbusd
34 %endif
35
36 Summary:        The new version of Logical Volume Manager for Linux
37 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
38 Name:           lvm2
39 Version:        2.03.07
40 Release:        0.2
41 License:        GPL v2 and LGPL v2.1
42 Group:          Applications/System
43 Source0:        ftp://sourceware.org/pub/lvm2/LVM2.%{version}.tgz
44 # Source0-md5:  5c06a01e1adacb96761188d6a8a17a2e
45 Patch0:         device-mapper-dmsetup-export.patch
46 Patch1:         %{name}-pld_init.patch
47 Patch2:         device-mapper-dmsetup-deps-export.patch
48 Patch3:         %{name}-thin.patch
49 URL:            http://www.sourceware.org/lvm2/
50 BuildRequires:  autoconf >= 2.69
51 BuildRequires:  automake
52 # for /run detection
53 BuildRequires:  filesystem >= 3.0-43
54 BuildRequires:  libaio-devel
55 BuildRequires:  libblkid-devel >= 2.24
56 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
57 %{?with_selinux:BuildRequires:  libsepol-devel}
58 BuildRequires:  ncurses-devel
59 BuildRequires:  pkgconfig
60 %{?with_python2:BuildRequires:  python-devel >= 2}
61 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
62 %if %{with lvmdbusd}
63 BuildRequires:  python3-dbus
64 BuildRequires:  python3-pyudev
65 %endif
66 BuildRequires:  readline-devel
67 BuildRequires:  rpmbuild(macros) >= 1.647
68 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
69 BuildRequires:  systemd-devel >= 1:221
70 BuildRequires:  udev-devel >= 1:176
71 %if %{with initrd}
72 %{?with_selinux:BuildRequires:  libselinux-static}
73 %{?with_selinux:BuildRequires:  libsepol-static}
74 BuildRequires:  glibc-static
75 %else
76 Obsoletes:      lvm2-initrd
77 %endif
78 %if %{with cluster}
79 BuildRequires:  corosync-devel
80 BuildRequires:  dlm-devel >= 3.99.5
81 %endif
82 Requires(post,preun,postun):    systemd-units >= 38
83 Requires(post,postun):  /sbin/chkconfig
84 Requires:       device-mapper >= %{version}-%{release}
85 %{?with_selinux:Requires:       libselinux >= 1.10}
86 Requires:       systemd-units >= 38
87 # doesn't work with 2.4 kernels
88 Requires:       uname(release) >= 2.6
89 Suggests:       thin-provisioning-tools >= 0.5.4
90 Obsoletes:      lvm
91 Obsoletes:      lvm2-systemd
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define         _sbindir        /sbin
95 %define         _usrsbindir     /usr/sbin
96
97 # changing CFLAGS in the middle confuses confcache
98 %undefine       configure_cache
99
100 # borken on AC
101 %define         filterout_ld    -Wl,--as-needed
102
103 # causes: undefined reference to `__stack_chk_fail_local'
104 %define         filterout_c     -fstack-protector
105
106 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*' 'liblvm2cmd.so.*'
107
108 %description
109 This package includes a number of utilities for creating, checking,
110 and repairing logical volumes.
111
112 %description -l pl.UTF-8
113 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
114 logicznych wolumenów dyskowych (LVM2).
115
116 %package initrd
117 Summary:        The new version of Logical Volume Manager for Linux - initrd version
118 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
119 Group:          Base
120 Conflicts:      geninitrd < 10000.18
121
122 %description initrd
123 This package includes a number of utilities for creating, checking,
124 and repairing logical volumes - staticaly linked for initrd.
125
126 %description initrd -l pl.UTF-8
127 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
128 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
129 potrzeby initrd.
130
131 %package cmirrord
132 Summary:        Cluster mirror log daemon
133 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
134 Group:          Applications/System
135 Requires:       %{name} = %{version}-%{release}
136
137 %description cmirrord
138 cmirrord is the daemon that tracks mirror log information in a
139 cluster. It is specific to device-mapper based mirrors (and by
140 extension, LVM cluster mirrors). Cluster mirrors are not possible
141 without this daemon running.
142
143 This daemon relies on the cluster infrastructure provided by the
144 Cluster MANager (CMAN), which must be set up and running in order for
145 cmirrord to function.
146
147 %description cmirrord
148 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
149 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
150 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
151 lustrzanych ten demon jest niezbędny.
152
153 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
154 (Cluster MANager), który musi być skonfigurowany i działający, aby
155 działał cmirrord.
156
157 %package dbusd
158 Summary:        LVM2 D-Bus daemon
159 Summary(pl.UTF-8):      Demon LVM2 D-Bus
160 Group:          Daemons
161 Requires(post,preun,postun):    systemd-units >= 38
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       python3-dbus
164 Requires:       python3-pygobject3 >= 3
165 Requires:       python3-pyudev
166
167 %description dbusd
168 Daemon for access to LVM2 functionality through a D-Bus interface.
169
170 %description dbusd -l pl.UTF-8
171 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
172 D-Bus.
173
174 %package lockd
175 Summary:        LVM2 locking daemon
176 Summary(pl.UTF-8):      Demon blokad LVM2
177 Group:          Daemons
178 Requires(post,preun,postun):    systemd-units >= 38
179 Requires:       %{name} = %{version}-%{release}
180 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
181 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
182
183 %description lockd
184 LVM commands use lvmlockd to coordinate access to shared storage.
185
186 %description lockd -l pl.UTF-8
187 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
188 współdzielonej pamięci masowej.
189
190 %package resource-agents
191 Summary:        OCF Resource Agents for LVM2 processes
192 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
193 Group:          Applications/System
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       resource-agents
196
197 %description resource-agents
198 OCF Resource Agents for LVM2 processes.
199
200 %description resource-agents -l pl.UTF-8
201 Agenci OCF do monitorowania procesów LVM2.
202
203 %package -n python-lvm
204 Summary:        Python 2 interface to LVM2
205 Summary(pl.UTF-8):      Interfejs Pythona 2 do LVM2
206 Group:          Libraries/Python
207 Requires:       device-mapper-libs = %{version}-%{release}
208
209 %description -n python-lvm
210 Python 2 interface to LVM2.
211
212 %description -n python-lvm -l pl.UTF-8
213 Interfejs Pythona 2 do LVM2.
214
215 %package -n python3-lvm
216 Summary:        Python 3 interface to LVM2
217 Summary(pl.UTF-8):      Interfejs Pythona 3 do LVM2
218 Group:          Libraries/Python
219 Requires:       device-mapper-libs = %{version}-%{release}
220
221 %description -n python3-lvm
222 Python 3 interface to LVM2.
223
224 %description -n python3-lvm -l pl.UTF-8
225 Interfejs Pythona 3 do LVM2.
226
227 %package -n device-mapper
228 Summary:        Userspace support for the device-mapper
229 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
230 Group:          Base
231 Requires(post,postun):  /sbin/ldconfig
232 Requires(post,preun,postun):    systemd-units >= 38
233 Requires:       device-mapper-libs = %{version}-%{release}
234 Requires:       systemd-units >= 38
235
236 %description -n device-mapper
237 The goal of this driver is to support volume management. The driver
238 enables the definition of new block devices composed of ranges of
239 sectors of existing devices. This can be used to define disk
240 partitions - or logical volumes. This light-weight kernel component
241 can support user-space tools for logical volume management.
242
243 %description -n device-mapper -l pl.UTF-8
244 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
245 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
246 sektorów na istniejących urządzeniach. Może to być wykorzystane do
247 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
248 składnik jądra może wspierać działające w przestrzeni użytkownika
249 narzędzia do zarządzania logicznymi wolumenami.
250
251 %package -n device-mapper-libs
252 Summary:        Device-mapper shared libraries
253 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
254 Group:          Libraries
255 Requires:       libblkid >= 2.24
256 Requires:       udev-libs >= 1:176
257 Conflicts:      device-mapper < 2.02.119-1
258
259 %description -n device-mapper-libs
260 Device-mapper shared libraries.
261
262 %description -n device-mapper-libs -l pl.UTF-8
263 Biblioteki współdzielone device-mappera.
264
265 %package -n device-mapper-devel
266 Summary:        Header files for device-mapper libraries
267 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
268 Group:          Development/Libraries
269 Requires:       device-mapper-libs = %{version}-%{release}
270 Requires:       libblkid-devel >= 2.24
271 %if %{with selinux}
272 Requires:       libselinux-devel
273 Requires:       libsepol-devel
274 %endif
275 Requires:       udev-devel >= 1:176
276
277 %description -n device-mapper-devel
278 Header files for device-mapper libraries.
279
280 %description -n device-mapper-devel -l pl.UTF-8
281 Pliki nagłówkowe bibliotek device-mappera.
282
283 %package -n device-mapper-static
284 Summary:        Static devmapper library
285 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
286 License:        LGPL v2.1
287 Group:          Development/Libraries
288 Requires:       device-mapper-devel = %{version}-%{release}
289
290 %description -n device-mapper-static
291 Static devmapper library.
292
293 %description -n device-mapper-static -l pl.UTF-8
294 Statyczna biblioteka devmapper.
295
296 %package -n device-mapper-initrd
297 Summary:        Userspace support for the device-mapper - initrd version
298 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
299 Group:          Base
300 Obsoletes:      device-mapper-initrd-devel
301 Conflicts:      geninitrd < 10000.10
302
303 %description -n device-mapper-initrd
304 The goal of this driver is to support volume management. The driver
305 enables the definition of new block devices composed of ranges of
306 sectors of existing devices. This can be used to define disk
307 partitions - or logical volumes. This light-weight kernel component
308 can support user-space tools for logical volume management.
309
310 This package contains dmsetup program linked staticaly for use in
311 initrd.
312
313 %description -n device-mapper-initrd -l pl.UTF-8
314 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
315 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
316 sektorów na istniejących urządzeniach. Może to być wykorzystane do
317 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
318 składnik jądra może wspierać działające w przestrzeni użytkownika
319 narzędzia do zarządzania logicznymi wolumenami.
320
321 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
322 potrzeby initrd.
323
324 %prep
325 %setup -q -n LVM2.%{version}
326 %patch0 -p1
327 %patch1 -p1
328 %patch2 -p1
329 %patch3 -p1
330
331 # do not force --export-symbol linker option for e.g. statically linked executables
332 # -rdynamic compiler option drives linker in the right way.
333 #%{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.ac
334
335 %build
336 cp -f /usr/share/automake/config.sub autoconf
337 %{__aclocal}
338 %{__autoconf}
339
340 %if %{with initrd}
341
342 %configure \
343         %{?debug:--enable-debug} \
344         --disable-nls \
345         --disable-readline \
346         --enable-selinux \
347         --enable-static_link \
348         --with-optimisation="%{rpmcflags} -Os"
349
350 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
351 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
352
353 %{__make} -j1 -C include V=1
354 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB= V=1
355 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB= V=1
356 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB= V=1
357 %{__make} -j1 -C tools dmsetup.static lvm.static V=1
358 %{__mv} tools/lvm.static initrd-lvm
359 %{__mv} tools/dmsetup.static initrd-dmsetup
360
361 # check if tools works
362 for tool in initrd-lvm initrd-dmsetup; do
363         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
364         if [ $rc -gt 127 ]; then
365                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
366                 exit 1
367         fi
368 done
369
370 %{__make} clean
371
372 unset CC
373 %endif
374
375 %configure \
376         --enable-applib \
377         --enable-cache_check_needs_check \
378         --enable-cmdlib \
379         %{?with_lvmdbusd:--enable-dbus-service} \
380         %{?debug:--enable-debug} \
381         --enable-dmeventd \
382         --enable-fsadm \
383         --with-default-locking-dir=/var/lock/lvm \
384 %if %{with lvmlockd}
385         %{?with_cluster:--enable-lvmlockd-dlm} \
386         %{?with_sanlock:--enable-lvmlockd-sanlock} \
387 %endif
388         --enable-lvmpolld \
389         --enable-ocf \
390         %{?with_python2:--enable-python2_bindings} \
391         %{?with_python3:--enable-python3_bindings} \
392         --enable-readline \
393         %{!?with_selinux:--disable-selinux} \
394         --enable-pkgconfig \
395         --enable-thin_check_needs_check \
396         --enable-udev_sync \
397         --enable-udev_rules \
398         --with-cache=internal \
399         --with-cache-check=/usr/sbin/cache_check \
400         --with-cache-dump=/usr/sbin/cache_dump \
401         --with-cache-repair=/usr/sbin/cache_repair \
402         --with-cache-restore=/usr/sbin/cache_restore \
403         --with-cluster=internal \
404 %if %{with cluster}
405         --enable-cmirrord \
406 %endif
407         --with-dmeventd-path=%{_sbindir}/dmeventd \
408         --with-interface=ioctl \
409         --with-lvm1=internal \
410         --with-mirrors=internal \
411         --with-optimisation="%{rpmcflags}" \
412         --with-snapshots=internal \
413         --with-systemdsystemunitdir=%{systemdunitdir} \
414         --with-tmpfilesdir=%{systemdtmpfilesdir} \
415         --with-thin=internal \
416         --with-thin-check=/usr/sbin/thin_check \
417         --with-thin-dump=/usr/sbin/thin_dump \
418         --with-thin-repair=/usr/sbin/thin_repair \
419         --with-thin-restore=/usr/sbin/thin_restore \
420         --with-udev-prefix=/ \
421         --with-writecache=internal \
422         --with-usrlibdir=%{_libdir}
423
424 # use bash because of "set -o pipefail"
425 %{__make} -j1 \
426         SHELL=/bin/bash \
427         V=1
428 %{__make} -j1 -C libdm \
429         LIB_STATIC=libdevmapper.a \
430         V=1
431
432 %install
433 rm -rf $RPM_BUILD_ROOT
434 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig,/var/lock/lvm/subsys}
435
436 %{__make} install install_system_dirs install_systemd_units install_initscripts install_tmpfiles_configuration \
437         DESTDIR=$RPM_BUILD_ROOT \
438         OWNER="" \
439         GROUP="" \
440         V=1 \
441         python3dir=%{py3_sitescriptdir}
442
443 %{__make} -C scripts install_tmpfiles_configuration \
444         DESTDIR=$RPM_BUILD_ROOT \
445         V=1
446
447 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
448 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
449         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
450         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
451         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
452 done
453
454 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
455
456 %if %{with initrd}
457 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
458 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
459 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
460 %endif
461
462 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
463
464 %clean
465 rm -rf $RPM_BUILD_ROOT
466
467 %post
468 /sbin/chkconfig --add lvm2-monitor
469 %service lvm2-monitor restart
470 %systemd_post lvm2-monitor.service
471 /sbin/chkconfig --add blk-availability
472 # no service blk-availability restart
473 %systemd_post blk-availability.service
474 %if %{with lvmpolld}
475 %systemd_post lvm2-lvmpolld.socket
476 %endif
477
478 %preun
479 %systemd_preun lvm2-monitor.service
480 %systemd_preun blk-availability.service
481 %if %{with lvmpolld}
482 %systemd_preun lvm2-lvmpolld.socket
483 %endif
484
485 %postun
486 if [ "$1" = "0" ]; then
487         %service lvm2-monitor stop
488         /sbin/chkconfig --del lvm2-monitor
489         #no service blk-availability stop
490         /sbin/chkconfig --del blk-availability
491 fi
492 %systemd_reload
493
494 %triggerpostun -- %{name} < 2.02.94-1
495 %systemd_trigger lvm2-monitor.service
496
497 %post -n device-mapper
498 %systemd_post dm-event.socket
499
500 %preun -n device-mapper
501 %systemd_preun dm-event.socket dm-event.service
502
503 %postun -n device-mapper
504 %systemd_reload
505
506 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
507 %systemd_trigger dm-event.socket
508
509 %post   -n device-mapper-libs -p /sbin/ldconfig
510 %postun -n device-mapper-libs -p /sbin/ldconfig
511
512 %post dbusd
513 %systemd_post lvm2-lvmdbusd.service
514
515 %preun dbusd
516 %systemd_preun lvm2-lvmdbusd.service
517
518 %postun dbusd
519 %systemd_reload
520
521 %post lockd
522 %systemd_post lvm2-lvmlockd.service lvm2-lvmlocking.service
523
524 %preun lockd
525 %systemd_preun lvm2-lvmlockd.service lvm2-lvmlocking.service
526
527 %postun lockd
528 %systemd_reload
529
530 %files
531 %defattr(644,root,root,755)
532 %doc README WHATS_NEW doc/*
533 %attr(755,root,root) %{_sbindir}/blkdeactivate
534 %attr(755,root,root) %{_sbindir}/fsadm
535 %attr(755,root,root) %{_sbindir}/lvchange
536 %attr(755,root,root) %{_sbindir}/lvconvert
537 %attr(755,root,root) %{_sbindir}/lvcreate
538 %attr(755,root,root) %{_sbindir}/lvdisplay
539 %attr(755,root,root) %{_sbindir}/lvextend
540 %attr(755,root,root) %{_sbindir}/lvm
541 #%attr(755,root,root) %{_sbindir}/lvmconf
542 %attr(755,root,root) %{_sbindir}/lvmconfig
543 %attr(755,root,root) %{_sbindir}/lvmdiskscan
544 %attr(755,root,root) %{_sbindir}/lvmdump
545 %attr(755,root,root) %{_sbindir}/lvmsadc
546 %attr(755,root,root) %{_sbindir}/lvmsar
547 %attr(755,root,root) %{_sbindir}/lvreduce
548 %attr(755,root,root) %{_sbindir}/lvremove
549 %attr(755,root,root) %{_sbindir}/lvrename
550 %attr(755,root,root) %{_sbindir}/lvresize
551 %attr(755,root,root) %{_sbindir}/lvs
552 %attr(755,root,root) %{_sbindir}/lvscan
553 %attr(755,root,root) %{_sbindir}/pvchange
554 %attr(755,root,root) %{_sbindir}/pvck
555 %attr(755,root,root) %{_sbindir}/pvcreate
556 %attr(755,root,root) %{_sbindir}/pvdisplay
557 %attr(755,root,root) %{_sbindir}/pvmove
558 %attr(755,root,root) %{_sbindir}/pvremove
559 %attr(755,root,root) %{_sbindir}/pvresize
560 %attr(755,root,root) %{_sbindir}/pvs
561 %attr(755,root,root) %{_sbindir}/pvscan
562 %attr(755,root,root) %{_sbindir}/vgcfgbackup
563 %attr(755,root,root) %{_sbindir}/vgcfgrestore
564 %attr(755,root,root) %{_sbindir}/vgchange
565 %attr(755,root,root) %{_sbindir}/vgck
566 %attr(755,root,root) %{_sbindir}/vgconvert
567 %attr(755,root,root) %{_sbindir}/vgcreate
568 %attr(755,root,root) %{_sbindir}/vgdisplay
569 %attr(755,root,root) %{_sbindir}/vgexport
570 %attr(755,root,root) %{_sbindir}/vgextend
571 %attr(755,root,root) %{_sbindir}/vgimport
572 %attr(755,root,root) %{_sbindir}/vgimportclone
573 %attr(755,root,root) %{_sbindir}/vgmerge
574 %attr(755,root,root) %{_sbindir}/vgmknodes
575 %attr(755,root,root) %{_sbindir}/vgreduce
576 %attr(755,root,root) %{_sbindir}/vgremove
577 %attr(755,root,root) %{_sbindir}/vgrename
578 %attr(755,root,root) %{_sbindir}/vgs
579 %attr(755,root,root) %{_sbindir}/vgscan
580 %attr(755,root,root) %{_sbindir}/vgsplit
581 %{_mandir}/man5/lvm.conf.5*
582 %{_mandir}/man7/lvmcache.7*
583 %{_mandir}/man7/lvmraid.7*
584 %{_mandir}/man7/lvmreport.7*
585 %{_mandir}/man7/lvmsystemid.7*
586 %{_mandir}/man7/lvmthin.7*
587 %{_mandir}/man8/blkdeactivate.8*
588 %{_mandir}/man8/fsadm.8*
589 %{_mandir}/man8/lvchange.8*
590 %{_mandir}/man8/lvconvert.8*
591 %{_mandir}/man8/lvcreate.8*
592 %{_mandir}/man8/lvdisplay.8*
593 %{_mandir}/man8/lvextend.8*
594 %{_mandir}/man8/lvm-config.8*
595 %{_mandir}/man8/lvm-dumpconfig.8*
596 %{_mandir}/man8/lvm-fullreport.8*
597 %{_mandir}/man8/lvm-lvpoll.8*
598 %{_mandir}/man8/lvm.8*
599 #%{_mandir}/man8/lvmconf.8*
600 %{_mandir}/man8/lvmconfig.8*
601 %{_mandir}/man8/lvmdiskscan.8*
602 %{_mandir}/man8/lvmdump.8*
603 %{_mandir}/man8/lvmsadc.8*
604 %{_mandir}/man8/lvmsar.8*
605 %{_mandir}/man8/lvreduce.8*
606 %{_mandir}/man8/lvremove.8*
607 %{_mandir}/man8/lvrename.8*
608 %{_mandir}/man8/lvresize.8*
609 %{_mandir}/man8/lvs.8*
610 %{_mandir}/man8/lvscan.8*
611 %{_mandir}/man8/pvchange.8*
612 %{_mandir}/man8/pvck.8*
613 %{_mandir}/man8/pvcreate.8*
614 %{_mandir}/man8/pvdisplay.8*
615 %{_mandir}/man8/pvmove.8*
616 %{_mandir}/man8/pvremove.8*
617 %{_mandir}/man8/pvresize.8*
618 %{_mandir}/man8/pvs.8*
619 %{_mandir}/man8/pvscan.8*
620 %{_mandir}/man8/vgcfgbackup.8*
621 %{_mandir}/man8/vgcfgrestore.8*
622 %{_mandir}/man8/vgchange.8*
623 %{_mandir}/man8/vgck.8*
624 %{_mandir}/man8/vgconvert.8*
625 %{_mandir}/man8/vgcreate.8*
626 %{_mandir}/man8/vgdisplay.8*
627 %{_mandir}/man8/vgexport.8*
628 %{_mandir}/man8/vgextend.8*
629 %{_mandir}/man8/vgimport.8*
630 %{_mandir}/man8/vgimportclone.8*
631 %{_mandir}/man8/vgmerge.8*
632 %{_mandir}/man8/vgmknodes.8*
633 %{_mandir}/man8/vgreduce.8*
634 %{_mandir}/man8/vgremove.8*
635 %{_mandir}/man8/vgrename.8*
636 %{_mandir}/man8/vgs.8*
637 %{_mandir}/man8/vgscan.8*
638 %{_mandir}/man8/vgsplit.8*
639 %attr(750,root,root) %dir %{_sysconfdir}/lvm
640 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
641 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
642 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
643 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
644 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
645 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
647 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
648 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
649 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/vdo-small.profile
650 %{systemdtmpfilesdir}/lvm2.conf
651 %{systemdunitdir}/blk-availability.service
652 %{systemdunitdir}/lvm2-monitor.service
653 %{systemdunitdir}/lvm2-pvscan@.service
654 %dir %{_sysconfdir}/lvm/cache
655 %ghost %{_sysconfdir}/lvm/cache/.cache
656 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
657 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
658 %attr(700,root,root) %dir /run/lvm
659 %attr(700,root,root) %dir /var/lock/lvm
660 %attr(700,root,root) %dir /var/lock/lvm/subsys
661 %if %{with lvmlockd}
662 %attr(755,root,root) %{_sbindir}/lvmlockctl
663 %attr(755,root,root) %{_sbindir}/lvmlockd
664 %{systemdunitdir}/lvmlockd.service
665 %{systemdunitdir}/lvmlocks.service
666 %{_mandir}/man8/lvmlockctl.8*
667 %{_mandir}/man8/lvmlockd.8*
668 %endif
669 %if %{with lvmpolld}
670 %attr(755,root,root) %{_sbindir}/lvmpolld
671 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
672 %{systemdunitdir}/lvm2-lvmpolld.service
673 %{systemdunitdir}/lvm2-lvmpolld.socket
674 %{_mandir}/man8/lvmpolld.8*
675 %endif
676
677 %if %{with cluster}
678 %files cmirrord
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_usrsbindir}/cmirrord
681 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
682 %{systemdunitdir}/lvm2-cmirrord.service
683 %{_mandir}/man8/cmirrord.8*
684 %endif
685
686 %if %{with lvmdbusd}
687 %files dbusd
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_sbindir}/lvmdbusd
690 %{py3_sitescriptdir}/lvmdbusd
691 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
692 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/com.redhat.lvmdbus1.conf
693 %{_datadir}/dbus-1/system-services/com.redhat.lvmdbus1.service
694 %{systemdunitdir}/lvm2-lvmdbusd.service
695 %{_mandir}/man8/lvmdbusd.8*
696 %endif
697
698 %files resource-agents
699 %defattr(644,root,root,755)
700 %dir %{_prefix}/lib/ocf/resource.d/lvm2
701 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
702
703 %if %{with python2}
704 %files -n python-lvm
705 %defattr(644,root,root,755)
706 #%attr(755,root,root) %{py_sitedir}/lvm.so
707 #%{py_sitedir}/lvm-%{version}_*-py*.egg-info
708 %endif
709
710 %if %{with python3}
711 %files -n python3-lvm
712 %defattr(644,root,root,755)
713 #%attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
714 #%{py3_sitedir}/lvm-%{version}_*-py*.egg-info
715 %endif
716
717 %files -n device-mapper
718 %defattr(644,root,root,755)
719 %doc *_DM
720 %{systemdunitdir}/dm-event.service
721 %{systemdunitdir}/dm-event.socket
722 /lib/udev/rules.d/10-dm.rules
723 /lib/udev/rules.d/11-dm-lvm.rules
724 /lib/udev/rules.d/13-dm-disk.rules
725 /lib/udev/rules.d/95-dm-notify.rules
726 /lib/udev/rules.d/69-dm-lvm-metad.rules
727 %attr(755,root,root) %{_sbindir}/dmeventd
728 %attr(755,root,root) %{_sbindir}/dmsetup
729 %attr(755,root,root) %{_sbindir}/dmstats
730 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
731 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
732 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
733 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
734 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2vdo.so
735 %dir %{_libdir}/device-mapper
736 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
737 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
738 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
739 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
740 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
741 %{_mandir}/man7/lvmvdo.7*
742 %{_mandir}/man8/dmsetup.8*
743 %{_mandir}/man8/dmstats.8*
744 %{_mandir}/man8/dmeventd.8*
745
746 %files -n device-mapper-libs
747 %defattr(644,root,root,755)
748 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
749 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
750 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
751 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
752
753 %files -n device-mapper-devel
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_libdir}/libdevmapper.so
756 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
757 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
758 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
759 %{_includedir}/libdevmapper.h
760 %{_includedir}/libdevmapper-event.h
761 %{_includedir}/lvm2cmd.h
762 %{_pkgconfigdir}/devmapper.pc
763 %{_pkgconfigdir}/devmapper-event.pc
764
765 %files -n device-mapper-static
766 %defattr(644,root,root,755)
767 %{_libdir}/libdevmapper.a
768
769 %if %{with initrd}
770 %files -n device-mapper-initrd
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{_libdir}/initrd/dmsetup
773
774 %files initrd
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_libdir}/initrd/lvm
777 %endif
This page took 0.118648 seconds and 2 git commands to generate.