]> git.pld-linux.org Git - packages/lvm2.git/blob - lvm2.spec
2d129ea608ac08143968ed3ed7e912c2a2b3d44e
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - --with-replicators (=internal/shared/none, default is none)?
4 # - fix initscripts:
5 #   # service lvm2-lvmetad start
6 #   /etc/rc.d/init.d/lvm2-lvmetad: line 55: action: command not found
7 #
8 # Conditional build:
9 # - initrf stuff
10 %bcond_with     initrd          # build initrd version
11 %bcond_without  uClibc          # link initrd version with uClibc
12 %bcond_with     dietlibc        # link initrd version with dietlibc
13 %bcond_with     glibc           # link initrd version with static GLIBC
14 # - functionality
15 %bcond_without  cluster         # disable all cluster support (clvmd&cmirrord)
16 %bcond_without  lvmetad         # disable lvmetad (and lvmlockd)
17 %bcond_without  lvmpolld        # disable lvmpolld (and lvmlockd)
18 %bcond_without  lvmlockd        # disable lvmlockd
19 %bcond_with     sanlock         # sanlock support in lvmlockd
20 %bcond_with     replicator      # internal replicator support
21 # - additional features
22 %bcond_without  selinux         # SELinux support
23 # - bindings
24 %bcond_without  python          # Python binding
25
26 # lvmlockd requires lvmetad and lvmpolld
27 %if %{without lvmetad} || %{without lvmpolld}
28 %undefine       with_lvmpolld
29 %endif
30
31 # only glibc possible on SPARC
32 %ifarch sparc sparcv9 sparc64
33 %define         with_glibc 1
34 %endif
35 # if one of the *libc is enabled disable default dietlibc
36 %if %{with dietlibc} && %{with uClibc}
37 %undefine       with_dietlibc
38 %endif
39 # with glibc disables default dietlibc
40 %if %{with glibc} && %{with dietlibc}
41 %undefine       with_dietlibc
42 %endif
43 # fallback is glibc if neither alternatives are enabled
44 %if %{without dietlibc} && %{without uClibc}
45 %define         with_glibc      1
46 %endif
47
48 Summary:        The new version of Logical Volume Manager for Linux
49 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
50 Name:           lvm2
51 Version:        2.02.132
52 Release:        3
53 License:        GPL v2 and LGPL v2.1
54 Group:          Applications/System
55 Source0:        ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
56 # Source0-md5:  80af5af726949bbbb2aceb15b24b7d20
57 Source2:        clvmd.service
58 Source3:        clvmd.sysconfig
59 Patch0:         %{name}-selinux.patch
60 Patch1:         %{name}-diet.patch
61 Patch2:         device-mapper-dmsetup-export.patch
62 Patch3:         %{name}-pld_init.patch
63 Patch4:         dl-dlsym.patch
64 Patch6:         %{name}-lvm_path.patch
65 Patch7:         %{name}-sd_notify.patch
66 Patch8:         %{name}-clvmd_cmd_timeout.patch
67 Patch9:         device-mapper-dmsetup-deps-export.patch
68 URL:            http://www.sourceware.org/lvm2/
69 BuildRequires:  autoconf >= 2.61
70 BuildRequires:  automake
71 # for /run detection
72 BuildRequires:  filesystem >= 3.0-43
73 BuildRequires:  libblkid-devel >= 2.24
74 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
75 %{?with_selinux:BuildRequires:  libsepol-devel}
76 BuildRequires:  ncurses-devel
77 BuildRequires:  pkgconfig
78 %{?with_python:BuildRequires:   python-devel >= 2}
79 BuildRequires:  readline-devel
80 BuildRequires:  rpmbuild(macros) >= 1.647
81 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.2.4}
82 BuildRequires:  systemd-devel >= 1:205
83 BuildRequires:  udev-devel >= 1:176
84 %if %{with initrd}
85 %if %{with dietlibc}
86 BuildRequires:  dietlibc-static >= 2:0.32-7
87 BuildConflicts: device-mapper-dietlibc
88 %endif
89 %if %{with glibc}
90 %{?with_selinux:BuildRequires:  libselinux-static}
91 %{?with_selinux:BuildRequires:  libsepol-static}
92 %endif
93 %{?with_glibc:BuildRequires:    glibc-static}
94 %{?with_uClibc:BuildRequires:   uClibc-static >= 2:0.9.29}
95 %endif
96 %if %{with cluster}
97 BuildRequires:  corosync-devel
98 BuildRequires:  dlm-devel >= 3.99.5
99 %endif
100 Requires(post,preun,postun):    systemd-units >= 38
101 Requires(post,postun):  /sbin/chkconfig
102 Requires:       device-mapper >= %{version}-%{release}
103 %{?with_selinux:Requires:       libselinux >= 1.10}
104 Requires:       systemd-units >= 38
105 # doesn't work with 2.4 kernels
106 Requires:       uname(release) >= 2.6
107 Suggests:       thin-provisioning-tools >= 0.5.4
108 Obsoletes:      lvm
109 Obsoletes:      lvm2-systemd
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define         _sbindir        /sbin
113 %define         _usrsbindir     /usr/sbin
114
115 # changing CFLAGS in the middle confuses confcache
116 %undefine       configure_cache
117
118 # borken on AC
119 %define         filterout_ld    -Wl,--as-needed
120
121 # causes: undefined reference to `__stack_chk_fail_local'
122 %define         filterout_c     -fstack-protector
123
124 # for some reason known only to rpm there must be "\\|" not "\|" here
125 %define         dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
126 %define         dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
127
128 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*'
129
130 %description
131 This package includes a number of utilities for creating, checking,
132 and repairing logical volumes.
133
134 %description -l pl.UTF-8
135 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
136 logicznych wolumenów dyskowych (LVM2).
137
138 %package initrd
139 Summary:        The new version of Logical Volume Manager for Linux - initrd version
140 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
141 Group:          Base
142 Conflicts:      geninitrd < 10000.18
143
144 %description initrd
145 This package includes a number of utilities for creating, checking,
146 and repairing logical volumes - staticaly linked for initrd.
147
148 %description initrd -l pl.UTF-8
149 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
150 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
151 potrzeby initrd.
152
153 %package clvmd
154 Summary:        Cluster LVM daemon
155 Summary(pl.UTF-8):      Demon clustra LVM
156 Group:          Applications/System
157 Requires:       %{name} = %{version}-%{release}
158
159 %description clvmd
160 clvmd is the daemon that distributes LVM metadata updates around a
161 cluster. It must be running on all nodes in the cluster and will give
162 an error if a node in the cluster does not have this daemon running.
163
164 %description clvmd -l pl.UTF-8
165 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
166 Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
167 węzeł w klastrze nie ma tego demona uruchomionego.
168
169 %package cmirrord
170 Summary:        Cluster mirror log daemon
171 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
172 Group:          Applications/System
173 Requires:       %{name} = %{version}-%{release}
174
175 %description cmirrord
176 cmirrord is the daemon that tracks mirror log information in a
177 cluster. It is specific to device-mapper based mirrors (and by
178 extension, LVM cluster mirrors). Cluster mirrors are not possible
179 without this daemon running.
180
181 This daemon relies on the cluster infrastructure provided by the
182 Cluster MANager (CMAN), which must be set up and running in order for
183 cmirrord to function.
184
185 %description cmirrord
186 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
187 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
188 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
189 lustrzanych ten demon jest niezbędny.
190
191 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
192 (Cluster MANager), który musi być skonfigurowany i działający, aby
193 działał cmirrord.
194
195 %package resource-agents
196 Summary:        OCF Resource Agents for LVM2 processes
197 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
198 Group:          Applications/System
199 Requires:       %{name} = %{version}-%{release}
200 Requires:       resource-agents
201
202 %description resource-agents
203 OCF Resource Agents for LVM2 processes.
204
205 %description resource-agents -l pl.UTF-8
206 Agenci OCF do monitorowania procesów LVM2.
207
208 %package -n python-lvm
209 Summary:        Python interface to LVM2
210 Summary(pl.UTF-8):      Interfejs Pythona do LVM2
211 Group:          Libraries/Python
212 Requires:       device-mapper-libs = %{version}-%{release}
213
214 %description -n python-lvm
215 Python interface to LVM2.
216
217 %description -n python-lvm -l pl.UTF-8
218 Interfejs Pythona do LVM2.
219
220 %package -n device-mapper
221 Summary:        Userspace support for the device-mapper
222 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
223 Group:          Base
224 Requires(post,postun):  /sbin/ldconfig
225 Requires(post,preun,postun):    systemd-units >= 38
226 Requires:       device-mapper-libs = %{version}-%{release}
227 Requires:       systemd-units >= 38
228
229 %description -n device-mapper
230 The goal of this driver is to support volume management. The driver
231 enables the definition of new block devices composed of ranges of
232 sectors of existing devices. This can be used to define disk
233 partitions - or logical volumes. This light-weight kernel component
234 can support user-space tools for logical volume management.
235
236 %description -n device-mapper -l pl.UTF-8
237 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
238 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
239 sektorów na istniejących urządzeniach. Może to być wykorzystane do
240 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
241 składnik jądra może wspierać działające w przestrzeni użytkownika
242 narzędzia do zarządzania logicznymi wolumenami.
243
244 %package -n device-mapper-libs
245 Summary:        Device-mapper shared libraries
246 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
247 Group:          Libraries
248 Conflicts:      device-mapper < 2.02.119-1
249 Requires:       libblkid >= 2.24
250 Requires:       udev-libs >= 1:176
251
252 %description -n device-mapper-libs
253 Device-mapper shared libraries.
254
255 %description -n device-mapper-libs -l pl.UTF-8
256 Biblioteki współdzielone device-mappera.
257
258 %package -n device-mapper-devel
259 Summary:        Header files for device-mapper libraries
260 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
261 Group:          Development/Libraries
262 Requires:       device-mapper-libs = %{version}-%{release}
263 Requires:       libblkid-devel >= 2.24
264 %if %{with selinux}
265 Requires:       libselinux-devel
266 Requires:       libsepol-devel
267 %endif
268 Requires:       udev-devel >= 1:176
269
270 %description -n device-mapper-devel
271 Header files for device-mapper libraries.
272
273 %description -n device-mapper-devel -l pl.UTF-8
274 Pliki nagłówkowe bibliotek device-mappera.
275
276 %package -n device-mapper-static
277 Summary:        Static devmapper library
278 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
279 License:        LGPL v2.1
280 Group:          Development/Libraries
281 Requires:       device-mapper-devel = %{version}-%{release}
282
283 %description -n device-mapper-static
284 Static devmapper library.
285
286 %description -n device-mapper-static -l pl.UTF-8
287 Statyczna biblioteka devmapper.
288
289 %package -n device-mapper-dietlibc
290 Summary:        Static devmapper library built with dietlibc
291 Summary(pl.UTF-8):      Statyczna biblioteka devmapper zbudowana z dietlibc
292 License:        LGPL v2.1
293 Group:          Development/Libraries
294 Requires:       device-mapper-devel = %{version}-%{release}
295
296 %description -n device-mapper-dietlibc
297 Static devmapper library built with dietlibc.
298
299 %description -n device-mapper-dietlibc -l pl.UTF-8
300 Statyczna biblioteka devmapper zbudowana z dietlibc.
301
302 %package -n device-mapper-initrd
303 Summary:        Userspace support for the device-mapper - initrd version
304 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
305 Group:          Base
306 Obsoletes:      device-mapper-initrd-devel
307 Conflicts:      geninitrd < 10000.10
308
309 %description -n device-mapper-initrd
310 The goal of this driver is to support volume management. The driver
311 enables the definition of new block devices composed of ranges of
312 sectors of existing devices. This can be used to define disk
313 partitions - or logical volumes. This light-weight kernel component
314 can support user-space tools for logical volume management.
315
316 This package contains dmsetup program linked staticaly for use in
317 initrd.
318
319 %description -n device-mapper-initrd -l pl.UTF-8
320 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
321 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
322 sektorów na istniejących urządzeniach. Może to być wykorzystane do
323 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
324 składnik jądra może wspierać działające w przestrzeni użytkownika
325 narzędzia do zarządzania logicznymi wolumenami.
326
327 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
328 potrzeby initrd.
329
330 %prep
331 %setup -q -n LVM2.%{version}
332 %{?with_selinux:%patch0 -p1}
333 %patch1 -p1
334 %patch2 -p1
335 %patch3 -p1
336 %patch4 -p1
337 %patch6 -p1
338 %patch7 -p1
339 %patch8 -p1
340 %patch9 -p1
341
342 # do not force --export-symbol linker option for e.g. statically linked executables
343 # -rdynamic compiler option drives linker in the right way.
344 %{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.in
345
346 %build
347 %if %{with initrd}
348 echo Using %{?with_glibc:GLIBC} %{?with_uClibc:uClibc} %{?with_dietlibc:diet} for initrd
349 %endif
350 cp -f /usr/share/automake/config.sub autoconf
351 %{__aclocal}
352 %{__autoconf}
353
354 %if %{with initrd}
355 %{?with_glibc:export CC="%{__cc}"}
356 %{?with_uClibc:export CC="%{_target_cpu}-uclibc-gcc"}
357 %{?with_dietlibc:cc="%{__cc}"; export CC="diet ${cc#ccache }"}
358
359 %configure \
360         ac_cv_lib_dl_dlopen=no \
361         %{?with_uClibc:ac_cv_func_siginterrupt=no} \
362         %{?debug:--enable-debug} \
363         --disable-nls \
364         --disable-readline \
365         --enable-selinux%{!?with_glibc:=no} \
366         --enable-static_link \
367         --with-lvm1=internal \
368         --with-optimisation="%{rpmcflags} -Os"
369 # glibc version links with normal static libdevicemapper which has selinux enabled
370 # and we need to keep these in sync between device-mapper and lvm2
371
372 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
373 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
374
375 %{__make} -j1 -C include
376 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
377 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
378 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
379 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
380 mv -f tools/lvm.static initrd-lvm
381 mv -f tools/dmsetup.static initrd-dmsetup
382
383 # check if tools works
384 for tool in initrd-lvm initrd-dmsetup; do
385         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
386         if [ $rc -gt 127 ]; then
387                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
388                 exit 1
389         fi
390 done
391
392 %{?with_dietlibc:mv -f libdm/ioctl/libdevmapper.a diet-libdevmapper.a}
393 %{__make} clean
394
395 unset CC
396 %endif
397
398 %configure \
399         --enable-applib \
400         --enable-cmdlib \
401         %{?debug:--enable-debug} \
402         --enable-dmeventd \
403         --enable-fsadm \
404 %if %{with lvmlockd}
405         %{?with_cluster:--enable-lockd-dlm} \
406         %{?with_sanlock:--enable-lockd-sanlock} \
407 %endif
408         %{?with_lvmetad:--enable-lvmetad} \
409         --enable-ocf \
410         %{?with_python:--enable-python_bindings} \
411         --enable-readline \
412         %{!?with_selinux:--disable-selinux} \
413         --enable-pkgconfig \
414         --enable-udev_sync \
415         --enable-udev_rules \
416         --with-cache=internal \
417         --with-cache-check=/usr/sbin/cache_check \
418         --with-cache-dump=/usr/sbin/cache_dump \
419         --with-cache-repair=/usr/sbin/cache_repair \
420         --with-cache-restore=/usr/sbin/cache_restore \
421         --with-cluster=internal \
422 %if %{with cluster}
423         --with-clvmd=corosync \
424         --enable-cmirrord \
425 %endif
426         --with-dmeventd-path=%{_sbindir}/dmeventd \
427         --with-interface=ioctl \
428         --with-lvm1=internal \
429         --with-mirrors=internal \
430         --with-optimisation="%{rpmcflags}" \
431         --with-pool=internal \
432         %{?with_replicator:--with-replicators=internal} \
433         --with-snapshots=internal \
434         --with-systemdsystemunitdir=%{systemdunitdir} \
435         --with-tmpfilesdir=%{systemdtmpfilesdir} \
436         --with-thin=internal \
437         --with-thin-check=/usr/sbin/thin_check \
438         --with-thin-dump=/usr/sbin/thin_dump \
439         --with-thin-repair=/usr/sbin/thin_repair \
440         --with-thin-restore=/usr/sbin/thin_restore \
441         --with-udev-prefix=/ \
442         --with-usrlibdir=%{_libdir}
443
444 %{__make} -j1
445 %{__make} -j1 -C libdm LIB_STATIC=libdevmapper.a
446
447 %install
448 rm -rf $RPM_BUILD_ROOT
449 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig}
450 %{?with_dietlibc:install -d $RPM_BUILD_ROOT%{dietlibdir}}
451
452 %{__make} install install_system_dirs install_systemd_units install_initscripts install_tmpfiles_configuration \
453         DESTDIR=$RPM_BUILD_ROOT \
454         OWNER="" \
455         GROUP=""
456
457 %{__make} -C scripts install_tmpfiles_configuration \
458         DESTDIR=$RPM_BUILD_ROOT \
459
460 %if %{with cluster}
461 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/clvmd.service
462 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/clvmd
463 %endif
464
465 mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
466 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
467         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
468         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
469         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
470 done
471
472 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
473
474 %if %{with initrd}
475 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
476 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
477 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
478
479 %{?with_dietlibc:cp -a diet-libdevmapper.a $RPM_BUILD_ROOT%{dietlibdir}/libdevmapper.a}
480 %endif
481
482 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
483
484 %clean
485 rm -rf $RPM_BUILD_ROOT
486
487 %post
488 /sbin/chkconfig --add lvm2-monitor
489 %service lvm2-monitor restart
490 %systemd_post lvm2-monitor.service
491 /sbin/chkconfig --add blk-availability
492 # no service blk-availability restart
493 %systemd_post blk-availability.service
494
495 %preun
496 %systemd_preun lvm2-monitor.service
497 %systemd_preun blk-availability.service
498
499 %postun
500 if [ "$1" = "0" ]; then
501         %service lvm2-monitor stop
502         /sbin/chkconfig --del lvm2-monitor
503         #no service blk-availability stop
504         /sbin/chkconfig --del blk-availability
505 fi
506 %systemd_reload
507
508 %triggerpostun -- %{name} < 2.02.94-1
509 %systemd_trigger lvm2-monitor.service
510
511 %post -n device-mapper
512 %systemd_post dm-event.socket
513
514 %preun -n device-mapper
515 %systemd_preun dm-event.socket dm-event.service
516
517 %postun -n device-mapper
518 %systemd_reload
519
520 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
521 %systemd_trigger dm-event.socket
522
523 %post   -n device-mapper-libs -p /sbin/ldconfig
524 %postun -n device-mapper-libs -p /sbin/ldconfig
525
526 %post clvmd
527 /sbin/chkconfig --add clvmd
528 # no service restart - it breaks current locks!
529 export NORESTART=1
530 %systemd_post clvmd.service
531 # re-exec instead
532 /usr/sbin/clvmd -S 2>/dev/null || :
533
534 %preun clvmd
535 %systemd_preun clvmd.service
536
537 %postun clvmd
538 if [ "$1" = "0" ]; then
539         %service clvmd stop
540         /sbin/chkconfig --del clvmd
541 fi
542 %systemd_reload
543
544 %files
545 %defattr(644,root,root,755)
546 %doc README WHATS_NEW doc/*
547 %attr(755,root,root) %{_sbindir}/blkdeactivate
548 %attr(755,root,root) %{_sbindir}/fsadm
549 %attr(755,root,root) %{_sbindir}/lv*
550 %attr(755,root,root) %{_sbindir}/pv*
551 %attr(755,root,root) %{_sbindir}/vg*
552 %{_mandir}/man5/lvm.conf.5*
553 %{_mandir}/man7/lvmcache.7*
554 %{_mandir}/man7/lvmsystemid.7*
555 %{_mandir}/man7/lvmthin.7*
556 %{_mandir}/man8/blkdeactivate.8*
557 %{_mandir}/man8/fsadm.8*
558 %{_mandir}/man8/lv*.8*
559 %{_mandir}/man8/pv*.8*
560 %{_mandir}/man8/vg*.8*
561 %attr(750,root,root) %dir %{_sysconfdir}/lvm
562 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
563 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
564 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
565 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
566 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
567 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
568 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
569 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
570 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
571 %if %{with lvmetad}
572 /lib/udev/rules.d/69-dm-lvm-metad.rules
573 %endif
574 %{systemdtmpfilesdir}/lvm2.conf
575 %{systemdunitdir}/blk-availability.service
576 %if %{with lvmetad}
577 %{systemdunitdir}/lvm2-lvmetad.service
578 %{systemdunitdir}/lvm2-lvmetad.socket
579 %endif
580 %if %{with lvmlockd}
581 %{systemdunitdir}/lvm2-lvmlockd.service
582 %{systemdunitdir}/lvm2-lvmlocking.service
583 %endif
584 %if %{with lvmpolld}
585 %{systemdunitdir}/lvm2-lvmpolld.service
586 %{systemdunitdir}/lvm2-lvmpolld.socket
587 %endif
588 %{systemdunitdir}/lvm2-monitor.service
589 %{systemdunitdir}/lvm2-pvscan@.service
590 %dir %{_sysconfdir}/lvm/cache
591 %ghost %{_sysconfdir}/lvm/cache/.cache
592 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
593 %if %{with lvmetad}
594 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmetad
595 %endif
596 %if %{with lvmpolld}
597 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
598 %endif
599 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
600 %attr(700,root,root) %dir /run/lvm
601 %attr(700,root,root) %dir /var/lock/lvm
602
603 %if %{with cluster}
604 %files clvmd
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_usrsbindir}/clvmd
607 %attr(754,root,root) /etc/rc.d/init.d/clvmd
608 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/clvmd
609 %attr(755,root,root) /lib/systemd/lvm2-cluster-activation
610 %{systemdunitdir}/clvmd.service
611 %{systemdunitdir}/lvm2-cluster-activation.service
612 %{systemdunitdir}/lvm2-clvmd.service
613 %{_mandir}/man8/clvmd.8*
614
615 %files cmirrord
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_usrsbindir}/cmirrord
618 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
619 %{systemdunitdir}/lvm2-cmirrord.service
620 %{_mandir}/man8/cmirrord.8*
621 %endif
622
623 %files resource-agents
624 %defattr(644,root,root,755)
625 %dir %{_prefix}/lib/ocf/resource.d/lvm2
626 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
627
628 %if %{with python}
629 %files -n python-lvm
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{py_sitedir}/lvm.so
632 %{py_sitedir}/lvm-%{version}_*-py*.egg-info
633 %endif
634
635 %files -n device-mapper
636 %defattr(644,root,root,755)
637 %doc *_DM
638 %{systemdunitdir}/dm-event.service
639 %{systemdunitdir}/dm-event.socket
640 /lib/udev/rules.d/10-dm.rules
641 /lib/udev/rules.d/11-dm-lvm.rules
642 /lib/udev/rules.d/13-dm-disk.rules
643 /lib/udev/rules.d/95-dm-notify.rules
644 %attr(755,root,root) %{_sbindir}/dmeventd
645 %attr(755,root,root) %{_sbindir}/dmsetup
646 %attr(755,root,root) %{_sbindir}/dmstats
647 %dir %{_libdir}/device-mapper
648 %attr(755,root,root) %{_libdir}/device-mapper/*.so
649 %attr(755,root,root) %{_libdir}/libdevmapper-event-*.so
650 %{_mandir}/man8/dmsetup.8*
651 %{_mandir}/man8/dmstats.8*
652 %{_mandir}/man8/dmeventd.8*
653
654 %files -n device-mapper-libs
655 %defattr(644,root,root,755)
656 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
657 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
658 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
659 %attr(755,root,root) /%{_lib}/liblvm2app.so.*.*
660 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
661
662 %files -n device-mapper-devel
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/libdevmapper.so
665 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
666 %attr(755,root,root) %{_libdir}/liblvm2app.so
667 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
668 %{_includedir}/libdevmapper.h
669 %{_includedir}/libdevmapper-event.h
670 %{_includedir}/lvm2app.h
671 %{_includedir}/lvm2cmd.h
672 %{_pkgconfigdir}/devmapper.pc
673 %{_pkgconfigdir}/devmapper-event.pc
674 %{_pkgconfigdir}/lvm2app.pc
675
676 %files -n device-mapper-static
677 %defattr(644,root,root,755)
678 %{_libdir}/libdevmapper.a
679
680 %if %{with initrd}
681 %if %{with dietlibc}
682 %files -n device-mapper-dietlibc
683 %defattr(644,root,root,755)
684 %{dietlibdir}/libdevmapper.a
685 %endif
686
687 %files -n device-mapper-initrd
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/initrd/dmsetup
690
691 %files initrd
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_libdir}/initrd/lvm
694 %endif
This page took 0.084641 seconds and 2 git commands to generate.