]> git.pld-linux.org Git - packages/lvm2.git/blob - lvm2.spec
- rel 1; enable activation generator, dmfilemapd
[packages/lvm2.git] / lvm2.spec
1 # TODO
2 # - vgscan --ignorelocking failure creates /var/lock/lvm (even if /var is not yet mounted)
3 # - internal vs shared for cluster,snapshots,mirrors,thin,cache ?
4 #   note: dmeventd requires mirrors=internal)
5 #
6 # Conditional build:
7 # - initrd stuff
8 %bcond_with     initrd          # build initrd version
9 # - functionality
10 %bcond_without  cluster         # disable all cluster support (cmirrord)
11 %bcond_without  lvmdbusd        # lvmdbusd
12 %bcond_without  lvmpolld        # lvmpolld (and lvmlockd)
13 %bcond_without  lvmlockd        # lvmlockd
14 %bcond_with     sanlock         # sanlock support in lvmlockd
15 # - additional features
16 %bcond_without  selinux         # SELinux support
17 # - bindings
18 %bcond_without  python          # Python bindings
19 %bcond_without  python2         # Python 2 binding
20 %bcond_without  python3         # Python 3 binding and lvmdbusd
21
22 # lvmlockd requires lvmpolld
23 %if %{without lvmpolld}
24 %undefine       with_lvmpolld
25 %endif
26
27 # for convenience
28 %if %{without python}
29 %undefine       with_python2
30 %undefine       with_python3
31 %endif
32 %if %{without python3}
33 %undefine       with_lvmdbusd
34 %endif
35
36 Summary:        The new version of Logical Volume Manager for Linux
37 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa
38 Name:           lvm2
39 Version:        2.03.07
40 Release:        1
41 License:        GPL v2 and LGPL v2.1
42 Group:          Applications/System
43 Source0:        ftp://sourceware.org/pub/lvm2/LVM2.%{version}.tgz
44 # Source0-md5:  5c06a01e1adacb96761188d6a8a17a2e
45 Patch0:         device-mapper-dmsetup-export.patch
46 Patch1:         %{name}-pld_init.patch
47 Patch2:         device-mapper-dmsetup-deps-export.patch
48 Patch3:         %{name}-thin.patch
49 URL:            http://www.sourceware.org/lvm2/
50 BuildRequires:  autoconf >= 2.69
51 BuildRequires:  automake
52 # for /run detection
53 BuildRequires:  filesystem >= 3.0-43
54 BuildRequires:  libaio-devel
55 BuildRequires:  libblkid-devel >= 2.24
56 %{?with_selinux:BuildRequires:  libselinux-devel >= 1.10}
57 %{?with_selinux:BuildRequires:  libsepol-devel}
58 BuildRequires:  ncurses-devel
59 BuildRequires:  pkgconfig
60 %{?with_python2:BuildRequires:  python-devel >= 2}
61 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
62 %if %{with lvmdbusd}
63 BuildRequires:  python3-dbus
64 BuildRequires:  python3-pyudev
65 %endif
66 BuildRequires:  readline-devel
67 BuildRequires:  rpmbuild(macros) >= 1.647
68 %{?with_sanlock:BuildRequires:  sanlock-devel >= 3.3.0}
69 BuildRequires:  systemd-devel >= 1:221
70 BuildRequires:  udev-devel >= 1:176
71 %if %{with initrd}
72 %{?with_selinux:BuildRequires:  libselinux-static}
73 %{?with_selinux:BuildRequires:  libsepol-static}
74 BuildRequires:  glibc-static
75 %else
76 Obsoletes:      lvm2-initrd
77 %endif
78 %if %{with cluster}
79 BuildRequires:  corosync-devel
80 BuildRequires:  dlm-devel >= 3.99.5
81 %endif
82 Requires(post,preun,postun):    systemd-units >= 38
83 Requires(post,postun):  /sbin/chkconfig
84 Requires:       device-mapper >= %{version}-%{release}
85 %{?with_selinux:Requires:       libselinux >= 1.10}
86 Requires:       systemd-units >= 38
87 # doesn't work with 2.4 kernels
88 Requires:       uname(release) >= 2.6
89 Suggests:       thin-provisioning-tools >= 0.5.4
90 Obsoletes:      lvm
91 Obsoletes:      lvm2-clvmd
92 Obsoletes:      lvm2-systemd
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         _sbindir        /sbin
96 %define         _usrsbindir     /usr/sbin
97
98 # changing CFLAGS in the middle confuses confcache
99 %undefine       configure_cache
100
101 # borken on AC
102 %define         filterout_ld    -Wl,--as-needed
103
104 # causes: undefined reference to `__stack_chk_fail_local'
105 %define         filterout_c     -fstack-protector
106
107 %define         skip_post_check_so      '.*libdevmapper-event-lvm2.so.*' 'liblvm2cmd.so.*'
108
109 %description
110 This package includes a number of utilities for creating, checking,
111 and repairing logical volumes.
112
113 %description -l pl.UTF-8
114 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
115 logicznych wolumenów dyskowych (LVM2).
116
117 %package initrd
118 Summary:        The new version of Logical Volume Manager for Linux - initrd version
119 Summary(pl.UTF-8):      Nowa wersja Logical Volume Managera dla Linuksa - wersja dla initrd
120 Group:          Base
121 Conflicts:      geninitrd < 10000.18
122
123 %description initrd
124 This package includes a number of utilities for creating, checking,
125 and repairing logical volumes - staticaly linked for initrd.
126
127 %description initrd -l pl.UTF-8
128 Pakiet ten zawiera narzędzia do tworzenia, sprawdzania i naprawiania
129 logicznych wolumenów dyskowych (LVM2) - statycznie skonsolidowane na
130 potrzeby initrd.
131
132 %package cmirrord
133 Summary:        Cluster mirror log daemon
134 Summary(pl.UTF-8):      Demon śledzący log lustrzany w klastrze
135 Group:          Applications/System
136 Requires:       %{name} = %{version}-%{release}
137
138 %description cmirrord
139 cmirrord is the daemon that tracks mirror log information in a
140 cluster. It is specific to device-mapper based mirrors (and by
141 extension, LVM cluster mirrors). Cluster mirrors are not possible
142 without this daemon running.
143
144 This daemon relies on the cluster infrastructure provided by the
145 Cluster MANager (CMAN), which must be set up and running in order for
146 cmirrord to function.
147
148 %description cmirrord
149 cmirrord to demon śledzący informacje logu lustrzanego w klastrze.
150 Jest specyficzny dla klastrów lustrzanych opartych na device-mapperze
151 (oraz, poprzez rozszerzenie, klastrów lustrzanych LVM). W klastrach
152 lustrzanych ten demon jest niezbędny.
153
154 Ten demon polega na infrastrukturze klastra dostarczanej przez CMAN
155 (Cluster MANager), który musi być skonfigurowany i działający, aby
156 działał cmirrord.
157
158 %package dbusd
159 Summary:        LVM2 D-Bus daemon
160 Summary(pl.UTF-8):      Demon LVM2 D-Bus
161 Group:          Daemons
162 Requires(post,preun,postun):    systemd-units >= 38
163 Requires:       %{name} = %{version}-%{release}
164 Requires:       python3-dbus
165 Requires:       python3-pygobject3 >= 3
166 Requires:       python3-pyudev
167
168 %description dbusd
169 Daemon for access to LVM2 functionality through a D-Bus interface.
170
171 %description dbusd -l pl.UTF-8
172 Demon umożliwiający dostęp do funkcjonalności LVM2 poprzez interfejs
173 D-Bus.
174
175 %package lockd
176 Summary:        LVM2 locking daemon
177 Summary(pl.UTF-8):      Demon blokad LVM2
178 Group:          Daemons
179 Requires(post,preun,postun):    systemd-units >= 38
180 Requires:       %{name} = %{version}-%{release}
181 %{?with_cluster:Requires:       dlm-libs >= 3.99.5}
182 %{?with_sanlock:Requires:       sanlock-libs >= 3.3.0}
183
184 %description lockd
185 LVM commands use lvmlockd to coordinate access to shared storage.
186
187 %description lockd -l pl.UTF-8
188 Polecenia LVM wykorzystują lvmlockd do koordynowania dostępu do
189 współdzielonej pamięci masowej.
190
191 %package resource-agents
192 Summary:        OCF Resource Agents for LVM2 processes
193 Summary(pl.UTF-8):      Agenci OCF do monitorowania procesów LVM2
194 Group:          Applications/System
195 Requires:       %{name} = %{version}-%{release}
196 Requires:       resource-agents
197
198 %description resource-agents
199 OCF Resource Agents for LVM2 processes.
200
201 %description resource-agents -l pl.UTF-8
202 Agenci OCF do monitorowania procesów LVM2.
203
204 %package -n python-lvm
205 Summary:        Python 2 interface to LVM2
206 Summary(pl.UTF-8):      Interfejs Pythona 2 do LVM2
207 Group:          Libraries/Python
208 Requires:       device-mapper-libs = %{version}-%{release}
209
210 %description -n python-lvm
211 Python 2 interface to LVM2.
212
213 %description -n python-lvm -l pl.UTF-8
214 Interfejs Pythona 2 do LVM2.
215
216 %package -n python3-lvm
217 Summary:        Python 3 interface to LVM2
218 Summary(pl.UTF-8):      Interfejs Pythona 3 do LVM2
219 Group:          Libraries/Python
220 Requires:       device-mapper-libs = %{version}-%{release}
221
222 %description -n python3-lvm
223 Python 3 interface to LVM2.
224
225 %description -n python3-lvm -l pl.UTF-8
226 Interfejs Pythona 3 do LVM2.
227
228 %package -n device-mapper
229 Summary:        Userspace support for the device-mapper
230 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika
231 Group:          Base
232 Requires(post,postun):  /sbin/ldconfig
233 Requires(post,preun,postun):    systemd-units >= 38
234 Requires:       device-mapper-libs = %{version}-%{release}
235 Requires:       systemd-units >= 38
236
237 %description -n device-mapper
238 The goal of this driver is to support volume management. The driver
239 enables the definition of new block devices composed of ranges of
240 sectors of existing devices. This can be used to define disk
241 partitions - or logical volumes. This light-weight kernel component
242 can support user-space tools for logical volume management.
243
244 %description -n device-mapper -l pl.UTF-8
245 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
246 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
247 sektorów na istniejących urządzeniach. Może to być wykorzystane do
248 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
249 składnik jądra może wspierać działające w przestrzeni użytkownika
250 narzędzia do zarządzania logicznymi wolumenami.
251
252 %package -n device-mapper-libs
253 Summary:        Device-mapper shared libraries
254 Summary(pl.UTF-8):      Biblioteki współdzielone device-mappera
255 Group:          Libraries
256 Requires:       libblkid >= 2.24
257 Requires:       udev-libs >= 1:176
258 Conflicts:      device-mapper < 2.02.119-1
259
260 %description -n device-mapper-libs
261 Device-mapper shared libraries.
262
263 %description -n device-mapper-libs -l pl.UTF-8
264 Biblioteki współdzielone device-mappera.
265
266 %package -n device-mapper-devel
267 Summary:        Header files for device-mapper libraries
268 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek device-mappera
269 Group:          Development/Libraries
270 Requires:       device-mapper-libs = %{version}-%{release}
271 Requires:       libblkid-devel >= 2.24
272 %if %{with selinux}
273 Requires:       libselinux-devel
274 Requires:       libsepol-devel
275 %endif
276 Requires:       udev-devel >= 1:176
277
278 %description -n device-mapper-devel
279 Header files for device-mapper libraries.
280
281 %description -n device-mapper-devel -l pl.UTF-8
282 Pliki nagłówkowe bibliotek device-mappera.
283
284 %package -n device-mapper-static
285 Summary:        Static devmapper library
286 Summary(pl.UTF-8):      Statyczna biblioteka devmapper
287 License:        LGPL v2.1
288 Group:          Development/Libraries
289 Requires:       device-mapper-devel = %{version}-%{release}
290
291 %description -n device-mapper-static
292 Static devmapper library.
293
294 %description -n device-mapper-static -l pl.UTF-8
295 Statyczna biblioteka devmapper.
296
297 %package -n device-mapper-initrd
298 Summary:        Userspace support for the device-mapper - initrd version
299 Summary(pl.UTF-8):      Wsparcie dla mapowania urządzeń w przestrzeni użytkownika - wersja dla initrd
300 Group:          Base
301 Obsoletes:      device-mapper-initrd-devel
302 Conflicts:      geninitrd < 10000.10
303
304 %description -n device-mapper-initrd
305 The goal of this driver is to support volume management. The driver
306 enables the definition of new block devices composed of ranges of
307 sectors of existing devices. This can be used to define disk
308 partitions - or logical volumes. This light-weight kernel component
309 can support user-space tools for logical volume management.
310
311 This package contains dmsetup program linked staticaly for use in
312 initrd.
313
314 %description -n device-mapper-initrd -l pl.UTF-8
315 Celem tego sterownika jest obsługa zarządzania wolumenami. Sterownik
316 włącza definiowanie nowych urządzeń blokowych złożonych z przedziałów
317 sektorów na istniejących urządzeniach. Może to być wykorzystane do
318 definiowania partycji na dysku lub logicznych wolumenów. Ten lekki
319 składnik jądra może wspierać działające w przestrzeni użytkownika
320 narzędzia do zarządzania logicznymi wolumenami.
321
322 Ten pakiet zawiera program dmsetup skonsolidowany statycznie na
323 potrzeby initrd.
324
325 %prep
326 %setup -q -n LVM2.%{version}
327 %patch0 -p1
328 %patch1 -p1
329 %patch2 -p1
330 %patch3 -p1
331
332 # do not force --export-symbol linker option for e.g. statically linked executables
333 # -rdynamic compiler option drives linker in the right way.
334 #%{__sed} -i -e 's#-Wl,--export-dynamic#-rdynamic#g' configure.ac
335
336 %build
337 cp -f /usr/share/automake/config.sub autoconf
338 %{__aclocal}
339 %{__autoconf}
340
341 %if %{with initrd}
342
343 %configure \
344         %{?debug:--enable-debug} \
345         --disable-nls \
346         --disable-readline \
347         --enable-selinux \
348         --enable-static_link \
349         --with-optimisation="%{rpmcflags} -Os"
350
351 %{__sed} -i -e 's#rpl_malloc#malloc#g' lib/misc/configure.h
352 %{__sed} -i -e 's#rpl_realloc#realloc#g' lib/misc/configure.h
353
354 %{__make} -j1 -C include V=1
355 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB= V=1
356 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB= V=1
357 %{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB= V=1
358 %{__make} -j1 -C tools dmsetup.static lvm.static V=1
359 %{__mv} tools/lvm.static initrd-lvm
360 %{__mv} tools/dmsetup.static initrd-dmsetup
361
362 # check if tools works
363 for tool in initrd-lvm initrd-dmsetup; do
364         LVM_SYSTEM_DIR=$(pwd) ./$tool help && rc=$? || rc=$?
365         if [ $rc -gt 127 ]; then
366                 echo >&2 "Unexpected failure (exit status: $rc) from $tool. Does this tool work?!"
367                 exit 1
368         fi
369 done
370
371 %{__make} clean
372
373 unset CC
374 %endif
375
376 %configure \
377         --enable-applib \
378         --enable-cache_check_needs_check \
379         --enable-cmdlib \
380         %{?with_lvmdbusd:--enable-dbus-service --enable-notify-dbus} \
381         %{?debug:--enable-debug} \
382         --enable-dmeventd \
383         --enable-dmfilemapd \
384         --enable-fsadm \
385         --with-default-locking-dir=/var/lock/lvm \
386 %if %{with lvmlockd}
387         %{?with_cluster:--enable-lvmlockd-dlm} \
388         %{?with_sanlock:--enable-lvmlockd-sanlock} \
389 %endif
390         --enable-lvmpolld \
391         --enable-ocf \
392         %{?with_python2:--enable-python2_bindings} \
393         %{?with_python3:--enable-python3_bindings} \
394         --enable-readline \
395         %{!?with_selinux:--disable-selinux} \
396         --enable-pkgconfig \
397         --enable-thin_check_needs_check \
398         --enable-udev_sync \
399         --enable-udev_rules \
400         --with-cache=internal \
401         --with-cache-check=/usr/sbin/cache_check \
402         --with-cache-dump=/usr/sbin/cache_dump \
403         --with-cache-repair=/usr/sbin/cache_repair \
404         --with-cache-restore=/usr/sbin/cache_restore \
405         --with-cluster=internal \
406 %if %{with cluster}
407         --enable-cmirrord \
408 %endif
409         --with-dmeventd-path=%{_sbindir}/dmeventd \
410         --with-interface=ioctl \
411         --with-lvm1=internal \
412         --with-mirrors=internal \
413         --with-optimisation="%{rpmcflags}" \
414         --with-snapshots=internal \
415         --with-systemdsystemunitdir=%{systemdunitdir} \
416         --with-tmpfilesdir=%{systemdtmpfilesdir} \
417         --with-thin=internal \
418         --with-thin-check=/usr/sbin/thin_check \
419         --with-thin-dump=/usr/sbin/thin_dump \
420         --with-thin-repair=/usr/sbin/thin_repair \
421         --with-thin-restore=/usr/sbin/thin_restore \
422         --with-udev-prefix=/ \
423         --with-vdo=internal --with-vdo-format=%{_bindir}/vdoformat \
424         --with-writecache=internal \
425         --with-usrlibdir=%{_libdir}
426
427 # use bash because of "set -o pipefail"
428 %{__make} -j1 \
429         SHELL=/bin/bash \
430         V=1
431 %{__make} -j1 -C libdm \
432         LIB_STATIC=libdevmapper.a \
433         V=1
434
435 %install
436 rm -rf $RPM_BUILD_ROOT
437 install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm,/etc/sysconfig,/var/lock/lvm/subsys}
438
439 %{__make} install install_system_dirs install_systemd_units install_systemd_generators install_initscripts install_tmpfiles_configuration \
440         DESTDIR=$RPM_BUILD_ROOT \
441         OWNER="" \
442         GROUP="" \
443         V=1 \
444         python3dir=%{py3_sitescriptdir}
445
446 %{__make} -C scripts install_tmpfiles_configuration \
447         DESTDIR=$RPM_BUILD_ROOT \
448         V=1
449
450 %{__mv} $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
451 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
452         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
453         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
454         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
455 done
456
457 touch $RPM_BUILD_ROOT%{_sysconfdir}/lvm/lvm.conf
458
459 %if %{with initrd}
460 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
461 install -p initrd-lvm $RPM_BUILD_ROOT%{_libdir}/initrd/lvm
462 install -p initrd-dmsetup $RPM_BUILD_ROOT%{_libdir}/initrd/dmsetup
463 %endif
464
465 cp -a libdm/libdevmapper.a $RPM_BUILD_ROOT%{_libdir}
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %post
471 /sbin/chkconfig --add lvm2-monitor
472 %service lvm2-monitor restart
473 %systemd_post lvm2-monitor.service
474 /sbin/chkconfig --add blk-availability
475 # no service blk-availability restart
476 %systemd_post blk-availability.service
477 %if %{with lvmpolld}
478 %systemd_post lvm2-lvmpolld.socket
479 %endif
480
481 %preun
482 %systemd_preun lvm2-monitor.service
483 %systemd_preun blk-availability.service
484 %if %{with lvmpolld}
485 %systemd_preun lvm2-lvmpolld.socket
486 %endif
487
488 %postun
489 if [ "$1" = "0" ]; then
490         %service lvm2-monitor stop
491         /sbin/chkconfig --del lvm2-monitor
492         #no service blk-availability stop
493         /sbin/chkconfig --del blk-availability
494 fi
495 %systemd_reload
496
497 %triggerpostun -- %{name} < 2.02.94-1
498 %systemd_trigger lvm2-monitor.service
499
500 %post -n device-mapper
501 %systemd_post dm-event.socket
502
503 %preun -n device-mapper
504 %systemd_preun dm-event.socket dm-event.service
505
506 %postun -n device-mapper
507 %systemd_reload
508
509 %triggerpostun -n device-mapper -- device-mapper < 2.02.94-1
510 %systemd_trigger dm-event.socket
511
512 %post   -n device-mapper-libs -p /sbin/ldconfig
513 %postun -n device-mapper-libs -p /sbin/ldconfig
514
515 %post dbusd
516 %systemd_post lvm2-lvmdbusd.service
517
518 %preun dbusd
519 %systemd_preun lvm2-lvmdbusd.service
520
521 %postun dbusd
522 %systemd_reload
523
524 %post lockd
525 %systemd_post lvm2-lvmlockd.service lvm2-lvmlocking.service
526
527 %preun lockd
528 %systemd_preun lvm2-lvmlockd.service lvm2-lvmlocking.service
529
530 %postun lockd
531 %systemd_reload
532
533 %files
534 %defattr(644,root,root,755)
535 %doc README WHATS_NEW doc/*
536 %attr(755,root,root) %{_sbindir}/blkdeactivate
537 %attr(755,root,root) %{_sbindir}/fsadm
538 %attr(755,root,root) %{_sbindir}/lvchange
539 %attr(755,root,root) %{_sbindir}/lvconvert
540 %attr(755,root,root) %{_sbindir}/lvcreate
541 %attr(755,root,root) %{_sbindir}/lvdisplay
542 %attr(755,root,root) %{_sbindir}/lvextend
543 %attr(755,root,root) %{_sbindir}/lvm
544 #%attr(755,root,root) %{_sbindir}/lvmconf
545 %attr(755,root,root) %{_sbindir}/lvmconfig
546 %attr(755,root,root) %{_sbindir}/lvmdiskscan
547 %attr(755,root,root) %{_sbindir}/lvmdump
548 %attr(755,root,root) %{_sbindir}/lvmsadc
549 %attr(755,root,root) %{_sbindir}/lvmsar
550 %attr(755,root,root) %{_sbindir}/lvreduce
551 %attr(755,root,root) %{_sbindir}/lvremove
552 %attr(755,root,root) %{_sbindir}/lvrename
553 %attr(755,root,root) %{_sbindir}/lvresize
554 %attr(755,root,root) %{_sbindir}/lvs
555 %attr(755,root,root) %{_sbindir}/lvscan
556 %attr(755,root,root) %{_sbindir}/pvchange
557 %attr(755,root,root) %{_sbindir}/pvck
558 %attr(755,root,root) %{_sbindir}/pvcreate
559 %attr(755,root,root) %{_sbindir}/pvdisplay
560 %attr(755,root,root) %{_sbindir}/pvmove
561 %attr(755,root,root) %{_sbindir}/pvremove
562 %attr(755,root,root) %{_sbindir}/pvresize
563 %attr(755,root,root) %{_sbindir}/pvs
564 %attr(755,root,root) %{_sbindir}/pvscan
565 %attr(755,root,root) %{_sbindir}/vgcfgbackup
566 %attr(755,root,root) %{_sbindir}/vgcfgrestore
567 %attr(755,root,root) %{_sbindir}/vgchange
568 %attr(755,root,root) %{_sbindir}/vgck
569 %attr(755,root,root) %{_sbindir}/vgconvert
570 %attr(755,root,root) %{_sbindir}/vgcreate
571 %attr(755,root,root) %{_sbindir}/vgdisplay
572 %attr(755,root,root) %{_sbindir}/vgexport
573 %attr(755,root,root) %{_sbindir}/vgextend
574 %attr(755,root,root) %{_sbindir}/vgimport
575 %attr(755,root,root) %{_sbindir}/vgimportclone
576 %attr(755,root,root) %{_sbindir}/vgmerge
577 %attr(755,root,root) %{_sbindir}/vgmknodes
578 %attr(755,root,root) %{_sbindir}/vgreduce
579 %attr(755,root,root) %{_sbindir}/vgremove
580 %attr(755,root,root) %{_sbindir}/vgrename
581 %attr(755,root,root) %{_sbindir}/vgs
582 %attr(755,root,root) %{_sbindir}/vgscan
583 %attr(755,root,root) %{_sbindir}/vgsplit
584 %{_mandir}/man5/lvm.conf.5*
585 %{_mandir}/man7/lvmcache.7*
586 %{_mandir}/man7/lvmraid.7*
587 %{_mandir}/man7/lvmreport.7*
588 %{_mandir}/man7/lvmsystemid.7*
589 %{_mandir}/man7/lvmthin.7*
590 %{_mandir}/man8/blkdeactivate.8*
591 %{_mandir}/man8/fsadm.8*
592 %{_mandir}/man8/lvchange.8*
593 %{_mandir}/man8/lvconvert.8*
594 %{_mandir}/man8/lvcreate.8*
595 %{_mandir}/man8/lvdisplay.8*
596 %{_mandir}/man8/lvextend.8*
597 %{_mandir}/man8/lvm2-activation-generator.8*
598 %{_mandir}/man8/lvm-config.8*
599 %{_mandir}/man8/lvm-dumpconfig.8*
600 %{_mandir}/man8/lvm-fullreport.8*
601 %{_mandir}/man8/lvm-lvpoll.8*
602 %{_mandir}/man8/lvm.8*
603 #%{_mandir}/man8/lvmconf.8*
604 %{_mandir}/man8/lvmconfig.8*
605 %{_mandir}/man8/lvmdiskscan.8*
606 %{_mandir}/man8/lvmdump.8*
607 %{_mandir}/man8/lvmsadc.8*
608 %{_mandir}/man8/lvmsar.8*
609 %{_mandir}/man8/lvreduce.8*
610 %{_mandir}/man8/lvremove.8*
611 %{_mandir}/man8/lvrename.8*
612 %{_mandir}/man8/lvresize.8*
613 %{_mandir}/man8/lvs.8*
614 %{_mandir}/man8/lvscan.8*
615 %{_mandir}/man8/pvchange.8*
616 %{_mandir}/man8/pvck.8*
617 %{_mandir}/man8/pvcreate.8*
618 %{_mandir}/man8/pvdisplay.8*
619 %{_mandir}/man8/pvmove.8*
620 %{_mandir}/man8/pvremove.8*
621 %{_mandir}/man8/pvresize.8*
622 %{_mandir}/man8/pvs.8*
623 %{_mandir}/man8/pvscan.8*
624 %{_mandir}/man8/vgcfgbackup.8*
625 %{_mandir}/man8/vgcfgrestore.8*
626 %{_mandir}/man8/vgchange.8*
627 %{_mandir}/man8/vgck.8*
628 %{_mandir}/man8/vgconvert.8*
629 %{_mandir}/man8/vgcreate.8*
630 %{_mandir}/man8/vgdisplay.8*
631 %{_mandir}/man8/vgexport.8*
632 %{_mandir}/man8/vgextend.8*
633 %{_mandir}/man8/vgimport.8*
634 %{_mandir}/man8/vgimportclone.8*
635 %{_mandir}/man8/vgmerge.8*
636 %{_mandir}/man8/vgmknodes.8*
637 %{_mandir}/man8/vgreduce.8*
638 %{_mandir}/man8/vgremove.8*
639 %{_mandir}/man8/vgrename.8*
640 %{_mandir}/man8/vgs.8*
641 %{_mandir}/man8/vgscan.8*
642 %{_mandir}/man8/vgsplit.8*
643 %attr(750,root,root) %dir %{_sysconfdir}/lvm
644 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
645 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvmlocal.conf
646 %attr(750,root,root) %dir %{_sysconfdir}/lvm/profile
647 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-mq.profile
648 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/cache-smq.profile
649 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/command_profile_template.profile
650 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/metadata_profile_template.profile
651 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-generic.profile
652 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/thin-performance.profile
653 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/vdo-small.profile
654 %{systemdtmpfilesdir}/lvm2.conf
655 %{systemdunitdir}/blk-availability.service
656 %{systemdunitdir}/lvm2-monitor.service
657 %{systemdunitdir}/lvm2-pvscan@.service
658 %attr(755,root,root) /lib/systemd/system-generators/lvm2-activation-generator
659 %dir %{_sysconfdir}/lvm/cache
660 %ghost %{_sysconfdir}/lvm/cache/.cache
661 %attr(754,root,root) /etc/rc.d/init.d/blk-availability
662 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
663 %attr(700,root,root) %dir /run/lvm
664 %attr(700,root,root) %dir /var/lock/lvm
665 %attr(700,root,root) %dir /var/lock/lvm/subsys
666 %if %{with lvmlockd}
667 %attr(755,root,root) %{_sbindir}/lvmlockctl
668 %attr(755,root,root) %{_sbindir}/lvmlockd
669 %{systemdunitdir}/lvmlockd.service
670 %{systemdunitdir}/lvmlocks.service
671 %{_mandir}/man8/lvmlockctl.8*
672 %{_mandir}/man8/lvmlockd.8*
673 %endif
674 %if %{with lvmpolld}
675 %attr(755,root,root) %{_sbindir}/lvmpolld
676 %attr(754,root,root) /etc/rc.d/init.d/lvm2-lvmpolld
677 %{systemdunitdir}/lvm2-lvmpolld.service
678 %{systemdunitdir}/lvm2-lvmpolld.socket
679 %{_mandir}/man8/lvmpolld.8*
680 %endif
681
682 %if %{with cluster}
683 %files cmirrord
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_usrsbindir}/cmirrord
686 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
687 %{systemdunitdir}/lvm2-cmirrord.service
688 %{_mandir}/man8/cmirrord.8*
689 %endif
690
691 %if %{with lvmdbusd}
692 %files dbusd
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_sbindir}/lvmdbusd
695 %{py3_sitescriptdir}/lvmdbusd
696 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/profile/lvmdbusd.profile
697 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/com.redhat.lvmdbus1.conf
698 %{_datadir}/dbus-1/system-services/com.redhat.lvmdbus1.service
699 %{systemdunitdir}/lvm2-lvmdbusd.service
700 %{_mandir}/man8/lvmdbusd.8*
701 %endif
702
703 %files resource-agents
704 %defattr(644,root,root,755)
705 %dir %{_prefix}/lib/ocf/resource.d/lvm2
706 %attr(755,root,root) %{_prefix}/lib/ocf/resource.d/lvm2/VolumeGroup
707
708 %if %{with python2}
709 %files -n python-lvm
710 %defattr(644,root,root,755)
711 #%attr(755,root,root) %{py_sitedir}/lvm.so
712 #%{py_sitedir}/lvm-%{version}_*-py*.egg-info
713 %endif
714
715 %if %{with python3}
716 %files -n python3-lvm
717 %defattr(644,root,root,755)
718 #%attr(755,root,root) %{py3_sitedir}/lvm.cpython-*.so
719 #%{py3_sitedir}/lvm-%{version}_*-py*.egg-info
720 %endif
721
722 %files -n device-mapper
723 %defattr(644,root,root,755)
724 %doc *_DM
725 %{systemdunitdir}/dm-event.service
726 %{systemdunitdir}/dm-event.socket
727 /lib/udev/rules.d/10-dm.rules
728 /lib/udev/rules.d/11-dm-lvm.rules
729 /lib/udev/rules.d/13-dm-disk.rules
730 /lib/udev/rules.d/95-dm-notify.rules
731 /lib/udev/rules.d/69-dm-lvm-metad.rules
732 %attr(755,root,root) %{_sbindir}/dmeventd
733 %attr(755,root,root) %{_sbindir}/dmfilemapd
734 %attr(755,root,root) %{_sbindir}/dmsetup
735 %attr(755,root,root) %{_sbindir}/dmstats
736 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2mirror.so
737 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2raid.so
738 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2snapshot.so
739 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2thin.so
740 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2vdo.so
741 %dir %{_libdir}/device-mapper
742 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2mirror.so
743 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2raid.so
744 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2snapshot.so
745 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2thin.so
746 %attr(755,root,root) %{_libdir}/device-mapper/libdevmapper-event-lvm2vdo.so
747 %{_mandir}/man7/lvmvdo.7*
748 %{_mandir}/man8/dmfilemapd.8*
749 %{_mandir}/man8/dmsetup.8*
750 %{_mandir}/man8/dmstats.8*
751 %{_mandir}/man8/dmeventd.8*
752
753 %files -n device-mapper-libs
754 %defattr(644,root,root,755)
755 %attr(755,root,root) /%{_lib}/libdevmapper.so.*.*
756 %attr(755,root,root) /%{_lib}/libdevmapper-event.so.*.*
757 %attr(755,root,root) /%{_lib}/libdevmapper-event-lvm2.so.*.*
758 %attr(755,root,root) /%{_lib}/liblvm2cmd.so.*.*
759
760 %files -n device-mapper-devel
761 %defattr(644,root,root,755)
762 %attr(755,root,root) %{_libdir}/libdevmapper.so
763 %attr(755,root,root) %{_libdir}/libdevmapper-event.so
764 %attr(755,root,root) %{_libdir}/libdevmapper-event-lvm2.so
765 %attr(755,root,root) %{_libdir}/liblvm2cmd.so
766 %{_includedir}/libdevmapper.h
767 %{_includedir}/libdevmapper-event.h
768 %{_includedir}/lvm2cmd.h
769 %{_pkgconfigdir}/devmapper.pc
770 %{_pkgconfigdir}/devmapper-event.pc
771
772 %files -n device-mapper-static
773 %defattr(644,root,root,755)
774 %{_libdir}/libdevmapper.a
775
776 %if %{with initrd}
777 %files -n device-mapper-initrd
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/initrd/dmsetup
780
781 %files initrd
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/initrd/lvm
784 %endif
This page took 0.109352 seconds and 3 git commands to generate.