]> git.pld-linux.org Git - packages/lutok.git/blob - lutok.spec
- ldconfig in proper package
[packages/lutok.git] / lutok.spec
1 Summary:        Lightweight C++ API library for Lua
2 Summary(pl.UTF-8):      Lekka biblioteka API C++ dla Lua
3 Name:           lutok
4 Version:        0.4
5 Release:        2
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/jmmv/lutok/releases
9 Source0:        https://github.com/jmmv/lutok/releases/download/%{name}-%{version}/lutok-%{version}.tar.gz
10 # Source0-md5:  5da43895d9209f8c19d79433dd046b3f
11 URL:            https://github.com/jmmv/lutok
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libatf-c++-devel >= 0.20
15 BuildRequires:  libtool
16 BuildRequires:  lua53-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         pkgtestsdir     %{_libexecdir}/lutok/tests
20
21 %description
22 Lutok provides thin C++ wrappers around the Lua C API to ease the
23 interaction between C++ and Lua. These wrappers make intensive use of
24 RAII to prevent resource leakage, expose C++-friendly data types,
25 report errors by means of exceptions and ensure that the Lua stack is
26 always left untouched in the face of errors. The library also provides
27 a small subset of miscellaneous utility functions built on top of the
28 wrappers.
29
30 Lutok focuses on providing a clean and safe C++ interface; the
31 drawback is that it is not suitable for performance-critical
32 environments. In order to implement error-safe C++ wrappers on top of
33 a Lua C binary library, Lutok adds several layers or abstraction and
34 error checking that go against the original spirit of the Lua C API
35 and thus degrade performance.
36
37 %description -l pl.UTF-8
38 Lutok udostępnia cienką warstwę obudowującą API C języka Lua, aby
39 ułatwić współpracę między C++ a Lua. Interfejsy te intensywnie
40 wykorzystują RAII (aby zapobiec wyciekowi zasobów), udostępniają
41 typy danych przyjazne dla C++, zgłaszają błędy poprzez wyjątki i
42 zapewniają, że stos Lua jest nienaruszony w przypadku błędów.
43 Biblioteka udostępnia także mały podzbiór różnych funkcji
44 narzędziowych, zbudowanych w oparciu o te interfejsy.
45
46 Lutok skupia się na zapewnieniu czystego i bezpiecznego interfejsu
47 C++; wadą jest to, że nie nadaje się w środowisku, gdzie krytyczna
48 jest wydajność. Aby zaimplementować bezpieczne pod kątem błędów
49 interfejsy C++ w oparciu o bibliotekę binarną C Lua, Lutok dodaje
50 kilka warstw lub abstrakcji oraz sprawdzania błędów, niezgodnych z
51 duchem API C Lua i zmniejszających wydajność.
52
53 %package -n liblutok
54 Summary:        Lutok library
55 Summary(pl.UTF-8):      Biblioteka Lutok
56 Group:          Libraries
57
58 %description -n liblutok
59 Lutok provides thin C++ wrappers around the Lua C API to ease the
60 interaction between C++ and Lua. These wrappers make intensive use of
61 RAII to prevent resource leakage, expose C++-friendly data types,
62 report errors by means of exceptions and ensure that the Lua stack is
63 always left untouched in the face of errors. The library also provides
64 a small subset of miscellaneous utility functions built on top of the
65 wrappers.
66
67 Lutok focuses on providing a clean and safe C++ interface; the
68 drawback is that it is not suitable for performance-critical
69 environments. In order to implement error-safe C++ wrappers on top of
70 a Lua C binary library, Lutok adds several layers or abstraction and
71 error checking that go against the original spirit of the Lua C API
72 and thus degrade performance.
73
74 %description -n liblutok -l pl.UTF-8
75 Lutok udostępnia cienką warstwę obudowującą API C języka Lua, aby
76 ułatwić współpracę między C++ a Lua. Interfejsy te intensywnie
77 wykorzystują RAII (aby zapobiec wyciekowi zasobów), udostępniają
78 typy danych przyjazne dla C++, zgłaszają błędy poprzez wyjątki i
79 zapewniają, że stos Lua jest nienaruszony w przypadku błędów.
80 Biblioteka udostępnia także mały podzbiór różnych funkcji
81 narzędziowych, zbudowanych w oparciu o te interfejsy.
82
83 Lutok skupia się na zapewnieniu czystego i bezpiecznego interfejsu
84 C++; wadą jest to, że nie nadaje się w środowisku, gdzie krytyczna
85 jest wydajność. Aby zaimplementować bezpieczne pod kątem błędów
86 interfejsy C++ w oparciu o bibliotekę binarną C Lua, Lutok dodaje
87 kilka warstw lub abstrakcji oraz sprawdzania błędów, niezgodnych z
88 duchem API C Lua i zmniejszających wydajność.
89
90 %package -n liblutok-devel
91 Summary:        Header files for Lutok development
92 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Lutok
93 Requires:       liblutok = %{version}-%{release}
94 Requires:       lua-devel >= 5.1
95
96 %description -n liblutok-devel
97 The header files to develop applications that use the Lutok C++ API to
98 Lua.
99
100 %description -n liblutok-devel -l pl.UTF-8
101 Pliki nagłówkowe do tworzenia aplikacji wykorzystująch API C++
102 biblioteki Lutok do Lua.
103
104 %package -n liblutok-static
105 Summary:        Static liblutok library
106 Summary(pl.UTF-8):      Statyczna biblioteka liblutok
107 Group:          Development/Libraries
108 Requires:       liblutok-devel = %{version}-%{release}
109
110 %description -n liblutok-static
111 Static liblutok library.
112
113 %description -n liblutok-static -l pl.UTF-8
114 Statyczna biblioteka liblutok.
115
116 %prep
117 %setup -q
118
119 %build
120 %{__libtoolize}
121 %{__aclocal}
122 %{__autoconf}
123 %{__autoheader}
124 %{__automake}
125 %configure \
126         --docdir=%{_docdir}/lutok-doc-%{version} \
127         --htmldir=%{_docdir}/lutok-doc-%{version}/html \
128         --with-atf \
129         --with-doxygen
130
131 %{__make} \
132         testsdir=%{pkgtestsdir}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT \
139         doc_DATA= \
140         testsdir=%{pkgtestsdir}
141
142 # obsoleted by pkg-config
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/liblutok.la
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -n liblutok -p /sbin/ldconfig
149 %postun -n liblutok -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %doc AUTHORS COPYING NEWS README
154 %doc %{_docdir}/lutok-doc-%{version}
155 %dir %{_libexecdir}/%{name}
156 %{pkgtestsdir}
157
158 %files -n liblutok
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/liblutok.so.*.*.*
161 %attr(755,root,root) %ghost %{_libdir}/liblutok.so.3
162
163 %files -n liblutok-devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/liblutok.so
166 %{_includedir}/lutok
167 %{_pkgconfigdir}/lutok.pc
168
169 %files -n liblutok-static
170 %defattr(644,root,root,755)
171 %{_libdir}/liblutok.a
This page took 0.060693 seconds and 3 git commands to generate.