]> git.pld-linux.org Git - packages/luajit.git/blob - luajit.spec
- new
[packages/luajit.git] / luajit.spec
1 Summary:        Just-in-Time compiler for Lua
2 Summary(pl.UTF-8):      Kompilator JIT dla języka Lua
3 Name:           luajit
4 Version:        2.0.3
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: http://luajit.org/download.html
9 Source0:        http://luajit.org/download/LuaJIT-%{version}.tar.gz
10 # Source0-md5:  f14e9104be513913810cd59c8c658dc0
11 URL:            http://luajit.org/
12 ExclusiveArch:  %{ix86} %{x8664} arm mips ppc
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         lua_abi         5.1
16
17 %description
18 LuaJIT is a Just-In-Time (JIT) compiler for the Lua programming
19 language.
20
21 %description -l pl.UTF-8
22 LuaJIT to działający w locie (Just-In-Time) kompilator języka Lua.
23
24 %package devel
25 Summary:        Header files for LuaJIT library
26 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LuaJIT
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29
30 %description devel
31 Header files for LuaJIT library.
32
33 %description devel -l pl.UTF-8
34 Pliki nagłówkowe biblioteki LuaJIT.
35
36 %package static
37 Summary:        Static LuaJIT library
38 Summary(pl.UTF-8):      Statyczna biblioteka LuaJIT
39 Group:          Development/Libraries
40 Requires:       %{name}-devel = %{version}-%{release}
41
42 %description static
43 Static LuaJIT library.
44
45 %description static -l pl.UTF-8
46 Statyczna biblioteka LuaJIT.
47
48 %prep
49 %setup -q -n LuaJIT-%{version}
50
51 %build
52 %{__make} \
53         CC="%{__cc}" \
54         CCOPT="%{rpmcflags} -fomit-frame-pointer" \
55         CCOPT_x86= \
56         E="@:" \
57         Q=
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT \
64         PREFIX=%{_prefix} \
65         MULTILIB=%{_lib}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post   -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %files
74 %defattr(644,root,root,755)
75 %doc COPYRIGHT README
76 %attr(755,root,root) %{_bindir}/luajit
77 %attr(755,root,root) %{_bindir}/luajit-%{version}
78 %attr(755,root,root) %{_libdir}/libluajit-%{lua_abi}.so.*.*.*
79 %attr(755,root,root) %ghost %{_libdir}/libluajit-%{lua_abi}.so.2
80 %{_datadir}/luajit-%{version}
81 %{_mandir}/man1/luajit.1*
82 # lua module dirs (shared with lua interpreters)
83 %dir %{_libdir}/lua
84 %dir %{_libdir}/lua/%{lua_abi}
85 %dir %{_datadir}/lua
86 %dir %{_datadir}/lua/%{lua_abi}
87
88 %files devel
89 %defattr(644,root,root,755)
90 %doc doc/*
91 %attr(755,root,root) %{_libdir}/libluajit-%{lua_abi}.so
92 %{_includedir}/luajit-2.0
93 %{_pkgconfigdir}/luajit.pc
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libluajit-%{lua_abi}.a
This page took 0.167845 seconds and 3 git commands to generate.