]> git.pld-linux.org Git - packages/lsh.git/blob - lsh.spec
- added extern patch (add missing externs to fix build with -fno-common, gcc 10+...
[packages/lsh.git] / lsh.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos5       # without kerberos V support
4 #
5 Summary:        GNU implementation of the Secure Shell protocols
6 Summary(pl.UTF-8):      Implementacja GNU bezpiecznego shella
7 Name:           lsh
8 Version:        2.1
9 Release:        11
10 License:        GPL v2+
11 Group:          Networking/Daemons
12 Source0:        http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
13 # Source0-md5:  cde8e1306b1c544909e1e9ecb86e6402
14 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
15 # Source1-md5:  164cdde8060577b54954c3f9f067927e
16 Patch0:         %{name}-info.patch
17 Patch1:         skip-argp.patch
18 Patch2:         nettle3.patch
19 Patch3:         nettle35.patch
20 Patch4:         guile.patch
21 Patch5:         %{name}-extern.patch
22 URL:            http://www.lysator.liu.se/~nisse/lsh/
23 BuildRequires:  autoconf >= 2.52
24 BuildRequires:  automake
25 BuildRequires:  gmp-devel >= 3.1
26 BuildRequires:  groff
27 %{?with_kerberos5:BuildRequires:        heimdal-devel}
28 BuildRequires:  liboop-devel
29 BuildRequires:  libwrap-devel
30 BuildRequires:  m4
31 BuildRequires:  nettle-devel >= 1.14
32 BuildRequires:  pam-devel
33 BuildRequires:  texinfo
34 BuildRequires:  xorg-lib-libXau-devel
35 BuildRequires:  zlib-devel
36 # only for maintainer mode
37 #BuildRequires: guile
38 #BuildRequires: slib
39 Requires:       nettle >= 1.14
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _sysconfdir      /etc/%{name}
43
44 %description
45 LSH is the GNU implementation of the secure shell protocols (secsh2).
46 LSH includes a client, a server, and a few scripts and utility
47 programs.
48
49 Note: it doesn't support SSH1 protocol, but the server can fallback to
50 /usr/sbin/sshd - if you need SSH1 support in server, please install
51 appropriate daemon (openssh-server, SSH.COM 1.2.x) as /usr/sbin/sshd.
52
53 %description -l pl.UTF-8
54 LSH jest implementacją GNU protokołów bezpiecznego shella (secsh2).
55 Zawiera klienta, serwer, kilka skryptów i narzędzi.
56
57 Uwaga: ta implementacja nie obsługuje protokołu SSH1, ale serwer może
58 wywołać /usr/sbin/sshd. Jeśli obsługa SSH1 jest potrzebna w serwerze,
59 należy zainstalować odpowiedniego demona (openssh-server lub SSH.COM
60 1.2.x) jako /usr/sbin/sshd.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67 %patch3 -p1
68 %patch4 -p1
69 %patch5 -p1
70
71 %build
72 cd src/spki
73 %{__aclocal}
74 %{__autoconf}
75 %{__automake}
76 cd ../..
77 %{__aclocal}
78 %{__autoconf}
79 %{__automake}
80 %configure \
81         XAUTH_PROGRAM=/usr/bin/xauth \
82         %{!?with_kerberos5:--disable-kerberos} \
83         --with-sshd1=%{_sbindir}/sshd \
84         --with-tcpwrappers \
85         --with-zlib
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,logrotate.d},/var/spool/lsh}
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 install -d $RPM_BUILD_ROOT%{_mandir}
97 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
98 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lsh-man-pages,diff.*}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/postshell
104 -/usr/sbin/fix-info-dir -c %{_infodir}
105
106 %postun -p /sbin/postshell
107 -/usr/sbin/fix-info-dir -c %{_infodir}
108
109 %files
110 %defattr(644,root,root,755)
111 %doc ANNOUNCE AUTHORS ChangeLog* FAQ NEWS README doc/{HACKING,NOTES,PORTS,TASKLIST,TODO,*.txt}
112 #%attr(754,root,root) /etc/rc.d/init.d/*
113 #%attr(640,root,root) /etc/sysconfig/*
114 #%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/*
115 %attr(6750,root,root) %dir /var/spool/lsh
116 %attr(755,root,root) %{_bindir}/lcp
117 %attr(755,root,root) %{_bindir}/lsftp
118 %attr(755,root,root) %{_bindir}/lsh
119 %attr(755,root,root) %{_bindir}/lsh-authorize
120 %attr(755,root,root) %{_bindir}/lsh-decode-key
121 %attr(755,root,root) %{_bindir}/lsh-decrypt-key
122 %attr(755,root,root) %{_bindir}/lsh-export-key
123 %attr(755,root,root) %{_bindir}/lsh-keygen
124 %attr(755,root,root) %{_bindir}/lsh-make-seed
125 %attr(755,root,root) %{_bindir}/lsh-upgrade
126 %attr(755,root,root) %{_bindir}/lsh-upgrade-key
127 %attr(755,root,root) %{_bindir}/lsh-writekey
128 %attr(755,root,root) %{_bindir}/lshg
129 %attr(755,root,root) %{_bindir}/srp-gen
130 %attr(755,root,root) %{_bindir}/ssh-conv
131 %attr(755,root,root) %{_sbindir}/lsh-execuv
132 %{?with_kerberos5:%attr(755,root,root) %{_sbindir}/lsh-krb-checkpw}
133 %attr(755,root,root) %{_sbindir}/lsh-pam-checkpw
134 %attr(755,root,root) %{_sbindir}/lshd
135 %attr(755,root,root) %{_sbindir}/sftp-server
136 %{_infodir}/lsh.info*
137 %{_mandir}/man1/lsftp.1*
138 %{_mandir}/man1/lsh.1*
139 %{_mandir}/man1/lsh-authorize.1*
140 %{_mandir}/man1/lsh-decode-key.1*
141 %{_mandir}/man1/lsh-decrypt-key.1*
142 %{_mandir}/man1/lsh-export-key.1*
143 %{_mandir}/man1/lsh-keygen.1*
144 %{_mandir}/man1/lsh-make-seed.1*
145 %{_mandir}/man1/lsh-upgrade.1*
146 %{_mandir}/man1/lsh-upgrade-key.1*
147 %{_mandir}/man1/lsh-writekey.1*
148 %{_mandir}/man1/lshg.1*
149 %{_mandir}/man1/sexp-conv.1*
150 %{_mandir}/man1/srp-gen.1*
151 %{_mandir}/man1/ssh-conv.1*
152 %{_mandir}/man5/DSA.5*
153 %{_mandir}/man5/SHA.5*
154 %{_mandir}/man5/SPKI.5*
155 %{_mandir}/man5/secsh.5*
156 %{_mandir}/man8/lshd.8*
157 %{_mandir}/man8/sftp-server.8*
This page took 0.15328 seconds and 4 git commands to generate.