]> git.pld-linux.org Git - packages/lsh.git/blob - lsh.spec
8468e40ef8fe691d4e9e3ccb5f0b31d20bef1e8b
[packages/lsh.git] / lsh.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos5       # without kerberos V support
4 #
5 Summary:        GNU implementation of the Secure Shell protocols
6 Summary(pl.UTF-8):      Implementacja GNU bezpiecznego shella
7 Name:           lsh
8 Version:        2.1
9 Release:        8
10 License:        GPL v2+
11 Group:          Networking/Daemons
12 Source0:        http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
13 # Source0-md5:  cde8e1306b1c544909e1e9ecb86e6402
14 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
15 # Source1-md5:  164cdde8060577b54954c3f9f067927e
16 Patch0:         %{name}-info.patch
17 Patch1:         skip-argp.patch
18 Patch2:         nettle3.patch
19 Patch3:         nettle35.patch
20 Patch4:         guile.patch
21 URL:            http://www.lysator.liu.se/~nisse/lsh/
22 BuildRequires:  autoconf >= 2.52
23 BuildRequires:  automake
24 BuildRequires:  gmp-devel >= 3.1
25 BuildRequires:  groff
26 %{?with_kerberos5:BuildRequires:        heimdal-devel}
27 BuildRequires:  liboop-devel
28 BuildRequires:  libwrap-devel
29 BuildRequires:  m4
30 BuildRequires:  nettle-devel >= 1.14
31 BuildRequires:  pam-devel
32 BuildRequires:  texinfo
33 BuildRequires:  xorg-lib-libXau-devel
34 BuildRequires:  zlib-devel
35 # only for maintainer mode
36 #BuildRequires: guile
37 #BuildRequires: slib
38 Requires:       nettle >= 1.14
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _sysconfdir      /etc/%{name}
42
43 %description
44 LSH is the GNU implementation of the secure shell protocols (secsh2).
45 LSH includes a client, a server, and a few scripts and utility
46 programs.
47
48 Note: it doesn't support SSH1 protocol, but the server can fallback to
49 /usr/sbin/sshd - if you need SSH1 support in server, please install
50 appropriate daemon (openssh-server, SSH.COM 1.2.x) as /usr/sbin/sshd.
51
52 %description -l pl.UTF-8
53 LSH jest implementacją GNU protokołów bezpiecznego shella (secsh2).
54 Zawiera klienta, serwer, kilka skryptów i narzędzi.
55
56 Uwaga: ta implementacja nie obsługuje protokołu SSH1, ale serwer może
57 wywołać /usr/sbin/sshd. Jeśli obsługa SSH1 jest potrzebna w serwerze,
58 należy zainstalować odpowiedniego demona (openssh-server lub SSH.COM
59 1.2.x) jako /usr/sbin/sshd.
60
61 %prep
62 %setup -q
63 %patch0 -p1
64 %patch1 -p1
65 %patch2 -p1
66 %patch3 -p1
67 %patch4 -p1
68
69 %build
70 cd src/spki
71 %{__aclocal}
72 %{__autoconf}
73 %{__automake}
74 cd ../..
75 %{__aclocal}
76 %{__autoconf}
77 %{__automake}
78 %configure \
79         XAUTH_PROGRAM=/usr/bin/xauth \
80         %{!?with_kerberos5:--disable-kerberos} \
81         --with-sshd1=%{_sbindir}/sshd \
82         --with-tcpwrappers \
83         --with-zlib
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,sysconfig,logrotate.d},/var/spool/lsh}
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 install -d $RPM_BUILD_ROOT%{_mandir}
95 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
96 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lsh-man-pages,diff.*}
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/postshell
102 -/usr/sbin/fix-info-dir -c %{_infodir}
103
104 %postun -p /sbin/postshell
105 -/usr/sbin/fix-info-dir -c %{_infodir}
106
107 %files
108 %defattr(644,root,root,755)
109 %doc ANNOUNCE AUTHORS ChangeLog* FAQ NEWS README doc/{HACKING,NOTES,PORTS,TASKLIST,TODO,*.txt}
110 #%attr(754,root,root) /etc/rc.d/init.d/*
111 #%attr(640,root,root) /etc/sysconfig/*
112 #%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/*
113 %attr(6750,root,root) %dir /var/spool/lsh
114 %attr(755,root,root) %{_bindir}/lcp
115 %attr(755,root,root) %{_bindir}/lsftp
116 %attr(755,root,root) %{_bindir}/lsh
117 %attr(755,root,root) %{_bindir}/lsh-authorize
118 %attr(755,root,root) %{_bindir}/lsh-decode-key
119 %attr(755,root,root) %{_bindir}/lsh-decrypt-key
120 %attr(755,root,root) %{_bindir}/lsh-export-key
121 %attr(755,root,root) %{_bindir}/lsh-keygen
122 %attr(755,root,root) %{_bindir}/lsh-make-seed
123 %attr(755,root,root) %{_bindir}/lsh-upgrade
124 %attr(755,root,root) %{_bindir}/lsh-upgrade-key
125 %attr(755,root,root) %{_bindir}/lsh-writekey
126 %attr(755,root,root) %{_bindir}/lshg
127 %attr(755,root,root) %{_bindir}/srp-gen
128 %attr(755,root,root) %{_bindir}/ssh-conv
129 %attr(755,root,root) %{_sbindir}/lsh-execuv
130 %{?with_kerberos5:%attr(755,root,root) %{_sbindir}/lsh-krb-checkpw}
131 %attr(755,root,root) %{_sbindir}/lsh-pam-checkpw
132 %attr(755,root,root) %{_sbindir}/lshd
133 %attr(755,root,root) %{_sbindir}/sftp-server
134 %{_infodir}/lsh.info*
135 %{_mandir}/man1/lsftp.1*
136 %{_mandir}/man1/lsh.1*
137 %{_mandir}/man1/lsh-authorize.1*
138 %{_mandir}/man1/lsh-decode-key.1*
139 %{_mandir}/man1/lsh-decrypt-key.1*
140 %{_mandir}/man1/lsh-export-key.1*
141 %{_mandir}/man1/lsh-keygen.1*
142 %{_mandir}/man1/lsh-make-seed.1*
143 %{_mandir}/man1/lsh-upgrade.1*
144 %{_mandir}/man1/lsh-upgrade-key.1*
145 %{_mandir}/man1/lsh-writekey.1*
146 %{_mandir}/man1/lshg.1*
147 %{_mandir}/man1/sexp-conv.1*
148 %{_mandir}/man1/srp-gen.1*
149 %{_mandir}/man1/ssh-conv.1*
150 %{_mandir}/man5/DSA.5*
151 %{_mandir}/man5/SHA.5*
152 %{_mandir}/man5/SPKI.5*
153 %{_mandir}/man5/secsh.5*
154 %{_mandir}/man8/lshd.8*
155 %{_mandir}/man8/sftp-server.8*
This page took 0.051617 seconds and 2 git commands to generate.