]> git.pld-linux.org Git - packages/lpcnetfreedv.git/blob - lpcnetfreedv.spec
- new, partially based on Fedora
[packages/lpcnetfreedv.git] / lpcnetfreedv.spec
1 #
2 # Conditional build:
3 %bcond_with     avx     # x86 AVX instructions
4 %bcond_with     avx2    # x86 AVX2 instructions
5 %bcond_with     armneon # ARM NEON instructions
6
7 Summary:        LPCNet for FreeDV
8 Summary(pl.UTF-8):      LPCNet dla FreeDV
9 Name:           lpcnetfreedv
10 Version:        0.2
11 Release:        1
12 License:        BSD
13 Group:          Libraries
14 #Source0Download: https://github.com/drowe67/LPCNet/releases
15 Source0:        https://github.com/drowe67/LPCNet/archive/v%{version}/LPCNet-%{version}.tar.gz
16 # Source0-md5:  f4b87be1825bd3fd5936b481b0f93bac
17 Source1:        http://rowetel.com/downloads/deep/lpcnet_191005_v1.0.tgz
18 # Source1-md5:  a86894b209a1869b50454fe591f047a1
19 # Fixes for aarch64 which has NEON instructions natively
20 Patch0:         %{name}-vector-updates.patch
21 URL:            https://github.com/drowe67/LPCNet
22 BuildRequires:  cmake >= 3.0
23 BuildRequires:  codec2-devel >= 0.9
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Experimental version of LPCNet that has been used to develop FreeDV
28 2020 - a HF radio Digital Voice mode for over the air experimentation
29 with Neural Net speech coding. Possibly the first use of Neural Net
30 speech coding in real world operation.
31
32 %description -l pl.UTF-8
33 Eksperymentalna wersja LPCNet, używana przy tworzeniu FreeDV 2020 - 
34 trybu radiowego dźwięku cyfrowego do eksperymentowania z kodowaniem
35 mowy opartym na sieci neuronowej. Jest to prawdopodobnie pierwsze
36 zastosowanie praktyczne kodowania mowy z użyciem sieci neuronowej.
37
38 %package devel
39 Summary:        Development files for LPCNet
40 Summary(pl.UTF-8):      Pliki programistyczne LPCNet
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Development files for LPCNet.
46
47 %description devel -l pl.UTF-8
48 Pliki programistyczne LPCNet.
49
50 %prep
51 %setup -q -n LPCNet-%{version}
52 %patch0 -p1
53
54 %build
55 install -d build
56 cd build
57 # Add model data archive to the build directory so CMake finds it.
58 cp %{SOURCE1} .
59
60 %cmake .. \
61         -DDISABLE_CPU_OPTIMIZATION=ON \
62         %{?with_avx:-DAVX=ON} \
63         %{?with_avx2:-DAVX2=ON} \
64         %{?with_armneon:-DNEON=ON}
65
66 %{__make}
67
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc COPYING README.md
81 %attr(755,root,root) %{_bindir}/lpcnet_dec
82 %attr(755,root,root) %{_bindir}/lpcnet_enc
83 %attr(755,root,root) %{_libdir}/liblpcnetfreedv.so
84
85 %files devel
86 %defattr(644,root,root,755)
87 %{_includedir}/lpcnet
88 %{_libdir}/cmake/lpcnetfreedv
This page took 0.074547 seconds and 3 git commands to generate.