]> git.pld-linux.org Git - packages/logrotate.git/blob - logrotate.spec
- fixed some typos in man page
[packages/logrotate.git] / logrotate.spec
1 Summary:        Rotates, compresses, removes and mails system log files
2 Summary(de):    Rotiert, komprimiert und verschickt Systemlogs
3 Summary(es):    Hace el rutado, comprime y envía mail de logs del sistema
4 Summary(fr):    Fait tourner, compresse, et envoie par mail les connexions au système
5 Summary(pl):    System rotacji i kompresowania logów
6 Summary(tr):    Sistem günlüklerini yönlendirir, sýkýþtýrýr ve mektup olarak yollar
7 Name:           logrotate
8 Version:        3.6
9 Release:        6
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.redhat.com/pub/redhat/code/logrotate/%{name}-%{version}.tar.gz
13 Source1:        %{name}.conf
14 Patch0:         %{name}-man.patch
15 Requires:       /bin/mail
16 Requires(post): fileutils
17 BuildRequires:  popt-devel >= 1.3
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         statdir         /var/lib/misc
21
22 %description
23 The logrotate utility is designed to simplify the administration of
24 log files on a system which generates a lot of log files. Logrotate
25 allows for the automatic rotation compression, removal and mailing of
26 log files. Logrotate can be set to handle a log file daily, weekly,
27 monthly or when the log file gets to a certain size. Normally,
28 logrotate runs as a daily cron job.
29
30 %description -l de
31 Logrotate vereinfacht die Verwaltung von Systemen, die sehr viele
32 Log-Dateien erzeugen, indem es das automatische Rotieren,
33 Komprimieren, Entfernen, und Senden von Log-Dateien ermöglicht. Jede
34 Log-Datei kann täglich, wöchentlich oder monatlich verarbeitet werden,
35 wenn sie zu groß wird.
36
37 %description -l es
38 Logrotate fue proyectado para facilitar la administración de sistemas
39 que generan gran número de archivos de log. Permite automatización en
40 la rotación, compresión, remoción y envío de mail de archivos de logs.
41 Cada archivo de log puede ser tratado diariamente, semanalmente,
42 mensualmente o cuanto crezca demasiado.
43
44 %description -l fr
45 Logrotate est conçu pour faciliter l'administration de systèmes qui
46 générent un grand nombre de fichiers de \"log\". Il permet le
47 roulement, la suppréssion la compression et l'envoi automatiques de
48 ces fichiers. Chaque fichier de \"log\" peut être pris en charge de
49 manière quotidienne, hebdomadaire, mensuelle, ou quand il devient trop
50 volumineux.
51
52 %description -l pl
53 Logrotate jest przeznaczony do ³atwej administracji plikami logów.
54 Program ten pozwala na automatyczn± kompresjê logów. Mo¿e kontrolowaæ
55 logi raz dziennie, raz na miesi±c, raz na tydzieñ lub wtedy kiedy
56 pliki z logami systemowymi s± ju¿ du¿e.
57
58 %description -l tr
59 logrotate çok fazla sayýda günlük dosyasý üreten sistemlerin
60 yönetimini kolaylaþtýrmak için tasarlanmýþtýr. Kayýt dosyalarýnýn
61 otomatik olarak yönlendirilmesini, sýkýþtýrýlmasýný, silinmesiný ve
62 mektup olarak yollanmasýný saðlar. Her dosya günlük, haftalýk, aylýk
63 olarak ya da çok büyük boyutlara ulaþtýðýnda iþlenebilir.
64
65 %prep
66 %setup -q
67 %patch -p0
68
69 %build
70 %{__make} \
71         CC=%{__cc} RPM_OPT_FLAGS="%{rpmcflags}" \
72         STATEFILE="%{statdir}/logrotate.status"
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT/etc/{cron.daily,logrotate.d} \
77         $RPM_BUILD_ROOT{%{_mandir},%{statdir},/var/log/archiv}
78
79 %{__make} install \
80         BINDIR=$RPM_BUILD_ROOT%{_sbindir} \
81         MANDIR=$RPM_BUILD_ROOT%{_mandir}
82
83 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.conf
84 install examples/logrotate.cron $RPM_BUILD_ROOT/etc/cron.daily/logrotate
85 > $RPM_BUILD_ROOT%{statdir}/logrotate.status
86
87 gzip -9nf CHANGES
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post
93 if [ -f /var/lib/logrotate.status ]; then
94         mv -f /var/lib/logrotate.status %{statdir}/logrotate.status
95 else
96         touch %{statdir}/logrotate.status
97         chmod 000 %{statdir}/logrotate.status
98         chown root.root %{statdir}/logrotate.status
99         chmod 640 %{statdir}/logrotate.status
100 fi
101
102 %files
103 %defattr(644,root,root,755)
104 %doc CHANGES.gz
105 %attr(755,root,root) %{_sbindir}/logrotate
106 %attr(750,root,root) %dir /etc/logrotate.d
107 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/cron.daily/logrotate
108 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*.conf
109 %attr(640,root,root) %ghost %{statdir}/logrotate.status
110 %attr(750,root,root) %dir /var/log/archiv
111
112 %{_mandir}/man8/*
This page took 0.087222 seconds and 4 git commands to generate.