]> git.pld-linux.org Git - packages/log4cxx.git/blob - log4cxx.spec
- added libesmtp patch, enabled libesmtp by default (the issue was outdated internal...
[packages/log4cxx.git] / log4cxx.spec
1 # TODO:
2 # LOG4CXX_QT_SUPPORT
3 #
4 # Conditional build:
5 %bcond_without  libesmtp        # (E)SMTP support via libesmtp
6
7 Summary:        Log4cxx - a port to C++ of the log4j project
8 Summary(pl.UTF-8):      Log4cxx - port projektu log4j dla C++
9 Name:           log4cxx
10 Version:        1.0.0
11 Release:        2
12 License:        Apache v2.0
13 Group:          Libraries
14 Source0:        http://www.apache.org/dist/logging/log4cxx/%{version}/apache-%{name}-%{version}.tar.gz
15 # Source0-md5:  2255f30cd968e2c1976081824e435bd5
16 Patch0:         %{name}-libesmtp.patch
17 URL:            http://logging.apache.org/log4cxx/
18 BuildRequires:  apr-devel >= 1
19 BuildRequires:  apr-util-devel >= 1
20 BuildRequires:  boost-devel
21 BuildRequires:  cmake >= 3.13
22 # for tests
23 BuildRequires:  expat-devel >= 1.95
24 %{?with_libesmtp:BuildRequires: libesmtp-devel}
25 BuildRequires:  libfmt-devel >= 7.1
26 BuildRequires:  libstdc++-devel >= 6:7
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpmbuild(macros) >= 1.605
29 BuildRequires:  unixODBC-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Log4cxx is C++ port of Log4j. Log4cxx attempts to mimic log4j usage as
34 much as the language will allow and to be compatible with log4j
35 configuration and output formats.
36
37 %description -l pl.UTF-8
38 Log4cxx jest portem Log4j dla C++. Log4cxx próbuje naśladować
39 użytkowanie log4j tak bardzo na ile pozwala na to język oraz próbuje
40 być kompatybilnym z plikami konfiguracyjnymi i formatami wyjściowymi
41 log4j.
42
43 %package devel
44 Summary:        Header files for log4cxx library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki log4cxx
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       apr-devel >= 1
49 Requires:       apr-util-devel >= 1
50 Requires:       libstdc++-devel >= 6:7
51 Obsoletes:      log4cxx-static < 1
52
53 %description devel
54 This is the package containing the header files for log4cxx library.
55
56 %description devel -l pl.UTF-8
57 Ten pakiet zawiera pliki nagłówkowe biblioteki log4cxx.
58
59 %prep
60 %setup -q -n apache-%{name}-%{version}
61 %patch0 -p1
62
63 %build
64 %cmake -B build \
65         -DCMAKE_INSTALL_INCLUDEDIR=include \
66         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
67         %{!?with_libesmtp:-DHAS_LIBESMTP=OFF}
68
69 %{__make} -C build
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} -C build install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc KEYS LICENSE NOTICE
86 %attr(755,root,root) %{_libdir}/liblog4cxx.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/liblog4cxx.so.15
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/liblog4cxx.so
92 %{_includedir}/%{name}
93 %{_pkgconfigdir}/liblog4cxx.pc
94 %{_libdir}/cmake/log4cxx
This page took 0.075462 seconds and 3 git commands to generate.