]> git.pld-linux.org Git - packages/llvm.git/blob - llvm.spec
- build also lld
[packages/llvm.git] / llvm.spec
1 #
2 # Conditional build:
3 %bcond_without  lldb    # LLDB debugger
4 %bcond_without  polly   # Polly cache-locality optimization, auto-parallelism and vectorization
5 %bcond_without  rt      # compiler-rt libraries
6 %bcond_without  ocaml   # OCaml binding
7 %bcond_without  doc     # HTML docs and man pages
8 %bcond_with     apidocs # doxygen docs (HUGE, so they are not built by default)
9 %bcond_with     tests   # run tests
10
11 %ifarch s390 s390x sparc64
12 # No ocaml on these arches
13 %undefine       with_ocaml
14 %endif
15
16 Summary:        The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
17 Summary(pl.UTF-8):      Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
18 Name:           llvm
19 Version:        3.5.0
20 Release:        1
21 License:        University of Illinois/NCSA Open Source License
22 Group:          Development/Languages
23 #Source0Download: http://llvm.org/releases/download.html
24 Source0:        http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
25 # Source0-md5:  d6987305a1a0e58e128c1374cd3b8fef
26 Source1:        http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
27 # Source1-md5:  27718dd13c7df83e15f997116bbb4aef
28 Source2:        http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
29 # Source2-md5:  02624d2a9144278c3808c00dbbab56c8
30 Source3:        http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
31 # Source3-md5:  9597d5376309805ac586adfbd1e992f4
32 Source4:        http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
33 # Source4-md5:  2ee0167c7ed7c85026cdb18ad6f4ade8
34 Source5:        http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
35 # Source5-md5:  6e2830316638ec0de9534b98361dfbec
36 Source6:        http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
37 # Source6-md5:  946404d534a51f1806d1ee955885d927
38 Patch0:         %{name}-config.patch
39 # Data files should be installed with timestamps preserved
40 Patch1:         %{name}-2.6-timestamp.patch
41 Patch2:         %{name}-pld.patch
42 Patch3:         %{name}-polly-update.patch
43 Patch4:         %{name}-lldb.patch
44 Patch5:         %{name}-lld-link.patch
45 URL:            http://llvm.org/
46 BuildRequires:  autoconf >= 2.60
47 BuildRequires:  automake >= 1:1.9.6
48 BuildRequires:  bash
49 BuildRequires:  bison
50 BuildRequires:  flex
51 BuildRequires:  gcc >= 5:3.4
52 # gcc4 might be installed, but not current __cc
53 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
54 BuildRequires:  __cc >= 3.4
55 %endif
56 BuildRequires:  groff
57 BuildRequires:  libltdl-devel
58 BuildRequires:  libtool >= 2:1.5.22
59 BuildRequires:  libstdc++-devel >= 5:3.4
60 BuildRequires:  ocaml-ocamldoc
61 BuildRequires:  perl-base >= 1:5.6
62 BuildRequires:  perl-tools-pod
63 BuildRequires:  rpm-pythonprov
64 %{?with_doc:BuildRequires:      sphinx-pdg}
65 BuildRequires:  tar >= 1:1.22
66 BuildRequires:  xz
67 %if %{with apidocs}
68 BuildRequires:  doxygen
69 BuildRequires:  graphviz
70 %endif
71 %if %{with tests}
72 BuildRequires:  dejagnu
73 BuildRequires:  python
74 BuildRequires:  tcl-devel
75 %endif
76 %if %{with lldb}
77 BuildRequires:  libedit-devel
78 BuildRequires:  libxml2-devel >= 2
79 BuildRequires:  ncurses-ext-devel
80 BuildRequires:  python-devel >= 2
81 %endif
82 %if %{with polly}
83 BuildRequires:  cloog-isl-devel
84 # >= 0.18.2-2
85 BuildRequires:  gmp-devel
86 BuildRequires:  isl-devel >= 0.13
87 # optional
88 BuildRequires:  pluto-devel
89 BuildRequires:  scoplib-devel >= 0.2.1-2
90 #cuda-devel
91 %endif
92 Requires:       %{name}-libs = %{version}-%{release}
93 # LLVM is not supported on PPC64
94 # http://llvm.org/bugs/show_bug.cgi?id=3729
95 ExcludeArch:    ppc64
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %define         _sysconfdir     /etc/%{name}
99
100 %define         specflags_ppc   -fno-var-tracking-assignments
101
102 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
103 %define         _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
104
105 %description
106 LLVM is a compiler infrastructure designed for compile-time,
107 link-time, runtime, and idle-time optimization of programs from
108 arbitrary programming languages. LLVM is written in C++ and has been
109 developed since 2000 at the University of Illinois and Apple. It
110 currently supports compilation of C and C++ programs using clang
111 frontend.
112
113 %description -l pl.UTF-8
114 LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
115 czasu kompilowania, linkowania, działania i bezczynności programów w
116 dowolnych językach programowania. Jest napisana w C++, rozwijana od
117 roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
118 kompilację programów w C i C++ przy użyciu frontendu clang.
119
120 %package libs
121 Summary:        LLVM shared library
122 Summary(pl.UTF-8):      Biblioteka współdzielona LLVM-a
123 Group:          Libraries
124 Conflicts:      llvm < 3.2
125
126 %description libs
127 LLVM shared library.
128
129 %description libs -l pl.UTF-8
130 Biblioteka współdzielona LLVM-a.
131
132 %package devel
133 Summary:        Static libraries and header files for LLVM
134 Summary(pl.UTF-8):      Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
135 Group:          Development/Languages
136 Requires:       %{name}-libs = %{version}-%{release}
137 Requires:       libstdc++-devel >= 6:3.4
138
139 %description devel
140 This package contains static libraries and header files needed to
141 develop new native programs that use the LLVM infrastructure.
142
143 %description devel -l pl.UTF-8
144 Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
145 potrzebne do tworzenia nowych programów natywnych wykorzystujących
146 infrastrukturę LLVM.
147
148 %package doc
149 Summary:        Documentation for LLVM
150 Summary(pl.UTF-8):      Dokumentacja do LLVM-a
151 Group:          Documentation
152 # does not require base
153
154 %description doc
155 Documentation for the LLVM compiler infrastructure.
156
157 %description doc -l pl.UTF-8
158 Dokumentacja do infrastruktury kompilatorów LLVM.
159
160 %package apidocs
161 Summary:        API documentation for LLVM
162 Summary(pl.UTF-8):      Dokumentacja API LLVM-a
163 Group:          Development/Languages
164 Requires:       %{name}-doc = %{version}-%{release}
165
166 %description apidocs
167 API documentation for the LLVM compiler infrastructure.
168
169 %description apidocs -l pl.UTF-8
170 Dokumentacja API infrastruktury kompilatorów LLVM.
171
172 %package polly
173 Summary:        Polyhedral optimizations for LLVM
174 Summary(pl.UTF-8):      Optymalizacje wielościanowe dla LLVM-a
175 Group:          Development/Tools
176 URL:            http://polly.llvm.org/
177 Requires:       %{name} = %{version}-%{release}
178
179 %description polly
180 Polly is a high-level loop and data-locality optimizer and
181 optimization infrastructure for LLVM. It uses an abstract mathematical
182 representation based on integer polyhedra to analyze and optimize the
183 memory access pattern of a program.
184
185 %description polly -l pl.UTF-8
186 Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
187 optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
188 reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
189 do analizy i optymalizacji wzorców dostępu do pamięci przez program.
190
191 %package polly-devel
192 Summary:        Header files for LLVM Polly optimization infrastructure
193 Summary(pl.UTF-8):      Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
194 Group:          Development/Libraries
195 URL:            http://polly.llvm.org/
196 Requires:       %{name}-devel = %{version}-%{release}
197 Requires:       %{name}-polly = %{version}-%{release}
198
199 %description polly-devel
200 Header files for LLVM Polly optimization infrastructure.
201
202 %description polly-devel -l pl.UTF-8
203 Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
204
205 %package -n clang
206 Summary:        A C language family frontend for LLVM
207 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C
208 License:        NCSA
209 Group:          Development/Languages
210 Requires:       %{name} = %{version}-%{release}
211
212 %description -n clang
213 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
214 of a crane or goose. 3. C-language family front-end toolkit.
215
216 The goal of the Clang project is to create a new C, C++, Objective C
217 and Objective C++ front-end for the LLVM compiler. Its tools are built
218 as libraries and designed to be loosely-coupled and extendable.
219
220 %description -n clang -l pl.UTF-8
221 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
222 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
223 z rodziny C.
224
225 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
226 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
227 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
228 i rozszerzaniu.
229
230 %package -n clang-analyzer
231 Summary:        A source code analysis framework
232 Summary(pl.UTF-8):      Szkielet do analizy kodu źródłowego
233 License:        NCSA
234 Group:          Development/Languages
235 Requires:       clang = %{version}-%{release}
236 # not picked up automatically since files are currently not instaled
237 # in standard Python hierarchies yet
238 Requires:       python
239
240 %description -n clang-analyzer
241 The Clang Static Analyzer consists of both a source code analysis
242 framework and a standalone tool that finds bugs in C and Objective-C
243 programs. The standalone tool is invoked from the command-line, and is
244 intended to run in tandem with a build of a project or code base.
245
246 %description -n clang-analyzer -l pl.UTF-8
247 Clang Static Analyzer składa się ze szkieletu do analizy kodu
248 źródłowego oraz samodzielnego narzędzia znajdującego błędy w
249 programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
250 myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
251
252 %package -n clang-devel
253 Summary:        Header files for Clang
254 Summary(pl.UTF-8):      Pliki nagłówkowe Clanga
255 Group:          Development/Languages
256 Requires:       %{name}-devel = %{version}-%{release}
257 Requires:       clang = %{version}-%{release}
258
259 %description -n clang-devel
260 This package contains header files for the Clang compiler.
261
262 %description -n clang-devel -l pl.UTF-8
263 Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
264
265 %package -n clang-doc
266 Summary:        Documentation for Clang
267 Summary(pl.UTF-8):      Dokumentacja do Clanga
268 Group:          Documentation
269 Requires:       %{name} = %{version}-%{release}
270
271 %description -n clang-doc
272 Documentation for the Clang compiler front-end.
273
274 %description -n clang-doc -l pl.UTF-8
275 Dokumentacja do frontendu kompilatora Clang.
276
277 %package -n clang-apidocs
278 Summary:        API documentation for Clang
279 Summary(pl.UTF-8):      Dokumentacja API Clanga
280 Group:          Development/Languages
281 Requires:       clang-doc = %{version}-%{release}
282
283 %description -n clang-apidocs
284 API documentation for the Clang compiler.
285
286 %description -n clang-apidocs -l pl.UTF-8
287 Dokumentacja API kompilatora Clang.
288
289 %package -n clang-tools-extra
290 Summary:        Extra tools for Clang
291 Summary(pl.UTF-8):      Dodatkowe narzędzia do kompilatora Clang
292 Group:          Development/Tools
293 URL:            http://clang.llvm.org/docs/ClangTools.html
294 Requires:       clang = %{version}-%{release}
295
296 %description -n clang-tools-extra
297 Extra tools for Clang.
298
299 %description -n clang-tools-extra -l pl.UTF-8
300 Dodatkowe narzędzia do kompilatora Clang.
301
302 %package -n lld
303 Summary:        The LLVM linker
304 Summary(pl.UTF-8):      Konsolidator z projektu LLVM
305 Group:          Development/Libraries
306 URL:            http://lld.llvm.org/
307 Requires:       %{name} = %{version}-%{release}
308
309 %description -n lld
310 lld is a new set of modular code for creating linker tools.
311
312 %description -n lld -l pl.UTF-8
313 lld to nowy zbiór modularnego kodu do tworzenia narzędzi
314 konsolidujących.
315
316 %package -n lld-devel
317 Summary:        Development files for LLD linker tools
318 Summary(pl.UTF-8):      Pliki programistyczne narzędzi konsolidujących LLD
319 Group:          Development/Tools
320 URL:            http://lld.llvm.org/
321 Requires:       %{name}-devel = %{version}-%{release}
322
323 %description -n lld-devel
324 Development files for LLD linker tools.
325
326 %description -n lld-devel -l pl.UTF-8
327 Pliki programistyczne narzędzi konsolidujących LLD.
328
329 %package -n lldb
330 Summary:        Next generation high-performance debugger
331 Summary(pl.UTF-8):      Wydajny debugger nowej generacji
332 Group:          Development/Debuggers
333 URL:            http://lldb.llvm.org/
334 Requires:       %{name} = %{version}-%{release}
335
336 %description -n lldb
337 LLDB is a next generation, high-performance debugger. It is built as a
338 set of reusable components which highly leverage existing libraries in
339 the larger LLVM Project, such as the Clang expression parser and LLVM
340 disassembler.
341
342 %description -n lldb -l pl.UTF-8
343 LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
344 komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
345 w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
346 disasembler LLVM.
347
348 %package -n lldb-devel
349 Summary:        Development files for LLDB debugger
350 Summary(pl.UTF-8):      Pliki programistyczne debuggera LLDB
351 Group:          Development/Libraries
352 URL:            http://lldb.llvm.org/
353 Requires:       %{name}-devel = %{version}-%{release}
354 Requires:       clang-devel = %{version}-%{release}
355 Requires:       lldb = %{version}-%{release}
356
357 %description -n lldb-devel
358 Development files for LLDB debugger.
359
360 %description -n lldb-devel -l pl.UTF-8
361 Pliki programistyczne debuggera LLDB.
362
363 %package ocaml
364 Summary:        OCaml binding for LLVM
365 Summary(pl.UTF-8):      Wiązanie OCamla do LLVM-a
366 Group:          Libraries
367 Requires:       %{name} = %{version}-%{release}
368 %requires_eq    ocaml-runtime
369
370 %description ocaml
371 OCaml binding for LLVM.
372
373 %description ocaml -l pl.UTF-8
374 Wiązanie OCamla do LLVM-a.
375
376 %package ocaml-devel
377 Summary:        Development files for LLVM OCaml binding
378 Summary(pl.UTF-8):      Pliki programistyczne wiązania OCamla do LLVM-a
379 Group:          Development/Libraries
380 Requires:       %{name}-devel = %{version}-%{release}
381 Requires:       %{name}-ocaml = %{version}-%{release}
382
383 %description ocaml-devel
384 The llvm-ocaml-devel package contains libraries and signature files
385 for developing applications that use llvm-ocaml binding.
386
387 %description ocaml-devel -l pl.UTF-8
388 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
389 wykorzystujących wiązanie llvm-ocaml.
390
391 %package ocaml-doc
392 Summary:        Documentation for LLVM's OCaml binding
393 Summary(pl.UTF-8):      Dokumentacja wiązania OCamla do LLVM-a
394 Group:          Documentation
395 Requires:       %{name}-ocaml = %{version}-%{release}
396
397 %description ocaml-doc
398 HTML documentation for LLVM's OCaml binding.
399
400 %description ocaml-doc -l pl.UTF-8
401 Dokumentacja HTML wiązania OCamla do LLVM-a.
402
403 %prep
404 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
405 mv cfe-%{version}.src tools/clang
406 %{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
407 %{?with_lldb:mv lldb-%{version}.src tools/lldb}
408 %{?with_polly:mv polly-%{version}.src tools/polly}
409 mv clang-tools-extra-%{version}.src tools/clang/tools/extra
410 mv lld-%{version}.src tools/lld
411
412 %patch0 -p1
413 %patch1 -p1
414 %patch2 -p1
415 %{?with_polly:%patch3 -p1}
416 %{?with_lldb:%patch4 -p1}
417 %patch5 -p1
418
419 # configure does not properly specify libdir
420 %{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
421 # clang resources
422 %{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
423 %{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
424
425 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
426         s,^#!.*bin/env python,#!%{__python},
427         s,^#!.*bin/env perl,#!%{__perl},
428 }'
429
430 install -d obj
431
432 %build
433 cd autoconf
434 %{__aclocal} -I m4
435 %{__autoconf} -o ../configure configure.ac
436 cd ..
437 %{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
438 %if %{with polly}
439 cd tools/polly/autoconf
440 %{__aclocal} -I m4 -I ../../../autoconf/m4
441 %{__autoconf} -o ../configure configure.ac
442 cd ..
443 %{__autoheader} -I autoconf -I autoconf/m4 -I ../../../autoconf/m4 autoconf/configure.ac
444 cd ../..
445 %endif
446
447 # Disabling assertions now, rec. by pure and needed for OpenGTL
448 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
449 #
450 # bash specific 'test a < b'
451 cd obj
452 bash ../%configure \
453         --datadir=%{_datadir}/%{name}-%{version} \
454         --disable-assertions \
455         --enable-cxx11 \
456 %ifarch %{ix86}
457         --disable-pic \
458 %endif
459         --disable-static \
460         --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
461         --enable-debug-runtime \
462 %if %{with apidocs}
463         --enable-doxygen \
464 %endif
465         --enable-experimental-targets=R600 \
466         --enable-jit \
467         --enable-optimized \
468         --enable-shared \
469         --with-pic
470
471 %{__make} \
472         VERBOSE=1 \
473         REQUIRES_RTTI=1 \
474         OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
475
476 %if %{with tests}
477 %{__make} check 2>&1 | tee llvm-testlog.txt
478 %{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
479 %endif
480
481 cd ..
482
483 %if %{with doc}
484 %{__make} -C docs -f Makefile.sphinx man
485 %{__make} -C tools/clang/tools/extra/docs html
486 %endif
487
488 %install
489 rm -rf $RPM_BUILD_ROOT
490 %{__make} -C obj -j1 install \
491         PROJ_docsdir=/moredocs \
492         DESTDIR=$RPM_BUILD_ROOT
493
494 # Static analyzer not installed by default:
495 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
496 install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
497 # create launchers
498 for f in scan-{build,view}; do
499         ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
500         cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
501 done
502 %{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
503 %py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
504 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
505 %py_postclean %{_libdir}/clang-analyzer/scan-view
506
507 %if %{with doc}
508 install -d $RPM_BUILD_ROOT%{_mandir}/man1
509 cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
510 # these tools are not installed
511 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
512 # make links
513 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
514 %endif
515
516 # Move documentation back to build directory
517 rm -rf moredocs
518 mv $RPM_BUILD_ROOT/moredocs .
519 %{__rm} -v moredocs/*.tar.gz
520 %{__rm} -v moredocs/ocamldoc/html/*.tar.gz
521
522 # and separate the apidoc
523 %if %{with apidocs}
524 rm -rf apidoc clang-apidoc
525 mv moredocs/html/doxygen apidoc
526 cp -a tools/clang/docs/doxygen/html clang-apidoc
527 %endif
528
529 # And prepare Clang documentation
530 rm -rf clang-docs
531 install -d clang-docs
532 for f in LICENSE.TXT NOTES.txt README.txt; do
533         ln tools/clang/$f clang-docs
534 done
535
536 # Get rid of erroneously installed example files.
537 %{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
538 # parts of test suite
539 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{FileCheck,count,not}
540 %{__rm} $RPM_BUILD_ROOT%{_bindir}/linker-script-test
541
542 # remove documentation makefiles:
543 # they require the build directory to work
544 rm -rf moredocs/examples
545 cp -a examples moredocs/examples
546 find moredocs/examples -name Makefile | xargs -0r rm -f
547
548 %clean
549 rm -rf $RPM_BUILD_ROOT
550
551 %post   libs -p /sbin/ldconfig
552 %postun libs -p /sbin/ldconfig
553
554 %post   -n clang -p /sbin/ldconfig
555 %postun -n clang -p /sbin/ldconfig
556
557 %post   -n lldb -p /sbin/ldconfig
558 %postun -n lldb -p /sbin/ldconfig
559
560 %files
561 %defattr(644,root,root,755)
562 %doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
563 %attr(755,root,root) %{_bindir}/bugpoint
564 %attr(755,root,root) %{_bindir}/llc
565 %attr(755,root,root) %{_bindir}/lli
566 %attr(755,root,root) %{_bindir}/lli-child-target
567 %attr(755,root,root) %{_bindir}/llvm-ar
568 %attr(755,root,root) %{_bindir}/llvm-as
569 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
570 %attr(755,root,root) %{_bindir}/llvm-cov
571 %attr(755,root,root) %{_bindir}/llvm-diff
572 %attr(755,root,root) %{_bindir}/llvm-dis
573 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
574 %attr(755,root,root) %{_bindir}/llvm-extract
575 %attr(755,root,root) %{_bindir}/llvm-link
576 %attr(755,root,root) %{_bindir}/llvm-mc
577 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
578 %attr(755,root,root) %{_bindir}/llvm-nm
579 %attr(755,root,root) %{_bindir}/llvm-objdump
580 %attr(755,root,root) %{_bindir}/llvm-profdata
581 %attr(755,root,root) %{_bindir}/llvm-ranlib
582 %attr(755,root,root) %{_bindir}/llvm-readobj
583 %attr(755,root,root) %{_bindir}/llvm-rtdyld
584 %attr(755,root,root) %{_bindir}/llvm-size
585 %attr(755,root,root) %{_bindir}/llvm-stress
586 %attr(755,root,root) %{_bindir}/llvm-symbolizer
587 %attr(755,root,root) %{_bindir}/llvm-tblgen
588 %attr(755,root,root) %{_bindir}/macho-dump
589 %attr(755,root,root) %{_bindir}/opt
590 %if %{with doc}
591 %{_mandir}/man1/bugpoint.1*
592 %{_mandir}/man1/lit.1*
593 %{_mandir}/man1/llc.1*
594 %{_mandir}/man1/lli.1*
595 %{_mandir}/man1/llvm-ar.1*
596 %{_mandir}/man1/llvm-as.1*
597 %{_mandir}/man1/llvm-bcanalyzer.1*
598 %{_mandir}/man1/llvm-cov.1*
599 %{_mandir}/man1/llvm-diff.1*
600 %{_mandir}/man1/llvm-dis.1*
601 %{_mandir}/man1/llvm-dwarfdump.1*
602 %{_mandir}/man1/llvm-extract.1*
603 %{_mandir}/man1/llvm-link.1*
604 %{_mandir}/man1/llvm-nm.1*
605 %{_mandir}/man1/llvm-profdata.1*
606 %{_mandir}/man1/llvm-ranlib.1*
607 %{_mandir}/man1/llvm-readobj.1*
608 %{_mandir}/man1/llvm-stress.1*
609 %{_mandir}/man1/llvm-symbolizer.1*
610 %{_mandir}/man1/opt.1*
611 %{_mandir}/man1/tblgen.1*
612 %endif
613
614 %files libs
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
617 %attr(755,root,root) %{_libdir}/libLLVM-3.5.so
618
619 %files devel
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_bindir}/llvm-config
622 %{_libdir}/libLLVM*.a
623 %ifarch %{x8664}
624 %attr(755,root,root) %{_libdir}/BugpointPasses.so
625 %attr(755,root,root) %{_libdir}/libLTO.so
626 %{_libdir}/libLTO.a
627 %endif
628 %{_includedir}/llvm
629 %{_includedir}/llvm-c
630 %dir %{_datadir}/llvm
631 %{_datadir}/llvm/cmake
632 %if %{with doc}
633 %{_mandir}/man1/llvm-config.1*
634 %endif
635
636 %files doc
637 %defattr(644,root,root,755)
638 %doc moredocs/examples moredocs/html
639
640 %if %{with apidocs}
641 %files apidocs
642 %defattr(644,root,root,755)
643 %doc apidoc/*
644 %endif
645
646 %if %{with polly}
647 %files polly
648 %defattr(644,root,root,755)
649 %doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
650 %attr(755,root,root) %{_libdir}/LLVMPolly.so
651
652 %files polly-devel
653 %defattr(644,root,root,755)
654 %{_includedir}/polly
655 %endif
656
657 %files -n clang
658 %defattr(644,root,root,755)
659 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
660 %attr(755,root,root) %{_bindir}/c-index-test
661 %attr(755,root,root) %{_bindir}/clang
662 %attr(755,root,root) %{_bindir}/clang++
663 %attr(755,root,root) %{_bindir}/clang-check
664 %attr(755,root,root) %{_bindir}/clang-format
665 %attr(755,root,root) %{_bindir}/clang-tblgen
666 %attr(755,root,root) %{_libdir}/libclang.so
667 %dir %{_libdir}/clang
668 %dir %{_libdir}/clang/%{version}
669 %{_libdir}/clang/%{version}/include
670 %if %{with rt}
671 %{_libdir}/clang/%{version}/lib
672 %endif
673 %{_mandir}/man1/clang.1*
674
675 %files -n clang-analyzer
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_bindir}/scan-build
678 %attr(755,root,root) %{_bindir}/scan-view
679 %{_mandir}/man1/scan-build.1*
680 %dir %{_libdir}/clang-analyzer
681
682 %dir %{_libdir}/clang-analyzer/scan-build
683 %{_libdir}/clang-analyzer/scan-build/*.css
684 %{_libdir}/clang-analyzer/scan-build/*.js
685 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
686 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
687
688 %dir %{_libdir}/clang-analyzer/scan-view
689 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
690 %{_libdir}/clang-analyzer/scan-view/Resources
691 %{_libdir}/clang-analyzer/scan-view/*.py[co]
692
693 %files -n clang-devel
694 %defattr(644,root,root,755)
695 %{_libdir}/libclang*.a
696 %{_includedir}/clang
697 %{_includedir}/clang-c
698
699 %files -n clang-doc
700 %defattr(644,root,root,755)
701 %doc tools/clang/docs/*.{css,html,png,txt}
702
703 %if %{with apidocs}
704 %files -n clang-apidocs
705 %defattr(644,root,root,755)
706 %doc clang-apidoc/*
707 %endif
708
709 %files -n clang-tools-extra
710 %defattr(644,root,root,755)
711 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt,docs/_build/html/{*.html,*.js,_static}}
712 %attr(755,root,root) %{_bindir}/clang-apply-replacements
713 %attr(755,root,root) %{_bindir}/clang-modernize
714 %attr(755,root,root) %{_bindir}/clang-query
715 %attr(755,root,root) %{_bindir}/clang-tidy
716 %attr(755,root,root) %{_bindir}/pp-trace
717 %{_libdir}/libmodernizeCore.a
718
719 %files -n lld
720 %defattr(644,root,root,755)
721 %doc tools/lld/{LICENSE.TXT,README.md}
722 %attr(755,root,root) %{_bindir}/lld
723
724 %files -n lld-devel
725 %defattr(644,root,root,755)
726 %{_libdir}/liblldCore.a
727 %{_libdir}/liblldDriver.a
728 %{_libdir}/liblldELF.a
729 %{_libdir}/liblldMachO.a
730 %{_libdir}/liblldNative.a
731 %{_libdir}/liblldPECOFF.a
732 %{_libdir}/liblldPasses.a
733 %{_libdir}/liblldReaderWriter.a
734 %{_libdir}/liblldYAML.a
735 %{_libdir}/liblld*ELFTarget.a
736 %{_includedir}/lld
737
738 %if %{with lldb}
739 %files -n lldb
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_bindir}/lldb
742 %attr(755,root,root) %{_bindir}/lldb-gdbserver
743 %attr(755,root,root) %{_bindir}/lldb-mi
744 %attr(755,root,root) %{_bindir}/lldb-platform
745 %attr(755,root,root) %{_libdir}/liblldb.so
746 %dir %{py_sitedir}/lldb
747 %attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
748 %attr(755,root,root) %{py_sitedir}/readline.so
749
750 %files -n lldb-devel
751 %defattr(644,root,root,755)
752 %{_libdir}/liblldb*.a
753 %{_includedir}/lldb
754 %endif
755
756 %if %{with ocaml}
757 %files ocaml
758 %defattr(644,root,root,755)
759 %{_libdir}/ocaml/META.llvm*
760 %attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
761 %{_libdir}/ocaml/llvm*.cma
762 %{_libdir}/ocaml/llvm*.cmi
763
764 %files ocaml-devel
765 %defattr(644,root,root,755)
766 %{_libdir}/libllvm*.a
767 %{_libdir}/ocaml/libLLVM*.a
768 %{_libdir}/ocaml/libllvm*.a
769 %{_libdir}/ocaml/llvm*.a
770 %{_libdir}/ocaml/llvm*.cmx*
771 %{_libdir}/ocaml/llvm*.mli
772
773 %files ocaml-doc
774 %defattr(644,root,root,755)
775 %doc moredocs/ocamldoc/html/*
776 %endif
This page took 1.932273 seconds and 3 git commands to generate.