]> git.pld-linux.org Git - packages/llvm.git/blob - llvm.spec
disable format-security due swig generated code
[packages/llvm.git] / llvm.spec
1 # TODO:
2 # - move and package:
3 #       %{_datadir}/clang/clang-format-sublime.py - sublime plugin
4 #       %{_datadir}/clang/clang-format.el - emacs mode
5 #       %{_datadir}/clang/clang-format.py - vim plugin
6 # - no content in doc package (it used to contain parts of clang apidocs and some examples)
7 #
8 # Conditional build:
9 %bcond_without  lldb            # LLDB debugger
10 %bcond_without  polly           # Polly cache-locality optimization, auto-parallelism and vectorization
11 %bcond_without  rt              # compiler-rt libraries
12 %bcond_without  multilib        # compiler-rt multilib libraries
13 %bcond_without  ocaml           # OCaml binding
14 %bcond_without  doc             # HTML docs and man pages
15 %bcond_with     apidocs         # doxygen docs (HUGE, so they are not built by default)
16 %bcond_with     tests           # run tests
17
18 # No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
19 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9 
20 %undefine       with_ocaml
21 %endif
22
23 Summary:        The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
24 Summary(pl.UTF-8):      Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
25 Name:           llvm
26 Version:        3.8.0
27 Release:        0.1
28 License:        University of Illinois/NCSA Open Source License
29 Group:          Development/Languages
30 #Source0Download: http://llvm.org/releases/download.html
31 Source0:        http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
32 # Source0-md5:  07a7a74f3c6bd65de4702bf941b511a0
33 Source1:        http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
34 # Source1-md5:  cc99e7019bb74e6459e80863606250c5
35 Source2:        http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
36 # Source2-md5:  d6fcbe14352ffb708e4d1ac2e48bb025
37 Source3:        http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
38 # Source3-md5:  a5da35ed9cc8c8817ee854e3dbfba00e
39 Source4:        http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
40 # Source4-md5:  1b3b20f52d34a4024e21a4ea7112caa7
41 Source5:        http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
42 # Source5-md5:  c2344f50e0eea0b402f0092a80ddc036
43 Source6:        http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
44 # Source6-md5:  de33b5c6c77698ee2f8d024fbffb8df1
45 Patch0:         %{name}-lld-link.patch
46 Patch1:         %{name}-pld.patch
47 Patch2:         libdir.patch
48 Patch3:         x32-gcc-toolchain.patch
49 Patch4:         cmake-buildtype.patch
50 URL:            http://llvm.org/
51 BuildRequires:  bash
52 BuildRequires:  bison
53 BuildRequires:  cmake
54 BuildRequires:  flex
55 BuildRequires:  gcc >= 5:3.4
56 # gcc4 might be installed, but not current __cc
57 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
58 BuildRequires:  __cc >= 3.4
59 %endif
60 %ifarch x32
61 BuildRequires:  glibc-devel(x86_64)
62 %endif
63 BuildRequires:  groff
64 BuildRequires:  libltdl-devel
65 BuildRequires:  libstdc++-devel >= 5:3.4
66 %if %{with ocaml}
67 BuildRequires:  ocaml-ctypes-devel >= 0.4
68 BuildRequires:  ocaml-findlib
69 BuildRequires:  ocaml-ocamldoc
70 BuildRequires:  ocaml-ounit
71 %endif
72 BuildRequires:  perl-base >= 1:5.6
73 BuildRequires:  perl-tools-pod
74 BuildRequires:  rpm-pythonprov
75 %{?with_doc:BuildRequires:      sphinx-pdg}
76 BuildRequires:  tar >= 1:1.22
77 BuildRequires:  xz
78 %if %{with apidocs}
79 BuildRequires:  doxygen
80 BuildRequires:  graphviz
81 %endif
82 %if %{with tests}
83 BuildRequires:  dejagnu
84 BuildRequires:  python
85 BuildRequires:  tcl-devel
86 %endif
87 %if %{with rt} && %{with multilib}
88 %ifarch %{x8664}
89 BuildRequires:  gcc-c++-multilib-32
90 BuildRequires:  libstdc++-multilib-32-devel
91 %endif
92 %endif
93 %if %{with lldb}
94 BuildRequires:  epydoc
95 %ifarch i386 i486
96 BuildRequires:  libatomic-devel
97 %endif
98 BuildRequires:  libedit-devel
99 BuildRequires:  libxml2-devel >= 2
100 BuildRequires:  ncurses-ext-devel
101 BuildRequires:  python-devel >= 2
102 BuildRequires:  swig-python
103 %endif
104 %if %{with polly}
105 BuildRequires:  cloog-isl-devel
106 # >= 0.18.2-2
107 BuildRequires:  gmp-devel
108 BuildRequires:  isl-devel >= 0.14
109 # optional
110 BuildRequires:  pluto-devel
111 BuildRequires:  scoplib-devel >= 0.2.1-2
112 #cuda-devel
113 %endif
114 Requires:       %{name}-libs = %{version}-%{release}
115 # LLVM is not supported on PPC64
116 # http://llvm.org/bugs/show_bug.cgi?id=3729
117 ExcludeArch:    ppc64
118 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120 %define         _sysconfdir     /etc/%{name}
121
122 %define         specflags_ppc   -fno-var-tracking-assignments
123
124 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
125 %define         _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
126
127 # clang doesn't know -fvar-tracking-assignments, and leaving it here would pollute llvm-config
128 # -Werror=format-security is for swig
129 # TODO: add - -Werror=format-security to tools/lldb/scripts/LLDBWrapPython.cpp
130 %define         filterout_c     -fvar-tracking-assignments
131 %define         filterout_cxx   -fvar-tracking-assignments -Werror=format-security
132 %define         filterout_ccpp  -fvar-tracking-assignments
133
134 # std::__once_call, std::__once_callable non-function symbols
135 %define         skip_post_check_so      liblldAArch64ELFTarget.so.* liblldARMELFTarget.so.* liblldHexagonELFTarget.so.* liblldMipsELFTarget.so.* liblldb.so.*
136
137 %description
138 LLVM is a compiler infrastructure designed for compile-time,
139 link-time, runtime, and idle-time optimization of programs from
140 arbitrary programming languages. LLVM is written in C++ and has been
141 developed since 2000 at the University of Illinois and Apple. It
142 currently supports compilation of C and C++ programs using clang
143 frontend.
144
145 %description -l pl.UTF-8
146 LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
147 czasu kompilowania, linkowania, działania i bezczynności programów w
148 dowolnych językach programowania. Jest napisana w C++, rozwijana od
149 roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
150 kompilację programów w C i C++ przy użyciu frontendu clang.
151
152 %package libs
153 Summary:        LLVM shared libraries
154 Summary(pl.UTF-8):      Biblioteki współdzielone LLVM-a
155 Group:          Libraries
156 Conflicts:      llvm < 3.2
157
158 %description libs
159 LLVM shared libraries.
160
161 %description libs -l pl.UTF-8
162 Biblioteki współdzielone LLVM-a.
163
164 %package devel
165 Summary:        Static libraries and header files for LLVM
166 Summary(pl.UTF-8):      Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
167 Group:          Development/Languages
168 Requires:       %{name}-libs = %{version}-%{release}
169 Requires:       libstdc++-devel >= 6:3.4
170
171 %description devel
172 This package contains static libraries and header files needed to
173 develop new native programs that use the LLVM infrastructure.
174
175 %description devel -l pl.UTF-8
176 Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
177 potrzebne do tworzenia nowych programów natywnych wykorzystujących
178 infrastrukturę LLVM.
179
180 %package doc
181 Summary:        Documentation for LLVM
182 Summary(pl.UTF-8):      Dokumentacja do LLVM-a
183 Group:          Documentation
184 # does not require base
185
186 %description doc
187 Documentation for the LLVM compiler infrastructure.
188
189 %description doc -l pl.UTF-8
190 Dokumentacja do infrastruktury kompilatorów LLVM.
191
192 %package apidocs
193 Summary:        API documentation for LLVM
194 Summary(pl.UTF-8):      Dokumentacja API LLVM-a
195 Group:          Development/Languages
196 Requires:       %{name}-doc = %{version}-%{release}
197
198 %description apidocs
199 API documentation for the LLVM compiler infrastructure.
200
201 %description apidocs -l pl.UTF-8
202 Dokumentacja API infrastruktury kompilatorów LLVM.
203
204 %package polly
205 Summary:        Polyhedral optimizations for LLVM
206 Summary(pl.UTF-8):      Optymalizacje wielościanowe dla LLVM-a
207 Group:          Development/Tools
208 URL:            http://polly.llvm.org/
209 Requires:       %{name} = %{version}-%{release}
210
211 %description polly
212 Polly is a high-level loop and data-locality optimizer and
213 optimization infrastructure for LLVM. It uses an abstract mathematical
214 representation based on integer polyhedra to analyze and optimize the
215 memory access pattern of a program.
216
217 %description polly -l pl.UTF-8
218 Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
219 optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
220 reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
221 do analizy i optymalizacji wzorców dostępu do pamięci przez program.
222
223 %package polly-devel
224 Summary:        Header files for LLVM Polly optimization infrastructure
225 Summary(pl.UTF-8):      Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
226 Group:          Development/Libraries
227 URL:            http://polly.llvm.org/
228 Requires:       %{name}-devel = %{version}-%{release}
229 Requires:       %{name}-polly = %{version}-%{release}
230
231 %description polly-devel
232 Header files for LLVM Polly optimization infrastructure.
233
234 %description polly-devel -l pl.UTF-8
235 Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
236
237 %package -n clang
238 Summary:        A C language family frontend for LLVM
239 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C
240 License:        NCSA
241 Group:          Development/Languages
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       clang-libs = %{version}-%{release}
244
245 %description -n clang
246 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
247 of a crane or goose. 3. C-language family front-end toolkit.
248
249 The goal of the Clang project is to create a new C, C++, Objective C
250 and Objective C++ front-end for the LLVM compiler. Its tools are built
251 as libraries and designed to be loosely-coupled and extendable.
252
253 %description -n clang -l pl.UTF-8
254 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
255 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
256 z rodziny C.
257
258 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
259 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
260 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
261 i rozszerzaniu.
262
263 %package -n clang-libs
264 Summary:        Clang shared libraries
265 Summary(pl.UTF-8):      Biblioteki współdzielone Clanga
266 Group:          Libraries
267
268 %description -n clang-libs
269 Clang shared libraries.
270
271 %description -n clang-libs -l pl.UTF-8
272 Biblioteki współdzielone Clanga.
273
274 %package -n clang-multilib
275 Summary:        A C language family frontend for LLVM - 32-bit support
276 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C - obsługa binariów 32-bitowych
277 License:        NCSA
278 Group:          Development/Languages
279 Requires:       clang = %{version}-%{release}
280
281 %description -n clang-multilib
282 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
283 of a crane or goose. 3. C-language family front-end toolkit.
284
285 The goal of the Clang project is to create a new C, C++, Objective C
286 and Objective C++ front-end for the LLVM compiler. Its tools are built
287 as libraries and designed to be loosely-coupled and extendable.
288
289 This package contains the C compiler support for producing 32-bit
290 programs on 64-bit host.
291
292 %description -n clang-multilib -l pl.UTF-8
293 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
294 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
295 z rodziny C.
296
297 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
298 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
299 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
300 i rozszerzaniu.
301
302 Ten pakiet zawiera rozszerzenie kompilatora C o obsługę tworzenia
303 programów 32-bitowych na maszynie 64-bitowej.
304
305 %package -n clang-analyzer
306 Summary:        A source code analysis framework
307 Summary(pl.UTF-8):      Szkielet do analizy kodu źródłowego
308 License:        NCSA
309 Group:          Development/Languages
310 Requires:       clang = %{version}-%{release}
311 # not picked up automatically since files are currently not instaled
312 # in standard Python hierarchies yet
313 Requires:       python
314
315 %description -n clang-analyzer
316 The Clang Static Analyzer consists of both a source code analysis
317 framework and a standalone tool that finds bugs in C and Objective-C
318 programs. The standalone tool is invoked from the command-line, and is
319 intended to run in tandem with a build of a project or code base.
320
321 %description -n clang-analyzer -l pl.UTF-8
322 Clang Static Analyzer składa się ze szkieletu do analizy kodu
323 źródłowego oraz samodzielnego narzędzia znajdującego błędy w
324 programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
325 myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
326
327 %package -n clang-devel
328 Summary:        Header files for Clang
329 Summary(pl.UTF-8):      Pliki nagłówkowe Clanga
330 Group:          Development/Languages
331 Requires:       %{name}-devel = %{version}-%{release}
332 Requires:       clang = %{version}-%{release}
333
334 %description -n clang-devel
335 This package contains header files for the Clang compiler.
336
337 %description -n clang-devel -l pl.UTF-8
338 Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
339
340 %package -n clang-doc
341 Summary:        Documentation for Clang
342 Summary(pl.UTF-8):      Dokumentacja do Clanga
343 Group:          Documentation
344 Requires:       %{name} = %{version}-%{release}
345
346 %description -n clang-doc
347 Documentation for the Clang compiler front-end.
348
349 %description -n clang-doc -l pl.UTF-8
350 Dokumentacja do frontendu kompilatora Clang.
351
352 %package -n clang-apidocs
353 Summary:        API documentation for Clang
354 Summary(pl.UTF-8):      Dokumentacja API Clanga
355 Group:          Development/Languages
356 Requires:       clang-doc = %{version}-%{release}
357
358 %description -n clang-apidocs
359 API documentation for the Clang compiler.
360
361 %description -n clang-apidocs -l pl.UTF-8
362 Dokumentacja API kompilatora Clang.
363
364 %package -n clang-tools-extra
365 Summary:        Extra tools for Clang
366 Summary(pl.UTF-8):      Dodatkowe narzędzia do kompilatora Clang
367 Group:          Development/Tools
368 URL:            http://clang.llvm.org/docs/ClangTools.html
369 Requires:       clang = %{version}-%{release}
370
371 %description -n clang-tools-extra
372 Extra tools for Clang.
373
374 %description -n clang-tools-extra -l pl.UTF-8
375 Dodatkowe narzędzia do kompilatora Clang.
376
377 %package -n lld
378 Summary:        The LLVM linker
379 Summary(pl.UTF-8):      Konsolidator z projektu LLVM
380 Group:          Development/Libraries
381 URL:            http://lld.llvm.org/
382 Requires:       %{name} = %{version}-%{release}
383
384 %description -n lld
385 lld is a new set of modular code for creating linker tools.
386
387 %description -n lld -l pl.UTF-8
388 lld to nowy zbiór modularnego kodu do tworzenia narzędzi
389 konsolidujących.
390
391 %package -n lld-devel
392 Summary:        Development files for LLD linker tools
393 Summary(pl.UTF-8):      Pliki programistyczne narzędzi konsolidujących LLD
394 Group:          Development/Tools
395 URL:            http://lld.llvm.org/
396 Requires:       %{name}-devel = %{version}-%{release}
397
398 %description -n lld-devel
399 Development files for LLD linker tools.
400
401 %description -n lld-devel -l pl.UTF-8
402 Pliki programistyczne narzędzi konsolidujących LLD.
403
404 %package -n lldb
405 Summary:        Next generation high-performance debugger
406 Summary(pl.UTF-8):      Wydajny debugger nowej generacji
407 Group:          Development/Debuggers
408 URL:            http://lldb.llvm.org/
409 Requires:       %{name} = %{version}-%{release}
410
411 %description -n lldb
412 LLDB is a next generation, high-performance debugger. It is built as a
413 set of reusable components which highly leverage existing libraries in
414 the larger LLVM Project, such as the Clang expression parser and LLVM
415 disassembler.
416
417 %description -n lldb -l pl.UTF-8
418 LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
419 komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
420 w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
421 disasembler LLVM.
422
423 %package -n lldb-devel
424 Summary:        Development files for LLDB debugger
425 Summary(pl.UTF-8):      Pliki programistyczne debuggera LLDB
426 Group:          Development/Libraries
427 URL:            http://lldb.llvm.org/
428 Requires:       %{name}-devel = %{version}-%{release}
429 Requires:       clang-devel = %{version}-%{release}
430 Requires:       lldb = %{version}-%{release}
431
432 %description -n lldb-devel
433 Development files for LLDB debugger.
434
435 %description -n lldb-devel -l pl.UTF-8
436 Pliki programistyczne debuggera LLDB.
437
438 %package ocaml
439 Summary:        OCaml binding for LLVM
440 Summary(pl.UTF-8):      Wiązanie OCamla do LLVM-a
441 Group:          Libraries
442 Requires:       %{name} = %{version}-%{release}
443 %requires_eq    ocaml-runtime
444
445 %description ocaml
446 OCaml binding for LLVM.
447
448 %description ocaml -l pl.UTF-8
449 Wiązanie OCamla do LLVM-a.
450
451 %package ocaml-devel
452 Summary:        Development files for LLVM OCaml binding
453 Summary(pl.UTF-8):      Pliki programistyczne wiązania OCamla do LLVM-a
454 Group:          Development/Libraries
455 Requires:       %{name}-devel = %{version}-%{release}
456 Requires:       %{name}-ocaml = %{version}-%{release}
457
458 %description ocaml-devel
459 The llvm-ocaml-devel package contains libraries and signature files
460 for developing applications that use llvm-ocaml binding.
461
462 %description ocaml-devel -l pl.UTF-8
463 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
464 wykorzystujących wiązanie llvm-ocaml.
465
466 %package ocaml-doc
467 Summary:        Documentation for LLVM's OCaml binding
468 Summary(pl.UTF-8):      Dokumentacja wiązania OCamla do LLVM-a
469 Group:          Documentation
470 Requires:       %{name}-ocaml = %{version}-%{release}
471
472 %description ocaml-doc
473 HTML documentation for LLVM's OCaml binding.
474
475 %description ocaml-doc -l pl.UTF-8
476 Dokumentacja HTML wiązania OCamla do LLVM-a.
477
478 %prep
479 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
480 mv cfe-%{version}.src tools/clang
481 %{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
482 %{?with_lldb:mv lldb-%{version}.src tools/lldb}
483 %{?with_polly:mv polly-%{version}.src tools/polly}
484 mv clang-tools-extra-%{version}.src tools/clang/tools/extra
485 mv lld-%{version}.src tools/lld
486
487 %patch0 -p1
488 %patch1 -p1
489 %patch2 -p1
490 %patch3 -p1
491 %patch4 -p1
492
493 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
494         s,^#!.*bin/env python,#!%{__python},
495         s,^#!.*bin/env perl,#!%{__perl},
496 }'
497
498 %build
499 install -d build
500
501 # Disabling assertions now, rec. by pure and needed for OpenGTL
502 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
503 cd build
504 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
505
506 %cmake \
507 %ifarch %{x8664}
508         -DLLVM_LIBDIR_SUFFIX:STRING=64 \
509 %endif
510 %ifarch x32
511         -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
512 %endif
513 %if %{with apidocs}
514         -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
515 %endif
516 %if %{with doc}
517         -DLLVM_ENABLE_SPHINX:BOOL=ON \
518 %endif
519         -DLLVM_ENABLE_PIC:BOOL=ON \
520         -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
521         -DLLVM_ENABLE_CXX1Y:BOOL=ON \
522         -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
523         -DBUILD_SHARED_LIBS:BOOL=ON \
524         ../
525
526 %{__make} \
527         VERBOSE=1 \
528         REQUIRES_RTTI=1 \
529         OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
530
531 %if %{with tests}
532 %{__make} check 2>&1 | tee llvm-testlog.txt
533 %{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
534 %endif
535
536 %if %{with doc}
537 %{__make} -C docs docs-llvm-html
538 %{__make} -C docs docs-llvm-man
539 %if %{with ocaml}
540 %{__make} -C docs ocaml_doc
541 %endif
542 %{__make} -C tools/clang/docs docs-clang-html
543 %{__make} -C tools/clang/docs docs-clang-man
544 %{__make} -C tools/lld/docs docs-lld-html
545 %{__make} -C tools/lldb/docs lldb-python-doc
546 %{__make} -C tools/lldb/docs lldb-cpp-doc
547 %{__make} -C ../tools/clang/tools/extra/docs html
548 %endif
549
550 %install
551 rm -rf $RPM_BUILD_ROOT
552 %{__make} -C build install \
553         DESTDIR=$RPM_BUILD_ROOT
554
555 # only some .pyc files are created by make install
556 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
557 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
558
559 # Static analyzer not installed by default:
560 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
561 install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
562 # create launchers
563 for f in scan-{build,view}; do
564         ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
565         cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
566 done
567 install -d $RPM_BUILD_ROOT%{_mandir}/man1
568 %{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
569 %py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
570 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
571 %py_postclean %{_libdir}/clang-analyzer/scan-view
572 # not this OS
573 %{__rm} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/*.bat
574
575 # not installed by cmake buildsystem
576 install build/bin/clang-query $RPM_BUILD_ROOT%{_bindir}
577 install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
578
579 %if %{with doc}
580 cp -p build/docs/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
581 # these tools are not installed
582 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
583 # make links
584 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
585 %endif
586
587 # Move documentation back to build directory
588 %if %{with ocaml}
589 rm -rf ocamldocs
590 mv $RPM_BUILD_ROOT%{_prefix}/docs/ocaml/html/html ocamldocs
591 %endif
592
593 # and separate the apidoc
594 %if %{with apidocs}
595 rm -rf clang-apidoc
596 cp -a build/tools/clang/docs/html clang-apidoc
597 %endif
598
599 # And prepare Clang documentation
600 rm -rf clang-docs
601 install -d clang-docs
602 for f in LICENSE.TXT NOTES.txt README.txt; do
603         ln tools/clang/$f clang-docs
604 done
605
606 # Get rid of erroneously installed example files.
607 %{__rm} $RPM_BUILD_ROOT%{_libdir}/LLVMHello.so
608 # test?
609 %{__rm} $RPM_BUILD_ROOT%{_bindir}/llvm-c-test
610 # not this OS
611 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
612
613 %clean
614 rm -rf $RPM_BUILD_ROOT
615
616 %post   libs -p /sbin/ldconfig
617 %postun libs -p /sbin/ldconfig
618
619 %post   -n clang -p /sbin/ldconfig
620 %postun -n clang -p /sbin/ldconfig
621
622 %post   -n clang-tools-extra -p /sbin/ldconfig
623 %postun -n clang-tools-extra -p /sbin/ldconfig
624
625 %post   -n lldb -p /sbin/ldconfig
626 %postun -n lldb -p /sbin/ldconfig
627
628 %files
629 %defattr(644,root,root,755)
630 %doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
631 %attr(755,root,root) %{_bindir}/bugpoint
632 %attr(755,root,root) %{_bindir}/llc
633 %attr(755,root,root) %{_bindir}/lli
634 %attr(755,root,root) %{_bindir}/llvm-ar
635 %attr(755,root,root) %{_bindir}/llvm-as
636 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
637 %attr(755,root,root) %{_bindir}/llvm-cov
638 %attr(755,root,root) %{_bindir}/llvm-diff
639 %attr(755,root,root) %{_bindir}/llvm-dis
640 %attr(755,root,root) %{_bindir}/llvm-dsymutil
641 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
642 %attr(755,root,root) %{_bindir}/llvm-extract
643 %attr(755,root,root) %{_bindir}/llvm-lib
644 %attr(755,root,root) %{_bindir}/llvm-link
645 %attr(755,root,root) %{_bindir}/llvm-lto
646 %attr(755,root,root) %{_bindir}/llvm-mc
647 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
648 %attr(755,root,root) %{_bindir}/llvm-nm
649 %attr(755,root,root) %{_bindir}/llvm-objdump
650 %attr(755,root,root) %{_bindir}/llvm-profdata
651 %attr(755,root,root) %{_bindir}/llvm-ranlib
652 %attr(755,root,root) %{_bindir}/llvm-readobj
653 %attr(755,root,root) %{_bindir}/llvm-rtdyld
654 %attr(755,root,root) %{_bindir}/llvm-size
655 %attr(755,root,root) %{_bindir}/llvm-stress
656 %attr(755,root,root) %{_bindir}/llvm-symbolizer
657 %attr(755,root,root) %{_bindir}/llvm-tblgen
658 %attr(755,root,root) %{_bindir}/llvm-cxxdump
659 %attr(755,root,root) %{_bindir}/llvm-pdbdump
660 %attr(755,root,root) %{_bindir}/macho-dump
661 %attr(755,root,root) %{_bindir}/obj2yaml
662 %attr(755,root,root) %{_bindir}/opt
663 %attr(755,root,root) %{_bindir}/verify-uselistorder
664 %attr(755,root,root) %{_bindir}/yaml2obj
665 %if %{with doc}
666 %{_mandir}/man1/bugpoint.1*
667 %{_mandir}/man1/lit.1*
668 %{_mandir}/man1/llc.1*
669 %{_mandir}/man1/lli.1*
670 %{_mandir}/man1/llvm-ar.1*
671 %{_mandir}/man1/llvm-as.1*
672 %{_mandir}/man1/llvm-bcanalyzer.1*
673 %{_mandir}/man1/llvm-cov.1*
674 %{_mandir}/man1/llvm-diff.1*
675 %{_mandir}/man1/llvm-dis.1*
676 %{_mandir}/man1/llvm-dwarfdump.1*
677 %{_mandir}/man1/llvm-extract.1*
678 %{_mandir}/man1/llvm-link.1*
679 %{_mandir}/man1/llvm-nm.1*
680 %{_mandir}/man1/llvm-profdata.1*
681 %{_mandir}/man1/llvm-ranlib.1*
682 %{_mandir}/man1/llvm-readobj.1*
683 %{_mandir}/man1/llvm-stress.1*
684 %{_mandir}/man1/llvm-symbolizer.1*
685 %{_mandir}/man1/opt.1*
686 %{_mandir}/man1/tblgen.1*
687 %endif
688
689 %files libs
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/libLLVM*.so.%{version}
692 %attr(755,root,root) %ghost %{_libdir}/libLLVM*.so.3.7
693 %attr(755,root,root) %{_libdir}/libLTO.so.%{version}
694 %attr(755,root,root) %ghost %{_libdir}/libLTO.so.3.7
695
696 %files devel
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_bindir}/llvm-config
699 %attr(755,root,root) %{_libdir}/libLLVM*.so
700 %attr(755,root,root) %{_libdir}/BugpointPasses.so
701 %attr(755,root,root) %{_libdir}/libLTO.so
702 %{_includedir}/llvm
703 %{_includedir}/llvm-c
704 %dir %{_datadir}/llvm
705 %{_datadir}/llvm/cmake
706 %if %{with doc}
707 %{_mandir}/man1/llvm-config.1*
708 %endif
709
710 #%files doc
711 #%defattr(644,root,root,755)
712
713 %if %{with apidocs}
714 %files apidocs
715 %defattr(644,root,root,755)
716 %doc apidoc/*
717 %endif
718
719 %if %{with polly}
720 %files polly
721 %defattr(644,root,root,755)
722 %doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
723 %attr(755,root,root) %{_libdir}/LLVMPolly.so
724 %attr(755,root,root) %{_libdir}/libPolly.so
725
726 %files polly-devel
727 %defattr(644,root,root,755)
728 %{_includedir}/polly
729 %endif
730
731 %files -n clang
732 %defattr(644,root,root,755)
733 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
734 %attr(755,root,root) %{_bindir}/clang
735 %attr(755,root,root) %{_bindir}/clang++
736 %attr(755,root,root) %{_bindir}/clang-3.7
737 %attr(755,root,root) %{_bindir}/clang-check
738 %attr(755,root,root) %{_bindir}/clang-cl
739 %attr(755,root,root) %{_bindir}/clang-format
740 %attr(755,root,root) %{_bindir}/git-clang-format
741 %dir %{_libdir}/clang
742 %dir %{_libdir}/clang/%{version}
743 %{_libdir}/clang/%{version}/include
744 %if %{with rt}
745 %ifarch %{ix86} %{x8664}
746 %{_libdir}/clang/%{version}/asan_blacklist.txt
747 %dir %{_libdir}/clang/%{version}/lib
748 %dir %{_libdir}/clang/%{version}/lib/linux
749 %endif
750 %ifarch %{ix86}
751 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.a
752 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.so
753 %endif
754 %ifarch %{x8664}
755 %{_libdir}/clang/%{version}/dfsan_abilist.txt
756 %{_libdir}/clang/%{version}/msan_blacklist.txt
757 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
758 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
759 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
760 %endif
761 %endif
762 %dir %{_datadir}/clang
763 %{_datadir}/clang/clang-format-diff.py
764
765 %files -n clang-libs
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_libdir}/libclang.so.3.7
768 %attr(755,root,root) %{_libdir}/libclang[A-Z]*.so.%{version}
769 %attr(755,root,root) %ghost %{_libdir}/libclang[A-Z]*.so.3.7
770
771 %if %{with rt} && %{with multilib}
772 %ifarch %{x8664}
773 %files -n clang-multilib
774 %defattr(644,root,root,755)
775 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.a
776 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.so
777 %endif
778 %endif
779
780 %files -n clang-analyzer
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_bindir}/scan-build
783 %attr(755,root,root) %{_bindir}/scan-view
784 %{_mandir}/man1/scan-build.1*
785 %dir %{_libdir}/clang-analyzer
786
787 %dir %{_libdir}/clang-analyzer/scan-build
788 %{_libdir}/clang-analyzer/scan-build/*.css
789 %{_libdir}/clang-analyzer/scan-build/*.js
790 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
791 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
792
793 %dir %{_libdir}/clang-analyzer/scan-view
794 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
795 %{_libdir}/clang-analyzer/scan-view/Resources
796 %{_libdir}/clang-analyzer/scan-view/*.py[co]
797
798 %files -n clang-devel
799 %defattr(644,root,root,755)
800 %attr(755,root,root) %{_libdir}/libclang*.so
801 %{_includedir}/clang
802 %{_includedir}/clang-c
803
804 %files -n clang-doc
805 %defattr(644,root,root,755)
806 %doc tools/clang/docs/*.{html,png,txt}
807
808 %if %{with apidocs}
809 %files -n clang-apidocs
810 %defattr(644,root,root,755)
811 %doc clang-apidoc/*
812 %endif
813
814 %files -n clang-tools-extra
815 %defattr(644,root,root,755)
816 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt} tools/clang/tools/extra/docs/_build/html/{*.html,*.js,_static}
817 %attr(755,root,root) %{_bindir}/clang-apply-replacements
818 %attr(755,root,root) %{_bindir}/clang-modernize
819 %attr(755,root,root) %{_bindir}/clang-query
820 %attr(755,root,root) %{_bindir}/clang-rename
821 %attr(755,root,root) %{_bindir}/clang-tidy
822 %attr(755,root,root) %{_bindir}/pp-trace
823 %attr(755,root,root) %{_libdir}/libmodernizeCore.so.%{version}
824 %attr(755,root,root) %ghost %{_libdir}/libmodernizeCore.so.3.7
825 # -devel?
826 %attr(755,root,root) %{_libdir}/libmodernizeCore.so
827
828 %files -n lld
829 %defattr(644,root,root,755)
830 %doc tools/lld/{LICENSE.TXT,README.md}
831 %attr(755,root,root) %{_bindir}/lld
832 %attr(755,root,root) %{_libdir}/liblld[ACDEHMPRXY]*.so.%{version}
833 %attr(755,root,root) %ghost %{_libdir}/liblld[ACDEHMPRXY]*.so.3.7
834
835 %files -n lld-devel
836 %defattr(644,root,root,755)
837 %attr(755,root,root) %{_libdir}/liblld[ACDEHMPRXY]*.so
838 %{_includedir}/lld
839
840 %if %{with lldb}
841 %files -n lldb
842 %defattr(644,root,root,755)
843 %attr(755,root,root) %{_bindir}/argdumper
844 %attr(755,root,root) %{_bindir}/lldb
845 %attr(755,root,root) %{_bindir}/lldb-%{version}
846 %attr(755,root,root) %{_bindir}/lldb-mi
847 %attr(755,root,root) %{_bindir}/lldb-mi-%{version}
848 %attr(755,root,root) %{_bindir}/lldb-server
849 %attr(755,root,root) %{_bindir}/lldb-server-%{version}
850 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
851 %attr(755,root,root) %ghost %{_libdir}/liblldb.so.3.7
852 %dir %{py_sitedir}/lldb
853 %attr(755,root,root) %{py_sitedir}/lldb/argdumper
854 %{py_sitedir}/lldb/formatters
855 %{py_sitedir}/lldb/runtime
856 %{py_sitedir}/lldb/utils
857 %{py_sitedir}/lldb/__init__.py[co]
858 %{py_sitedir}/lldb/embedded_interpreter.py[co]
859 %attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
860 %attr(755,root,root) %{py_sitedir}/readline.so
861
862 %files -n lldb-devel
863 %defattr(644,root,root,755)
864 %attr(755,root,root) %{_libdir}/liblldb.so
865 %{_libdir}/liblldb*.a
866 %{_includedir}/lldb
867 %endif
868
869 %if %{with ocaml}
870 %files ocaml
871 %defattr(644,root,root,755)
872 %{_libdir}/ocaml/META.llvm*
873 %attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
874 %{_libdir}/ocaml/llvm*.cma
875 %{_libdir}/ocaml/llvm*.cmi
876
877 %files ocaml-devel
878 %defattr(644,root,root,755)
879 %{_libdir}/ocaml/libllvm*.a
880 %{_libdir}/ocaml/llvm*.a
881 %{_libdir}/ocaml/llvm*.cmx*
882
883 %files ocaml-doc
884 %defattr(644,root,root,755)
885 %doc ocamldocs/*
886 %endif
This page took 0.142116 seconds and 3 git commands to generate.