]> git.pld-linux.org Git - packages/llvm.git/blob - llvm.spec
8d90fb000b3115aedb5b89b9da4a4619a167cfee
[packages/llvm.git] / llvm.spec
1 # TODO: dragonegg, lld, openmp?
2 #
3 # Conditional build:
4 %bcond_without  lldb    # LLDB debugger
5 %bcond_without  polly   # Polly cache-locality optimization, auto-parallelism and vectorization
6 %bcond_without  rt      # compiler-rt libraries
7 %bcond_without  ocaml   # OCaml binding
8 %bcond_without  doc     # HTML docs and man pages
9 %bcond_with     apidocs # doxygen docs (HUGE, so they are not built by default)
10 %bcond_with     tests   # run tests
11
12 %ifarch s390 s390x sparc64
13 # No ocaml on these arches
14 %undefine       with_ocaml
15 %endif
16
17 Summary:        The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
18 Summary(pl.UTF-8):      Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
19 Name:           llvm
20 Version:        3.5.0
21 Release:        1
22 License:        University of Illinois/NCSA Open Source License
23 Group:          Development/Languages
24 #Source0Download: http://llvm.org/releases/download.html
25 Source0:        http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
26 # Source0-md5:  d6987305a1a0e58e128c1374cd3b8fef
27 Source1:        http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
28 # Source1-md5:  27718dd13c7df83e15f997116bbb4aef
29 Source2:        http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
30 # Source2-md5:  02624d2a9144278c3808c00dbbab56c8
31 Source3:        http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
32 # Source3-md5:  9597d5376309805ac586adfbd1e992f4
33 Source4:        http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
34 # Source4-md5:  2ee0167c7ed7c85026cdb18ad6f4ade8
35 Source5:        http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
36 # Source5-md5:  6e2830316638ec0de9534b98361dfbec
37 Patch0:         %{name}-config.patch
38 # Data files should be installed with timestamps preserved
39 Patch1:         %{name}-2.6-timestamp.patch
40 Patch2:         %{name}-pld.patch
41 Patch3:         %{name}-polly-update.patch
42 Patch4:         %{name}-lldb.patch
43 URL:            http://llvm.org/
44 BuildRequires:  autoconf >= 2.60
45 BuildRequires:  automake >= 1:1.9.6
46 BuildRequires:  bash
47 BuildRequires:  bison
48 BuildRequires:  flex
49 BuildRequires:  gcc >= 5:3.4
50 # gcc4 might be installed, but not current __cc
51 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
52 BuildRequires:  __cc >= 3.4
53 %endif
54 BuildRequires:  groff
55 BuildRequires:  libltdl-devel
56 BuildRequires:  libtool >= 2:1.5.22
57 BuildRequires:  libstdc++-devel >= 5:3.4
58 BuildRequires:  ocaml-ocamldoc
59 BuildRequires:  perl-base >= 1:5.6
60 BuildRequires:  perl-tools-pod
61 BuildRequires:  rpm-pythonprov
62 %{?with_doc:BuildRequires:      sphinx-pdg}
63 BuildRequires:  tar >= 1:1.22
64 BuildRequires:  xz
65 %if %{with apidocs}
66 BuildRequires:  doxygen
67 BuildRequires:  graphviz
68 %endif
69 %if %{with tests}
70 BuildRequires:  dejagnu
71 BuildRequires:  python
72 BuildRequires:  tcl-devel
73 %endif
74 %if %{with lldb}
75 BuildRequires:  libedit-devel
76 BuildRequires:  libxml2-devel >= 2
77 BuildRequires:  ncurses-ext-devel
78 BuildRequires:  python-devel >= 2
79 %endif
80 %if %{with polly}
81 BuildRequires:  cloog-isl-devel
82 # >= 0.18.2-2
83 BuildRequires:  gmp-devel
84 BuildRequires:  isl-devel >= 0.13
85 # optional
86 BuildRequires:  scoplib-devel >= 0.2.1-2
87 # optional
88 #BuildRequires: libpluto-devel
89 #cuda-devel
90 %endif
91 Requires:       %{name}-libs = %{version}-%{release}
92 # LLVM is not supported on PPC64
93 # http://llvm.org/bugs/show_bug.cgi?id=3729
94 ExcludeArch:    ppc64
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _sysconfdir     /etc/%{name}
98
99 %define         specflags_ppc   -fno-var-tracking-assignments
100
101 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
102 %define         _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
103
104 %description
105 LLVM is a compiler infrastructure designed for compile-time,
106 link-time, runtime, and idle-time optimization of programs from
107 arbitrary programming languages. LLVM is written in C++ and has been
108 developed since 2000 at the University of Illinois and Apple. It
109 currently supports compilation of C and C++ programs using clang
110 frontend.
111
112 %description -l pl.UTF-8
113 LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
114 czasu kompilowania, linkowania, działania i bezczynności programów w
115 dowolnych językach programowania. Jest napisana w C++, rozwijana od
116 roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
117 kompilację programów w C i C++ przy użyciu frontendu clang.
118
119 %package libs
120 Summary:        LLVM shared library
121 Summary(pl.UTF-8):      Biblioteka współdzielona LLVM-a
122 Group:          Libraries
123 Conflicts:      llvm < 3.2
124
125 %description libs
126 LLVM shared library.
127
128 %description libs -l pl.UTF-8
129 Biblioteka współdzielona LLVM-a.
130
131 %package devel
132 Summary:        Static libraries and header files for LLVM
133 Summary(pl.UTF-8):      Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
134 Group:          Development/Languages
135 Requires:       %{name}-libs = %{version}-%{release}
136 Requires:       libstdc++-devel >= 6:3.4
137
138 %description devel
139 This package contains static libraries and header files needed to
140 develop new native programs that use the LLVM infrastructure.
141
142 %description devel -l pl.UTF-8
143 Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
144 potrzebne do tworzenia nowych programów natywnych wykorzystujących
145 infrastrukturę LLVM.
146
147 %package doc
148 Summary:        Documentation for LLVM
149 Summary(pl.UTF-8):      Dokumentacja do LLVM-a
150 Group:          Documentation
151 # does not require base
152
153 %description doc
154 Documentation for the LLVM compiler infrastructure.
155
156 %description doc -l pl.UTF-8
157 Dokumentacja do infrastruktury kompilatorów LLVM.
158
159 %package apidocs
160 Summary:        API documentation for LLVM
161 Summary(pl.UTF-8):      Dokumentacja API LLVM-a
162 Group:          Development/Languages
163 Requires:       %{name}-doc = %{version}-%{release}
164
165 %description apidocs
166 API documentation for the LLVM compiler infrastructure.
167
168 %description apidocs -l pl.UTF-8
169 Dokumentacja API infrastruktury kompilatorów LLVM.
170
171 %package polly
172 Summary:        Polyhedral optimizations for LLVM
173 Summary(pl.UTF-8):      Optymalizacje wielościanowe dla LLVM-a
174 Group:          Development/Tools
175 URL:            http://polly.llvm.org/
176 Requires:       %{name} = %{version}-%{release}
177
178 %description polly
179 Polly is a high-level loop and data-locality optimizer and
180 optimization infrastructure for LLVM. It uses an abstract mathematical
181 representation based on integer polyhedra to analyze and optimize the
182 memory access pattern of a program.
183
184 %description polly -l pl.UTF-8
185 Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
186 optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
187 reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
188 do analizy i optymalizacji wzorców dostępu do pamięci przez program.
189
190 %package polly-devel
191 Summary:        Header files for LLVM Polly optimization infrastructure
192 Summary(pl.UTF-8):      Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
193 Group:          Development/Libraries
194 URL:            http://polly.llvm.org/
195 Requires:       %{name}-devel = %{version}-%{release}
196 Requires:       %{name}-polly = %{version}-%{release}
197
198 %description polly-devel
199 Header files for LLVM Polly optimization infrastructure.
200
201 %description polly-devel -l pl.UTF-8
202 Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
203
204 %package -n clang
205 Summary:        A C language family frontend for LLVM
206 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C
207 License:        NCSA
208 Group:          Development/Languages
209 Requires:       %{name} = %{version}-%{release}
210
211 %description -n clang
212 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
213 of a crane or goose. 3. C-language family front-end toolkit.
214
215 The goal of the Clang project is to create a new C, C++, Objective C
216 and Objective C++ front-end for the LLVM compiler. Its tools are built
217 as libraries and designed to be loosely-coupled and extendable.
218
219 %description -n clang -l pl.UTF-8
220 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
221 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
222 z rodziny C.
223
224 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
225 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
226 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
227 i rozszerzaniu.
228
229 %package -n clang-analyzer
230 Summary:        A source code analysis framework
231 Summary(pl.UTF-8):      Szkielet do analizy kodu źródłowego
232 License:        NCSA
233 Group:          Development/Languages
234 Requires:       clang = %{version}-%{release}
235 # not picked up automatically since files are currently not instaled
236 # in standard Python hierarchies yet
237 Requires:       python
238
239 %description -n clang-analyzer
240 The Clang Static Analyzer consists of both a source code analysis
241 framework and a standalone tool that finds bugs in C and Objective-C
242 programs. The standalone tool is invoked from the command-line, and is
243 intended to run in tandem with a build of a project or code base.
244
245 %description -n clang-analyzer -l pl.UTF-8
246 Clang Static Analyzer składa się ze szkieletu do analizy kodu
247 źródłowego oraz samodzielnego narzędzia znajdującego błędy w
248 programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
249 myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
250
251 %package -n clang-devel
252 Summary:        Header files for Clang
253 Summary(pl.UTF-8):      Pliki nagłówkowe Clanga
254 Group:          Development/Languages
255 Requires:       %{name}-devel = %{version}-%{release}
256 Requires:       clang = %{version}-%{release}
257
258 %description -n clang-devel
259 This package contains header files for the Clang compiler.
260
261 %description -n clang-devel -l pl.UTF-8
262 Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
263
264 %package -n clang-doc
265 Summary:        Documentation for Clang
266 Summary(pl.UTF-8):      Dokumentacja do Clanga
267 Group:          Documentation
268 Requires:       %{name} = %{version}-%{release}
269
270 %description -n clang-doc
271 Documentation for the Clang compiler front-end.
272
273 %description -n clang-doc -l pl.UTF-8
274 Dokumentacja do frontendu kompilatora Clang.
275
276 %package -n clang-apidocs
277 Summary:        API documentation for Clang
278 Summary(pl.UTF-8):      Dokumentacja API Clanga
279 Group:          Development/Languages
280 Requires:       clang-doc = %{version}-%{release}
281
282 %description -n clang-apidocs
283 API documentation for the Clang compiler.
284
285 %description -n clang-apidocs -l pl.UTF-8
286 Dokumentacja API kompilatora Clang.
287
288 %package -n clang-tools-extra
289 Summary:        Extra tools for Clang
290 Summary(pl.UTF-8):      Dodatkowe narzędzia do kompilatora Clang
291 Group:          Development/Tools
292 URL:            http://clang.llvm.org/docs/ClangTools.html
293 Requires:       clang = %{version}-%{release}
294
295 %description -n clang-tools-extra
296 Extra tools for Clang.
297
298 %description -n clang-tools-extra -l pl.UTF-8
299 Dodatkowe narzędzia do kompilatora Clang.
300
301 %package -n lldb
302 Summary:        Next generation high-performance debugger
303 Summary(pl.UTF-8):      Wydajny debugger nowej generacji
304 Group:          Development/Debuggers
305 Requires:       %{name} = %{version}-%{release}
306
307 %description -n lldb
308 LLDB is a next generation, high-performance debugger. It is built as a
309 set of reusable components which highly leverage existing libraries in
310 the larger LLVM Project, such as the Clang expression parser and LLVM
311 disassembler.
312
313 %description -n lldb -l pl.UTF-8
314 LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
315 komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
316 w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
317 disasembler LLVM.
318
319 %package -n lldb-devel
320 Summary:        Header files for LLDB
321 Summary(pl.UTF-8):      Pliki nagłówkowe LLDB
322 Group:          Development/Libraries
323 Requires:       %{name}-devel = %{version}-%{release}
324 Requires:       clang-devel = %{version}-%{release}
325 Requires:       lldb = %{version}-%{release}
326
327 %description -n lldb-devel
328 Header files for LLDB.
329
330 %description -n lldb-devel -l pl.UTF-8
331 Pliki nagłówkowe LLDB.
332
333 %package ocaml
334 Summary:        OCaml binding for LLVM
335 Summary(pl.UTF-8):      Wiązanie OCamla do LLVM-a
336 Group:          Libraries
337 Requires:       %{name} = %{version}-%{release}
338 %requires_eq    ocaml-runtime
339
340 %description ocaml
341 OCaml binding for LLVM.
342
343 %description ocaml -l pl.UTF-8
344 Wiązanie OCamla do LLVM-a.
345
346 %package ocaml-devel
347 Summary:        Development files for LLVM OCaml binding
348 Summary(pl.UTF-8):      Pliki programistyczne wiązania OCamla do LLVM-a
349 Group:          Development/Libraries
350 Requires:       %{name}-devel = %{version}-%{release}
351 Requires:       %{name}-ocaml = %{version}-%{release}
352
353 %description ocaml-devel
354 The llvm-ocaml-devel package contains libraries and signature files
355 for developing applications that use llvm-ocaml binding.
356
357 %description ocaml-devel -l pl.UTF-8
358 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
359 wykorzystujących wiązanie llvm-ocaml.
360
361 %package ocaml-doc
362 Summary:        Documentation for LLVM's OCaml binding
363 Summary(pl.UTF-8):      Dokumentacja wiązania OCamla do LLVM-a
364 Group:          Documentation
365 Requires:       %{name}-ocaml = %{version}-%{release}
366
367 %description ocaml-doc
368 HTML documentation for LLVM's OCaml binding.
369
370 %description ocaml-doc -l pl.UTF-8
371 Dokumentacja HTML wiązania OCamla do LLVM-a.
372
373 %prep
374 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5
375 mv cfe-%{version}.src tools/clang
376 %{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
377 %{?with_lldb:mv lldb-%{version}.src tools/lldb}
378 %{?with_polly:mv polly-%{version}.src tools/polly}
379 mv clang-tools-extra-%{version}.src tools/clang/tools/extra
380
381 %patch0 -p1
382 %patch1 -p1
383 %patch2 -p1
384 %patch3 -p1
385 %patch4 -p1
386
387 # configure does not properly specify libdir
388 %{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
389 # clang resources
390 %{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
391 %{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
392
393 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
394         s,^#!.*bin/env python,#!%{__python},
395         s,^#!.*bin/env perl,#!%{__perl},
396 }'
397
398 install -d obj
399
400 %build
401 cd autoconf
402 %{__aclocal} -I m4
403 %{__autoconf} -o ../configure configure.ac
404 cd ..
405 %{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
406
407 # Disabling assertions now, rec. by pure and needed for OpenGTL
408 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
409 #
410 # bash specific 'test a < b'
411 cd obj
412 bash ../%configure \
413         --datadir=%{_datadir}/%{name}-%{version} \
414         --disable-assertions \
415         --enable-cxx11 \
416 %ifarch %{ix86}
417         --disable-pic \
418 %endif
419         --disable-static \
420         --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
421         --enable-debug-runtime \
422 %if %{with apidocs}
423         --enable-doxygen \
424 %endif
425         --enable-experimental-targets=R600 \
426         --enable-jit \
427         --enable-optimized \
428         --enable-shared \
429         --with-pic
430
431 %{__make} \
432         VERBOSE=1 \
433         REQUIRES_RTTI=1 \
434         OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
435
436 %if %{with tests}
437 %{__make} check 2>&1 | tee llvm-testlog.txt
438 %{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
439 %endif
440
441 cd ..
442
443 %if %{with doc}
444 %{__make} -C docs -f Makefile.sphinx man
445 %{__make} -C tools/clang/tools/extra/docs html
446 %endif
447
448 %install
449 rm -rf $RPM_BUILD_ROOT
450 %{__make} -C obj -j1 install \
451         PROJ_docsdir=/moredocs \
452         DESTDIR=$RPM_BUILD_ROOT
453
454 # Static analyzer not installed by default:
455 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
456 install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
457 # create launchers
458 for f in scan-{build,view}; do
459         ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
460         cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
461 done
462 %{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
463 %py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
464 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
465 %py_postclean %{_libdir}/clang-analyzer/scan-view
466
467 %if %{with doc}
468 install -d $RPM_BUILD_ROOT%{_mandir}/man1
469 cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
470 # these tools are not installed
471 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
472 # make links
473 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
474 %endif
475
476 # Move documentation back to build directory
477 rm -rf moredocs
478 mv $RPM_BUILD_ROOT/moredocs .
479 %{__rm} -v moredocs/*.tar.gz
480 %{__rm} -v moredocs/ocamldoc/html/*.tar.gz
481
482 # and separate the apidoc
483 %if %{with apidocs}
484 rm -rf apidoc clang-apidoc
485 mv moredocs/html/doxygen apidoc
486 cp -a tools/clang/docs/doxygen/html clang-apidoc
487 %endif
488
489 # And prepare Clang documentation
490 rm -rf clang-docs
491 install -d clang-docs
492 for f in LICENSE.TXT NOTES.txt README.txt; do
493         ln tools/clang/$f clang-docs
494 done
495
496 # Get rid of erroneously installed example files.
497 %{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
498 # parts of test suite
499 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{FileCheck,count,not}
500
501 # remove documentation makefiles:
502 # they require the build directory to work
503 rm -rf moredocs/examples
504 cp -a examples moredocs/examples
505 find moredocs/examples -name Makefile | xargs -0r rm -f
506
507 %clean
508 rm -rf $RPM_BUILD_ROOT
509
510 %post   libs -p /sbin/ldconfig
511 %postun libs -p /sbin/ldconfig
512
513 %post   -n clang -p /sbin/ldconfig
514 %postun -n clang -p /sbin/ldconfig
515
516 %post   -n lldb -p /sbin/ldconfig
517 %postun -n lldb -p /sbin/ldconfig
518
519 %files
520 %defattr(644,root,root,755)
521 %doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
522 %attr(755,root,root) %{_bindir}/bugpoint
523 %attr(755,root,root) %{_bindir}/llc
524 %attr(755,root,root) %{_bindir}/lli
525 %attr(755,root,root) %{_bindir}/lli-child-target
526 %attr(755,root,root) %{_bindir}/llvm-ar
527 %attr(755,root,root) %{_bindir}/llvm-as
528 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
529 %attr(755,root,root) %{_bindir}/llvm-cov
530 %attr(755,root,root) %{_bindir}/llvm-diff
531 %attr(755,root,root) %{_bindir}/llvm-dis
532 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
533 %attr(755,root,root) %{_bindir}/llvm-extract
534 %attr(755,root,root) %{_bindir}/llvm-link
535 %attr(755,root,root) %{_bindir}/llvm-mc
536 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
537 %attr(755,root,root) %{_bindir}/llvm-nm
538 %attr(755,root,root) %{_bindir}/llvm-objdump
539 %attr(755,root,root) %{_bindir}/llvm-profdata
540 %attr(755,root,root) %{_bindir}/llvm-ranlib
541 %attr(755,root,root) %{_bindir}/llvm-readobj
542 %attr(755,root,root) %{_bindir}/llvm-rtdyld
543 %attr(755,root,root) %{_bindir}/llvm-size
544 %attr(755,root,root) %{_bindir}/llvm-stress
545 %attr(755,root,root) %{_bindir}/llvm-symbolizer
546 %attr(755,root,root) %{_bindir}/llvm-tblgen
547 %attr(755,root,root) %{_bindir}/macho-dump
548 %attr(755,root,root) %{_bindir}/opt
549 %if %{with doc}
550 %{_mandir}/man1/bugpoint.1*
551 %{_mandir}/man1/lit.1*
552 %{_mandir}/man1/llc.1*
553 %{_mandir}/man1/lli.1*
554 %{_mandir}/man1/llvm-ar.1*
555 %{_mandir}/man1/llvm-as.1*
556 %{_mandir}/man1/llvm-bcanalyzer.1*
557 %{_mandir}/man1/llvm-cov.1*
558 %{_mandir}/man1/llvm-diff.1*
559 %{_mandir}/man1/llvm-dis.1*
560 %{_mandir}/man1/llvm-dwarfdump.1*
561 %{_mandir}/man1/llvm-extract.1*
562 %{_mandir}/man1/llvm-link.1*
563 %{_mandir}/man1/llvm-nm.1*
564 %{_mandir}/man1/llvm-profdata.1*
565 %{_mandir}/man1/llvm-ranlib.1*
566 %{_mandir}/man1/llvm-readobj.1*
567 %{_mandir}/man1/llvm-stress.1*
568 %{_mandir}/man1/llvm-symbolizer.1*
569 %{_mandir}/man1/opt.1*
570 %{_mandir}/man1/tblgen.1*
571 %endif
572
573 %files libs
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
576 %attr(755,root,root) %{_libdir}/libLLVM-3.5.so
577
578 %files devel
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_bindir}/llvm-config
581 %{_libdir}/libLLVM*.a
582 %ifarch %{x8664}
583 %attr(755,root,root) %{_libdir}/BugpointPasses.so
584 %attr(755,root,root) %{_libdir}/libLTO.so
585 %{_libdir}/libLTO.a
586 %endif
587 %{_includedir}/llvm
588 %{_includedir}/llvm-c
589 %dir %{_datadir}/llvm
590 %{_datadir}/llvm/cmake
591 %if %{with doc}
592 %{_mandir}/man1/llvm-config.1*
593 %endif
594
595 %files doc
596 %defattr(644,root,root,755)
597 %doc moredocs/examples moredocs/html
598
599 %if %{with apidocs}
600 %files apidocs
601 %defattr(644,root,root,755)
602 %doc apidoc/*
603 %endif
604
605 %if %{with polly}
606 %files polly
607 %defattr(644,root,root,755)
608 %doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
609 %attr(755,root,root) %{_libdir}/LLVMPolly.so
610
611 %files polly-devel
612 %defattr(644,root,root,755)
613 %{_includedir}/polly
614 %endif
615
616 %files -n clang
617 %defattr(644,root,root,755)
618 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
619 %attr(755,root,root) %{_bindir}/c-index-test
620 %attr(755,root,root) %{_bindir}/clang
621 %attr(755,root,root) %{_bindir}/clang++
622 %attr(755,root,root) %{_bindir}/clang-check
623 %attr(755,root,root) %{_bindir}/clang-format
624 %attr(755,root,root) %{_bindir}/clang-tblgen
625 %attr(755,root,root) %{_libdir}/libclang.so
626 %dir %{_libdir}/clang
627 %dir %{_libdir}/clang/%{version}
628 %{_libdir}/clang/%{version}/include
629 %if %{with rt}
630 %{_libdir}/clang/%{version}/lib
631 %endif
632 %{_mandir}/man1/clang.1*
633
634 %files -n clang-analyzer
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_bindir}/scan-build
637 %attr(755,root,root) %{_bindir}/scan-view
638 %{_mandir}/man1/scan-build.1*
639 %dir %{_libdir}/clang-analyzer
640
641 %dir %{_libdir}/clang-analyzer/scan-build
642 %{_libdir}/clang-analyzer/scan-build/*.css
643 %{_libdir}/clang-analyzer/scan-build/*.js
644 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
645 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
646
647 %dir %{_libdir}/clang-analyzer/scan-view
648 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
649 %{_libdir}/clang-analyzer/scan-view/Resources
650 %{_libdir}/clang-analyzer/scan-view/*.py[co]
651
652 %files -n clang-devel
653 %defattr(644,root,root,755)
654 %{_libdir}/libclang*.a
655 %{_includedir}/clang
656 %{_includedir}/clang-c
657
658 %files -n clang-doc
659 %defattr(644,root,root,755)
660 %doc tools/clang/docs/*.{css,html,png,txt}
661
662 %if %{with apidocs}
663 %files -n clang-apidocs
664 %defattr(644,root,root,755)
665 %doc clang-apidoc/*
666 %endif
667
668 %files -n clang-tools-extra
669 %defattr(644,root,root,755)
670 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt,docs/_build/html/{*.html,*.js,_static}}
671 %attr(755,root,root) %{_bindir}/clang-apply-replacements
672 %attr(755,root,root) %{_bindir}/clang-modernize
673 %attr(755,root,root) %{_bindir}/clang-query
674 %attr(755,root,root) %{_bindir}/clang-tidy
675 %attr(755,root,root) %{_bindir}/pp-trace
676 %{_libdir}/libmodernizeCore.a
677
678 %if %{with lldb}
679 %files -n lldb
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_bindir}/lldb
682 %attr(755,root,root) %{_bindir}/lldb-gdbserver
683 %attr(755,root,root) %{_bindir}/lldb-mi
684 %attr(755,root,root) %{_bindir}/lldb-platform
685 %attr(755,root,root) %{_libdir}/liblldb.so
686 %dir %{py_sitedir}/lldb
687 %attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
688 %attr(755,root,root) %{py_sitedir}/readline.so
689
690 %files -n lldb-devel
691 %defattr(644,root,root,755)
692 %{_libdir}/liblldb*.a
693 %{_includedir}/lldb
694 %endif
695
696 %if %{with ocaml}
697 %files ocaml
698 %defattr(644,root,root,755)
699 %{_libdir}/ocaml/META.llvm*
700 %attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
701 %{_libdir}/ocaml/llvm*.cma
702 %{_libdir}/ocaml/llvm*.cmi
703
704 %files ocaml-devel
705 %defattr(644,root,root,755)
706 %{_libdir}/libllvm*.a
707 %{_libdir}/ocaml/libLLVM*.a
708 %{_libdir}/ocaml/libllvm*.a
709 %{_libdir}/ocaml/llvm*.a
710 %{_libdir}/ocaml/llvm*.cmx*
711 %{_libdir}/ocaml/llvm*.mli
712
713 %files ocaml-doc
714 %defattr(644,root,root,755)
715 %doc moredocs/ocamldoc/html/*
716 %endif
This page took 0.117534 seconds and 2 git commands to generate.