]> git.pld-linux.org Git - packages/llvm.git/blob - llvm.spec
81f4454663f14c26e62373474ade93239097153b
[packages/llvm.git] / llvm.spec
1 #
2 # TODO:
3 # - fix include search path to support libdir/gcc/platform/version/include.
4 #   current error: /usr/include/wchar.h:39:11: fatal error: 'stdarg.h' file not found# include <stdarg.h>
5 #
6 # Conditional build:
7 %bcond_without  ocaml   # ocaml binding
8 %bcond_with     apidocs # The doxygen docs are HUGE, so they are not built by default.
9 %bcond_without  man     # man pages
10 %bcond_with     tests   # run tests
11
12 %ifarch s390 s390x sparc64
13 # No ocaml on these arches
14 %undefine       with_ocaml
15 %endif
16
17 Summary:        The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
18 Summary(pl.UTF-8):      Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
19 Name:           llvm
20 Version:        3.2
21 Release:        2
22 License:        University of Illinois/NCSA Open Source License
23 Group:          Development/Languages
24 #Source0Download: http://llvm.org/releases/download.html
25 Source0:        http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.gz
26 # Source0-md5:  71610289bbc819e3e15fdd562809a2d7
27 Source1:        http://llvm.org/releases/%{version}/clang-%{version}.src.tar.gz
28 # Source1-md5:  3896ef4334df08563b05d0848ba80582
29 Patch0:         %{name}-config.patch
30 # Data files should be installed with timestamps preserved
31 Patch1:         %{name}-2.6-timestamp.patch
32 Patch2:         %{name}-pld.patch
33 # R600 target support from git://people.freedesktop.org/~tstellar/llvm
34 Patch3:         %{name}-r600.patch
35 URL:            http://llvm.org/
36 BuildRequires:  autoconf >= 2.60
37 BuildRequires:  automake >= 1:1.9.6
38 BuildRequires:  bash
39 BuildRequires:  bison
40 BuildRequires:  flex
41 BuildRequires:  gcc >= 5:3.4
42 # gcc4 might be installed, but not current __cc
43 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
44 BuildRequires:  __cc >= 3.4
45 %endif
46 BuildRequires:  groff
47 BuildRequires:  libltdl-devel
48 BuildRequires:  libtool >= 2:1.5.22
49 BuildRequires:  libstdc++-devel >= 5:3.4
50 BuildRequires:  ocaml-ocamldoc
51 BuildRequires:  perl-base >= 1:5.6
52 BuildRequires:  perl-tools-pod
53 BuildRequires:  rpm-pythonprov
54 %{?with_man:BuildRequires:      sphinx-pdg}
55 %if %{with apidocs}
56 BuildRequires:  doxygen
57 BuildRequires:  graphviz
58 %endif
59 %if %{with tests}
60 BuildRequires:  dejagnu
61 BuildRequires:  python
62 BuildRequires:  tcl-devel
63 %endif
64 Requires:       %{name}-libs = %{version}-%{release}
65 # LLVM is not supported on PPC64
66 # http://llvm.org/bugs/show_bug.cgi?id=3729
67 ExcludeArch:    ppc64
68 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
69
70 %define         _sysconfdir     /etc/%{name}
71
72 %define         specflags_ppc   -fno-var-tracking-assignments
73
74 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
75 %define         _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
76
77 %description
78 LLVM is a compiler infrastructure designed for compile-time,
79 link-time, runtime, and idle-time optimization of programs from
80 arbitrary programming languages. LLVM is written in C++ and has been
81 developed since 2000 at the University of Illinois and Apple. It
82 currently supports compilation of C and C++ programs using clang
83 frontend.
84
85 %description -l pl.UTF-8
86 LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
87 czasu kompilowania, linkowania, działania i bezczynności programów w
88 dowolnych językach programowania. Jest napisana w C++, rozwijana od
89 roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
90 kompilację programów w C i C++ przy użyciu frontendu clang.
91
92 %package libs
93 Summary:        LLVM shared library
94 Summary(pl.UTF-8):      Biblioteka współdzielona LLVM-a
95 Group:          Libraries
96 Conflicts:      llvm < 3.2
97
98 %description libs
99 LLVM shared library.
100
101 %description libs -l pl.UTF-8
102 Biblioteka współdzielona LLVM-a.
103
104 %package devel
105 Summary:        Static libraries and header files for LLVM
106 Summary(pl.UTF-8):      Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
107 Group:          Development/Languages
108 Requires:       %{name}-libs = %{version}-%{release}
109 Requires:       libstdc++-devel >= 6:3.4
110
111 %description devel
112 This package contains static libraries and header files needed to
113 develop new native programs that use the LLVM infrastructure.
114
115 %description devel -l pl.UTF-8
116 Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
117 potrzebne do tworzenia nowych programów natywnych wykorzystujących
118 infrastrukturę LLVM.
119
120 %package doc
121 Summary:        Documentation for LLVM
122 Summary(pl.UTF-8):      Dokumentacja do LLVM-a
123 Group:          Documentation
124 # does not require base
125
126 %description doc
127 Documentation for the LLVM compiler infrastructure.
128
129 %description doc -l pl.UTF-8
130 Dokumentacja do infrastruktury kompilatorów LLVM.
131
132 %package apidocs
133 Summary:        API documentation for LLVM
134 Summary(pl.UTF-8):      Dokumentacja API LLVM-a
135 Group:          Development/Languages
136 Requires:       %{name}-doc = %{version}-%{release}
137
138 %description apidocs
139 API documentation for the LLVM compiler infrastructure.
140
141 %description apidocs -l pl.UTF-8
142 Dokumentacja API infrastruktury kompilatorów LLVM.
143
144 %package -n clang
145 Summary:        A C language family frontend for LLVM
146 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C
147 License:        NCSA
148 Group:          Development/Languages
149 Requires:       %{name} = %{version}-%{release}
150
151 %description -n clang
152 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
153 of a crane or goose. 3. C-language family front-end toolkit.
154
155 The goal of the Clang project is to create a new C, C++, Objective C
156 and Objective C++ front-end for the LLVM compiler. Its tools are built
157 as libraries and designed to be loosely-coupled and extendable.
158
159 %description -n clang -l pl.UTF-8
160 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
161 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
162 z rodziny C.
163
164 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
165 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
166 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
167 i rozszerzaniu.
168
169 %package -n clang-analyzer
170 Summary:        A source code analysis framework
171 Summary(pl.UTF-8):      Szkielet do analizy kodu źródłowego
172 License:        NCSA
173 Group:          Development/Languages
174 Requires:       clang = %{version}-%{release}
175 # not picked up automatically since files are currently not instaled
176 # in standard Python hierarchies yet
177 Requires:       python
178
179 %description -n clang-analyzer
180 The Clang Static Analyzer consists of both a source code analysis
181 framework and a standalone tool that finds bugs in C and Objective-C
182 programs. The standalone tool is invoked from the command-line, and is
183 intended to run in tandem with a build of a project or code base.
184
185 %description -n clang-analyzer -l pl.UTF-8
186 Clang Static Analyzer składa się ze szkieletu do analizy kodu
187 źródłowego oraz samodzielnego narzędzia znajdującego błędy w
188 programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
189 myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
190
191 %package -n clang-devel
192 Summary:        Header files for Clang
193 Summary(pl.UTF-8):      Pliki nagłówkowe Clanga
194 Group:          Development/Languages
195 Requires:       %{name}-devel = %{version}-%{release}
196 Requires:       clang = %{version}-%{release}
197
198 %description -n clang-devel
199 This package contains header files for the Clang compiler.
200
201 %description -n clang-devel -l pl.UTF-8
202 Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
203
204 %package -n clang-doc
205 Summary:        Documentation for Clang
206 Summary(pl.UTF-8):      Dokumentacja do Clanga
207 Group:          Documentation
208 Requires:       %{name} = %{version}-%{release}
209
210 %description -n clang-doc
211 Documentation for the Clang compiler front-end.
212
213 %description -n clang-doc -l pl.UTF-8
214 Dokumentacja do frontendu kompilatora Clang.
215
216 %package -n clang-apidocs
217 Summary:        API documentation for Clang
218 Summary(pl.UTF-8):      Dokumentacja API Clanga
219 Group:          Development/Languages
220 Requires:       clang-doc = %{version}-%{release}
221
222 %description -n clang-apidocs
223 API documentation for the Clang compiler.
224
225 %description -n clang-apidocs -l pl.UTF-8
226 Dokumentacja API kompilatora Clang.
227
228 %package ocaml
229 Summary:        OCaml binding for LLVM
230 Summary(pl.UTF-8):      Wiązanie OCamla do LLVM-a
231 Group:          Libraries
232 Requires:       %{name} = %{version}-%{release}
233 %requires_eq    ocaml-runtime
234
235 %description ocaml
236 OCaml binding for LLVM.
237
238 %description ocaml -l pl.UTF-8
239 Wiązanie OCamla do LLVM-a.
240
241 %package ocaml-devel
242 Summary:        Development files for LLVM OCaml binding
243 Summary(pl.UTF-8):      Pliki programistyczne wiązania OCamla do LLVM-a
244 Group:          Development/Libraries
245 Requires:       %{name}-devel = %{version}-%{release}
246 Requires:       %{name}-ocaml = %{version}-%{release}
247
248 %description ocaml-devel
249 The llvm-ocaml-devel package contains libraries and signature files
250 for developing applications that use llvm-ocaml binding.
251
252 %description ocaml-devel -l pl.UTF-8
253 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
254 wykorzystujących wiązanie llvm-ocaml.
255
256 %package ocaml-doc
257 Summary:        Documentation for LLVM's OCaml binding
258 Summary(pl.UTF-8):      Dokumentacja wiązania OCamla do LLVM-a
259 Group:          Documentation
260 Requires:       %{name}-ocaml = %{version}-%{release}
261
262 %description ocaml-doc
263 HTML documentation for LLVM's OCaml binding.
264
265 %description ocaml-doc -l pl.UTF-8
266 Dokumentacja HTML wiązania OCamla do LLVM-a.
267
268 %prep
269 %setup -q -a1 -n %{name}-%{version}.src
270 mv clang-*.* tools/clang
271 %patch0 -p1
272 %patch1 -p1
273 %patch2 -p1
274 %patch3 -p1
275
276 # configure does not properly specify libdir
277 %{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
278 %{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
279 %{__sed} -i 's|/lib/|/%{_lib}/|' lib/Support/Unix/Path.inc
280
281 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
282         s,^#!.*bin/env python,#!%{__python},
283         s,^#!.*bin/env perl,#!%{__perl},
284 }'
285
286 install -d obj
287
288 %build
289 cd autoconf
290 %{__aclocal} -I m4
291 %{__autoconf} -o ../configure configure.ac
292 cd ..
293 %{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
294
295 # Disabling assertions now, rec. by pure and needed for OpenGTL
296 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
297 #
298 # bash specific 'test a < b'
299 cd obj
300 bash ../%configure \
301         --datadir=%{_datadir}/%{name}-%{version} \
302         --disable-assertions \
303 %ifarch %{ix86}
304         --disable-pic \
305 %endif
306         --disable-static \
307         --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
308         --enable-debug-runtime \
309 %if %{with apidocs}
310         --enable-doxygen \
311 %endif
312         --enable-experimental-targets=R600 \
313         --enable-jit \
314         --enable-optimized \
315         --enable-shared \
316         --with-pic
317
318 %{__make} \
319         REQUIRES_RTTI=1 \
320         OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
321
322 %if %{with tests}
323 %{__make} check 2>&1 | tee llvm-testlog.txt
324 %{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
325 %endif
326
327 cd ..
328
329 %if %{with man}
330 %{__make} -C docs -f Makefile.sphinx man
331 %endif
332
333 %install
334 rm -rf $RPM_BUILD_ROOT
335 %{__make} -C obj -j1 install \
336         PROJ_docsdir=/moredocs \
337         DESTDIR=$RPM_BUILD_ROOT
338
339 # Static analyzer not installed by default:
340 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
341 install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
342 # create launchers
343 for f in scan-{build,view}; do
344         ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
345         cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
346 done
347 %{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
348 %py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
349 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
350 %py_postclean %{_libdir}/clang-analyzer/scan-view
351
352 %if %{with man}
353 install -d $RPM_BUILD_ROOT%{_mandir}/man1
354 cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
355 # these tools are not installed
356 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
357 %endif
358
359 # Move documentation back to build directory
360 rm -rf moredocs
361 mv $RPM_BUILD_ROOT/moredocs .
362 %{__rm} -v moredocs/*.tar.gz
363 %{__rm} -v moredocs/ocamldoc/html/*.tar.gz
364
365 # and separate the apidoc
366 %if %{with apidocs}
367 rm -rf apidoc clang-apidoc
368 mv moredocs/html/doxygen apidoc
369 cp -a tools/clang/docs/doxygen/html clang-apidoc
370 %endif
371
372 # And prepare Clang documentation
373 rm -rf clang-docs
374 install -d clang-docs
375 for f in LICENSE.TXT NOTES.txt README.txt; do
376         ln tools/clang/$f clang-docs
377 done
378
379 # Get rid of erroneously installed example files.
380 %{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
381
382 # remove documentation makefiles:
383 # they require the build directory to work
384 rm -rf moredocs/examples
385 cp -a examples moredocs/examples
386 find moredocs/examples -name Makefile | xargs -0r rm -f
387
388 %clean
389 rm -rf $RPM_BUILD_ROOT
390
391 %post   libs -p /sbin/ldconfig
392 %postun libs -p /sbin/ldconfig
393
394 %files
395 %defattr(644,root,root,755)
396 %doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
397 %attr(755,root,root) %{_bindir}/bugpoint
398 %attr(755,root,root) %{_bindir}/llc
399 %attr(755,root,root) %{_bindir}/lli
400 %attr(755,root,root) %{_bindir}/llvm-ar
401 %attr(755,root,root) %{_bindir}/llvm-as
402 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
403 %attr(755,root,root) %{_bindir}/llvm-cov
404 %attr(755,root,root) %{_bindir}/llvm-diff
405 %attr(755,root,root) %{_bindir}/llvm-dis
406 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
407 %attr(755,root,root) %{_bindir}/llvm-extract
408 %attr(755,root,root) %{_bindir}/llvm-link
409 %attr(755,root,root) %{_bindir}/llvm-mc
410 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
411 %attr(755,root,root) %{_bindir}/llvm-nm
412 %attr(755,root,root) %{_bindir}/llvm-objdump
413 %attr(755,root,root) %{_bindir}/llvm-prof
414 %attr(755,root,root) %{_bindir}/llvm-ranlib
415 %attr(755,root,root) %{_bindir}/llvm-readobj
416 %attr(755,root,root) %{_bindir}/llvm-rtdyld
417 %attr(755,root,root) %{_bindir}/llvm-size
418 %attr(755,root,root) %{_bindir}/llvm-stress
419 %attr(755,root,root) %{_bindir}/llvm-tblgen
420 %attr(755,root,root) %{_bindir}/macho-dump
421 %attr(755,root,root) %{_bindir}/opt
422 %{_mandir}/man1/bugpoint.1*
423 %{_mandir}/man1/lit.1*
424 %{_mandir}/man1/llc.1*
425 %{_mandir}/man1/lli.1*
426 %{_mandir}/man1/llvm-ar.1*
427 %{_mandir}/man1/llvm-as.1*
428 %{_mandir}/man1/llvm-bcanalyzer.1*
429 %{_mandir}/man1/llvm-cov.1*
430 %{_mandir}/man1/llvm-diff.1*
431 %{_mandir}/man1/llvm-dis.1*
432 %{_mandir}/man1/llvm-extract.1*
433 %{_mandir}/man1/llvm-link.1*
434 %{_mandir}/man1/llvm-nm.1*
435 %{_mandir}/man1/llvm-prof.1*
436 %{_mandir}/man1/llvm-ranlib.1*
437 %{_mandir}/man1/llvm-stress.1*
438 %{_mandir}/man1/opt.1*
439 %{_mandir}/man1/tblgen.1*
440
441 %files libs
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_libdir}/libLLVM-%{version}svn.so
444
445 %files devel
446 %defattr(644,root,root,755)
447 %attr(755,root,root) %{_bindir}/llvm-config
448 %attr(755,root,root) %{_libdir}/libprofile_rt.so
449 %{_libdir}/libLLVM*.a
450 %{_libdir}/libprofile_rt.a
451 %ifarch %{x8664}
452 %attr(755,root,root) %{_libdir}/BugpointPasses.so
453 %attr(755,root,root) %{_libdir}/libLTO.so
454 %{_libdir}/libLTO.a
455 %endif
456 %{_includedir}/llvm
457 %{_includedir}/llvm-c
458 %{_mandir}/man1/llvm-config.1*
459
460 %files doc
461 %defattr(644,root,root,755)
462 %doc moredocs/examples moredocs/html
463
464 %if %{with apidocs}
465 %files apidocs
466 %defattr(644,root,root,755)
467 %doc apidoc/*
468 %endif
469
470 %files -n clang
471 %defattr(644,root,root,755)
472 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
473 %attr(755,root,root) %{_bindir}/c-index-test
474 %attr(755,root,root) %{_bindir}/clang
475 %attr(755,root,root) %{_bindir}/clang++
476 %attr(755,root,root) %{_bindir}/clang-check
477 %attr(755,root,root) %{_bindir}/clang-tblgen
478 %attr(755,root,root) %{_libdir}/libclang.so
479 %{_libdir}/clang
480 %{_mandir}/man1/clang.1*
481
482 %files -n clang-analyzer
483 %defattr(644,root,root,755)
484 %attr(755,root,root) %{_bindir}/scan-build
485 %attr(755,root,root) %{_bindir}/scan-view
486 %{_mandir}/man1/scan-build.1*
487 %dir %{_libdir}/clang-analyzer
488
489 %dir %{_libdir}/clang-analyzer/scan-build
490 %{_libdir}/clang-analyzer/scan-build/*.css
491 %{_libdir}/clang-analyzer/scan-build/*.js
492 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
493 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
494
495 %dir %{_libdir}/clang-analyzer/scan-view
496 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
497 %{_libdir}/clang-analyzer/scan-view/Resources
498 %{_libdir}/clang-analyzer/scan-view/*.py[co]
499
500 %files -n clang-devel
501 %defattr(644,root,root,755)
502 %{_libdir}/libclang*.a
503 %{_includedir}/clang
504 %{_includedir}/clang-c
505
506 %files -n clang-doc
507 %defattr(644,root,root,755)
508 %doc tools/clang/docs/*.{css,html,png,txt}
509
510 %if %{with apidocs}
511 %files -n clang-apidocs
512 %defattr(644,root,root,755)
513 %doc clang-apidoc/*
514 %endif
515
516 %if %{with ocaml}
517 %files ocaml
518 %defattr(644,root,root,755)
519 %{_libdir}/ocaml/META.llvm
520 %{_libdir}/ocaml/llvm*.cma
521 %{_libdir}/ocaml/llvm*.cmi
522
523 %files ocaml-devel
524 %defattr(644,root,root,755)
525 %{_libdir}/libllvm*.a
526 %{_libdir}/ocaml/libLLVM*.a
527 %{_libdir}/ocaml/libllvm*.a
528 %{_libdir}/ocaml/llvm*.a
529 %{_libdir}/ocaml/llvm*.cmx*
530 %{_libdir}/ocaml/llvm*.mli
531
532 %files ocaml-doc
533 %defattr(644,root,root,755)
534 %doc moredocs/ocamldoc/html/*
535 %endif
This page took 0.078167 seconds and 3 git commands to generate.