]> git.pld-linux.org Git - packages/llvm-openmp.git/blob - llvm-openmp.spec
- updated to 7.0.0
[packages/llvm-openmp.git] / llvm-openmp.spec
1 # TODO: offload library? (requires Intel COI Runtime + Intel MYO Runtime)
2 #
3 # Conditional build:
4 %bcond_without  fortran         # Fortran modules
5 #
6 Summary:        Intel OpenMP runtime library implementation for use with Clang
7 Summary(pl.UTF-8):      Implementacja biblioteki uruchomieniowej OpenMP firmy Intel dla kompilatora Clang
8 Name:           llvm-openmp
9 Version:        7.0.0
10 Release:        1
11 License:        BSD-like or MIT
12 Group:          Libraries
13 Source0:        http://releases.llvm.org/%{version}/openmp-%{version}.src.tar.xz
14 # Source0-md5:  8800aac08f2f9dad0ebf66e0e152bd63
15 URL:            http://openmp.llvm.org/
16 BuildRequires:  cmake >= 2.8
17 %{?with_fortran:BuildRequires:  gcc-fortran}
18 BuildRequires:  rpmbuild(macros) >= 1.605
19 ExclusiveArch:  %{ix86} %{x8664} %{arm} aarch64 ppc64
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %ifarch %{ix86}
23 %define         iomp_arch       32
24 %endif
25 %ifarch %{x8664}
26 %define         iomp_arch       32e
27 %endif
28 %ifarch %{arm} aarch64 ppc64
29 %define         iomp_arch       %{_arch}
30 %endif
31
32 %description
33 The OpenMP subproject of LLVM is intended to contain all of the
34 components required to build an executing OpenMP program that are
35 outside the compiler itself. Support for OpenMP 3.1 in Clang is in the
36 process of being promoted into the Clang mainline, and can be found at
37 OpenMP/Clang: <http://clang-omp.github.io/>. 
38
39 %description -l pl.UTF-8
40 Podprojekt OpenMP projektu LLVM ma na celu skompletowanie wszystkich
41 komponentów wymaganych do zbudowania działającego programu OpenMP poza
42 samym kompilatorem. Obsługa OpenMP 3.1 w Clangu jest w trakcie
43 włączania do głównej linii kompilatora i można ją znaleźć w
44 repozytorium OpenMP/Clang: <http://clang-omp.github.io/>. 
45
46 %package devel
47 Summary:        Header file for Intel OpenMP implementation
48 Summary(pl.UTF-8):      Plik nagłówkowy implementacji OpenMP firmy Intel
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header file for Intel OpenMP implementation.
54
55 %description devel -l pl.UTF-8
56 Plik nagłówkowy implementacji OpenMP firmy Intel.
57
58 %package fortran-devel
59 Summary:        Fortran modules for Intel OpenMP implementation
60 Summary(pl.UTF-8):      Moduły Fortranu implementacji OpenMP firmy Intel
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description fortran-devel
65 Fortran modules for Intel OpenMP implementation.
66
67 %description fortran-devel -l pl.UTF-8
68 Moduły Fortranu implementacji OpenMP firmy Intel.
69
70 %prep
71 %setup -q -n openmp-%{version}.src
72
73 %build
74 install -d build
75 cd build
76 libsubdir=%{_lib}
77 %cmake .. \
78 %ifarch %{arm} ppc64
79         -DLIBOMP_ARCH=%{iomp_arch} \
80 %endif
81         -DLIBOMP_LIBDIR_SUFFIX="${libsuffix#lib}" \
82         %{?with_fortran:-DLIBOMP_FORTRAN_MODULES=ON}
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} -C build install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # libgomp dropin symlink, but PLD ships original libgomp
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgomp.so
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc CREDITS.txt LICENSE.txt www/{README.txt,Reference.pdf,*.{html,css}}
104 %attr(755,root,root) %{_libdir}/libomp.so
105 %attr(755,root,root) %{_libdir}/libomptarget.so
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/libiomp5.so
110 %{_includedir}/omp.h
111 %{_includedir}/ompt.h
112
113 %if %{with fortran}
114 %files fortran-devel
115 %defattr(644,root,root,755)
116 %{_includedir}/omp_lib.h
117 %{_includedir}/omp_lib.mod
118 %{_includedir}/omp_lib_kinds.mod
119 %endif
This page took 0.093488 seconds and 3 git commands to generate.