]> git.pld-linux.org Git - packages/llvm-libcxxabi.git/blob - llvm-libcxxabi.spec
- updated to 3.7.0
[packages/llvm-libcxxabi.git] / llvm-libcxxabi.spec
1 Summary:        libc++abi - C++ standard library support from LLVM project
2 Summary(pl.UTF-8):      libc++abi - wsparcie dla biblioteki standardowej C++ z projektu LLVM
3 Name:           llvm-libcxxabi
4 Version:        3.7.0
5 Release:        1
6 License:        MIT or BSD-like
7 Group:          Libraries
8 #Source0Download: http://llvm.org/releases/download.html
9 Source0:        http://llvm.org/releases/%{version}/libcxxabi-%{version}.src.tar.xz
10 # Source0-md5:  5aa769e2fca79fa5335cfae8f6258772
11 URL:            http://libcxxabi.llvm.org/
12 BuildRequires:  cmake >= 2.8.8
13 BuildRequires:  clang >= %{version}
14 %ifarch arm
15 BuildRequires:  libunwind-devel
16 %endif
17 BuildRequires:  llvm-devel >= %{version}
18 BuildRequires:  llvm-libcxx-devel >= 3.6.0
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 libc++abi is a new implementation of low level support for a standard
23 C++ library.
24
25 %description -l pl.UTF-8
26 libc++abi to nowa implementacja niskopoziomowego wsparcia dla
27 biblioteki standardowej C++.
28
29 %package devel
30 Summary:        Development files for LLVM libc++abi library
31 Summary(pl.UTF-8):      Pliki programistyczne biblioteki LLVM libc++abi
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Development files for LLVM libc++abi library.
37
38 %description devel -l pl.UTF-8
39 Pliki programistyczne biblioteki LLVM libc++abi.
40
41 %package static
42 Summary:        Static LLVM libc++abi library
43 Summary(pl.UTF-8):      Statyczna biblioteka LLVM libc++abi
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 Static LLVM libc++abi library.
49
50 %description static -l pl.UTF-8
51 Statyczna biblioteka LLVM libc++abi.
52
53 %prep
54 %setup -q -n libcxxabi-%{version}.src
55
56 %build
57 install -d build
58 cd build
59 %cmake .. \
60         -DCMAKE_C_COMPILER="clang" \
61         -DCMAKE_CXX_COMPILER="clang++"
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} -C build install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 install -d $RPM_BUILD_ROOT%{_includedir}/libcxxabi
71 cp -p include/*.h $RPM_BUILD_ROOT%{_includedir}/libcxxabi
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post   -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc CREDITS.TXT LICENSE.TXT
82 %attr(755,root,root) %{_libdir}/libc++abi.so.*.*
83 %attr(755,root,root) %ghost %{_libdir}/libc++abi.so.1
84
85 %files devel
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_libdir}/libc++abi.so
88 %{_includedir}/libcxxabi
89
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/libc++abi.a
This page took 0.072253 seconds and 3 git commands to generate.