]> git.pld-linux.org Git - packages/llvm-libclc.git/blob - llvm-libclc.spec
b9d76e8ac5c3ea420d4d1699c9feb44598c58f84
[packages/llvm-libclc.git] / llvm-libclc.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 #
5 Summary:        OpenCL C programming language library implementation
6 Summary(pl.UTF-8):      Implementacja biblioteki języka programowania OpenCL C
7 Name:           llvm-libclc
8 Version:        0.2.0
9 %define snap    20171128
10 Release:        0.%{snap}.1
11 License:        BSD-like or MIT
12 Group:          Libraries
13 # https://github.com/llvm/llvm-project/tree/master/libclc
14 Source0:        libclc-%{snap}.tar.xz
15 # Source0-md5:  ea25d81625b12e7659881509aa7546cb
16 Patch0:         build.patch
17 URL:            http://libclc.llvm.org/
18 BuildRequires:  clang >= 3.9
19 BuildRequires:  llvm-devel >= 3.9
20 BuildRequires:  python >= 1:2.7
21 BuildRequires:  rpmbuild(macros) >= 1.446
22 Requires:       llvm-libs >= 3.9
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 libclc is an open source, BSD licensed implementation of the library
27 requirements of the OpenCL C programming language, as specified by the
28 OpenCL 1.1 Specification. The following sections of the specification
29 impose library requirements:
30
31  * 6.1: Supported Data Types
32  * 6.2.3: Explicit Conversions
33  * 6.2.4.2: Reinterpreting Types Using as_type() and as_typen()
34  * 6.9: Preprocessor Directives and Macros
35  * 6.11: Built-in Functions
36  * 9.3: Double Precision Floating-Point
37  * 9.4: 64-bit Atomics
38  * 9.5: Writing to 3D image memory objects
39  * 9.6: Half Precision Floating-Point
40
41 libclc is intended to be used with the Clang compiler's OpenCL
42 frontend.
43
44 %description -l pl.UTF-8
45 libclc to mająca otwarte źródła, wydana na licencji BSD implementacja
46 wymagań bibliotecznych języka programowania OpenCL C zgodna ze
47 specyfikacją OpenCL 1.1. Wymagania biblioteczne wynikają z
48 następujących sekcji specyfikacji:
49
50  * 6.1: obsługiwane typy danych
51  * 6.2.3: jawne konwersje
52  * 6.2.4.2: reinterpretacja typów przy użyciu as_type() i as_typen()
53  * 6.9: dyrektywy i makra preprocesora
54  * 6.11: funkcje wbudowane
55  * 9.3: arytmetyka zmiennoprzecinkowa podwójnej precyzji
56  * 9.4: 64-bitowe operacje atomowe
57  * 9.5: zapis do biektów obrazów 3D w pamięci
58  * 9.6: arytmetyka zmiennoprzecinkowa połówkowej precyzji
59
60 libclc jest przeznaczona do używania z frontendem OpenCL kompilatora
61 Clang.
62
63 %prep
64 %setup -q -n libclc
65 %patch0 -p1
66
67 %build
68 ./configure.py \
69         --prefix=%{_prefix} \
70         --libexecdir=%{_datadir}/clc \
71         --pkgconfigdir=%{_npkgconfigdir} \
72         --with-llvm-config=/usr/bin/llvm-config
73
74 %{__make} \
75         VERBOSE=1
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc CREDITS.TXT LICENSE.TXT README.TXT www/index.html
89 %{_includedir}/clc
90 %{_datadir}/clc
91 %{_npkgconfigdir}/libclc.pc
This page took 0.45607 seconds and 2 git commands to generate.