]> git.pld-linux.org Git - packages/lirc.git/blob - lirc.spec
- does not build, too many hacks :/
[packages/lirc.git] / lirc.spec
1 # TODO
2 # - restore lirc_parallel driver
3 # - try to make it use builder_kernel_modules and install_kernel_modules; I couldn't make it
4 # - build is running kernel arch dependent, try to get rid of this
5 # - libcaraca_client (http://caraca.sourceforge.net/) - no releases yet
6 #
7 # Conditional build:
8 %bcond_without  dist_kernel     # without sources of distribution kernel
9 %bcond_without  kernel          # don't build kernel modules, only library+programs
10 %bcond_without  userspace       # build only packages with kernel modules
11 %bcond_with     svga            # without svgalib-based utility
12 %bcond_without  x               # without X11-based utilitied
13
14 %if %{without kernel}
15 %undefine       with_dist_kernel
16 %endif
17
18 %if "%{_alt_kernel}" != "%{nil}"
19 %undefine       with_userspace
20 %endif
21
22 %define         pname   lirc
23 %define         rel     24.1
24
25 #
26 # main package
27 #
28 # lirc_gpio fails to build under kernel >= 2.6.23
29 #
30 %if "%{_kernel_ver}" >= "2.6.23"
31 %if "%{_kernel_ver}" >= "3.0.0"
32 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir"
33 %else
34 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
35 %endif
36 %else
37 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_gpio lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
38 %endif
39 Summary:        Linux Infrared Remote Control daemons
40 Summary(pl.UTF-8):      Serwery do zdalnego sterowania Linuksem za pomocą podczerwieni
41 Name:           %{pname}%{_alt_kernel}
42 Version:        0.9.0
43 Release:        %{rel}
44 License:        GPL v2+
45 Group:          Daemons
46 Source0:        http://downloads.sourceforge.net/lirc/%{pname}-%{version}.tar.bz2
47 # Source0-md5:  b232aef26f23fe33ea8305d276637086
48 Source1:        http://lirc.sourceforge.net/remotes.tar.bz2
49 # Source1-md5:  238d1773d3c405acc02813674f5a55f8
50 Source2:        %{pname}d.sysconfig
51 Source3:        %{pname}d.init
52 Source4:        %{pname}md.init
53 Source5:        %{pname}.tmpfiles
54 Patch0:         %{pname}-opt.patch
55 Patch1:         %{pname}-tmp.patch
56 Patch2:         %{pname}-no-svgalib.patch
57 Patch3:         %{pname}-kernel.patch
58 Patch4:         %{pname}-sparc.patch
59 Patch5:         %{pname}-remotes.patch
60 Patch6:         %{pname}-kernelcc.patch
61 URL:            http://www.lirc.org/
62 BuildRequires:  alsa-lib-devel
63 BuildRequires:  autoconf >= 2.50
64 BuildRequires:  automake
65 BuildRequires:  iguanaIR-devel
66 BuildRequires:  libftdi-devel >= 0.12
67 BuildRequires:  libirman-devel >= 0.4.5
68 BuildRequires:  libtool
69 BuildRequires:  libusb-compat-devel >= 0.1.0
70 %if %{with kernel}
71 BuildRequires:  kernel%{_alt_kernel}-module-build
72 BuildRequires:  kernel%{_alt_kernel}-headers
73 %endif
74 %{?with_kernel:BuildRequires:   %{kgcc_package}}
75 BuildRequires:  rpm-pythonprov
76 BuildRequires:  rpmbuild(macros) >= 1.379
77 %{?with_svga:BuildRequires:     svgalib-devel}
78 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
79 Requires(post,preun):   /sbin/chkconfig
80 Requires:       %{pname}-libs = %{version}-%{release}
81 Requires:       libftdi >= 0.12
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %description
85 LIRC is a package that allows you to decode and send infra-red signals
86 of many (but not all) commonly used remote controls.
87
88 %description -l pl.UTF-8
89 LIRC to program pozwalający na dekodowanie nadchodzących oraz
90 wysyłanie sygnałów w podczerwieni za pomocą wielu (ale nie
91 wszystkich) popularnych urządzeń do zdalnego sterowania.
92
93 %package remotes
94 Summary:        Lirc remotes database
95 Summary(pl.UTF-8):      Baza pilotów obsługiwanych przez lirc
96 Group:          Documentation
97 Requires:       %{pname} = %{version}-%{rel}
98
99 %description remotes
100 This package contains configuration files for many remotes supported
101 by lirc.
102
103 %description remotes -l pl.UTF-8
104 Ten pakiet zawiera pliki konfiguracyjne dla wielu pilotów
105 obsługiwanych przez lirc.
106
107 %package X11
108 Summary:        Linux Infrared Remote Control - X11 utilities
109 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11
110 Group:          X11/Applications
111 Requires:       %{pname}-libs = %{version}-%{release}
112
113 %description X11
114 Linux Infrared Remote Control - X11 utilities.
115
116 %description X11 -l pl.UTF-8
117 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11.
118
119 %package svga
120 Summary:        Linux Infrared Remote Control - svgalib utilities
121 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia svgalib
122 Group:          Applications
123 Requires:       %{pname}-libs = %{version}-%{release}
124
125 %description svga
126 Linux Infrared Remote Control - svgalib-based utilities.
127
128 %description svga -l pl.UTF-8
129 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia oparte
130 na svgalibie.
131
132 %package libs
133 Summary:        LIRC libraries
134 Summary(pl.UTF-8):      Biblioteki LIRC
135 Group:          Libraries
136 Conflicts:      lirc < 0.6.3-3
137 # didn't use /tmp/.lircd
138
139 %description libs
140 This package provides the libraries necessary to run lirc client
141 programs.
142
143 %description libs -l pl.UTF-8
144 Ten pakiet zawiera biblioteki niezbędne do działania klientów LIRC.
145
146 %package devel
147 Summary:        Header files for LIRC development
148 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów z obsługą LIRC
149 Group:          Development/Libraries
150 Requires:       %{pname}-libs = %{version}-%{release}
151
152 %description devel
153 This package provides the files necessary to develop LIRC-based
154 programs.
155
156 %description devel -l pl.UTF-8
157 Ten pakiet zawiera pliki niezbędne do tworzenia programów opartych
158 na LIRC.
159
160 %package static
161 Summary:        Static library for LIRC development
162 Summary(pl.UTF-8):      Biblioteka statyczna LIRC
163 Group:          Development/Libraries
164 Requires:       %{pname}-devel = %{version}-%{release}
165
166 %description static
167 The files necessary for development of statically-linked lirc-based
168 programs.
169
170 %description static -l pl.UTF-8
171 Pliki potrzebne do tworzenia łączonych statycznie programów
172 opartych na LIRC.
173
174 %package -n kernel%{_alt_kernel}-char-lirc-atiusb
175 Summary:        Kernel modules for Linux Infrared Remote Control
176 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
177 Release:        %{rel}@%{_kernel_ver_str}
178 Group:          Base/Kernel
179 %if %{with dist_kernel}
180 %requires_releq_kernel
181 Requires(postun):       %releq_kernel
182 %endif
183 Requires(post,postun):  /sbin/depmod
184 Requires:       %{pname} = %{version}-%{rel}
185 Conflicts:      dev < 2.8.0-3
186
187 %description -n kernel%{_alt_kernel}-char-lirc-atiusb
188 This package contains the kernel modules necessary to operate some
189 infrared remote control devices (such as the ones bundled with TV
190 cards).
191
192 lirc_atiusb module.
193
194 %description -n kernel%{_alt_kernel}-char-lirc-atiusb -l pl.UTF-8
195 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
196 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
197
198 Moduł lirc_atiusb.
199
200 %package -n kernel%{_alt_kernel}-char-lirc-bt829
201 Summary:        Kernel modules for Linux Infrared Remote Control
202 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
203 Release:        %{rel}@%{_kernel_ver_str}
204 Group:          Base/Kernel
205 %if %{with dist_kernel}
206 %requires_releq_kernel
207 Requires(postun):       %releq_kernel
208 %endif
209 Requires(post,postun):  /sbin/depmod
210 Requires:       %{pname} = %{version}-%{rel}
211 Conflicts:      dev < 2.8.0-3
212
213 %description -n kernel%{_alt_kernel}-char-lirc-bt829
214 This package contains the kernel modules necessary to operate some
215 infrared remote control devices (such as the ones bundled with TV
216 cards).
217
218 lirc_bt829 module.
219
220 %description -n kernel%{_alt_kernel}-char-lirc-bt829 -l pl.UTF-8
221 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
222 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
223
224 Moduł lirc_bt829.
225
226 %package -n kernel%{_alt_kernel}-char-lirc-dev
227 Summary:        Kernel modules for Linux Infrared Remote Control
228 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
229 Release:        %{rel}@%{_kernel_ver_str}
230 Group:          Base/Kernel
231 %if %{with dist_kernel}
232 %requires_releq_kernel
233 Requires(postun):       %releq_kernel
234 %endif
235 Requires(post,postun):  /sbin/depmod
236 Requires:       %{pname} = %{version}-%{rel}
237 Obsoletes:      lirc-modules
238 Obsoletes:      lirc-modules-dev
239 Conflicts:      dev < 2.8.0-3
240
241 %description -n kernel%{_alt_kernel}-char-lirc-dev
242 This package contains the kernel modules necessary to operate some
243 infrared remote control devices (such as the ones bundled with TV
244 cards).
245
246 lirc_dev module.
247
248 %description -n kernel%{_alt_kernel}-char-lirc-dev -l pl.UTF-8
249 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
250 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
251
252 Moduł lirc_dev.
253
254 %package -n kernel%{_alt_kernel}-char-lirc-ene0100
255 Summary:        Kernel modules for Linux Infrared Remote Control
256 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
257 Release:        %{rel}@%{_kernel_ver_str}
258 Group:          Base/Kernel
259 %if %{with dist_kernel}
260 %requires_releq_kernel
261 Requires(postun):       %releq_kernel
262 %endif
263 Requires(post,postun):  /sbin/depmod
264 Requires:       %{pname} = %{version}-%{rel}
265 Obsoletes:      lirc-modules
266 Conflicts:      dev < 2.8.0-3
267
268 %description -n kernel%{_alt_kernel}-char-lirc-ene0100
269 This package contains the kernel modules necessary to operate some
270 infrared remote control ene0100ices (such as the ones bundled with TV
271 cards).
272
273 lirc_ene0100 module.
274
275 %description -n kernel%{_alt_kernel}-char-lirc-ene0100 -l pl.UTF-8
276 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
277 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
278
279 Moduł lirc_ene0100.
280
281 %package -n kernel%{_alt_kernel}-char-lirc-gpio
282 Summary:        Kernel modules for Linux Infrared Remote Control
283 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
284 Release:        %{rel}@%{_kernel_ver_str}
285 Group:          Base/Kernel
286 %if %{with dist_kernel}
287 %requires_releq_kernel
288 Requires(postun):       %releq_kernel
289 %endif
290 Requires(post,postun):  /sbin/depmod
291 Requires:       %{pname} = %{version}-%{rel}
292 Obsoletes:      lirc-modules
293 Obsoletes:      lirc-modules-gpio
294 Conflicts:      dev < 2.8.0-3
295
296 %description -n kernel%{_alt_kernel}-char-lirc-gpio
297 This package contains the kernel modules necessary to operate some
298 infrared remote control devices (such as the ones bundled with TV
299 cards).
300
301 lirc_gpio module.
302
303 %description -n kernel%{_alt_kernel}-char-lirc-gpio -l pl.UTF-8
304 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
305 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
306
307 Moduł lirc_gpio.
308
309 %package -n kernel%{_alt_kernel}-char-lirc-i2c
310 Summary:        Kernel modules for Linux Infrared Remote Control
311 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
312 Release:        %{rel}@%{_kernel_ver_str}
313 Group:          Base/Kernel
314 %if %{with dist_kernel}
315 %requires_releq_kernel
316 Requires(postun):       %releq_kernel
317 %endif
318 Requires(post,postun):  /sbin/depmod
319 Requires:       %{pname} = %{version}-%{rel}
320 Obsoletes:      lirc-modules
321 Obsoletes:      lirc-modules-i2c
322 Conflicts:      dev < 2.8.0-3
323
324 %description -n kernel%{_alt_kernel}-char-lirc-i2c
325 This package contains the kernel modules necessary to operate some
326 infrared remote control devices (such as the ones bundled with TV
327 cards).
328
329 lirc_i2c module.
330
331 %description -n kernel%{_alt_kernel}-char-lirc-i2c -l pl.UTF-8
332 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
333 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
334
335 Moduł lirc_i2c.
336
337 %package -n kernel%{_alt_kernel}-char-lirc-igorplugusb
338 Summary:        Kernel modules for Linux Infrared Remote Control
339 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
340 Release:        %{rel}@%{_kernel_ver_str}
341 Group:          Base/Kernel
342 %if %{with dist_kernel}
343 %requires_releq_kernel
344 Requires(postun):       %releq_kernel
345 %endif
346 Requires(post,postun):  /sbin/depmod
347 Requires:       %{pname} = %{version}-%{rel}
348 Obsoletes:      lirc-modules
349 Obsoletes:      lirc-modules-igorplugusb
350 Conflicts:      dev < 2.8.0-3
351
352 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb
353 This package contains the kernel modules necessary to operate some
354 infrared remote control devices (such as the ones bundled with TV
355 cards).
356
357 lirc_igorplugusb module.
358
359 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb -l pl.UTF-8
360 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
361 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
362
363 Moduł lirc_igorplugusb.
364
365 %package -n kernel%{_alt_kernel}-char-lirc-imon
366 Summary:        Kernel modules for Linux Infrared Remote Control
367 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
368 Release:        %{rel}@%{_kernel_ver_str}
369 Group:          Base/Kernel
370 %if %{with dist_kernel}
371 %requires_releq_kernel
372 Requires(postun):       %releq_kernel
373 %endif
374 Requires(post,postun):  /sbin/depmod
375 Requires:       %{pname} = %{version}-%{rel}
376 Obsoletes:      lirc-modules
377 Obsoletes:      lirc-modules-imon
378 Conflicts:      dev < 2.8.0-3
379
380 %description -n kernel%{_alt_kernel}-char-lirc-imon
381 This package contains the kernel modules necessary to operate some
382 infrared remote control devices (such as the ones bundled with TV
383 cards).
384
385 lirc_imon module.
386
387 %description -n kernel%{_alt_kernel}-char-lirc-imon -l pl.UTF-8
388 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
389 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
390
391 Moduł lirc_imon.
392
393 %package -n kernel%{_alt_kernel}-char-lirc-sasem
394 Summary:        Kernel modules for Linux Infrared Remote Control
395 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
396 Release:        %{rel}@%{_kernel_ver_str}
397 Group:          Base/Kernel
398 %if %{with dist_kernel}
399 %requires_releq_kernel
400 Requires(postun):       %releq_kernel
401 %endif
402 Requires(post,postun):  /sbin/depmod
403 Requires:       %{pname} = %{version}-%{rel}
404 Conflicts:      dev < 2.8.0-3
405
406 %description -n kernel%{_alt_kernel}-char-lirc-sasem
407 This package contains the kernel modules necessary to operate some
408 infrared remote control devices (such as the ones bundled with TV
409 cards).
410
411 lirc_sasem module.
412
413 %description -n kernel%{_alt_kernel}-char-lirc-sasem -l pl.UTF-8
414 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
415 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
416
417 Moduł lirc_sasem.
418
419 %package -n kernel%{_alt_kernel}-char-lirc-serial
420 Summary:        Kernel modules for Linux Infrared Remote Control
421 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
422 Release:        %{rel}@%{_kernel_ver_str}
423 Group:          Base/Kernel
424 %if %{with dist_kernel}
425 %requires_releq_kernel
426 Requires(postun):       %releq_kernel
427 %endif
428 Requires(post,postun):  /sbin/depmod
429 Requires:       %{pname} = %{version}-%{rel}
430 %{?with_dist_kernel:Requires:   setserial}
431 Obsoletes:      lirc-modules
432 Obsoletes:      lirc-modules-serial
433 Conflicts:      dev < 2.8.0-3
434
435 %description -n kernel%{_alt_kernel}-char-lirc-serial
436 This package contains the kernel modules necessary to operate some
437 infrared remote control devices (such as the ones bundled with TV
438 cards).
439
440 lirc_serial module for devices connected to serial port.
441
442 %description -n kernel%{_alt_kernel}-char-lirc-serial -l pl.UTF-8
443 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
444 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
445
446 Moduł lirc_serial dla urządzeń podłączanych do portu szeregowego.
447
448 %package -n kernel%{_alt_kernel}-char-lirc-sir
449 Summary:        Kernel modules for Linux Infrared Remote Control
450 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
451 Release:        %{rel}@%{_kernel_ver_str}
452 Group:          Base/Kernel
453 %if %{with dist_kernel}
454 %requires_releq_kernel
455 Requires(postun):       %releq_kernel
456 %endif
457 Requires(post,postun):  /sbin/depmod
458 Requires:       %{pname} = %{version}-%{rel}
459 Obsoletes:      lirc-modules
460 Obsoletes:      lirc-modules-sir
461 Conflicts:      dev < 2.8.0-3
462
463 %description -n kernel%{_alt_kernel}-char-lirc-sir
464 This package contains the kernel modules necessary to operate some
465 infrared remote control devices (such as the ones bundled with TV
466 cards).
467
468 lirc_sir module.
469
470 %description -n kernel%{_alt_kernel}-char-lirc-sir -l pl.UTF-8
471 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
472 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
473
474 Moduł lirc_sir.
475
476 %package -n kernel%{_alt_kernel}-char-lirc-ttusbir
477 Summary:        Kernel modules for Linux Infrared Remote Control
478 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
479 Release:        %{rel}@%{_kernel_ver_str}
480 Group:          Base/Kernel
481 %if %{with dist_kernel}
482 %requires_releq_kernel
483 Requires(postun):       %releq_kernel
484 %endif
485 Requires(post,postun):  /sbin/depmod
486 Requires:       %{pname} = %{version}-%{rel}
487 Obsoletes:      lirc-modules
488 Obsoletes:      lirc-modules-ttusbir
489 Conflicts:      dev < 2.8.0-3
490
491 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir
492 This package contains the kernel modules necessary to operate
493 TechnoTrend USB IR Receiver.
494
495 lirc_ttusbir module.
496
497 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir -l pl.UTF-8
498 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
499 TechnoTrend USB IR Receiver.
500
501 Moduł lirc_ttusbir.
502
503 %package -n kernel%{_alt_kernel}-char-lirc-wpc87691
504 Summary:        Kernel modules for Linux Infrared Remote Control
505 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
506 Release:        %{rel}@%{_kernel_ver_str}
507 Group:          Base/Kernel
508 %if %{with dist_kernel}
509 %requires_releq_kernel
510 Requires(postun):       %releq_kernel
511 %endif
512 Requires(post,postun):  /sbin/depmod
513 Requires:       %{pname} = %{version}-%{rel}
514 Conflicts:      dev < 2.8.0-3
515
516 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691
517 This package contains the kernel modules necessary to operate
518 TechnoTrend USB IR Receiver.
519
520 lirc_wpc87691 module.
521
522 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691 -l pl.UTF-8
523 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
524 TechnoTrend USB IR Receiver.
525
526 Moduł lirc_wpc87691.
527
528 %package -n kernel%{_alt_kernel}-char-lirc-parallel
529 Summary:        Kernel modules for Linux Infrared Remote Control
530 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
531 Release:        %{rel}@%{_kernel_ver_str}
532 Group:          Base/Kernel
533 %if %{with dist_kernel}
534 %requires_releq_kernel
535 Requires(postun):       %releq_kernel
536 %endif
537 Requires(post,postun):  /sbin/depmod
538 Requires:       %{pname} = %{version}-%{rel}
539 Obsoletes:      lirc-modules
540 Obsoletes:      lirc-modules-parallel
541 Conflicts:      dev < 2.8.0-3
542
543 %description -n kernel%{_alt_kernel}-char-lirc-parallel
544 This package contains the kernel modules necessary to operate some
545 infrared remote control devices (such as the ones bundled with TV
546 cards).
547
548 lirc-parallel module for devices connected to parallel port.
549
550 %description -n kernel%{_alt_kernel}-char-lirc-parallel -l pl.UTF-8
551 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
552 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
553
554 Moduł lirc_parallel dla urządzeń podłączanych do portu
555 równoległego.
556
557 %prep
558 %setup -q -n %{pname}-%{version} -a 1
559 %patch0 -p1
560 %patch1 -p1
561 %if !%{with svga}
562 %patch2 -p1
563 %endif
564 %patch3 -p1
565 %patch4 -p1
566 %patch5 -p1
567 %patch6 -p1
568
569 %build
570 echo '#' > drivers/Makefile.am
571 %{__libtoolize}
572 %{__aclocal}
573 %{__automake}
574 %{__autoheader}
575 %{__autoconf}
576
577 %configure \
578         ac_cv_header_portaudio_h=no \
579 %if %{with kernel}
580         KERNELCC="%{kgcc}" \
581 %else
582         ac_cv_have_kernel="no_kernel=yes" \
583 %endif
584         --with-kerneldir=%{_kernelsrcdir} \
585         %{?with_x:--with-x} \
586         --with-port=0x2f8 \
587         --with-irq=3 \
588         --without-soft-carrier \
589         --with-driver=userspace \
590         --with-igor
591
592 %if %{with userspace}
593 %{__make} -j1
594 %endif
595
596 %if %{with kernel}
597 cd drivers
598
599 drivers=%{drivers}
600 rm -rf o
601 if [ -r "%{_kernelsrcdir}/config-dist" ]; then
602         install -d o/include/{linux,generated,config} o/arch/powerpc/lib
603         ln -sf %{_kernelsrcdir}/config-dist o/.config
604         if [ -f %{_kernelsrcdir}/include/generated/autoconf-dist.h ]; then
605                 ln -sf %{_kernelsrcdir}/include/generated/autoconf-dist.h o/include/generated/autoconf.h
606                 ln -s ../generated/autoconf.h o/include/linux/autoconf.h
607         else
608                 ln -sf %{_kernelsrcdir}/include/linux/autoconf-dist.h o/include/linux/autoconf.h
609         fi
610         ln -sf %{_kernelsrcdir}/Module.symvers-dist o/Module.symvers
611         %{__make} -j1 -C %{_kernelsrcdir} O=$PWD/o prepare scripts
612 else
613         ln -s %{_kernelsrcdir} o
614 fi
615
616 for drv in $drivers; do
617         cd $drv
618         ln -sf ../o
619         %{__make} clean \
620                 RCS_FIND_IGNORE="-name '*.ko' -o" \
621                 M=$PWD O=$PWD/o \
622                 %{?with_verbose:V=1}
623
624         %{__make} -j1 \
625                 M=$PWD O=$PWD/o \
626                 CONSTIFY_PLUGIN="" \
627                 KBUILD_MODPOST_WARN=1 \
628                 %{?with_verbose:V=1}
629         [ -r "%{_kernelsrcdir}/config-dist" ] && mv $drv{,-dist}.ko
630         cd ..
631 done
632
633 cd ..
634
635 %endif
636
637 %install
638 rm -rf $RPM_BUILD_ROOT
639 install -d $RPM_BUILD_ROOT{%{_bindir},%{_aclocaldir},/dev,/var/{log,run/lirc}} \
640         $RPM_BUILD_ROOT/etc/{lirc,rc.d/init.d,sysconfig} \
641         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
642
643 %if %{with kernel}
644 drivers=%{drivers}
645 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
646 for drv in $drivers; do
647         if [ -r "%{_kernelsrcdir}/config-dist" ]; then
648                 install drivers/$drv/$drv-%{?with_dist_kernel:dist}%{!?with_dist_kernel:nondist}.ko \
649                         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/$drv.ko
650         else
651                 install drivers/$drv/$drv.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/$drv.ko
652         fi
653 done
654 %endif
655
656 %if %{with userspace}
657 %{__make} -j1 install \
658         DESTDIR=$RPM_BUILD_ROOT \
659         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
660
661 cat>$RPM_BUILD_ROOT%{_sysconfdir}/lirc/lircd.conf<<END
662 #
663 # This is a placeholder for your configuration file.
664 # See %{_docdir}/%{pname}-%{version}/remotes for some examples.
665 #
666 END
667 cp -f $RPM_BUILD_ROOT%{_sysconfdir}/lirc/lirc{,m}d.conf
668 install contrib/*.m4 $RPM_BUILD_ROOT%{_aclocaldir}
669 :> $RPM_BUILD_ROOT/var/log/lircd
670
671 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lircd
672 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircd
673 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircmd
674 install %{SOURCE5} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
675 %endif
676
677 %clean
678 rm -rf $RPM_BUILD_ROOT
679
680 %post   libs -p /sbin/ldconfig
681 %postun libs -p /sbin/ldconfig
682
683 %post
684 /sbin/chkconfig --add lircd
685 if [ -f /var/lock/subsys/lircd ]; then
686         /etc/rc.d/init.d/lircd restart >&2
687 else
688         echo "Run \"/etc/rc.d/init.d/lircd start\" to start lircd." >&2
689 fi
690 /sbin/chkconfig --add lircmd
691 if [ -f /var/lock/subsys/lircmd ]; then
692         /etc/rc.d/init.d/lircmd restart >&2
693 else
694         echo "Run \"/etc/rc.d/init.d/lircmd start\" to start lircmd." >&2
695 fi
696 echo "If you are using a kernel-module-based driver, don't forget to"
697 echo "install the kernel%{_alt_kernel}-char-lirc-<your_driver> or"
698 echo "kernel%{_alt_kernel}-smp-char-lirc-<your_driver> package."
699
700 %preun
701 if [ "$1" = "0" ]; then
702         if [ -f /var/lock/subsys/lircd ]; then
703                 /etc/rc.d/init.d/lircd stop >&2
704         fi
705         /sbin/chkconfig --del lircd
706 fi
707 if [ "$1" = "0" ]; then
708         if [ -f /var/lock/subsys/lircmd ]; then
709                 /etc/rc.d/init.d/lircmd stop >&2
710         fi
711         /sbin/chkconfig --del lircmd
712 fi
713
714 %triggerpostun -- %{name} < 0.8.6-8
715 if [ -f %{_sysconfdir}/lircd.conf.rpmsave ]; then
716         mv -f %{_sysconfdir}/lircd.conf.rpmsave %{_sysconfdir}/lirc/lircd.conf
717 fi
718 if [ -f %{_sysconfdir}/lircmd.conf.rpmsave ]; then
719         mv -f %{_sysconfdir}/lircmd.conf.rpmsave %{_sysconfdir}/lirc/lircmd.conf
720 fi
721
722 %post   -n kernel%{_alt_kernel}-char-lirc-atiusb
723 %depmod %{_kernel_ver}
724 if [ "$1" = "1" ]; then
725         echo "Don't forget to add an 'alias lirc lirc_atiusb' line"
726         echo "to your /etc/modules.conf."
727 fi
728
729 %postun -n kernel%{_alt_kernel}-char-lirc-atiusb
730 %depmod %{_kernel_ver}
731
732 %post   -n kernel%{_alt_kernel}-char-lirc-bt829
733 %depmod %{_kernel_ver}
734 if [ "$1" = "1" ]; then
735         echo "Don't forget to add an 'alias lirc lirc_bt829' line"
736         echo "to your /etc/modules.conf."
737 fi
738
739 %postun -n kernel%{_alt_kernel}-char-lirc-bt829
740 %depmod %{_kernel_ver}
741
742 %post   -n kernel%{_alt_kernel}-char-lirc-dev
743 %depmod %{_kernel_ver}
744
745 %postun -n kernel%{_alt_kernel}-char-lirc-dev
746 %depmod %{_kernel_ver}
747
748 %post   -n kernel%{_alt_kernel}-char-lirc-ene0100
749 %depmod %{_kernel_ver}
750
751 %postun -n kernel%{_alt_kernel}-char-lirc-ene0100
752 %depmod %{_kernel_ver}
753
754 %post   -n kernel%{_alt_kernel}-char-lirc-gpio
755 %depmod %{_kernel_ver}
756 if [ "$1" = "1" ]; then
757         echo "Don't forget to add an 'alias lirc lirc_gpio' line"
758         echo "to your /etc/modules.conf."
759 fi
760
761 %postun -n kernel%{_alt_kernel}-char-lirc-gpio
762 %depmod %{_kernel_ver}
763
764 %post   -n kernel%{_alt_kernel}-char-lirc-i2c
765 %depmod %{_kernel_ver}
766 if [ "$1" = "1" ]; then
767         echo "Don't forget to add an 'alias lirc lirc_i2c' line"
768         echo "to your /etc/modules.conf."
769 fi
770
771 %postun -n kernel%{_alt_kernel}-char-lirc-i2c
772 %depmod %{_kernel_ver}
773
774 %post   -n kernel%{_alt_kernel}-char-lirc-igorplugusb
775 %depmod %{_kernel_ver}
776 if [ "$1" = "1" ]; then
777         echo "Don't forget to add an 'alias lirc lirc_igorplugusb' line"
778         echo "to your /etc/modules.conf."
779 fi
780
781 %postun -n kernel%{_alt_kernel}-char-lirc-igorplugusb
782 %depmod %{_kernel_ver}
783
784 %post   -n kernel%{_alt_kernel}-char-lirc-imon
785 %depmod %{_kernel_ver}
786 if [ "$1" = "1" ]; then
787         echo "Don't forget to add an 'alias lirc lirc_imon' line"
788         echo "to your /etc/modules.conf."
789 fi
790
791 %postun -n kernel%{_alt_kernel}-char-lirc-imon
792 %depmod %{_kernel_ver}
793
794 %post   -n kernel%{_alt_kernel}-char-lirc-sasem
795 %depmod %{_kernel_ver}
796 if [ "$1" = "1" ]; then
797         echo "Don't forget to add an 'alias lirc lirc_sasem' line"
798         echo "to your /etc/modules.conf."
799 fi
800
801 %postun -n kernel%{_alt_kernel}-char-lirc-sasem
802 %depmod %{_kernel_ver}
803
804 %post   -n kernel%{_alt_kernel}-char-lirc-serial
805 %depmod %{_kernel_ver}
806 if [ "$1" = "1" ]; then
807         echo "Don't forget to add an 'alias lirc lirc_serial' line"
808         echo "to your /etc/modules.conf."
809 fi
810
811 %postun -n kernel%{_alt_kernel}-char-lirc-serial
812 %depmod %{_kernel_ver}
813
814 %post   -n kernel%{_alt_kernel}-char-lirc-parallel
815 %depmod %{_kernel_ver}
816 if [ "$1" = "1" ]; then
817         echo "Don't forget to add an 'alias lirc lirc_parallel' line"
818         echo "to your /etc/modules.conf."
819 fi
820
821 %postun -n kernel%{_alt_kernel}-char-lirc-parallel
822 %depmod %{_kernel_ver}
823
824 %post   -n kernel%{_alt_kernel}-char-lirc-sir
825 %depmod %{_kernel_ver}
826 if [ "$1" = "1" ]; then
827         echo "Don't forget to add an 'alias lirc lirc_sir' line"
828         echo "to your /etc/modules.conf."
829 fi
830
831 %postun -n kernel%{_alt_kernel}-char-lirc-sir
832 %depmod %{_kernel_ver}
833
834 %post   -n kernel%{_alt_kernel}-char-lirc-ttusbir
835 %depmod %{_kernel_ver}
836 if [ "$1" = "1" ]; then
837         echo "Don't forget to add an 'alias lirc lirc_ttusbir' line"
838         echo "to your /etc/modules.conf."
839 fi
840
841 %postun -n kernel%{_alt_kernel}-char-lirc-ttusbir
842 %depmod %{_kernel_ver}
843
844 %post   -n kernel%{_alt_kernel}-char-lirc-wpc87691
845 %depmod %{_kernel_ver}
846 if [ "$1" = "1" ]; then
847         echo "Don't forget to add an 'alias lirc lirc_wpc87691' line"
848         echo "to your /etc/modules.conf."
849 fi
850
851 %postun -n kernel%{_alt_kernel}-char-lirc-wpc87691
852 %depmod %{_kernel_ver}
853
854 %if %{with userspace}
855 %files
856 %defattr(644,root,root,755)
857 %doc ANNOUNCE AUTHORS NEWS README TODO ChangeLog
858 %doc contrib/lircrc doc/{html,images,lirc.css}
859 %attr(755,root,root) %{_bindir}/ircat
860 %attr(755,root,root) %{_bindir}/irexec
861 %attr(755,root,root) %{_bindir}/irpty
862 %attr(755,root,root) %{_bindir}/irrecord
863 %attr(755,root,root) %{_bindir}/irsend
864 %attr(755,root,root) %{_bindir}/irw
865 %attr(755,root,root) %{_bindir}/mode2
866 %attr(755,root,root) %{_bindir}/lircrcd
867 %attr(755,root,root) %{_bindir}/pronto2lirc
868 %attr(755,root,root) %{_sbindir}/lircd
869 %attr(755,root,root) %{_sbindir}/lircmd
870 %attr(754,root,root) /etc/rc.d/init.d/lircd
871 %attr(754,root,root) /etc/rc.d/init.d/lircmd
872 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lircd
873 %dir %{_sysconfdir}/lirc
874 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircd.conf
875 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircmd.conf
876 %{_mandir}/man1/ircat.1*
877 %{_mandir}/man1/irexec.1*
878 %{_mandir}/man1/irpty.1*
879 %{_mandir}/man1/irrecord.1*
880 %{_mandir}/man1/irsend.1*
881 %{_mandir}/man1/irw.1*
882 %{_mandir}/man1/lircrcd.1*
883 %{_mandir}/man1/mode2.1*
884 %{_mandir}/man8/lircd.8*
885 %{_mandir}/man8/lircmd.8*
886 %attr(600,root,root) %ghost /var/log/lircd
887 %dir /var/run/lirc
888 /usr/lib/tmpfiles.d/%{name}.conf
889
890 %files remotes
891 %defattr(644,root,root,755)
892 # XXX: are jpegs in docs (remotes) a good idea?
893 %doc remotes
894
895 %if %{with x}
896 %files X11
897 %defattr(644,root,root,755)
898 %doc doc/irxevent.keys
899 %attr(755,root,root) %{_bindir}/irxevent
900 %attr(755,root,root) %{_bindir}/xmode2
901 %{_mandir}/man1/irxevent.1*
902 %{_mandir}/man1/xmode2.1*
903 %endif
904
905 %if %{with svga}
906 %files svga
907 %defattr(644,root,root,755)
908 %attr(755,root,root) %{_bindir}/smode2
909 %{_mandir}/man1/smode2.1*
910 %endif
911
912 %files libs
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_libdir}/liblirc_client.so.*.*.*
915 %attr(755,root,root) %ghost %{_libdir}/liblirc_client.so.0
916
917 %files devel
918 %defattr(644,root,root,755)
919 %attr(755,root,root) %{_libdir}/liblirc_client.so
920 %{_libdir}/liblirc_client.la
921 %{_includedir}/lirc
922 %{_aclocaldir}/lirc.m4
923
924 %files static
925 %defattr(644,root,root,755)
926 %{_libdir}/liblirc_client.a
927 %endif
928
929 %if %{with kernel}
930 %files -n kernel%{_alt_kernel}-char-lirc-atiusb
931 %defattr(644,root,root,755)
932 /lib/modules/%{_kernel_ver}/misc/lirc_atiusb.ko*
933
934 %files -n kernel%{_alt_kernel}-char-lirc-bt829
935 %defattr(644,root,root,755)
936 /lib/modules/%{_kernel_ver}/misc/lirc_bt829.ko*
937
938 %files -n kernel%{_alt_kernel}-char-lirc-dev
939 %defattr(644,root,root,755)
940 /lib/modules/%{_kernel_ver}/misc/lirc_dev.ko*
941
942 %if "%{_kernel_ver}" < "3.0.0"
943 %files -n kernel%{_alt_kernel}-char-lirc-ene0100
944 %defattr(644,root,root,755)
945 /lib/modules/%{_kernel_ver}/misc/lirc_ene0100.ko*
946 %endif
947
948 %if "%{_kernel_ver}" < "2.6.23"
949 %files -n kernel%{_alt_kernel}-char-lirc-gpio
950 %defattr(644,root,root,755)
951 /lib/modules/%{_kernel_ver}/misc/lirc_gpio.ko*
952 %endif
953
954 %files -n kernel%{_alt_kernel}-char-lirc-i2c
955 %defattr(644,root,root,755)
956 /lib/modules/%{_kernel_ver}/misc/lirc_i2c.ko*
957
958 %files -n kernel%{_alt_kernel}-char-lirc-igorplugusb
959 %defattr(644,root,root,755)
960 /lib/modules/%{_kernel_ver}/misc/lirc_igorplugusb.ko*
961
962 %files -n kernel%{_alt_kernel}-char-lirc-imon
963 %defattr(644,root,root,755)
964 /lib/modules/%{_kernel_ver}/misc/lirc_imon.ko*
965
966 %files -n kernel%{_alt_kernel}-char-lirc-sasem
967 %defattr(644,root,root,755)
968 /lib/modules/%{_kernel_ver}/misc/lirc_sasem.ko*
969
970 %files -n kernel%{_alt_kernel}-char-lirc-serial
971 %defattr(644,root,root,755)
972 /lib/modules/%{_kernel_ver}/misc/lirc_serial.ko*
973
974 %files -n kernel%{_alt_kernel}-char-lirc-sir
975 %defattr(644,root,root,755)
976 /lib/modules/%{_kernel_ver}/misc/lirc_sir.ko*
977
978 %files -n kernel%{_alt_kernel}-char-lirc-ttusbir
979 %defattr(644,root,root,755)
980 /lib/modules/%{_kernel_ver}/misc/lirc_ttusbir.ko*
981
982 %if "%{_kernel_ver}" < "3.0.0"
983 %files -n kernel%{_alt_kernel}-char-lirc-wpc87691
984 %defattr(644,root,root,755)
985 /lib/modules/%{_kernel_ver}/misc/lirc_wpc8769l.ko*
986 %endif
987
988 %files -n kernel%{_alt_kernel}-char-lirc-parallel
989 %defattr(644,root,root,755)
990 /lib/modules/%{_kernel_ver}/misc/lirc_parallel.ko*
991 %endif
This page took 0.11195 seconds and 4 git commands to generate.