]> git.pld-linux.org Git - packages/lirc.git/blob - lirc.spec
more %service
[packages/lirc.git] / lirc.spec
1 # TODO
2 # - restore lirc_parallel driver
3 # - try to make it use builder_kernel_modules and install_kernel_modules; I couldn't make it
4 # - build is running kernel arch dependent, try to get rid of this
5 # - libcaraca_client (http://caraca.sourceforge.net/) - no releases yet
6 #
7 # Conditional build:
8 %bcond_without  dist_kernel     # without sources of distribution kernel
9 %bcond_without  kernel          # don't build kernel modules, only library+programs
10 %bcond_without  userspace       # build only packages with kernel modules
11 %bcond_with     svga            # without svgalib-based utility
12 %bcond_without  x               # without X11-based utilitied
13
14 %if %{without kernel}
15 %undefine       with_dist_kernel
16 %endif
17
18 %if "%{_alt_kernel}" != "%{nil}"
19 %undefine       with_userspace
20 %endif
21
22 %define         pname   lirc
23 %define         rel     73
24
25 #
26 # main package
27 #
28 # lirc_gpio fails to build under kernel >= 2.6.23
29 #
30 %if "%{_kernel_ver}" >= "2.6.23"
31 %if "%{_kernel_ver}" >= "3.0.0"
32 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir"
33 %else
34 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
35 %endif
36 %else
37 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_gpio lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
38 %endif
39 Summary:        Linux Infrared Remote Control daemons
40 Summary(pl.UTF-8):      Serwery do zdalnego sterowania Linuksem za pomocą podczerwieni
41 Name:           %{pname}%{_alt_kernel}
42 Version:        0.9.0
43 Release:        %{rel}
44 License:        GPL v2+
45 Group:          Daemons
46 Source0:        http://downloads.sourceforge.net/lirc/%{pname}-%{version}.tar.bz2
47 # Source0-md5:  b232aef26f23fe33ea8305d276637086
48 Source1:        http://lirc.sourceforge.net/remotes.tar.bz2
49 # Source1-md5:  238d1773d3c405acc02813674f5a55f8
50 Source2:        %{pname}d.sysconfig
51 Source3:        %{pname}d.init
52 Source4:        %{pname}md.init
53 Source5:        %{pname}.tmpfiles
54 Patch0:         %{pname}-opt.patch
55 Patch1:         %{pname}-tmp.patch
56 Patch2:         %{pname}-no-svgalib.patch
57 Patch3:         %{pname}-kernel.patch
58 Patch4:         %{pname}-sparc.patch
59 Patch5:         %{pname}-remotes.patch
60 Patch6:         %{pname}-kernelcc.patch
61 Patch7:         format-security.patch
62 URL:            http://www.lirc.org/
63 BuildRequires:  alsa-lib-devel
64 BuildRequires:  autoconf >= 2.50
65 BuildRequires:  automake
66 BuildRequires:  iguanaIR-devel
67 BuildRequires:  libftdi-devel >= 0.12
68 BuildRequires:  libirman-devel >= 0.4.5
69 BuildRequires:  libtool
70 BuildRequires:  libusb-compat-devel >= 0.1.0
71 %if %{with kernel}
72 BuildRequires:  kernel%{_alt_kernel}-headers
73 BuildRequires:  kernel%{_alt_kernel}-module-build
74 %endif
75 %{?with_kernel:BuildRequires:   %{kgcc_package}}
76 BuildRequires:  rpm-pythonprov
77 BuildRequires:  rpmbuild(macros) >= 1.379
78 %{?with_svga:BuildRequires:     svgalib-devel}
79 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
80 Requires(post,preun):   /sbin/chkconfig
81 BuildRequires:  rpmbuild(macros) >= 1.268
82 Requires:       %{pname}-libs = %{version}-%{release}
83 Requires:       libftdi >= 0.12
84 Requires:       rc-scripts
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %if %{without userspace}
88 %define         no_spec_install_post_check_tmpfiles     1
89 %endif
90
91 %description
92 LIRC is a package that allows you to decode and send infra-red signals
93 of many (but not all) commonly used remote controls.
94
95 %description -l pl.UTF-8
96 LIRC to program pozwalający na dekodowanie nadchodzących oraz
97 wysyłanie sygnałów w podczerwieni za pomocą wielu (ale nie wszystkich)
98 popularnych urządzeń do zdalnego sterowania.
99
100 %package remotes
101 Summary:        Lirc remotes database
102 Summary(pl.UTF-8):      Baza pilotów obsługiwanych przez lirc
103 Group:          Documentation
104 Requires:       %{pname} = %{version}-%{rel}
105
106 %description remotes
107 This package contains configuration files for many remotes supported
108 by lirc.
109
110 %description remotes -l pl.UTF-8
111 Ten pakiet zawiera pliki konfiguracyjne dla wielu pilotów
112 obsługiwanych przez lirc.
113
114 %package X11
115 Summary:        Linux Infrared Remote Control - X11 utilities
116 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11
117 Group:          X11/Applications
118 Requires:       %{pname}-libs = %{version}-%{release}
119
120 %description X11
121 Linux Infrared Remote Control - X11 utilities.
122
123 %description X11 -l pl.UTF-8
124 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11.
125
126 %package svga
127 Summary:        Linux Infrared Remote Control - svgalib utilities
128 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia svgalib
129 Group:          Applications
130 Requires:       %{pname}-libs = %{version}-%{release}
131
132 %description svga
133 Linux Infrared Remote Control - svgalib-based utilities.
134
135 %description svga -l pl.UTF-8
136 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia oparte
137 na svgalibie.
138
139 %package libs
140 Summary:        LIRC libraries
141 Summary(pl.UTF-8):      Biblioteki LIRC
142 Group:          Libraries
143 Conflicts:      lirc < 0.6.3-3
144 # didn't use /tmp/.lircd
145
146 %description libs
147 This package provides the libraries necessary to run lirc client
148 programs.
149
150 %description libs -l pl.UTF-8
151 Ten pakiet zawiera biblioteki niezbędne do działania klientów LIRC.
152
153 %package devel
154 Summary:        Header files for LIRC development
155 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów z obsługą LIRC
156 Group:          Development/Libraries
157 Requires:       %{pname}-libs = %{version}-%{release}
158
159 %description devel
160 This package provides the files necessary to develop LIRC-based
161 programs.
162
163 %description devel -l pl.UTF-8
164 Ten pakiet zawiera pliki niezbędne do tworzenia programów opartych na
165 LIRC.
166
167 %package static
168 Summary:        Static library for LIRC development
169 Summary(pl.UTF-8):      Biblioteka statyczna LIRC
170 Group:          Development/Libraries
171 Requires:       %{pname}-devel = %{version}-%{release}
172
173 %description static
174 The files necessary for development of statically-linked lirc-based
175 programs.
176
177 %description static -l pl.UTF-8
178 Pliki potrzebne do tworzenia łączonych statycznie programów opartych
179 na LIRC.
180
181 %package -n kernel%{_alt_kernel}-char-lirc-atiusb
182 Summary:        Kernel modules for Linux Infrared Remote Control
183 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
184 Release:        %{rel}@%{_kernel_ver_str}
185 Group:          Base/Kernel
186 %if %{with dist_kernel}
187 %requires_releq_kernel
188 Requires(postun):       %releq_kernel
189 %endif
190 Requires(post,postun):  /sbin/depmod
191 Requires:       %{pname} = %{version}-%{rel}
192 Conflicts:      dev < 2.8.0-3
193
194 %description -n kernel%{_alt_kernel}-char-lirc-atiusb
195 This package contains the kernel modules necessary to operate some
196 infrared remote control devices (such as the ones bundled with TV
197 cards).
198
199 lirc_atiusb module.
200
201 %description -n kernel%{_alt_kernel}-char-lirc-atiusb -l pl.UTF-8
202 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
203 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
204
205 Moduł lirc_atiusb.
206
207 %package -n kernel%{_alt_kernel}-char-lirc-bt829
208 Summary:        Kernel modules for Linux Infrared Remote Control
209 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
210 Release:        %{rel}@%{_kernel_ver_str}
211 Group:          Base/Kernel
212 %if %{with dist_kernel}
213 %requires_releq_kernel
214 Requires(postun):       %releq_kernel
215 %endif
216 Requires(post,postun):  /sbin/depmod
217 Requires:       %{pname} = %{version}-%{rel}
218 Conflicts:      dev < 2.8.0-3
219
220 %description -n kernel%{_alt_kernel}-char-lirc-bt829
221 This package contains the kernel modules necessary to operate some
222 infrared remote control devices (such as the ones bundled with TV
223 cards).
224
225 lirc_bt829 module.
226
227 %description -n kernel%{_alt_kernel}-char-lirc-bt829 -l pl.UTF-8
228 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
229 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
230
231 Moduł lirc_bt829.
232
233 %package -n kernel%{_alt_kernel}-char-lirc-dev
234 Summary:        Kernel modules for Linux Infrared Remote Control
235 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
236 Release:        %{rel}@%{_kernel_ver_str}
237 Group:          Base/Kernel
238 %if %{with dist_kernel}
239 %requires_releq_kernel
240 Requires(postun):       %releq_kernel
241 %endif
242 Requires(post,postun):  /sbin/depmod
243 Requires:       %{pname} = %{version}-%{rel}
244 Obsoletes:      lirc-modules
245 Obsoletes:      lirc-modules-dev
246 Conflicts:      dev < 2.8.0-3
247
248 %description -n kernel%{_alt_kernel}-char-lirc-dev
249 This package contains the kernel modules necessary to operate some
250 infrared remote control devices (such as the ones bundled with TV
251 cards).
252
253 lirc_dev module.
254
255 %description -n kernel%{_alt_kernel}-char-lirc-dev -l pl.UTF-8
256 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
257 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
258
259 Moduł lirc_dev.
260
261 %package -n kernel%{_alt_kernel}-char-lirc-ene0100
262 Summary:        Kernel modules for Linux Infrared Remote Control
263 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
264 Release:        %{rel}@%{_kernel_ver_str}
265 Group:          Base/Kernel
266 %if %{with dist_kernel}
267 %requires_releq_kernel
268 Requires(postun):       %releq_kernel
269 %endif
270 Requires(post,postun):  /sbin/depmod
271 Requires:       %{pname} = %{version}-%{rel}
272 Obsoletes:      lirc-modules
273 Conflicts:      dev < 2.8.0-3
274
275 %description -n kernel%{_alt_kernel}-char-lirc-ene0100
276 This package contains the kernel modules necessary to operate some
277 infrared remote control ene0100ices (such as the ones bundled with TV
278 cards).
279
280 lirc_ene0100 module.
281
282 %description -n kernel%{_alt_kernel}-char-lirc-ene0100 -l pl.UTF-8
283 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
284 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
285
286 Moduł lirc_ene0100.
287
288 %package -n kernel%{_alt_kernel}-char-lirc-gpio
289 Summary:        Kernel modules for Linux Infrared Remote Control
290 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
291 Release:        %{rel}@%{_kernel_ver_str}
292 Group:          Base/Kernel
293 %if %{with dist_kernel}
294 %requires_releq_kernel
295 Requires(postun):       %releq_kernel
296 %endif
297 Requires(post,postun):  /sbin/depmod
298 Requires:       %{pname} = %{version}-%{rel}
299 Obsoletes:      lirc-modules
300 Obsoletes:      lirc-modules-gpio
301 Conflicts:      dev < 2.8.0-3
302
303 %description -n kernel%{_alt_kernel}-char-lirc-gpio
304 This package contains the kernel modules necessary to operate some
305 infrared remote control devices (such as the ones bundled with TV
306 cards).
307
308 lirc_gpio module.
309
310 %description -n kernel%{_alt_kernel}-char-lirc-gpio -l pl.UTF-8
311 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
312 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
313
314 Moduł lirc_gpio.
315
316 %package -n kernel%{_alt_kernel}-char-lirc-i2c
317 Summary:        Kernel modules for Linux Infrared Remote Control
318 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
319 Release:        %{rel}@%{_kernel_ver_str}
320 Group:          Base/Kernel
321 %if %{with dist_kernel}
322 %requires_releq_kernel
323 Requires(postun):       %releq_kernel
324 %endif
325 Requires(post,postun):  /sbin/depmod
326 Requires:       %{pname} = %{version}-%{rel}
327 Obsoletes:      lirc-modules
328 Obsoletes:      lirc-modules-i2c
329 Conflicts:      dev < 2.8.0-3
330
331 %description -n kernel%{_alt_kernel}-char-lirc-i2c
332 This package contains the kernel modules necessary to operate some
333 infrared remote control devices (such as the ones bundled with TV
334 cards).
335
336 lirc_i2c module.
337
338 %description -n kernel%{_alt_kernel}-char-lirc-i2c -l pl.UTF-8
339 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
340 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
341
342 Moduł lirc_i2c.
343
344 %package -n kernel%{_alt_kernel}-char-lirc-igorplugusb
345 Summary:        Kernel modules for Linux Infrared Remote Control
346 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
347 Release:        %{rel}@%{_kernel_ver_str}
348 Group:          Base/Kernel
349 %if %{with dist_kernel}
350 %requires_releq_kernel
351 Requires(postun):       %releq_kernel
352 %endif
353 Requires(post,postun):  /sbin/depmod
354 Requires:       %{pname} = %{version}-%{rel}
355 Obsoletes:      lirc-modules
356 Obsoletes:      lirc-modules-igorplugusb
357 Conflicts:      dev < 2.8.0-3
358
359 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb
360 This package contains the kernel modules necessary to operate some
361 infrared remote control devices (such as the ones bundled with TV
362 cards).
363
364 lirc_igorplugusb module.
365
366 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb -l pl.UTF-8
367 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
368 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
369
370 Moduł lirc_igorplugusb.
371
372 %package -n kernel%{_alt_kernel}-char-lirc-imon
373 Summary:        Kernel modules for Linux Infrared Remote Control
374 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
375 Release:        %{rel}@%{_kernel_ver_str}
376 Group:          Base/Kernel
377 %if %{with dist_kernel}
378 %requires_releq_kernel
379 Requires(postun):       %releq_kernel
380 %endif
381 Requires(post,postun):  /sbin/depmod
382 Requires:       %{pname} = %{version}-%{rel}
383 Obsoletes:      lirc-modules
384 Obsoletes:      lirc-modules-imon
385 Conflicts:      dev < 2.8.0-3
386
387 %description -n kernel%{_alt_kernel}-char-lirc-imon
388 This package contains the kernel modules necessary to operate some
389 infrared remote control devices (such as the ones bundled with TV
390 cards).
391
392 lirc_imon module.
393
394 %description -n kernel%{_alt_kernel}-char-lirc-imon -l pl.UTF-8
395 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
396 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
397
398 Moduł lirc_imon.
399
400 %package -n kernel%{_alt_kernel}-char-lirc-sasem
401 Summary:        Kernel modules for Linux Infrared Remote Control
402 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
403 Release:        %{rel}@%{_kernel_ver_str}
404 Group:          Base/Kernel
405 %if %{with dist_kernel}
406 %requires_releq_kernel
407 Requires(postun):       %releq_kernel
408 %endif
409 Requires(post,postun):  /sbin/depmod
410 Requires:       %{pname} = %{version}-%{rel}
411 Conflicts:      dev < 2.8.0-3
412
413 %description -n kernel%{_alt_kernel}-char-lirc-sasem
414 This package contains the kernel modules necessary to operate some
415 infrared remote control devices (such as the ones bundled with TV
416 cards).
417
418 lirc_sasem module.
419
420 %description -n kernel%{_alt_kernel}-char-lirc-sasem -l pl.UTF-8
421 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
422 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
423
424 Moduł lirc_sasem.
425
426 %package -n kernel%{_alt_kernel}-char-lirc-serial
427 Summary:        Kernel modules for Linux Infrared Remote Control
428 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
429 Release:        %{rel}@%{_kernel_ver_str}
430 Group:          Base/Kernel
431 %if %{with dist_kernel}
432 %requires_releq_kernel
433 Requires(postun):       %releq_kernel
434 %endif
435 Requires(post,postun):  /sbin/depmod
436 Requires:       %{pname} = %{version}-%{rel}
437 %{?with_dist_kernel:Requires:   setserial}
438 Obsoletes:      lirc-modules
439 Obsoletes:      lirc-modules-serial
440 Conflicts:      dev < 2.8.0-3
441
442 %description -n kernel%{_alt_kernel}-char-lirc-serial
443 This package contains the kernel modules necessary to operate some
444 infrared remote control devices (such as the ones bundled with TV
445 cards).
446
447 lirc_serial module for devices connected to serial port.
448
449 %description -n kernel%{_alt_kernel}-char-lirc-serial -l pl.UTF-8
450 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
451 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
452
453 Moduł lirc_serial dla urządzeń podłączanych do portu szeregowego.
454
455 %package -n kernel%{_alt_kernel}-char-lirc-sir
456 Summary:        Kernel modules for Linux Infrared Remote Control
457 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
458 Release:        %{rel}@%{_kernel_ver_str}
459 Group:          Base/Kernel
460 %if %{with dist_kernel}
461 %requires_releq_kernel
462 Requires(postun):       %releq_kernel
463 %endif
464 Requires(post,postun):  /sbin/depmod
465 Requires:       %{pname} = %{version}-%{rel}
466 Obsoletes:      lirc-modules
467 Obsoletes:      lirc-modules-sir
468 Conflicts:      dev < 2.8.0-3
469
470 %description -n kernel%{_alt_kernel}-char-lirc-sir
471 This package contains the kernel modules necessary to operate some
472 infrared remote control devices (such as the ones bundled with TV
473 cards).
474
475 lirc_sir module.
476
477 %description -n kernel%{_alt_kernel}-char-lirc-sir -l pl.UTF-8
478 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
479 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
480
481 Moduł lirc_sir.
482
483 %package -n kernel%{_alt_kernel}-char-lirc-ttusbir
484 Summary:        Kernel modules for Linux Infrared Remote Control
485 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
486 Release:        %{rel}@%{_kernel_ver_str}
487 Group:          Base/Kernel
488 %if %{with dist_kernel}
489 %requires_releq_kernel
490 Requires(postun):       %releq_kernel
491 %endif
492 Requires(post,postun):  /sbin/depmod
493 Requires:       %{pname} = %{version}-%{rel}
494 Obsoletes:      lirc-modules
495 Obsoletes:      lirc-modules-ttusbir
496 Conflicts:      dev < 2.8.0-3
497
498 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir
499 This package contains the kernel modules necessary to operate
500 TechnoTrend USB IR Receiver.
501
502 lirc_ttusbir module.
503
504 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir -l pl.UTF-8
505 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
506 TechnoTrend USB IR Receiver.
507
508 Moduł lirc_ttusbir.
509
510 %package -n kernel%{_alt_kernel}-char-lirc-wpc87691
511 Summary:        Kernel modules for Linux Infrared Remote Control
512 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
513 Release:        %{rel}@%{_kernel_ver_str}
514 Group:          Base/Kernel
515 %if %{with dist_kernel}
516 %requires_releq_kernel
517 Requires(postun):       %releq_kernel
518 %endif
519 Requires(post,postun):  /sbin/depmod
520 Requires:       %{pname} = %{version}-%{rel}
521 Conflicts:      dev < 2.8.0-3
522
523 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691
524 This package contains the kernel modules necessary to operate
525 TechnoTrend USB IR Receiver.
526
527 lirc_wpc87691 module.
528
529 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691 -l pl.UTF-8
530 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
531 TechnoTrend USB IR Receiver.
532
533 Moduł lirc_wpc87691.
534
535 %package -n kernel%{_alt_kernel}-char-lirc-parallel
536 Summary:        Kernel modules for Linux Infrared Remote Control
537 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
538 Release:        %{rel}@%{_kernel_ver_str}
539 Group:          Base/Kernel
540 %if %{with dist_kernel}
541 %requires_releq_kernel
542 Requires(postun):       %releq_kernel
543 %endif
544 Requires(post,postun):  /sbin/depmod
545 Requires:       %{pname} = %{version}-%{rel}
546 Obsoletes:      lirc-modules
547 Obsoletes:      lirc-modules-parallel
548 Conflicts:      dev < 2.8.0-3
549
550 %description -n kernel%{_alt_kernel}-char-lirc-parallel
551 This package contains the kernel modules necessary to operate some
552 infrared remote control devices (such as the ones bundled with TV
553 cards).
554
555 lirc-parallel module for devices connected to parallel port.
556
557 %description -n kernel%{_alt_kernel}-char-lirc-parallel -l pl.UTF-8
558 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
559 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
560
561 Moduł lirc_parallel dla urządzeń podłączanych do portu równoległego.
562
563 %prep
564 %setup -q -n %{pname}-%{version} -a 1
565 %patch0 -p1
566 %patch1 -p1
567 %if !%{with svga}
568 %patch2 -p1
569 %endif
570 %patch3 -p1
571 %patch4 -p1
572 %patch5 -p1
573 %patch6 -p1
574 %patch7 -p1
575
576 %build
577 echo '#' > drivers/Makefile.am
578 %{__libtoolize}
579 %{__aclocal}
580 %{__automake}
581 %{__autoheader}
582 %{__autoconf}
583
584 %configure \
585         ac_cv_header_portaudio_h=no \
586 %if %{with kernel}
587         KERNELCC="%{kgcc}" \
588 %else
589         ac_cv_have_kernel="no_kernel=yes" \
590 %endif
591         --with-kerneldir=%{_kernelsrcdir} \
592         %{?with_x:--with-x} \
593         --with-port=0x2f8 \
594         --with-irq=3 \
595         --without-soft-carrier \
596         --with-driver=userspace \
597         --with-igor
598
599 %if %{with userspace}
600 %{__make} -j1
601 %endif
602
603 %if %{with kernel}
604 cd drivers
605
606 drivers=%{drivers}
607
608 for drv in $drivers; do
609         cd $drv
610         %{__make} clean \
611                 LIRC_DEVDIR=`pwd` \
612                 RCS_FIND_IGNORE="-name '*.ko' -o" \
613                 %{?with_verbose:V=1}
614
615         %{__make} -j1 \
616                 LIRC_DEVDIR=`pwd` \
617                 CONSTIFY_PLUGIN="" \
618                 KBUILD_MODPOST_WARN=1 \
619                 %{?with_verbose:V=1}
620         cd ..
621 done
622
623 cd ..
624
625 %endif
626
627 %install
628 rm -rf $RPM_BUILD_ROOT
629
630 %if %{with kernel}
631 drivers=%{drivers}
632 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
633 for drv in $drivers; do
634         install -p drivers/$drv/$drv.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/$drv.ko
635 done
636 %endif
637
638 %if %{with userspace}
639 install -d $RPM_BUILD_ROOT{%{_bindir},%{_aclocaldir},/dev,/var/{log,run/lirc}} \
640         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,lirc} \
641         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
642
643 %{__make} -j1 install \
644         DESTDIR=$RPM_BUILD_ROOT \
645         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
646
647 cat>$RPM_BUILD_ROOT%{_sysconfdir}/lirc/lircd.conf<<END
648 #
649 # This is a placeholder for your configuration file.
650 # See %{_docdir}/%{pname}-%{version}/remotes for some examples.
651 #
652 END
653 cp -f $RPM_BUILD_ROOT%{_sysconfdir}/lirc/lirc{,m}d.conf
654 cp -p contrib/*.m4 $RPM_BUILD_ROOT%{_aclocaldir}
655 :> $RPM_BUILD_ROOT/var/log/lircd
656
657 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lircd
658 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircd
659 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircmd
660 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
661 %endif
662
663 %clean
664 rm -rf $RPM_BUILD_ROOT
665
666 %post   libs -p /sbin/ldconfig
667 %postun libs -p /sbin/ldconfig
668
669 %post
670 /sbin/chkconfig --add lircd
671 /sbin/chkconfig --add lircmd
672 %service lircd restart
673 %service lircmd restart
674
675 echo "If you are using a kernel-module-based driver, don't forget to"
676 echo "install the kernel%{_alt_kernel}-char-lirc-<your_driver> or"
677 echo "kernel%{_alt_kernel}-smp-char-lirc-<your_driver> package."
678
679 %preun
680 if [ "$1" = "0" ]; then
681         %service lircd stop
682         %service lircmd stop
683         /sbin/chkconfig --del lircd
684         /sbin/chkconfig --del lircmd
685 fi
686
687 %triggerpostun -- %{name} < 0.8.6-8
688 if [ -f %{_sysconfdir}/lircd.conf.rpmsave ]; then
689         mv -f %{_sysconfdir}/lircd.conf.rpmsave %{_sysconfdir}/lirc/lircd.conf
690 fi
691 if [ -f %{_sysconfdir}/lircmd.conf.rpmsave ]; then
692         mv -f %{_sysconfdir}/lircmd.conf.rpmsave %{_sysconfdir}/lirc/lircmd.conf
693 fi
694
695 %post   -n kernel%{_alt_kernel}-char-lirc-atiusb
696 %depmod %{_kernel_ver}
697 if [ "$1" = "1" ]; then
698         echo "Don't forget to add an 'alias lirc lirc_atiusb' line"
699         echo "to your /etc/modules.conf."
700 fi
701
702 %postun -n kernel%{_alt_kernel}-char-lirc-atiusb
703 %depmod %{_kernel_ver}
704
705 %post   -n kernel%{_alt_kernel}-char-lirc-bt829
706 %depmod %{_kernel_ver}
707 if [ "$1" = "1" ]; then
708         echo "Don't forget to add an 'alias lirc lirc_bt829' line"
709         echo "to your /etc/modules.conf."
710 fi
711
712 %postun -n kernel%{_alt_kernel}-char-lirc-bt829
713 %depmod %{_kernel_ver}
714
715 %post   -n kernel%{_alt_kernel}-char-lirc-dev
716 %depmod %{_kernel_ver}
717
718 %postun -n kernel%{_alt_kernel}-char-lirc-dev
719 %depmod %{_kernel_ver}
720
721 %post   -n kernel%{_alt_kernel}-char-lirc-ene0100
722 %depmod %{_kernel_ver}
723
724 %postun -n kernel%{_alt_kernel}-char-lirc-ene0100
725 %depmod %{_kernel_ver}
726
727 %post   -n kernel%{_alt_kernel}-char-lirc-gpio
728 %depmod %{_kernel_ver}
729 if [ "$1" = "1" ]; then
730         echo "Don't forget to add an 'alias lirc lirc_gpio' line"
731         echo "to your /etc/modules.conf."
732 fi
733
734 %postun -n kernel%{_alt_kernel}-char-lirc-gpio
735 %depmod %{_kernel_ver}
736
737 %post   -n kernel%{_alt_kernel}-char-lirc-i2c
738 %depmod %{_kernel_ver}
739 if [ "$1" = "1" ]; then
740         echo "Don't forget to add an 'alias lirc lirc_i2c' line"
741         echo "to your /etc/modules.conf."
742 fi
743
744 %postun -n kernel%{_alt_kernel}-char-lirc-i2c
745 %depmod %{_kernel_ver}
746
747 %post   -n kernel%{_alt_kernel}-char-lirc-igorplugusb
748 %depmod %{_kernel_ver}
749 if [ "$1" = "1" ]; then
750         echo "Don't forget to add an 'alias lirc lirc_igorplugusb' line"
751         echo "to your /etc/modules.conf."
752 fi
753
754 %postun -n kernel%{_alt_kernel}-char-lirc-igorplugusb
755 %depmod %{_kernel_ver}
756
757 %post   -n kernel%{_alt_kernel}-char-lirc-imon
758 %depmod %{_kernel_ver}
759 if [ "$1" = "1" ]; then
760         echo "Don't forget to add an 'alias lirc lirc_imon' line"
761         echo "to your /etc/modules.conf."
762 fi
763
764 %postun -n kernel%{_alt_kernel}-char-lirc-imon
765 %depmod %{_kernel_ver}
766
767 %post   -n kernel%{_alt_kernel}-char-lirc-sasem
768 %depmod %{_kernel_ver}
769 if [ "$1" = "1" ]; then
770         echo "Don't forget to add an 'alias lirc lirc_sasem' line"
771         echo "to your /etc/modules.conf."
772 fi
773
774 %postun -n kernel%{_alt_kernel}-char-lirc-sasem
775 %depmod %{_kernel_ver}
776
777 %post   -n kernel%{_alt_kernel}-char-lirc-serial
778 %depmod %{_kernel_ver}
779 if [ "$1" = "1" ]; then
780         echo "Don't forget to add an 'alias lirc lirc_serial' line"
781         echo "to your /etc/modules.conf."
782 fi
783
784 %postun -n kernel%{_alt_kernel}-char-lirc-serial
785 %depmod %{_kernel_ver}
786
787 %post   -n kernel%{_alt_kernel}-char-lirc-parallel
788 %depmod %{_kernel_ver}
789 if [ "$1" = "1" ]; then
790         echo "Don't forget to add an 'alias lirc lirc_parallel' line"
791         echo "to your /etc/modules.conf."
792 fi
793
794 %postun -n kernel%{_alt_kernel}-char-lirc-parallel
795 %depmod %{_kernel_ver}
796
797 %post   -n kernel%{_alt_kernel}-char-lirc-sir
798 %depmod %{_kernel_ver}
799 if [ "$1" = "1" ]; then
800         echo "Don't forget to add an 'alias lirc lirc_sir' line"
801         echo "to your /etc/modules.conf."
802 fi
803
804 %postun -n kernel%{_alt_kernel}-char-lirc-sir
805 %depmod %{_kernel_ver}
806
807 %post   -n kernel%{_alt_kernel}-char-lirc-ttusbir
808 %depmod %{_kernel_ver}
809 if [ "$1" = "1" ]; then
810         echo "Don't forget to add an 'alias lirc lirc_ttusbir' line"
811         echo "to your /etc/modules.conf."
812 fi
813
814 %postun -n kernel%{_alt_kernel}-char-lirc-ttusbir
815 %depmod %{_kernel_ver}
816
817 %post   -n kernel%{_alt_kernel}-char-lirc-wpc87691
818 %depmod %{_kernel_ver}
819 if [ "$1" = "1" ]; then
820         echo "Don't forget to add an 'alias lirc lirc_wpc87691' line"
821         echo "to your /etc/modules.conf."
822 fi
823
824 %postun -n kernel%{_alt_kernel}-char-lirc-wpc87691
825 %depmod %{_kernel_ver}
826
827 %if %{with userspace}
828 %files
829 %defattr(644,root,root,755)
830 %doc ANNOUNCE AUTHORS NEWS README TODO ChangeLog
831 %doc contrib/lircrc doc/{html,images,lirc.css}
832 %attr(755,root,root) %{_bindir}/ircat
833 %attr(755,root,root) %{_bindir}/irexec
834 %attr(755,root,root) %{_bindir}/irpty
835 %attr(755,root,root) %{_bindir}/irrecord
836 %attr(755,root,root) %{_bindir}/irsend
837 %attr(755,root,root) %{_bindir}/irw
838 %attr(755,root,root) %{_bindir}/mode2
839 %attr(755,root,root) %{_bindir}/lircrcd
840 %attr(755,root,root) %{_bindir}/pronto2lirc
841 %attr(755,root,root) %{_sbindir}/lircd
842 %attr(755,root,root) %{_sbindir}/lircmd
843 %attr(754,root,root) /etc/rc.d/init.d/lircd
844 %attr(754,root,root) /etc/rc.d/init.d/lircmd
845 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lircd
846 %dir %{_sysconfdir}/lirc
847 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircd.conf
848 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircmd.conf
849 %{_mandir}/man1/ircat.1*
850 %{_mandir}/man1/irexec.1*
851 %{_mandir}/man1/irpty.1*
852 %{_mandir}/man1/irrecord.1*
853 %{_mandir}/man1/irsend.1*
854 %{_mandir}/man1/irw.1*
855 %{_mandir}/man1/lircrcd.1*
856 %{_mandir}/man1/mode2.1*
857 %{_mandir}/man8/lircd.8*
858 %{_mandir}/man8/lircmd.8*
859 %attr(600,root,root) %ghost /var/log/lircd
860 %dir /var/run/lirc
861 %{systemdtmpfilesdir}/%{name}.conf
862
863 %files remotes
864 %defattr(644,root,root,755)
865 # XXX: are jpegs in docs (remotes) a good idea?
866 %doc remotes
867
868 %if %{with x}
869 %files X11
870 %defattr(644,root,root,755)
871 %doc doc/irxevent.keys
872 %attr(755,root,root) %{_bindir}/irxevent
873 %attr(755,root,root) %{_bindir}/xmode2
874 %{_mandir}/man1/irxevent.1*
875 %{_mandir}/man1/xmode2.1*
876 %endif
877
878 %if %{with svga}
879 %files svga
880 %defattr(644,root,root,755)
881 %attr(755,root,root) %{_bindir}/smode2
882 %{_mandir}/man1/smode2.1*
883 %endif
884
885 %files libs
886 %defattr(644,root,root,755)
887 %attr(755,root,root) %{_libdir}/liblirc_client.so.*.*.*
888 %attr(755,root,root) %ghost %{_libdir}/liblirc_client.so.0
889
890 %files devel
891 %defattr(644,root,root,755)
892 %attr(755,root,root) %{_libdir}/liblirc_client.so
893 %{_libdir}/liblirc_client.la
894 %{_includedir}/lirc
895 %{_aclocaldir}/lirc.m4
896
897 %files static
898 %defattr(644,root,root,755)
899 %{_libdir}/liblirc_client.a
900 %endif
901
902 %if %{with kernel}
903 %files -n kernel%{_alt_kernel}-char-lirc-atiusb
904 %defattr(644,root,root,755)
905 /lib/modules/%{_kernel_ver}/misc/lirc_atiusb.ko*
906
907 %files -n kernel%{_alt_kernel}-char-lirc-bt829
908 %defattr(644,root,root,755)
909 /lib/modules/%{_kernel_ver}/misc/lirc_bt829.ko*
910
911 %files -n kernel%{_alt_kernel}-char-lirc-dev
912 %defattr(644,root,root,755)
913 /lib/modules/%{_kernel_ver}/misc/lirc_dev.ko*
914
915 %if "%{_kernel_ver}" < "3.0.0"
916 %files -n kernel%{_alt_kernel}-char-lirc-ene0100
917 %defattr(644,root,root,755)
918 /lib/modules/%{_kernel_ver}/misc/lirc_ene0100.ko*
919 %endif
920
921 %if "%{_kernel_ver}" < "2.6.23"
922 %files -n kernel%{_alt_kernel}-char-lirc-gpio
923 %defattr(644,root,root,755)
924 /lib/modules/%{_kernel_ver}/misc/lirc_gpio.ko*
925 %endif
926
927 %files -n kernel%{_alt_kernel}-char-lirc-i2c
928 %defattr(644,root,root,755)
929 /lib/modules/%{_kernel_ver}/misc/lirc_i2c.ko*
930
931 %files -n kernel%{_alt_kernel}-char-lirc-igorplugusb
932 %defattr(644,root,root,755)
933 /lib/modules/%{_kernel_ver}/misc/lirc_igorplugusb.ko*
934
935 %files -n kernel%{_alt_kernel}-char-lirc-imon
936 %defattr(644,root,root,755)
937 /lib/modules/%{_kernel_ver}/misc/lirc_imon.ko*
938
939 %files -n kernel%{_alt_kernel}-char-lirc-sasem
940 %defattr(644,root,root,755)
941 /lib/modules/%{_kernel_ver}/misc/lirc_sasem.ko*
942
943 %files -n kernel%{_alt_kernel}-char-lirc-serial
944 %defattr(644,root,root,755)
945 /lib/modules/%{_kernel_ver}/misc/lirc_serial.ko*
946
947 %files -n kernel%{_alt_kernel}-char-lirc-sir
948 %defattr(644,root,root,755)
949 /lib/modules/%{_kernel_ver}/misc/lirc_sir.ko*
950
951 %files -n kernel%{_alt_kernel}-char-lirc-ttusbir
952 %defattr(644,root,root,755)
953 /lib/modules/%{_kernel_ver}/misc/lirc_ttusbir.ko*
954
955 %if "%{_kernel_ver}" < "3.0.0"
956 %files -n kernel%{_alt_kernel}-char-lirc-wpc87691
957 %defattr(644,root,root,755)
958 /lib/modules/%{_kernel_ver}/misc/lirc_wpc8769l.ko*
959 %endif
960
961 %files -n kernel%{_alt_kernel}-char-lirc-parallel
962 %defattr(644,root,root,755)
963 /lib/modules/%{_kernel_ver}/misc/lirc_parallel.ko*
964 %endif
This page took 0.153883 seconds and 4 git commands to generate.