]> git.pld-linux.org Git - packages/lirc.git/blob - lirc.spec
- release 14
[packages/lirc.git] / lirc.spec
1 # TODO
2 # - restore lirc_parallel driver
3 # - try to make it use builder_kernel_modules and install_kernel_modules; I couldn't make it
4 # - build is running kernel arch dependent, try to get rid of this
5 # - libcaraca_client (http://caraca.sourceforge.net/) - no releases yet
6 #
7 # Conditional build:
8 %bcond_without  dist_kernel     # without sources of distribution kernel
9 %bcond_without  kernel          # don't build kernel modules, only library+programs
10 %bcond_without  userspace       # build only packages with kernel modules
11 %bcond_with     svga            # without svgalib-based utility
12 %bcond_without  x               # without X11-based utilitied
13
14 %if %{without kernel}
15 %undefine       with_dist_kernel
16 %endif
17
18 %if "%{_alt_kernel}" != "%{nil}"
19 %undefine       with_userspace
20 %endif
21
22 %define         pname   lirc
23 %define         rel     14
24
25 #
26 # main package
27 #
28 # lirc_gpio fails to build under kernel >= 2.6.23
29 #
30 %if "%{_kernel_ver}" >= "2.6.23"
31 %if "%{_kernel_ver}" >= "3.0.0"
32 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir"
33 %else
34 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
35 %endif
36 %else
37 %define         drivers         "lirc_atiusb lirc_bt829 lirc_dev lirc_gpio lirc_i2c lirc_igorplugusb lirc_imon lirc_parallel lirc_sasem lirc_serial lirc_sir lirc_ttusbir lirc_wpc8769l"
38 %endif
39 Summary:        Linux Infrared Remote Control daemons
40 Summary(pl.UTF-8):      Serwery do zdalnego sterowania Linuksem za pomocą podczerwieni
41 Name:           %{pname}%{_alt_kernel}
42 Version:        0.9.0
43 Release:        %{rel}
44 License:        GPL v2+
45 Group:          Daemons
46 Source0:        http://downloads.sourceforge.net/lirc/%{pname}-%{version}.tar.bz2
47 # Source0-md5:  b232aef26f23fe33ea8305d276637086
48 Source1:        http://lirc.sourceforge.net/remotes.tar.bz2
49 # Source1-md5:  238d1773d3c405acc02813674f5a55f8
50 Source2:        %{pname}d.sysconfig
51 Source3:        %{pname}d.init
52 Source4:        %{pname}md.init
53 Patch0:         %{pname}-opt.patch
54 Patch1:         %{pname}-tmp.patch
55 Patch2:         %{pname}-no-svgalib.patch
56 Patch3:         %{pname}-kernel.patch
57 Patch4:         %{pname}-sparc.patch
58 Patch5:         %{pname}-remotes.patch
59 Patch6:         %{pname}-kernelcc.patch
60 URL:            http://www.lirc.org/
61 BuildRequires:  alsa-lib-devel
62 BuildRequires:  autoconf >= 2.50
63 BuildRequires:  automake
64 BuildRequires:  iguanaIR-devel
65 BuildRequires:  libftdi-devel >= 0.12
66 BuildRequires:  libirman-devel >= 0.4.5
67 BuildRequires:  libtool
68 BuildRequires:  libusb-compat-devel >= 0.1.0
69 %if %{with kernel}
70 BuildRequires:  kernel%{_alt_kernel}-module-build
71 BuildRequires:  kernel%{_alt_kernel}-headers
72 %endif
73 %{?with_kernel:BuildRequires:   %{kgcc_package}}
74 BuildRequires:  rpm-pythonprov
75 BuildRequires:  rpmbuild(macros) >= 1.379
76 %{?with_svga:BuildRequires:     svgalib-devel}
77 %{?with_x:BuildRequires:        xorg-lib-libX11-devel}
78 Requires(post,preun):   /sbin/chkconfig
79 Requires:       %{pname}-libs = %{version}-%{release}
80 Requires:       libftdi >= 0.12
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 LIRC is a package that allows you to decode and send infra-red signals
85 of many (but not all) commonly used remote controls.
86
87 %description -l pl.UTF-8
88 LIRC to program pozwalający na dekodowanie nadchodzących oraz
89 wysyłanie sygnałów w podczerwieni za pomocą wielu (ale nie
90 wszystkich) popularnych urządzeń do zdalnego sterowania.
91
92 %package remotes
93 Summary:        Lirc remotes database
94 Summary(pl.UTF-8):      Baza pilotów obsługiwanych przez lirc
95 Group:          Documentation
96 Requires:       %{pname} = %{version}-%{rel}
97
98 %description remotes
99 This package contains configuration files for many remotes supported
100 by lirc.
101
102 %description remotes -l pl.UTF-8
103 Ten pakiet zawiera pliki konfiguracyjne dla wielu pilotów
104 obsługiwanych przez lirc.
105
106 %package X11
107 Summary:        Linux Infrared Remote Control - X11 utilities
108 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11
109 Group:          X11/Applications
110 Requires:       %{pname}-libs = %{version}-%{release}
111
112 %description X11
113 Linux Infrared Remote Control - X11 utilities.
114
115 %description X11 -l pl.UTF-8
116 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia X11.
117
118 %package svga
119 Summary:        Linux Infrared Remote Control - svgalib utilities
120 Summary(pl.UTF-8):      Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia svgalib
121 Group:          Applications
122 Requires:       %{pname}-libs = %{version}-%{release}
123
124 %description svga
125 Linux Infrared Remote Control - svgalib-based utilities.
126
127 %description svga -l pl.UTF-8
128 Zdalne sterowanie Linuksem za pomocą podczerwieni - narzędzia oparte
129 na svgalibie.
130
131 %package libs
132 Summary:        LIRC libraries
133 Summary(pl.UTF-8):      Biblioteki LIRC
134 Group:          Libraries
135 Conflicts:      lirc < 0.6.3-3
136 # didn't use /tmp/.lircd
137
138 %description libs
139 This package provides the libraries necessary to run lirc client
140 programs.
141
142 %description libs -l pl.UTF-8
143 Ten pakiet zawiera biblioteki niezbędne do działania klientów LIRC.
144
145 %package devel
146 Summary:        Header files for LIRC development
147 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów z obsługą LIRC
148 Group:          Development/Libraries
149 Requires:       %{pname}-libs = %{version}-%{release}
150
151 %description devel
152 This package provides the files necessary to develop LIRC-based
153 programs.
154
155 %description devel -l pl.UTF-8
156 Ten pakiet zawiera pliki niezbędne do tworzenia programów opartych
157 na LIRC.
158
159 %package static
160 Summary:        Static library for LIRC development
161 Summary(pl.UTF-8):      Biblioteka statyczna LIRC
162 Group:          Development/Libraries
163 Requires:       %{pname}-devel = %{version}-%{release}
164
165 %description static
166 The files necessary for development of statically-linked lirc-based
167 programs.
168
169 %description static -l pl.UTF-8
170 Pliki potrzebne do tworzenia łączonych statycznie programów
171 opartych na LIRC.
172
173 %package -n kernel%{_alt_kernel}-char-lirc-atiusb
174 Summary:        Kernel modules for Linux Infrared Remote Control
175 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
176 Release:        %{rel}@%{_kernel_ver_str}
177 Group:          Base/Kernel
178 %if %{with dist_kernel}
179 %requires_releq_kernel
180 Requires(postun):       %releq_kernel
181 %endif
182 Requires(post,postun):  /sbin/depmod
183 Requires:       %{pname} = %{version}-%{rel}
184 Conflicts:      dev < 2.8.0-3
185
186 %description -n kernel%{_alt_kernel}-char-lirc-atiusb
187 This package contains the kernel modules necessary to operate some
188 infrared remote control devices (such as the ones bundled with TV
189 cards).
190
191 lirc_atiusb module.
192
193 %description -n kernel%{_alt_kernel}-char-lirc-atiusb -l pl.UTF-8
194 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
195 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
196
197 Moduł lirc_atiusb.
198
199 %package -n kernel%{_alt_kernel}-char-lirc-bt829
200 Summary:        Kernel modules for Linux Infrared Remote Control
201 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
202 Release:        %{rel}@%{_kernel_ver_str}
203 Group:          Base/Kernel
204 %if %{with dist_kernel}
205 %requires_releq_kernel
206 Requires(postun):       %releq_kernel
207 %endif
208 Requires(post,postun):  /sbin/depmod
209 Requires:       %{pname} = %{version}-%{rel}
210 Conflicts:      dev < 2.8.0-3
211
212 %description -n kernel%{_alt_kernel}-char-lirc-bt829
213 This package contains the kernel modules necessary to operate some
214 infrared remote control devices (such as the ones bundled with TV
215 cards).
216
217 lirc_bt829 module.
218
219 %description -n kernel%{_alt_kernel}-char-lirc-bt829 -l pl.UTF-8
220 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
221 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
222
223 Moduł lirc_bt829.
224
225 %package -n kernel%{_alt_kernel}-char-lirc-dev
226 Summary:        Kernel modules for Linux Infrared Remote Control
227 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
228 Release:        %{rel}@%{_kernel_ver_str}
229 Group:          Base/Kernel
230 %if %{with dist_kernel}
231 %requires_releq_kernel
232 Requires(postun):       %releq_kernel
233 %endif
234 Requires(post,postun):  /sbin/depmod
235 Requires:       %{pname} = %{version}-%{rel}
236 Obsoletes:      lirc-modules
237 Obsoletes:      lirc-modules-dev
238 Conflicts:      dev < 2.8.0-3
239
240 %description -n kernel%{_alt_kernel}-char-lirc-dev
241 This package contains the kernel modules necessary to operate some
242 infrared remote control devices (such as the ones bundled with TV
243 cards).
244
245 lirc_dev module.
246
247 %description -n kernel%{_alt_kernel}-char-lirc-dev -l pl.UTF-8
248 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
249 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
250
251 Moduł lirc_dev.
252
253 %package -n kernel%{_alt_kernel}-char-lirc-ene0100
254 Summary:        Kernel modules for Linux Infrared Remote Control
255 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
256 Release:        %{rel}@%{_kernel_ver_str}
257 Group:          Base/Kernel
258 %if %{with dist_kernel}
259 %requires_releq_kernel
260 Requires(postun):       %releq_kernel
261 %endif
262 Requires(post,postun):  /sbin/depmod
263 Requires:       %{pname} = %{version}-%{rel}
264 Obsoletes:      lirc-modules
265 Conflicts:      dev < 2.8.0-3
266
267 %description -n kernel%{_alt_kernel}-char-lirc-ene0100
268 This package contains the kernel modules necessary to operate some
269 infrared remote control ene0100ices (such as the ones bundled with TV
270 cards).
271
272 lirc_ene0100 module.
273
274 %description -n kernel%{_alt_kernel}-char-lirc-ene0100 -l pl.UTF-8
275 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
276 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
277
278 Moduł lirc_ene0100.
279
280 %package -n kernel%{_alt_kernel}-char-lirc-gpio
281 Summary:        Kernel modules for Linux Infrared Remote Control
282 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
283 Release:        %{rel}@%{_kernel_ver_str}
284 Group:          Base/Kernel
285 %if %{with dist_kernel}
286 %requires_releq_kernel
287 Requires(postun):       %releq_kernel
288 %endif
289 Requires(post,postun):  /sbin/depmod
290 Requires:       %{pname} = %{version}-%{rel}
291 Obsoletes:      lirc-modules
292 Obsoletes:      lirc-modules-gpio
293 Conflicts:      dev < 2.8.0-3
294
295 %description -n kernel%{_alt_kernel}-char-lirc-gpio
296 This package contains the kernel modules necessary to operate some
297 infrared remote control devices (such as the ones bundled with TV
298 cards).
299
300 lirc_gpio module.
301
302 %description -n kernel%{_alt_kernel}-char-lirc-gpio -l pl.UTF-8
303 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
304 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
305
306 Moduł lirc_gpio.
307
308 %package -n kernel%{_alt_kernel}-char-lirc-i2c
309 Summary:        Kernel modules for Linux Infrared Remote Control
310 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
311 Release:        %{rel}@%{_kernel_ver_str}
312 Group:          Base/Kernel
313 %if %{with dist_kernel}
314 %requires_releq_kernel
315 Requires(postun):       %releq_kernel
316 %endif
317 Requires(post,postun):  /sbin/depmod
318 Requires:       %{pname} = %{version}-%{rel}
319 Obsoletes:      lirc-modules
320 Obsoletes:      lirc-modules-i2c
321 Conflicts:      dev < 2.8.0-3
322
323 %description -n kernel%{_alt_kernel}-char-lirc-i2c
324 This package contains the kernel modules necessary to operate some
325 infrared remote control devices (such as the ones bundled with TV
326 cards).
327
328 lirc_i2c module.
329
330 %description -n kernel%{_alt_kernel}-char-lirc-i2c -l pl.UTF-8
331 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
332 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
333
334 Moduł lirc_i2c.
335
336 %package -n kernel%{_alt_kernel}-char-lirc-igorplugusb
337 Summary:        Kernel modules for Linux Infrared Remote Control
338 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
339 Release:        %{rel}@%{_kernel_ver_str}
340 Group:          Base/Kernel
341 %if %{with dist_kernel}
342 %requires_releq_kernel
343 Requires(postun):       %releq_kernel
344 %endif
345 Requires(post,postun):  /sbin/depmod
346 Requires:       %{pname} = %{version}-%{rel}
347 Obsoletes:      lirc-modules
348 Obsoletes:      lirc-modules-igorplugusb
349 Conflicts:      dev < 2.8.0-3
350
351 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb
352 This package contains the kernel modules necessary to operate some
353 infrared remote control devices (such as the ones bundled with TV
354 cards).
355
356 lirc_igorplugusb module.
357
358 %description -n kernel%{_alt_kernel}-char-lirc-igorplugusb -l pl.UTF-8
359 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
360 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
361
362 Moduł lirc_igorplugusb.
363
364 %package -n kernel%{_alt_kernel}-char-lirc-imon
365 Summary:        Kernel modules for Linux Infrared Remote Control
366 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
367 Release:        %{rel}@%{_kernel_ver_str}
368 Group:          Base/Kernel
369 %if %{with dist_kernel}
370 %requires_releq_kernel
371 Requires(postun):       %releq_kernel
372 %endif
373 Requires(post,postun):  /sbin/depmod
374 Requires:       %{pname} = %{version}-%{rel}
375 Obsoletes:      lirc-modules
376 Obsoletes:      lirc-modules-imon
377 Conflicts:      dev < 2.8.0-3
378
379 %description -n kernel%{_alt_kernel}-char-lirc-imon
380 This package contains the kernel modules necessary to operate some
381 infrared remote control devices (such as the ones bundled with TV
382 cards).
383
384 lirc_imon module.
385
386 %description -n kernel%{_alt_kernel}-char-lirc-imon -l pl.UTF-8
387 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
388 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
389
390 Moduł lirc_imon.
391
392 %package -n kernel%{_alt_kernel}-char-lirc-sasem
393 Summary:        Kernel modules for Linux Infrared Remote Control
394 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
395 Release:        %{rel}@%{_kernel_ver_str}
396 Group:          Base/Kernel
397 %if %{with dist_kernel}
398 %requires_releq_kernel
399 Requires(postun):       %releq_kernel
400 %endif
401 Requires(post,postun):  /sbin/depmod
402 Requires:       %{pname} = %{version}-%{rel}
403 Conflicts:      dev < 2.8.0-3
404
405 %description -n kernel%{_alt_kernel}-char-lirc-sasem
406 This package contains the kernel modules necessary to operate some
407 infrared remote control devices (such as the ones bundled with TV
408 cards).
409
410 lirc_sasem module.
411
412 %description -n kernel%{_alt_kernel}-char-lirc-sasem -l pl.UTF-8
413 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
414 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
415
416 Moduł lirc_sasem.
417
418 %package -n kernel%{_alt_kernel}-char-lirc-serial
419 Summary:        Kernel modules for Linux Infrared Remote Control
420 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
421 Release:        %{rel}@%{_kernel_ver_str}
422 Group:          Base/Kernel
423 %if %{with dist_kernel}
424 %requires_releq_kernel
425 Requires(postun):       %releq_kernel
426 %endif
427 Requires(post,postun):  /sbin/depmod
428 Requires:       %{pname} = %{version}-%{rel}
429 %{?with_dist_kernel:Requires:   setserial}
430 Obsoletes:      lirc-modules
431 Obsoletes:      lirc-modules-serial
432 Conflicts:      dev < 2.8.0-3
433
434 %description -n kernel%{_alt_kernel}-char-lirc-serial
435 This package contains the kernel modules necessary to operate some
436 infrared remote control devices (such as the ones bundled with TV
437 cards).
438
439 lirc_serial module for devices connected to serial port.
440
441 %description -n kernel%{_alt_kernel}-char-lirc-serial -l pl.UTF-8
442 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
443 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
444
445 Moduł lirc_serial dla urządzeń podłączanych do portu szeregowego.
446
447 %package -n kernel%{_alt_kernel}-char-lirc-sir
448 Summary:        Kernel modules for Linux Infrared Remote Control
449 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
450 Release:        %{rel}@%{_kernel_ver_str}
451 Group:          Base/Kernel
452 %if %{with dist_kernel}
453 %requires_releq_kernel
454 Requires(postun):       %releq_kernel
455 %endif
456 Requires(post,postun):  /sbin/depmod
457 Requires:       %{pname} = %{version}-%{rel}
458 Obsoletes:      lirc-modules
459 Obsoletes:      lirc-modules-sir
460 Conflicts:      dev < 2.8.0-3
461
462 %description -n kernel%{_alt_kernel}-char-lirc-sir
463 This package contains the kernel modules necessary to operate some
464 infrared remote control devices (such as the ones bundled with TV
465 cards).
466
467 lirc_sir module.
468
469 %description -n kernel%{_alt_kernel}-char-lirc-sir -l pl.UTF-8
470 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
471 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
472
473 Moduł lirc_sir.
474
475 %package -n kernel%{_alt_kernel}-char-lirc-ttusbir
476 Summary:        Kernel modules for Linux Infrared Remote Control
477 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
478 Release:        %{rel}@%{_kernel_ver_str}
479 Group:          Base/Kernel
480 %if %{with dist_kernel}
481 %requires_releq_kernel
482 Requires(postun):       %releq_kernel
483 %endif
484 Requires(post,postun):  /sbin/depmod
485 Requires:       %{pname} = %{version}-%{rel}
486 Obsoletes:      lirc-modules
487 Obsoletes:      lirc-modules-ttusbir
488 Conflicts:      dev < 2.8.0-3
489
490 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir
491 This package contains the kernel modules necessary to operate
492 TechnoTrend USB IR Receiver.
493
494 lirc_ttusbir module.
495
496 %description -n kernel%{_alt_kernel}-char-lirc-ttusbir -l pl.UTF-8
497 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
498 TechnoTrend USB IR Receiver.
499
500 Moduł lirc_ttusbir.
501
502 %package -n kernel%{_alt_kernel}-char-lirc-wpc87691
503 Summary:        Kernel modules for Linux Infrared Remote Control
504 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
505 Release:        %{rel}@%{_kernel_ver_str}
506 Group:          Base/Kernel
507 %if %{with dist_kernel}
508 %requires_releq_kernel
509 Requires(postun):       %releq_kernel
510 %endif
511 Requires(post,postun):  /sbin/depmod
512 Requires:       %{pname} = %{version}-%{rel}
513 Conflicts:      dev < 2.8.0-3
514
515 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691
516 This package contains the kernel modules necessary to operate
517 TechnoTrend USB IR Receiver.
518
519 lirc_wpc87691 module.
520
521 %description -n kernel%{_alt_kernel}-char-lirc-wpc87691 -l pl.UTF-8
522 Ten pakiet zawiera moduł kernela niezbędny do obsługi urządzenia
523 TechnoTrend USB IR Receiver.
524
525 Moduł lirc_wpc87691.
526
527 %package -n kernel%{_alt_kernel}-char-lirc-parallel
528 Summary:        Kernel modules for Linux Infrared Remote Control
529 Summary(pl.UTF-8):      Moduły jądra dla zdalnej obsługi Linuksa za pomocą podczerwieni
530 Release:        %{rel}@%{_kernel_ver_str}
531 Group:          Base/Kernel
532 %if %{with dist_kernel}
533 %requires_releq_kernel
534 Requires(postun):       %releq_kernel
535 %endif
536 Requires(post,postun):  /sbin/depmod
537 Requires:       %{pname} = %{version}-%{rel}
538 Obsoletes:      lirc-modules
539 Obsoletes:      lirc-modules-parallel
540 Conflicts:      dev < 2.8.0-3
541
542 %description -n kernel%{_alt_kernel}-char-lirc-parallel
543 This package contains the kernel modules necessary to operate some
544 infrared remote control devices (such as the ones bundled with TV
545 cards).
546
547 lirc-parallel module for devices connected to parallel port.
548
549 %description -n kernel%{_alt_kernel}-char-lirc-parallel -l pl.UTF-8
550 Ten pakiet zawiera moduły jądra niezbędne do obsługi niektórych
551 pilotów na podczerwień (w tym tych dostarczanych z kartami TV).
552
553 Moduł lirc_parallel dla urządzeń podłączanych do portu
554 równoległego.
555
556 %prep
557 %setup -q -n %{pname}-%{version} -a 1
558 %patch0 -p1
559 %patch1 -p1
560 %if !%{with svga}
561 %patch2 -p1
562 %endif
563 %patch3 -p1
564 %patch4 -p1
565 %patch5 -p1
566 %patch6 -p1
567
568 %build
569 echo '#' > drivers/Makefile.am
570 %{__libtoolize}
571 %{__aclocal}
572 %{__automake}
573 %{__autoheader}
574 %{__autoconf}
575
576 %configure \
577         ac_cv_header_portaudio_h=no \
578 %if %{with kernel}
579         KERNELCC="%{kgcc}" \
580 %else
581         ac_cv_have_kernel="no_kernel=yes" \
582 %endif
583         --with-kerneldir=%{_kernelsrcdir} \
584         %{?with_x:--with-x} \
585         --with-port=0x2f8 \
586         --with-irq=3 \
587         --without-soft-carrier \
588         --with-driver=userspace \
589         --with-igor
590
591 %if %{with userspace}
592 %{__make} -j1
593 %endif
594
595 %if %{with kernel}
596 cd drivers
597
598 drivers=%{drivers}
599 rm -rf o
600 if [ ! -r "%{_kernelsrcdir}/config-dist" ]; then
601         exit 1
602 fi
603
604 install -d o/include/{linux,generated,config} o/arch/powerpc/lib
605 ln -sf %{_kernelsrcdir}/config-dist o/.config
606 if [ -f %{_kernelsrcdir}/include/generated/autoconf-dist.h ]; then
607         ln -sf %{_kernelsrcdir}/include/generated/autoconf-dist.h o/include/generated/autoconf.h
608         ln -s ../generated/autoconf.h o/include/linux/autoconf.h
609 else
610         ln -sf %{_kernelsrcdir}/include/linux/autoconf-dist.h o/include/linux/autoconf.h
611 fi
612 ln -sf %{_kernelsrcdir}/Module.symvers-dist o/Module.symvers
613
614 %if %{without dist_kernel}
615         touch o/include/config/MARKER
616         ln -sf %{_kernelsrcdir}/scripts o/
617 %else
618         %{__make} -j1 -C %{_kernelsrcdir} O=$PWD/o prepare scripts
619 %endif
620
621 for drv in $drivers; do
622         cd $drv
623         ln -sf ../o
624         %{__make} clean \
625                 RCS_FIND_IGNORE="-name '*.ko' -o" \
626                 M=$PWD O=$PWD/o \
627                 %{?with_verbose:V=1}
628
629         %{__make} -j1 \
630                 M=$PWD O=$PWD/o \
631                 CONSTIFY_PLUGIN="" \
632                 KBUILD_MODPOST_WARN=1 \
633                 %{?with_verbose:V=1}
634         mv $drv{,-dist}.ko
635         cd ..
636 done
637
638 cd ..
639
640 %endif
641
642 %install
643 rm -rf $RPM_BUILD_ROOT
644 install -d $RPM_BUILD_ROOT{%{_bindir},%{_aclocaldir},/dev,/var/{log,run/lirc}} \
645         $RPM_BUILD_ROOT/etc/{lirc,rc.d/init.d,sysconfig}
646
647 %if %{with kernel}
648 drivers=%{drivers}
649 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
650 for drv in $drivers; do
651         install drivers/$drv/$drv-%{?with_dist_kernel:dist}%{!?with_dist_kernel:nondist}.ko \
652         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/$drv.ko
653 done
654 %endif
655
656 %if %{with userspace}
657 %{__make} -j1 install \
658         DESTDIR=$RPM_BUILD_ROOT \
659         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
660
661 cat>$RPM_BUILD_ROOT%{_sysconfdir}/lirc/lircd.conf<<END
662 #
663 # This is a placeholder for your configuration file.
664 # See %{_docdir}/%{pname}-%{version}/remotes for some examples.
665 #
666 END
667 cp -f $RPM_BUILD_ROOT%{_sysconfdir}/lirc/lirc{,m}d.conf
668 install contrib/*.m4 $RPM_BUILD_ROOT%{_aclocaldir}
669 :> $RPM_BUILD_ROOT/var/log/lircd
670
671 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/lircd
672 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircd
673 install %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/lircmd
674 %endif
675
676 %clean
677 rm -rf $RPM_BUILD_ROOT
678
679 %post   libs -p /sbin/ldconfig
680 %postun libs -p /sbin/ldconfig
681
682 %post
683 /sbin/chkconfig --add lircd
684 if [ -f /var/lock/subsys/lircd ]; then
685         /etc/rc.d/init.d/lircd restart >&2
686 else
687         echo "Run \"/etc/rc.d/init.d/lircd start\" to start lircd." >&2
688 fi
689 /sbin/chkconfig --add lircmd
690 if [ -f /var/lock/subsys/lircmd ]; then
691         /etc/rc.d/init.d/lircmd restart >&2
692 else
693         echo "Run \"/etc/rc.d/init.d/lircmd start\" to start lircmd." >&2
694 fi
695 echo "If you are using a kernel-module-based driver, don't forget to"
696 echo "install the kernel%{_alt_kernel}-char-lirc-<your_driver> or"
697 echo "kernel%{_alt_kernel}-smp-char-lirc-<your_driver> package."
698
699 %preun
700 if [ "$1" = "0" ]; then
701         if [ -f /var/lock/subsys/lircd ]; then
702                 /etc/rc.d/init.d/lircd stop >&2
703         fi
704         /sbin/chkconfig --del lircd
705 fi
706 if [ "$1" = "0" ]; then
707         if [ -f /var/lock/subsys/lircmd ]; then
708                 /etc/rc.d/init.d/lircmd stop >&2
709         fi
710         /sbin/chkconfig --del lircmd
711 fi
712
713 %triggerpostun -- %{name} < 0.8.6-8
714 if [ -f %{_sysconfdir}/lircd.conf.rpmsave ]; then
715         mv -f %{_sysconfdir}/lircd.conf.rpmsave %{_sysconfdir}/lirc/lircd.conf
716 fi
717 if [ -f %{_sysconfdir}/lircmd.conf.rpmsave ]; then
718         mv -f %{_sysconfdir}/lircmd.conf.rpmsave %{_sysconfdir}/lirc/lircmd.conf
719 fi
720
721 %post   -n kernel%{_alt_kernel}-char-lirc-atiusb
722 %depmod %{_kernel_ver}
723 if [ "$1" = "1" ]; then
724         echo "Don't forget to add an 'alias lirc lirc_atiusb' line"
725         echo "to your /etc/modules.conf."
726 fi
727
728 %postun -n kernel%{_alt_kernel}-char-lirc-atiusb
729 %depmod %{_kernel_ver}
730
731 %post   -n kernel%{_alt_kernel}-char-lirc-bt829
732 %depmod %{_kernel_ver}
733 if [ "$1" = "1" ]; then
734         echo "Don't forget to add an 'alias lirc lirc_bt829' line"
735         echo "to your /etc/modules.conf."
736 fi
737
738 %postun -n kernel%{_alt_kernel}-char-lirc-bt829
739 %depmod %{_kernel_ver}
740
741 %post   -n kernel%{_alt_kernel}-char-lirc-dev
742 %depmod %{_kernel_ver}
743
744 %postun -n kernel%{_alt_kernel}-char-lirc-dev
745 %depmod %{_kernel_ver}
746
747 %post   -n kernel%{_alt_kernel}-char-lirc-ene0100
748 %depmod %{_kernel_ver}
749
750 %postun -n kernel%{_alt_kernel}-char-lirc-ene0100
751 %depmod %{_kernel_ver}
752
753 %post   -n kernel%{_alt_kernel}-char-lirc-gpio
754 %depmod %{_kernel_ver}
755 if [ "$1" = "1" ]; then
756         echo "Don't forget to add an 'alias lirc lirc_gpio' line"
757         echo "to your /etc/modules.conf."
758 fi
759
760 %postun -n kernel%{_alt_kernel}-char-lirc-gpio
761 %depmod %{_kernel_ver}
762
763 %post   -n kernel%{_alt_kernel}-char-lirc-i2c
764 %depmod %{_kernel_ver}
765 if [ "$1" = "1" ]; then
766         echo "Don't forget to add an 'alias lirc lirc_i2c' line"
767         echo "to your /etc/modules.conf."
768 fi
769
770 %postun -n kernel%{_alt_kernel}-char-lirc-i2c
771 %depmod %{_kernel_ver}
772
773 %post   -n kernel%{_alt_kernel}-char-lirc-igorplugusb
774 %depmod %{_kernel_ver}
775 if [ "$1" = "1" ]; then
776         echo "Don't forget to add an 'alias lirc lirc_igorplugusb' line"
777         echo "to your /etc/modules.conf."
778 fi
779
780 %postun -n kernel%{_alt_kernel}-char-lirc-igorplugusb
781 %depmod %{_kernel_ver}
782
783 %post   -n kernel%{_alt_kernel}-char-lirc-imon
784 %depmod %{_kernel_ver}
785 if [ "$1" = "1" ]; then
786         echo "Don't forget to add an 'alias lirc lirc_imon' line"
787         echo "to your /etc/modules.conf."
788 fi
789
790 %postun -n kernel%{_alt_kernel}-char-lirc-imon
791 %depmod %{_kernel_ver}
792
793 %post   -n kernel%{_alt_kernel}-char-lirc-sasem
794 %depmod %{_kernel_ver}
795 if [ "$1" = "1" ]; then
796         echo "Don't forget to add an 'alias lirc lirc_sasem' line"
797         echo "to your /etc/modules.conf."
798 fi
799
800 %postun -n kernel%{_alt_kernel}-char-lirc-sasem
801 %depmod %{_kernel_ver}
802
803 %post   -n kernel%{_alt_kernel}-char-lirc-serial
804 %depmod %{_kernel_ver}
805 if [ "$1" = "1" ]; then
806         echo "Don't forget to add an 'alias lirc lirc_serial' line"
807         echo "to your /etc/modules.conf."
808 fi
809
810 %postun -n kernel%{_alt_kernel}-char-lirc-serial
811 %depmod %{_kernel_ver}
812
813 %post   -n kernel%{_alt_kernel}-char-lirc-parallel
814 %depmod %{_kernel_ver}
815 if [ "$1" = "1" ]; then
816         echo "Don't forget to add an 'alias lirc lirc_parallel' line"
817         echo "to your /etc/modules.conf."
818 fi
819
820 %postun -n kernel%{_alt_kernel}-char-lirc-parallel
821 %depmod %{_kernel_ver}
822
823 %post   -n kernel%{_alt_kernel}-char-lirc-sir
824 %depmod %{_kernel_ver}
825 if [ "$1" = "1" ]; then
826         echo "Don't forget to add an 'alias lirc lirc_sir' line"
827         echo "to your /etc/modules.conf."
828 fi
829
830 %postun -n kernel%{_alt_kernel}-char-lirc-sir
831 %depmod %{_kernel_ver}
832
833 %post   -n kernel%{_alt_kernel}-char-lirc-ttusbir
834 %depmod %{_kernel_ver}
835 if [ "$1" = "1" ]; then
836         echo "Don't forget to add an 'alias lirc lirc_ttusbir' line"
837         echo "to your /etc/modules.conf."
838 fi
839
840 %postun -n kernel%{_alt_kernel}-char-lirc-ttusbir
841 %depmod %{_kernel_ver}
842
843 %post   -n kernel%{_alt_kernel}-char-lirc-wpc87691
844 %depmod %{_kernel_ver}
845 if [ "$1" = "1" ]; then
846         echo "Don't forget to add an 'alias lirc lirc_wpc87691' line"
847         echo "to your /etc/modules.conf."
848 fi
849
850 %postun -n kernel%{_alt_kernel}-char-lirc-wpc87691
851 %depmod %{_kernel_ver}
852
853 %if %{with userspace}
854 %files
855 %defattr(644,root,root,755)
856 %doc ANNOUNCE AUTHORS NEWS README TODO ChangeLog
857 %doc contrib/lircrc doc/{html,images,lirc.css}
858 %attr(755,root,root) %{_bindir}/ircat
859 %attr(755,root,root) %{_bindir}/irexec
860 %attr(755,root,root) %{_bindir}/irpty
861 %attr(755,root,root) %{_bindir}/irrecord
862 %attr(755,root,root) %{_bindir}/irsend
863 %attr(755,root,root) %{_bindir}/irw
864 %attr(755,root,root) %{_bindir}/mode2
865 %attr(755,root,root) %{_bindir}/lircrcd
866 %attr(755,root,root) %{_bindir}/pronto2lirc
867 %attr(755,root,root) %{_sbindir}/lircd
868 %attr(755,root,root) %{_sbindir}/lircmd
869 %attr(754,root,root) /etc/rc.d/init.d/lircd
870 %attr(754,root,root) /etc/rc.d/init.d/lircmd
871 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/lircd
872 %dir %{_sysconfdir}/lirc
873 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircd.conf
874 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lirc/lircmd.conf
875 %{_mandir}/man1/ircat.1*
876 %{_mandir}/man1/irexec.1*
877 %{_mandir}/man1/irpty.1*
878 %{_mandir}/man1/irrecord.1*
879 %{_mandir}/man1/irsend.1*
880 %{_mandir}/man1/irw.1*
881 %{_mandir}/man1/lircrcd.1*
882 %{_mandir}/man1/mode2.1*
883 %{_mandir}/man8/lircd.8*
884 %{_mandir}/man8/lircmd.8*
885 %attr(600,root,root) %ghost /var/log/lircd
886 %dir /var/run/lirc
887
888 %files remotes
889 %defattr(644,root,root,755)
890 # XXX: are jpegs in docs (remotes) a good idea?
891 %doc remotes
892
893 %if %{with x}
894 %files X11
895 %defattr(644,root,root,755)
896 %doc doc/irxevent.keys
897 %attr(755,root,root) %{_bindir}/irxevent
898 %attr(755,root,root) %{_bindir}/xmode2
899 %{_mandir}/man1/irxevent.1*
900 %{_mandir}/man1/xmode2.1*
901 %endif
902
903 %if %{with svga}
904 %files svga
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_bindir}/smode2
907 %{_mandir}/man1/smode2.1*
908 %endif
909
910 %files libs
911 %defattr(644,root,root,755)
912 %attr(755,root,root) %{_libdir}/liblirc_client.so.*.*.*
913 %attr(755,root,root) %ghost %{_libdir}/liblirc_client.so.0
914
915 %files devel
916 %defattr(644,root,root,755)
917 %attr(755,root,root) %{_libdir}/liblirc_client.so
918 %{_libdir}/liblirc_client.la
919 %{_includedir}/lirc
920 %{_aclocaldir}/lirc.m4
921
922 %files static
923 %defattr(644,root,root,755)
924 %{_libdir}/liblirc_client.a
925 %endif
926
927 %if %{with kernel}
928 %files -n kernel%{_alt_kernel}-char-lirc-atiusb
929 %defattr(644,root,root,755)
930 /lib/modules/%{_kernel_ver}/misc/lirc_atiusb.ko*
931
932 %files -n kernel%{_alt_kernel}-char-lirc-bt829
933 %defattr(644,root,root,755)
934 /lib/modules/%{_kernel_ver}/misc/lirc_bt829.ko*
935
936 %files -n kernel%{_alt_kernel}-char-lirc-dev
937 %defattr(644,root,root,755)
938 /lib/modules/%{_kernel_ver}/misc/lirc_dev.ko*
939
940 %if "%{_kernel_ver}" < "3.0.0"
941 %files -n kernel%{_alt_kernel}-char-lirc-ene0100
942 %defattr(644,root,root,755)
943 /lib/modules/%{_kernel_ver}/misc/lirc_ene0100.ko*
944 %endif
945
946 %if "%{_kernel_ver}" < "2.6.23"
947 %files -n kernel%{_alt_kernel}-char-lirc-gpio
948 %defattr(644,root,root,755)
949 /lib/modules/%{_kernel_ver}/misc/lirc_gpio.ko*
950 %endif
951
952 %files -n kernel%{_alt_kernel}-char-lirc-i2c
953 %defattr(644,root,root,755)
954 /lib/modules/%{_kernel_ver}/misc/lirc_i2c.ko*
955
956 %files -n kernel%{_alt_kernel}-char-lirc-igorplugusb
957 %defattr(644,root,root,755)
958 /lib/modules/%{_kernel_ver}/misc/lirc_igorplugusb.ko*
959
960 %files -n kernel%{_alt_kernel}-char-lirc-imon
961 %defattr(644,root,root,755)
962 /lib/modules/%{_kernel_ver}/misc/lirc_imon.ko*
963
964 %files -n kernel%{_alt_kernel}-char-lirc-sasem
965 %defattr(644,root,root,755)
966 /lib/modules/%{_kernel_ver}/misc/lirc_sasem.ko*
967
968 %files -n kernel%{_alt_kernel}-char-lirc-serial
969 %defattr(644,root,root,755)
970 /lib/modules/%{_kernel_ver}/misc/lirc_serial.ko*
971
972 %files -n kernel%{_alt_kernel}-char-lirc-sir
973 %defattr(644,root,root,755)
974 /lib/modules/%{_kernel_ver}/misc/lirc_sir.ko*
975
976 %files -n kernel%{_alt_kernel}-char-lirc-ttusbir
977 %defattr(644,root,root,755)
978 /lib/modules/%{_kernel_ver}/misc/lirc_ttusbir.ko*
979
980 %if "%{_kernel_ver}" < "3.0.0"
981 %files -n kernel%{_alt_kernel}-char-lirc-wpc87691
982 %defattr(644,root,root,755)
983 /lib/modules/%{_kernel_ver}/misc/lirc_wpc8769l.ko*
984 %endif
985
986 %files -n kernel%{_alt_kernel}-char-lirc-parallel
987 %defattr(644,root,root,755)
988 /lib/modules/%{_kernel_ver}/misc/lirc_parallel.ko*
989 %endif
This page took 0.134933 seconds and 4 git commands to generate.