]> git.pld-linux.org Git - packages/linux-live.git/blob - linux-live.spec
actually build with /pld/ in dir path; do not remove buildfiles
[packages/linux-live.git] / linux-live.spec
1 Summary:        Linux Live Kit
2 Name:           linux-live
3 Version:        1.8
4 Release:        0.1
5 Epoch:          1
6 License:        GPL
7 Group:          Applications/System
8 Source0:        https://github.com/Tomas-M/linux-live/archive/v%{version}.tar.gz?/%{name}-%{version}.tgz
9 # Source0-md5:  393c52991be3e4d21660e00b6bbf316c
10 Source1:        http://www.kernel.org/pub/linux/utils/boot/syslinux/syslinux-4.06.tar.gz
11 # Source1-md5:  ab705f8a0be0598770014bd5498b2eb2
12 Source2:        %{name}-build.sh
13 Patch0:         pld.patch
14 Patch1:         https://github.com/Tomas-M/linux-live/pull/5.patch
15 # Patch1-md5:   603c98f4c516929044bccf0419423586
16 URL:            http://www.linux-live.org/
17 BuildRequires:  nasm
18 BuildRequires:  perl-base
19 BuildRequires:  rpmbuild(macros) >= 1.583
20 Requires:       coreutils
21 Requires:       grep
22 Requires:       mawk
23 Requires:       mkisofs
24 Requires:       sed
25 Requires:       squashfs
26 # suggests for rebuidling isolinux
27 Suggests:       gcc
28 Suggests:       glibc-devel
29 Suggests:       gzip
30 Suggests:       make
31 Suggests:       nasm
32 Suggests:       perl-base
33 Suggests:       tar
34 Suggests:       wget
35 Obsoletes:      linux-live-build < 6.2.4-7
36 ExclusiveArch:  %{ix86} %{x8664} arm
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _libdir         %{_prefix}/lib
40 %define         _libexecdir     %{_libdir}/%{name}
41 %define         _sysconfdir     /etc/%{name}
42
43 # autostrip nothing and disable debug (it is supposed to be noarch)
44 %define         _noautoprov     lib.*\.so.* ld-linux.*\.so.*
45 %define         _noautoreq      %{_noautoprov}
46 %define         _noautostrip    .*
47 %define         _enable_debug_packages 0
48
49 # undefined sym: pthread_sigmask
50 %define         skip_post_check_so      libulockmgr.so.1.0.1
51
52 %description
53 Linux Live Kit is a set of shell scripts which allows you to create
54 your own Live Linux from an already installed Linux distribution. The
55 Live system you create will be bootable from CD-ROM or a disk device,
56 for example USB Flash Drive, USB Pen Drive, Camera connected to USB
57 port, and so on. People use Linux Live Kit to boot Linux from iPod as
58 well.
59
60 %description -l pl.UTF-8
61 Linux Live to zestaw skryptów powłoki pozwalających tworzyć własne
62 LiveCD z każdej dystrybucji Linuksa. Wystarczy zainstalować ulubioną
63 dystrybucję, usunąć wszystkie niepotrzebne pliki (na przykład strony
64 manuala i wszystkie inne nieistotne dla nas pliki), a następnie
65 ściągnąć i uruchomić te skrypty, aby stworzyć własnego Live Linuksa.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70 %patch1 -p1
71
72 cd initramfs/static
73 ./update
74 rm -v *-{i486,x86_64}
75 cd -
76
77 tar -xf %{SOURCE1} -C tools
78
79 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
80
81 %build
82 # rebuild isolinux to be in /pld/ subdir
83 cd tools
84 CC="%{__cc}" \
85 sed -e '/rm/d' ./isolinux.bin.update | sh -x
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_bindir},%{_sbindir}}
90 cp -a bootfiles bootinfo.txt build initramfs livekitlib tools $RPM_BUILD_ROOT%{_libexecdir}
91 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_sbindir}/linux-live-build
92
93 rm -r $RPM_BUILD_ROOT%{_libexecdir}/tools/syslinux-*
94
95 install -d $RPM_BUILD_ROOT%{_sysconfdir}
96 cp -p .config $RPM_BUILD_ROOT%{_sysconfdir}/config
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %doc README TODO DOC/*.txt
104 %attr(755,root,root) %{_sbindir}/linux-live-build
105 %dir %{_sysconfdir}
106 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
107 %dir %{_libexecdir}
108 %attr(755,root,root) %{_libexecdir}/build
109 %{_libexecdir}/livekitlib
110 %{_libexecdir}/bootinfo.txt
111
112 %dir %{_libexecdir}/bootfiles
113 %{_libexecdir}/bootfiles/bootinst.bat
114 %{_libexecdir}/bootfiles/bootinst.sh
115 %{_libexecdir}/bootfiles/bootlogo.png
116 %{_libexecdir}/bootfiles/extlinux.exe
117 %{_libexecdir}/bootfiles/isolinux.bin
118 %{_libexecdir}/bootfiles/mbr.bin
119 %{_libexecdir}/bootfiles/pxelinux.0
120 %{_libexecdir}/bootfiles/syslinux.cfg
121 %{_libexecdir}/bootfiles/syslinux.com
122 %{_libexecdir}/bootfiles/syslinux.exe
123 %{_libexecdir}/bootfiles/vesamenu.c32
124
125 %dir %{_libexecdir}/initramfs
126 %{_libexecdir}/initramfs/cleanup
127 %{_libexecdir}/initramfs/init
128 %{_libexecdir}/initramfs/initramfs_create
129
130 %dir %{_libexecdir}/initramfs/static
131 %{_libexecdir}/initramfs/static/busybox
132 %{_libexecdir}/initramfs/static/eject
133 %{_libexecdir}/initramfs/static/mount.dynfilefs
134 %{_libexecdir}/initramfs/static/mount.ntfs-3g
135 %{_libexecdir}/initramfs/static/update
136
137 %dir %{_libexecdir}/tools
138 %attr(755,root,root) %{_libexecdir}/tools/isolinux.bin.update
This page took 0.076191 seconds and 3 git commands to generate.