]> git.pld-linux.org Git - packages/linux-live.git/blob - linux-live.spec
updated BR deps
[packages/linux-live.git] / linux-live.spec
1 Summary:        Linux Live Kit
2 Name:           linux-live
3 Version:        1.8
4 Release:        0.1
5 Epoch:          1
6 License:        GPL
7 Group:          Applications/System
8 Source0:        https://github.com/Tomas-M/linux-live/archive/v%{version}.tar.gz?/%{name}-%{version}.tgz
9 # Source0-md5:  393c52991be3e4d21660e00b6bbf316c
10 Source1:        http://www.kernel.org/pub/linux/utils/boot/syslinux/syslinux-4.06.tar.gz
11 # Source1-md5:  ab705f8a0be0598770014bd5498b2eb2
12 Source2:        %{name}-build.sh
13 Patch0:         pld.patch
14 Patch1:         https://github.com/Tomas-M/linux-live/pull/5.patch
15 # Patch1-md5:   603c98f4c516929044bccf0419423586
16 URL:            http://www.linux-live.org/
17 BuildRequires:  libuuid-devel
18 BuildRequires:  nasm
19 BuildRequires:  perl-base
20 BuildRequires:  rpmbuild(macros) >= 1.583
21 BuildRequires:  upx
22 Requires:       coreutils
23 Requires:       grep
24 Requires:       mawk
25 Requires:       mkisofs
26 Requires:       sed
27 Requires:       squashfs
28 # suggests for rebuidling isolinux
29 Suggests:       gcc
30 Suggests:       glibc-devel
31 Suggests:       gzip
32 Suggests:       make
33 Suggests:       nasm
34 Suggests:       perl-base
35 Suggests:       tar
36 Suggests:       wget
37 Obsoletes:      linux-live-build < 6.2.4-7
38 ExclusiveArch:  %{ix86} %{x8664} arm
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _libdir         %{_prefix}/lib
42 %define         _libexecdir     %{_libdir}/%{name}
43 %define         _sysconfdir     /etc/%{name}
44
45 # autostrip nothing and disable debug (it is supposed to be noarch)
46 %define         _noautoprov     lib.*\.so.* ld-linux.*\.so.*
47 %define         _noautoreq      %{_noautoprov}
48 %define         _noautostrip    .*
49 %define         _enable_debug_packages 0
50
51 # undefined sym: pthread_sigmask
52 %define         skip_post_check_so      libulockmgr.so.1.0.1
53
54 %description
55 Linux Live Kit is a set of shell scripts which allows you to create
56 your own Live Linux from an already installed Linux distribution. The
57 Live system you create will be bootable from CD-ROM or a disk device,
58 for example USB Flash Drive, USB Pen Drive, Camera connected to USB
59 port, and so on. People use Linux Live Kit to boot Linux from iPod as
60 well.
61
62 %description -l pl.UTF-8
63 Linux Live to zestaw skryptów powłoki pozwalających tworzyć własne
64 LiveCD z każdej dystrybucji Linuksa. Wystarczy zainstalować ulubioną
65 dystrybucję, usunąć wszystkie niepotrzebne pliki (na przykład strony
66 manuala i wszystkie inne nieistotne dla nas pliki), a następnie
67 ściągnąć i uruchomić te skrypty, aby stworzyć własnego Live Linuksa.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73
74 cd initramfs/static
75 ./update
76 rm -v *-{i486,x86_64}
77 cd -
78
79 tar -xf %{SOURCE1} -C tools
80
81 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
82
83 %build
84 # rebuild isolinux to be in /pld/ subdir
85 cd tools
86 CC="%{__cc}" \
87 sed -e '/rm/d' ./isolinux.bin.update | sh -x
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_bindir},%{_sbindir}}
92 cp -a bootfiles bootinfo.txt build initramfs livekitlib tools $RPM_BUILD_ROOT%{_libexecdir}
93 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_sbindir}/linux-live-build
94
95 rm -r $RPM_BUILD_ROOT%{_libexecdir}/tools/syslinux-*
96
97 install -d $RPM_BUILD_ROOT%{_sysconfdir}
98 cp -p .config $RPM_BUILD_ROOT%{_sysconfdir}/config
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %files
104 %defattr(644,root,root,755)
105 %doc README TODO DOC/*.txt
106 %attr(755,root,root) %{_sbindir}/linux-live-build
107 %dir %{_sysconfdir}
108 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
109 %dir %{_libexecdir}
110 %attr(755,root,root) %{_libexecdir}/build
111 %{_libexecdir}/livekitlib
112 %{_libexecdir}/bootinfo.txt
113
114 %dir %{_libexecdir}/bootfiles
115 %{_libexecdir}/bootfiles/bootinst.bat
116 %{_libexecdir}/bootfiles/bootinst.sh
117 %{_libexecdir}/bootfiles/bootlogo.png
118 %{_libexecdir}/bootfiles/extlinux.exe
119 %{_libexecdir}/bootfiles/isolinux.bin
120 %{_libexecdir}/bootfiles/mbr.bin
121 %{_libexecdir}/bootfiles/pxelinux.0
122 %{_libexecdir}/bootfiles/syslinux.cfg
123 %{_libexecdir}/bootfiles/syslinux.com
124 %{_libexecdir}/bootfiles/syslinux.exe
125 %{_libexecdir}/bootfiles/vesamenu.c32
126
127 %dir %{_libexecdir}/initramfs
128 %{_libexecdir}/initramfs/cleanup
129 %{_libexecdir}/initramfs/init
130 %{_libexecdir}/initramfs/initramfs_create
131
132 %dir %{_libexecdir}/initramfs/static
133 %{_libexecdir}/initramfs/static/busybox
134 %{_libexecdir}/initramfs/static/eject
135 %{_libexecdir}/initramfs/static/mount.dynfilefs
136 %{_libexecdir}/initramfs/static/mount.ntfs-3g
137 %{_libexecdir}/initramfs/static/update
138
139 %dir %{_libexecdir}/tools
140 %attr(755,root,root) %{_libexecdir}/tools/isolinux.bin.update
This page took 0.103228 seconds and 3 git commands to generate.