]> git.pld-linux.org Git - packages/linux-live.git/blob - linux-live.spec
349aed8c88a9bb3eac5f3a46b754eb3e47c067a2
[packages/linux-live.git] / linux-live.spec
1 Summary:        Linux Live Kit
2 Name:           linux-live
3 Version:        1.8
4 Release:        0.1
5 Epoch:          1
6 License:        GPL
7 Group:          Applications/System
8 Source0:        https://github.com/Tomas-M/linux-live/archive/v%{version}.tar.gz?/%{name}-%{version}.tgz
9 # Source0-md5:  393c52991be3e4d21660e00b6bbf316c
10 Source1:        http://www.kernel.org/pub/linux/utils/boot/syslinux/syslinux-4.06.tar.gz
11 # Source1-md5:  ab705f8a0be0598770014bd5498b2eb2
12 Source2:        %{name}-build.sh
13 Patch0:         https://github.com/Tomas-M/linux-live/pull/5.patch
14 # Patch0-md5:   603c98f4c516929044bccf0419423586
15 URL:            http://www.linux-live.org/
16 BuildRequires:  nasm
17 BuildRequires:  perl-base
18 BuildRequires:  rpmbuild(macros) >= 1.583
19 Requires:       coreutils
20 Requires:       grep
21 Requires:       mawk
22 Requires:       mkisofs
23 Requires:       sed
24 Requires:       squashfs
25 # suggests for rebuidling isolinux
26 Suggests:       gcc
27 Suggests:       glibc-devel
28 Suggests:       gzip
29 Suggests:       make
30 Suggests:       nasm
31 Suggests:       perl-base
32 Suggests:       tar
33 Suggests:       wget
34 Obsoletes:      linux-live-build < 6.2.4-7
35 ExclusiveArch:  %{ix86} %{x8664} arm
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _libdir         %{_prefix}/lib
39 %define         _libexecdir     %{_libdir}/%{name}
40 %define         _sysconfdir     /etc/%{name}
41
42 # autostrip nothing and disable debug (it is supposed to be noarch)
43 %define         _noautoprov     lib.*\.so.* ld-linux.*\.so.*
44 %define         _noautoreq      %{_noautoprov}
45 %define         _noautostrip    .*
46 %define         _enable_debug_packages 0
47
48 # undefined sym: pthread_sigmask
49 %define         skip_post_check_so      libulockmgr.so.1.0.1
50
51 %description
52 Linux Live Kit is a set of shell scripts which allows you to create
53 your own Live Linux from an already installed Linux distribution. The
54 Live system you create will be bootable from CD-ROM or a disk device,
55 for example USB Flash Drive, USB Pen Drive, Camera connected to USB
56 port, and so on. People use Linux Live Kit to boot Linux from iPod as
57 well.
58
59 %description -l pl.UTF-8
60 Linux Live to zestaw skryptów powłoki pozwalających tworzyć własne
61 LiveCD z każdej dystrybucji Linuksa. Wystarczy zainstalować ulubioną
62 dystrybucję, usunąć wszystkie niepotrzebne pliki (na przykład strony
63 manuala i wszystkie inne nieistotne dla nas pliki), a następnie
64 ściągnąć i uruchomić te skrypty, aby stworzyć własnego Live Linuksa.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69
70 cd initramfs/static
71 ./update
72 rm -v *-{i486,x86_64}
73 cd -
74
75 tar -xf %{SOURCE1} -C tools
76
77 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
78
79 %build
80 # rebuild isolinux to be in /pld/ subdir
81 cd tools
82 CC="%{__cc}" \
83 sh -x ./isolinux.bin.update
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_bindir},%{_sbindir}}
88 cp -a bootfiles bootinfo.txt build initramfs livekitlib tools $RPM_BUILD_ROOT%{_libexecdir}
89 install -p %{SOURCE2} $RPM_BUILD_ROOT%{_sbindir}/linux-live-build
90
91 install -d $RPM_BUILD_ROOT%{_sysconfdir}
92 cp -p .config $RPM_BUILD_ROOT%{_sysconfdir}/config
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README TODO DOC/*.txt
100 %attr(755,root,root) %{_sbindir}/linux-live-build
101 %dir %{_sysconfdir}
102 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
103 %dir %{_libexecdir}
104 %attr(755,root,root) %{_libexecdir}/build
105 %{_libexecdir}/livekitlib
106 %{_libexecdir}/bootinfo.txt
107
108 %dir %{_libexecdir}/bootfiles
109 %{_libexecdir}/bootfiles/bootinst.bat
110 %{_libexecdir}/bootfiles/bootinst.sh
111 %{_libexecdir}/bootfiles/bootlogo.png
112 %{_libexecdir}/bootfiles/extlinux.exe
113 %{_libexecdir}/bootfiles/isolinux.bin
114 %{_libexecdir}/bootfiles/mbr.bin
115 %{_libexecdir}/bootfiles/pxelinux.0
116 %{_libexecdir}/bootfiles/syslinux.cfg
117 %{_libexecdir}/bootfiles/syslinux.com
118 %{_libexecdir}/bootfiles/syslinux.exe
119 %{_libexecdir}/bootfiles/vesamenu.c32
120
121 %dir %{_libexecdir}/initramfs
122 %{_libexecdir}/initramfs/cleanup
123 %{_libexecdir}/initramfs/init
124 %{_libexecdir}/initramfs/initramfs_create
125
126 %dir %{_libexecdir}/initramfs/static
127 %{_libexecdir}/initramfs/static/busybox
128 %{_libexecdir}/initramfs/static/eject
129 %{_libexecdir}/initramfs/static/mount.dynfilefs
130 %{_libexecdir}/initramfs/static/mount.ntfs-3g
131 %{_libexecdir}/initramfs/static/update
132
133 %dir %{_libexecdir}/tools
134 %attr(755,root,root) %{_libexecdir}/tools/isolinux.bin.update
This page took 0.242607 seconds and 2 git commands to generate.