]> git.pld-linux.org Git - packages/linux-kvm.git/blob - linux-kvm.spec
- release 3
[packages/linux-kvm.git] / linux-kvm.spec
1 # TODO: use linux tarball when kernel 3.1 is released
2 %define rel     3
3 %define snap    20110726
4 Summary:        Native Linux KVM tool
5 Name:           linux-kvm
6 Version:        3.1
7 Release:        0.%{snap}.%{rel}
8 License:        GPL v2
9 Group:          Applications/System
10 # git://github.com/penberg/linux-kvm.git
11 Source0:        %{name}-%{version}-%{snap}.tar.bz2
12 # Source0-md5:  b0b94a75d915f70ae14a089ddc7d7abb
13 BuildRequires:  binutils-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The goal of this tool is to provide a clean, from-scratch, lightweight
18 KVM host tool implementation that can boot Linux guest images (just a
19 hobby, won't be big and professional like QEMU) with no BIOS
20 dependencies and with only the minimal amount of legacy device
21 emulation.
22
23 %prep
24 %setup -q -n %{name}
25
26 %build
27 %{__make} -C tools/kvm \
28         CC="%{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags}" \
29         V=1
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33
34 install -d $RPM_BUILD_ROOT%{_sbindir}
35
36 install tools/kvm/kvm $RPM_BUILD_ROOT%{_sbindir}
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %files
42 %defattr(644,root,root,755)
43 %doc tools/kvm/Documentation/* tools/kvm/README
44 %attr(755,root,root) %{_sbindir}/kvm
This page took 0.050509 seconds and 4 git commands to generate.