]> git.pld-linux.org Git - packages/linux-kvm.git/blob - linux-kvm.spec
BR binutils-devel
[packages/linux-kvm.git] / linux-kvm.spec
1 # TODO: use linux tarball when kernel 3.1 is released
2 %define snap    20110726
3 Summary:        Native Linux KVM tool
4 Name:           linux-kvm
5 Version:        3.1
6 Release:        0.%{snap}.1
7 License:        GPL v2
8 Group:          Applications/System
9 # git://github.com/penberg/linux-kvm.git
10 Source0:        %{name}-%{version}-%{snap}.tar.bz2
11 # Source0-md5:  b0b94a75d915f70ae14a089ddc7d7abb
12 BuildRequires:  binutils-devel
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 The goal of this tool is to provide a clean, from-scratch, lightweight
17 KVM host tool implementation that can boot Linux guest images (just a
18 hobby, won't be big and professional like QEMU) with no BIOS
19 dependencies and with only the minimal amount of legacy device
20 emulation.
21
22 %prep
23 %setup -q -n %{name}
24
25 %build
26 %{__make} -C tools/kvm \
27         CC="%{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags}" \
28         V=1
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32
33 install -d $RPM_BUILD_ROOT%{_sbindir}
34
35 install tools/kvm/kvm $RPM_BUILD_ROOT%{_sbindir}
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(644,root,root,755)
42 %doc tools/kvm/Documentation/* tools/kvm/README
43 %attr(755,root,root) %{_sbindir}/kvm
This page took 0.054032 seconds and 4 git commands to generate.