]> git.pld-linux.org Git - packages/linux-kvm.git/blob - linux-kvm.spec
eed00f9511b3348d56ef2d81d3e0a04e7b24cc05
[packages/linux-kvm.git] / linux-kvm.spec
1 # TODO: use linux tarball when kernel 3.1 is released
2 %define rel     23
3 %define snap    20110726
4 Summary:        Native Linux KVM tool
5 Summary(pl.UTF-8):      Natywne narzędzie KVM dla Linuksa
6 Name:           linux-kvm
7 Version:        3.1
8 Release:        0.%{snap}.%{rel}
9 License:        GPL v2
10 Group:          Applications/System
11 # git://github.com/penberg/linux-kvm.git
12 Source0:        %{name}-%{version}-%{snap}.tar.bz2
13 # Source0-md5:  b0b94a75d915f70ae14a089ddc7d7abb
14 Patch0:         fix-types.patch
15 BuildRequires:  binutils-devel
16 BuildRequires:  glibc-devel(ix86)
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The goal of this tool is to provide a clean, from-scratch, lightweight
21 KVM host tool implementation that can boot Linux guest images (just a
22 hobby, won't be big and professional like QEMU) with no BIOS
23 dependencies and with only the minimal amount of legacy device
24 emulation.
25
26 %description -l pl.UTF-8
27 Celem tego narzędzia jest dostarczenie czystej, lekkiej, napisanej od
28 zera implementacji hosta KVM, potrafiącego uruchamiać obrazy gościa
29 Linuksa (tylko hobby, nie będzie duża i profesjonalna jak QEMU) bez
30 zależności oD BIOS-u i z minimalną emulacją tradycyjnych urządzeń.
31
32 %prep
33 %setup -q -n %{name}
34 %patch0 -p1
35
36 %build
37 %{__make} -C tools/kvm \
38         CC="%{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags}" \
39         WERROR=0 \
40         V=1
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_sbindir}
45
46 install tools/kvm/kvm $RPM_BUILD_ROOT%{_sbindir}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc tools/kvm/Documentation/* tools/kvm/README
54 %attr(755,root,root) %{_sbindir}/kvm
This page took 0.031796 seconds and 2 git commands to generate.