]> git.pld-linux.org Git - packages/linphone.git/blob - linphone.spec
- up to 0.12.0
[packages/linphone.git] / linphone.spec
1 # TODO:
2 #  - split main package to few smaller (there is linphonec for console,
3 #    auto-answering machine and linphone applet for gnome)
4 #  - check why --enable-alsa doesn't require alsa-lib-devel
5 #  - check if all this configure option I've set are really needed
6
7 Summary:        Linphone Internet Phone
8 Summary(pl):    Linphone - telefon internetowy
9 Name:           linphone
10 Version:        0.12.0
11 Release:        0.1
12 License:        LGPL/GPL
13 Group:          Applications/Communications
14 Source0:        http://simon.morlat.free.fr/download/%{version}/source/%{name}-%{version}.tar.gz
15 # Source0-md5:  79abbdcbec4c59cdd28a2722fe333b6e
16 Patch0:         %{name}-DESTDIR.patch
17 Patch1:         %{name}-automake.patch
18 #Patch2:                %{name}-system-libs.patch
19 URL:            http://www.linphone.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  ffmpeg-devel >= 0.4.5
23 BuildRequires:  gnome-panel-devel
24 BuildRequires:  libgnomeui-devel
25 BuildRequires:  libgsm-devel >= 1.0.10
26 BuildRequires:  libosip-devel >= 0.9.7
27 BuildRequires:  libtool >= 1:1.4.2-9
28 BuildRequires:  lpc10-devel >= 1.5
29 BuildRequires:  scrollkeeper
30 BuildRequires:  speex-devel >= 1.0.0
31 BuildRequires:  xft-devel
32 Requires(post,postun):  /sbin/ldconfig
33 Requires(post,postun):  /usr/bin/scrollkeeper-update
34 Requires:       applnk
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _sysconfdir     /etc/X11/GNOME
38 %define         _gtkdocdir      %{_defaultdocdir}/gtk-doc/html
39
40 %description
41 Linphone is a web phone: it let you phone to your friends anywhere in
42 the whole world, freely, simply by using the internet. The cost of the
43 phone call is the cost that you spend connected to the internet.
44
45 Here are the main features of linphone:
46     - Works with the GNOME Desktop under linux.
47     - Works as simply as a cellular phone. Two buttons, no more.
48     - Understands the SIP protocol.
49     - You just require a soundcard to use linphone.
50     - Linphone is free software, released under the General Public
51       Licence.
52     - Linphone is documented: there is a complete user manual readable
53       from the application that explains you all you need to know.
54
55 %description -l pl
56 Linphone to telefon internetowy - pozwala dzwoniæ do znajomych na
57 ca³ym ¶wiecie bez dodatkowych op³at, u¿ywaj±c tylko Internetu.
58
59 G³ówne cechy linphone:
60  - dzia³anie ze ¶rodowiskiem GNOME
61  - na¶ladowanie prostego telefonu komórkowego - tylko dwa przyciski
62  - obs³uga protoko³u SIP
63  - wymaga karty d¼wiêkowej
64  - jest wolnodostêpnym oprogramowaniem (na licencji GPL)
65  - ma dokumentacjê: pe³ny podrêcznik dostêpny z aplikacji.
66
67 %package devel
68 Summary:        Linphone Internet Phone - header files
69 Summary(pl):    Telefon internetowy Linphone - pliki nag³ówkowe
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}
72 Requires:       gtk-doc-common
73
74 %description devel
75 Development files for the Linphone Internet Phone.
76
77 %description devel -l pl
78 Pliki dla programistów u¿ywaj±cych telefonu internetowego Linphone.
79
80 %package static
81 Summary:        Linphone static libraries
82 Summary(pl):    Statyczne biblioteki Linphone
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}
85
86 %description static
87 Static version of Linphone libraries.
88
89 %description static -l pl
90 Statyczne wersje bibliotek Linphone.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 #%patch2 -p1
97
98 %build
99 rm -f missing
100 # gettext 0.11.5 used
101 #%%{__gettextize}
102 %{__libtoolize}
103 %{__aclocal} -I /usr/share/aclocal/gnome2-macros
104 %{__autoconf}
105 %{__automake}
106 cd oRTP
107         %{__libtoolize}
108         %{__aclocal}
109         %{__autoconf}
110         # don't use -f here
111         automake -a -c --foreign
112 cd ..
113 %configure \
114         --with-html-dir=%{_gtkdocdir} \
115         --enable-platform-gnome-2 \
116         --enable-alsa \
117         --enable-ipv6
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications \
123         $RPM_BUILD_ROOT%{_sysconfdir}/CORBA/servers \
124         $RPM_BUILD_ROOT%{_pixmapsdir}
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT \
128         HTML_DIR=%{_gtkdocdir}
129
130 install share/linphone.desktop $RPM_BUILD_ROOT%{_applnkdir}/Network/Communications
131 install share/linphone.gnorba $RPM_BUILD_ROOT%{_sysconfdir}/CORBA/servers
132 install pixmaps/*.png pixmaps/*.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
133
134 %find_lang %{name} --with-gnome --all-name
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post
140 /usr/bin/scrollkeeper-update
141 /sbin/ldconfig
142
143 %postun
144 /usr/bin/scrollkeeper-update
145 /sbin/ldconfig
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc AUTHORS BUGS ChangeLog NEWS README TODO
150 %config(noreplace) %{_sysconfdir}/CORBA/servers/*
151 %attr(755,root,root) %{_bindir}/*
152 %attr(755,root,root) %{_libdir}/lib*.so.*.*
153 %{_applnkdir}/Network/Communications/*
154 %{_pixmapsdir}/*
155 %{_datadir}/sounds/*
156 %{_datadir}/linphonec
157 %{_mandir}/man*/*
158 %{_libdir}/bonobo/servers/GNOME_LinphoneApplet.server
159 %attr(755,root,root) %{_libdir}/linphone_applet
160 %{_datadir}/gnome-2.0/ui/GNOME_LinphoneApplet.xml
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/*.so
165 %{_libdir}/*.la
166 %{_includedir}/ortp
167 %{_includedir}/osipua
168 %{_gtkdocdir}/*
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/*.a
This page took 0.05188 seconds and 3 git commands to generate.