]> git.pld-linux.org Git - packages/linphone.git/blob - linphone.spec
- do not list %{_desktopdir}/* -- dangerous, could list directories unexpectedly
[packages/linphone.git] / linphone.spec
1 # TODO:
2 #  - split main package to few smaller (there is linphonec for console,
3 #    auto-answering machine and linphone applet for gnome)
4 #  - check if all this configure option I've set are really needed
5 #  - separate libraries that do not require gnome into subpackages for Jingle support in kopete
6 Summary:        Linphone Internet Phone
7 Summary(pl):    Linphone - telefon internetowy
8 Name:           linphone
9 Version:        1.3.5
10 Release:        1
11 License:        LGPL/GPL
12 Group:          Applications/Communications
13 Source0:        http://simon.morlat.free.fr/download/1.3.x/source/%{name}-%{version}.tar.gz
14 # Source0-md5:  522b08a22c5e1de281676cddd3f2bcf6
15 Patch0:         %{name}-desktop.patch
16 Patch1:         %{name}-system-libs.patch
17 URL:            http://www.linphone.org/
18 BuildRequires:  alsa-lib-devel >= 0.9.0
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  ffmpeg-devel >= 0.4.5
22 BuildRequires:  gettext-devel
23 BuildRequires:  gnome-common >= 2.8.0
24 BuildRequires:  gnome-panel-devel
25 BuildRequires:  gtk-doc
26 BuildRequires:  jack-audio-connection-kit-devel >= 0.15.0
27 BuildRequires:  libgnomeui-devel
28 BuildRequires:  libgsm-devel >= 1.0.10
29 BuildRequires:  libosip2-devel >= 2.2.0
30 BuildRequires:  libsamplerate-devel >= 0.0.13
31 BuildRequires:  libtool >= 1:1.4.2-9
32 BuildRequires:  lpc10-devel >= 1.5
33 BuildRequires:  ortp-devel >= 0.9.1
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.98
36 BuildRequires:  scrollkeeper
37 BuildRequires:  speex-devel >= 1.0.0
38 Requires(post,postun):  /sbin/ldconfig
39 Requires(post,postun):  /usr/bin/scrollkeeper-update
40 Requires:       ortp >= 0.9.1
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Linphone is a web phone: it let you phone to your friends anywhere in
45 the whole world, freely, simply by using the internet. The cost of the
46 phone call is the cost that you spend connected to the internet.
47
48 Here are the main features of linphone:
49 - Works with the GNOME Desktop under linux.
50 - Works as simply as a cellular phone. Two buttons, no more.
51 - Understands the SIP protocol.
52 - You just require a soundcard to use linphone.
53 - Linphone is free software, released under the General Public
54   Licence.
55 - Linphone is documented: there is a complete user manual readable
56   from the application that explains you all you need to know.
57
58 %description -l pl
59 Linphone to telefon internetowy - pozwala dzwoniæ do znajomych na
60 ca³ym ¶wiecie bez dodatkowych op³at, u¿ywaj±c tylko Internetu.
61
62 G³ówne cechy linphone:
63 - dzia³anie ze ¶rodowiskiem GNOME
64 - na¶ladowanie prostego telefonu komórkowego - tylko dwa przyciski
65 - obs³uga protoko³u SIP
66 - wymaga karty d¼wiêkowej
67 - jest wolnodostêpnym oprogramowaniem (na licencji GPL)
68 - ma dokumentacjê: pe³ny podrêcznik dostêpny z aplikacji.
69
70 %package devel
71 Summary:        Linphone Internet Phone - header files
72 Summary(pl):    Telefon internetowy Linphone - pliki nag³ówkowe
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       alsa-lib-devel >= 0.9.0
76 Requires:       glib2-devel >= 2.0.0
77 Requires:       gtk-doc-common
78 Requires:       jack-audio-connection-kit-devel >= 0.15.0
79 Requires:       libgsm-devel >= 1.0.10
80 Requires:       libosip2-devel >= 2.2.0
81 Requires:       libsamplerate-devel >= 0.0.13
82 Requires:       lpc10-devel >= 1.5
83 Requires:       ortp-devel >= 0.9.1
84 Requires:       speex-devel >= 1.0.0
85
86 %description devel
87 Development files for the Linphone Internet Phone.
88
89 %description devel -l pl
90 Pliki dla programistów u¿ywaj±cych telefonu internetowego Linphone.
91
92 %package static
93 Summary:        Linphone static libraries
94 Summary(pl):    Statyczne biblioteki Linphone
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 Static version of Linphone libraries.
100
101 %description static -l pl
102 Statyczne wersje bibliotek Linphone.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108
109 %build
110 # requires .po file fixes
111 #%%{__glib_gettextize}
112 %{__libtoolize}
113 %{__aclocal} -I m4
114 %{__autoconf}
115 %{__autoheader}
116 %{__automake}
117 %configure \
118         --with-html-dir=%{_gtkdocdir} \
119         --enable-alsa \
120         --enable-ipv6
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT%{_desktopdir} \
126         $RPM_BUILD_ROOT%{_pixmapsdir}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install share/linphone.desktop $RPM_BUILD_ROOT%{_desktopdir}
132 install pixmaps/*.png pixmaps/*.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
133
134 # kill .desktop in GNOME1-specific location
135 rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/apps
136
137 %find_lang %{name} --with-gnome --all-name
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 /usr/bin/scrollkeeper-update
144 /sbin/ldconfig
145
146 %postun
147 /usr/bin/scrollkeeper-update
148 /sbin/ldconfig
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc AUTHORS BUGS ChangeLog NEWS README TODO
153 %attr(755,root,root) %{_bindir}/*
154 %attr(755,root,root) %{_libdir}/liblinphone.so.*.*.*
155 %attr(755,root,root) %{_libdir}/linphone_applet
156 %{_libdir}/mediastream
157 %{_libdir}/bonobo/servers/GNOME_LinphoneApplet.server
158 %{_datadir}/gnome-2.0/ui/GNOME_LinphoneApplet.xml
159 %{_datadir}/sounds/*
160 %{_desktopdir}/*.desktop
161 %{_pixmapsdir}/*
162 %{_mandir}/man1/*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/liblinphone.so
167 %{_libdir}/liblinphone.la
168 %{_includedir}/linphone
169 %{_gtkdocdir}/mediastreamer
170 %{_pkgconfigdir}/*.pc
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/liblinphone.a
This page took 0.076956 seconds and 3 git commands to generate.