]> git.pld-linux.org Git - packages/link-grammar.git/blob - link-grammar.spec
0f758861b592d7d52bf2733a79dbaf3077fed9b7
[packages/link-grammar.git] / link-grammar.spec
1 #
2 # Conditional build:
3 %bcond_without  java    # Java bindings
4 %bcond_without  perl    # Perl bindings
5 %bcond_without  python  # Python bindings
6
7 Summary:        Link Grammar - a syntactic parser of English
8 Summary(pl.UTF-8):      Link Grammar - składniowy analizator języka angielskiego
9 Name:           link-grammar
10 Version:        5.7.0
11 Release:        1
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        http://www.nl.abisource.com/downloads/link-grammar/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  69c51be8cba7a23bbea5b80e41b51891
16 Patch0:         %{name}-modules.patch
17 URL:            http://www.link.cs.cmu.edu/link/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  gcc >= 6:4.7
21 %{?with_java:BuildRequires:     jdk}
22 BuildRequires:  hunspell-devel
23 BuildRequires:  libedit-devel
24 BuildRequires:  libstdc++-devel >= 6:4.7
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  pcre2-8-devel
27 %{?with_perl:BuildRequires:     perl-devel}
28 BuildRequires:  pkgconfig
29 %{?with_perl:BuildRequires:     swig-perl >= 2.0.0}
30 %if %{with python}
31 BuildRequires:  swig-python >= 2.0.0
32 BuildRequires:  python-devel >= 1:2.6
33 BuildRequires:  python3-devel >= 1:3.4
34 %endif
35 BuildRequires:  rpmbuild(macros) >= 1.714
36 BuildRequires:  sqlite3-devel >= 3.0.0
37 BuildRequires:  zlib-devel
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 The Link Grammar Parser is a syntactic parser of English, based on
42 link grammar, an original theory of English syntax. Given a sentence,
43 the system assigns to it a syntactic structure, which consists of a
44 set of labeled links connecting pairs of words. The parser also
45 produces a "constituent" representation of a sentence (showing noun
46 phrases, verb phrases, etc.).
47
48 %description -l pl.UTF-8
49 Parser Link Grammar to składniowy analizator języka angielskiego
50 oparty na gramatyce łączeń - oryginalnej teorii składni języka
51 angielskiego. Po podaniu zdania system przypisuje mu strukturę
52 składniową, składającą się ze zbioru oznaczonych łączeń wiążących pary
53 słów. Analizator tworzy także składową reprezentację zdania
54 (pokazującą frazy rzeczownika, frazy czasownika itp.).
55
56 %package devel
57 Summary:        Header files for link-grammar library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki link-grammar
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Header files for link-grammar library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki link-grammar.
67
68 %package static
69 Summary:        Static link-grammar library
70 Summary(pl.UTF-8):      Statyczna biblioteka link-grammar
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static link-grammar library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka link-grammar.
79
80 %package -n java-link-grammar
81 Summary:        Java binding for link-grammar library
82 Summary(pl.UTF-8):      Wiązanie Javy do biblioteki link-grammar
83 Group:          Libraries/Java
84 Requires:       %{name} = %{version}-%{release}
85
86 %description -n java-link-grammar
87 Java binding for link-grammar library.
88
89 %description -n java-link-grammar -l pl.UTF-8
90 Wiązanie Javy do biblioteki link-grammar.
91
92 %package -n perl-linkgrammar
93 Summary:        Perl binding for link-grammar library
94 Summary(pl.UTF-8):      Wiązanie Perla do biblioteki link-grammar
95 Group:          Development/Languages/Perl
96 Requires:       %{name} = %{version}-%{release}
97
98 %description -n perl-linkgrammar
99 Perl binding for link-grammar library.
100
101 %description -n perl-linkgrammar -l pl.UTF-8
102 Wiązanie Perla do biblioteki link-grammar.
103
104 %package -n python-linkgrammar
105 Summary:        Python 2 binding for link-grammar library
106 Summary(pl.UTF-8):      Wiązanie Pythona 2 do biblioteki link-grammar
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       python-libs >= 1:2.6
110
111 %description -n python-linkgrammar
112 Python 2 binding for link-grammar library.
113
114 %description -n python-linkgrammar -l pl.UTF-8
115 Wiązanie Pythona 2 do biblioteki link-grammar.
116
117 %package -n python3-linkgrammar
118 Summary:        Python 3 binding for link-grammar library
119 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki link-grammar
120 Group:          Libraries/Python
121 Requires:       %{name} = %{version}-%{release}
122 Requires:       python3-libs >= 1:3.4
123
124 %description -n python3-linkgrammar
125 Python 3 binding for link-grammar library.
126
127 %description -n python3-linkgrammar -l pl.UTF-8
128 Wiązanie Pythona 3 do biblioteki link-grammar.
129
130 %prep
131 %setup -q
132 %patch0 -p1
133
134 %build
135 %{__libtoolize}
136 %{__aclocal} -I m4
137 %{__autoconf}
138 %{__automake}
139 %configure \
140         %{!?with_java:--disable-java-bindings} \
141         %{?with_perl:--enable-perl-bindings} \
142         %{!?with_python:--disable-python-bindings} \
143         --disable-silent-rules
144
145 %{__make} -j1 \
146         pkgperldir=%{perl_vendorarch} \
147         python2dir=%{py_sitedir} \
148         python3dir=%{py3_sitedir}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT \
155         pkgperldir=%{perl_vendorarch} \
156         python2dir=%{py_sitedir} \
157         python3dir=%{py3_sitedir}
158
159 %if %{with java}
160 %{__rm} $RPM_BUILD_ROOT%{_libdir}/liblink-grammar-java.la \
161         $RPM_BUILD_ROOT%{_libdir}/liblink-grammar-java.a
162 %endif
163 %if %{with perl}
164 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/clinkgrammar.la \
165         $RPM_BUILD_ROOT%{perl_vendorarch}/clinkgrammar.a
166 %endif
167 %if %{with python}
168 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/linkgrammar/_clinkgrammar.la \
169         $RPM_BUILD_ROOT%{py_sitedir}/linkgrammar/_clinkgrammar.a
170 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/linkgrammar/_clinkgrammar.la \
171         $RPM_BUILD_ROOT%{py3_sitedir}/linkgrammar/_clinkgrammar.a
172
173 %py_postclean
174 %endif
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -p /sbin/ldconfig
180 %postun -p /sbin/ldconfig
181
182 %files
183 %defattr(644,root,root,755)
184 %doc AUTHORS ChangeLog LICENSE MAINTAINERS NEWS README.md TODO
185 %attr(755,root,root) %{_bindir}/link-parser
186 %attr(755,root,root) %{_libdir}/liblink-grammar.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/liblink-grammar.so.5
188 %{_datadir}/link-grammar
189 %{_mandir}/man1/link-parser.1*
190
191 %files devel
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_libdir}/liblink-grammar.so
194 %{_libdir}/liblink-grammar.la
195 %{_includedir}/link-grammar
196 %{_pkgconfigdir}/link-grammar.pc
197
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/liblink-grammar.a
201
202 %if %{with java}
203 %files -n java-link-grammar
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/liblink-grammar-java.so.*.*.*
206 %attr(755,root,root) %ghost %{_libdir}/liblink-grammar-java.so.5
207 %attr(755,root,root) %{_libdir}/liblink-grammar-java.so
208 %{_javadir}/linkgrammar-%{version}.jar
209 %{_javadir}/linkgrammar.jar
210 %endif
211
212 %if %{with perl}
213 %files -n perl-linkgrammar
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{perl_vendorarch}/clinkgrammar.so
216 %{perl_vendorarch}/clinkgrammar.pm
217 %endif
218
219 %if %{with python}
220 %files -n python-linkgrammar
221 %defattr(644,root,root,755)
222 %dir %{py_sitedir}/linkgrammar
223 %attr(755,root,root) %{py_sitedir}/linkgrammar/_clinkgrammar.so
224 %{py_sitedir}/linkgrammar/*.py[co]
225
226 %files -n python3-linkgrammar
227 %defattr(644,root,root,755)
228 %{py3_sitedir}/linkgrammar.pth
229 %dir %{py3_sitedir}/linkgrammar
230 %attr(755,root,root) %{py3_sitedir}/linkgrammar/_clinkgrammar.so
231 %{py3_sitedir}/linkgrammar/*.py
232 %{py3_sitedir}/linkgrammar/__pycache__
233 %endif
This page took 0.110057 seconds and 2 git commands to generate.