]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
36c1f56b5e7f175d4efed7f9b8b6ee89e4a61629
[packages/lilypond.git] / lilypond.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # build docs
4 #
5 Summary:        Music typesetter
6 Summary(pl.UTF-8):      Program do składania nut
7 Name:           lilypond
8 # note: 2.22.x is stable, 2.23.x devel
9 Version:        2.22.0
10 Release:        1
11 License:        GPL v3+ with font exception
12 Group:          Applications/Sound
13 Source0:        https://lilypond.org/download/sources/v2.22/%{name}-%{version}.tar.gz
14 # Source0-md5:  4b0d869873b0120bda2e8bd94e1a628a
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-sh.patch
17 Patch2:         %{name}-aclocal.patch
18 Patch3:         %{name}-mf.patch
19 URL:            http://www.lilypond.org/
20 BuildRequires:  autoconf >= 2.60
21 BuildRequires:  automake
22 BuildRequires:  bison >= 2.4.1
23 BuildRequires:  flex >= 2.5.4a
24 BuildRequires:  fontconfig >= 1:2.4.0
25 BuildRequires:  fontconfig-devel >= 1:2.4.0
26 BuildRequires:  fontforge >= 20110222
27 BuildRequires:  fonts-TTF-DejaVu
28 BuildRequires:  fonts-Type1-urw
29 BuildRequires:  freetype >= 1:2.1.10
30 BuildRequires:  gettext-tools >= 0.17
31 BuildRequires:  ghostscript-fonts-std
32 BuildRequires:  glib2-devel >= 1:2.38
33 BuildRequires:  guile-devel >= 5:1.8.2
34 BuildRequires:  kpathsea-devel
35 BuildRequires:  libstdc++-devel >= 5:3.4
36 BuildRequires:  pango-devel >= 1:1.38.0
37 BuildRequires:  perl-base
38 BuildRequires:  pkgconfig >= 1:0.9.0
39 BuildRequires:  python3-devel >= 1:3.5
40 BuildRequires:  python3-modules >= 1:3.5
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  t1utils
43 BuildRequires:  texinfo >= 6.1
44 BuildRequires:  texlive-fonts-other
45 BuildRequires:  texlive-metapost
46 %if %{with doc}
47 BuildRequires:  ImageMagick
48 BuildRequires:  ImageMagick-coder-png
49 BuildRequires:  dblatex >= 0.1.4
50 BuildRequires:  ghostscript >= 9.20
51 BuildRequires:  netpbm-progs
52 BuildRequires:  rsync
53 BuildRequires:  texi2html >= 1.82
54 BuildRequires:  texinfo-texi2dvi >= 6.1
55 # `kpsewhich tex epsf`
56 BuildRequires:  texlive
57 # `kpsewhich -format=mf fikparm`
58 BuildRequires:  texlive-fonts-lh
59 BuildRequires:  texlive-latex-bibtex
60 BuildRequires:  texlive-xetex
61 BuildRequires:  zip
62 %endif
63 BuildConflicts: lilypond < 1.6.0
64 Requires:       fonts-TTF-DejaVu
65 Requires:       ghostscript >= 9.20
66 Requires:       glib2 >= 1:2.38
67 Requires:       pango >= 1:1.38.0
68 Requires:       python3-modules >= 1:3.5
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         texmfdir        %{_datadir}/texmf
72 %define         texmfdistdir    %{texmfdir}-dist
73 %if "%{pld_release}" != "th"
74 %define         texfontsdir     %{texmfdir}/fonts
75 %else
76 %define         texfontsdir     %{texmfdistdir}/fonts
77 %endif
78
79 %description
80 LilyPond is a music typesetter. It produces beautiful sheet music
81 using a high level description file as input. It excels at typesetting
82 classical music, but you can also print pop-songs. With LilyPond we
83 hope to make music publication software available to anyone on the
84 internet.
85
86 %description -l pl.UTF-8
87 LilyPond jest programem do składu muzycznego. Produkuje piękne
88 partytury używając języka wysokiego poziomu jako wejście. Służy przede
89 wszystkim do składania nut muzyki klasycznej, ale można drukować także
90 piosenki pop. Autorzy udostępniają LilyPond z nadzieją dostarczenia
91 wszystkim oprogramowania do publikacji muzycznych.
92
93 %package -n emacs-lilypond-mode-pkg
94 Summary:        LilyPond mode for Emacs
95 Summary(pl.UTF-8):      Tryb edycji plików LilyPond dla Emacsa
96 Group:          Applications/Editors/Emacs
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       emacs
99
100 %description -n emacs-lilypond-mode-pkg
101 LilyPond mode for Emacs.
102
103 %description -n emacs-lilypond-mode-pkg -l pl.UTF-8
104 Tryb edycji plików LilyPond dla Emacsa.
105
106 %package -n vim-syntax-lilypond
107 Summary:        LilyPond files support for Vim
108 Summary(pl.UTF-8):      Obsługa plików LilyPonda dla Vima
109 Group:          Applications/Editors/Vim
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       vim-rt >= 4:6.4.001-2
112
113 %description -n vim-syntax-lilypond
114 LilyPond files support for Vim.
115
116 %description -n vim-syntax-lilypond -l pl.UTF-8
117 Obsługa plików LilyPonda dla Vima.
118
119 %prep
120 %setup -q
121 %patch0 -p1
122 %patch1 -p1
123 %patch2 -p1
124 %patch3 -p1
125
126 %build
127 %{__autoconf}
128 %configure \
129         PYTHON=%{__python3} \
130         %{?debug:--disable-optimising} \
131         --with-texgyre-dir=%{texfontsdir}/opentype/public/tex-gyre/ \
132         %{__enable_disable doc documentation}
133 %{__make} -j1
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT{%{texmfdir}/{dvips,tex},%{texfontsdir}/{source,tfm/lilypond,type1/lilypond}}
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 cp -p mf/out/*.tfm $RPM_BUILD_ROOT%{texfontsdir}/tfm/lilypond
143 cp -p mf/out/*.pfb $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
144
145 find $RPM_BUILD_ROOT -name fonts.cache-1 | xargs rm -f
146
147 # ?
148 %{__mv} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
149         $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
150 # for latex and dvips
151 %{__mv} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/tex \
152         $RPM_BUILD_ROOT%{texmfdir}/tex/lilypond
153 # both for lilypond and dvips
154 ln -sf %{_datadir}/lilypond/%{version}/ps \
155         $RPM_BUILD_ROOT%{texmfdir}/dvips/lilypond
156
157 # vim syntax/etc. files
158 install -d $RPM_BUILD_ROOT%{_datadir}/vim
159 %{__mv} $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/vim \
160         $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles
161
162 %find_lang %{name}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %pre
168 test -h %{texmfdir}/dvips/lilypond || rm -rf %{texmfdir}/dvips/lilypond
169
170 %post
171 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
172 [ ! -x %{_bindir}/texhash ] || %{_bindir}/texhash 1>&2
173 [ ! -x %{_bindir}/scrollkeeper-update ] || %{_bindir}/scrollkeeper-update
174
175 %postun
176 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
177 [ ! -x %{_bindir}/texhash ] || %{_bindir}/texhash 1>&2
178 [ ! -x %{_bindir}/scrollkeeper-update ] || %{_bindir}/scrollkeeper-update
179
180 %files -f %{name}.lang
181 %defattr(644,root,root,755)
182 %doc AUTHORS.txt DEDICATION LICENSE* NEWS.txt README.md ROADMAP
183 %attr(755,root,root) %{_bindir}/abc2ly
184 %attr(755,root,root) %{_bindir}/convert-ly
185 %attr(755,root,root) %{_bindir}/etf2ly
186 %attr(755,root,root) %{_bindir}/lilymidi
187 %attr(755,root,root) %{_bindir}/lilypond
188 %attr(755,root,root) %{_bindir}/lilypond-book
189 %attr(755,root,root) %{_bindir}/lilypond-invoke-editor
190 %attr(755,root,root) %{_bindir}/lilysong
191 %attr(755,root,root) %{_bindir}/midi2ly
192 %attr(755,root,root) %{_bindir}/musicxml2ly
193 %dir %{_datadir}/lilypond
194 %dir %{_datadir}/lilypond/%{version}
195 %{_datadir}/lilypond/%{version}/fonts
196 %{_datadir}/lilypond/%{version}/ly
197 %{_datadir}/lilypond/%{version}/ps
198 %{_datadir}/lilypond/%{version}/python
199 %{_datadir}/lilypond/%{version}/scm
200
201 %{texfontsdir}/source/lilypond
202 %{texfontsdir}/tfm/lilypond
203 %{texfontsdir}/type1/lilypond
204 %{texmfdir}/dvips/lilypond
205 %{texmfdir}/tex/lilypond
206
207 %if %{with doc}
208 %{_infodir}/lilypond-*.info*
209 %{_infodir}/music-glossary.info*
210 %{_mandir}/man1/abc2ly.1*
211 %{_mandir}/man1/convert-ly.1*
212 %{_mandir}/man1/etf2ly.1*
213 %{_mandir}/man1/lilymidi.1*
214 %{_mandir}/man1/lilypond.1*
215 %{_mandir}/man1/lilypond-book.1*
216 %{_mandir}/man1/lilypond-invoke-editor.1*
217 %{_mandir}/man1/lilysong.1*
218 %{_mandir}/man1/midi2ly.1*
219 %{_mandir}/man1/musicxml2ly.1*
220 %endif
221
222 %files -n emacs-lilypond-mode-pkg
223 %defattr(644,root,root,755)
224 %{_datadir}/emacs/site-lisp/lilypond-*.el
225
226 %files -n vim-syntax-lilypond
227 %defattr(644,root,root,755)
228 %{_datadir}/vim/vimfiles/compiler/lilypond.vim
229 %{_datadir}/vim/vimfiles/ftdetect/lilypond.vim
230 %{_datadir}/vim/vimfiles/ftplugin/lilypond.vim
231 %{_datadir}/vim/vimfiles/indent/lilypond.vim
232 %{_datadir}/vim/vimfiles/syntax/lilypond*
This page took 0.054896 seconds and 2 git commands to generate.