]> git.pld-linux.org Git - packages/lightdm.git/blob - lightdm.spec
- fix library name and paths in lightdm-qt pkgconfigs
[packages/lightdm.git] / lightdm.spec
1 Summary:        A lightweight display manager
2 Summary(hu.UTF-8):      Egy könnyűsúlyú bejelentkezéskezelő
3 Name:           lightdm
4 Version:        1.7.0
5 Release:        2
6 # library/bindings are LGPLv2 or LGPLv3, the rest GPLv3+
7 License:        (LGPLv2 or LGPLv3) and GPLv3+
8 Group:          X11/Applications
9 Source0:        https://launchpad.net/lightdm/1.8/%{version}/+download/%{name}-%{version}.tar.xz
10 # Source0-md5:  8149739fde801982cfcc8006133df21d
11 Source1:        %{name}.pamd
12 Patch0:         lightdm-qt-3.patch
13 Patch2:         upstart-path.patch
14 URL:            http://www.freedesktop.org/wiki/Software/LightDM
15 BuildRequires:  QtCore-devel
16 BuildRequires:  QtDBus-devel
17 BuildRequires:  QtGui-devel
18 BuildRequires:  QtNetwork-devel
19 BuildRequires:  autoconf
20 BuildRequires:  dbus-glib-devel
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  gettext-devel
23 BuildRequires:  gnome-common
24 BuildRequires:  gnome-doc-utils
25 BuildRequires:  gtk+2-devel >= 2:2.24
26 BuildRequires:  gtk-doc
27 BuildRequires:  gtk-webkit-devel
28 BuildRequires:  intltool
29 BuildRequires:  itstool
30 BuildRequires:  libtool
31 BuildRequires:  libxklavier-devel
32 BuildRequires:  pam-devel
33 BuildRequires:  perl-XML-Parser
34 BuildRequires:  perl-base
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.583
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  vala
39 BuildRequires:  xz
40 BuildRequires:  yelp-tools
41 Requires:       /usr/bin/X
42 Requires:       dbus-x11
43 Requires:       lightdm-greeter
44 Provides:       XDM
45 Provides:       group(xdm)
46 Provides:       user(xdm)
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 An X display manager that:
51  - Has a lightweight codebase
52  - Is standards compliant (PAM, ConsoleKit, etc)
53  - Has a well defined interface between the server and user interface
54  - Fully themeable (easiest with the webkit interface)
55  - Cross-desktop (greeters can be written in any toolkit)
56
57 %description -l hu.UTF-8
58 Egy X bejelentkezéskezelő, amely:
59  - pehelysúlyú kóddal rendelkezik
60  - követi a standardokat (PAM, ConsoleKit, stb.)
61  - jól-definiált felület a szerver és a felhasználói felület között
62  - teljesen témázható (a legkönnyebb a webkit felülettel)
63  - desktop-független (üdvözlők bármilyen eszközkészlettel írhatók)
64
65 %package libs-gobject
66 Summary:        LightDM GObject client library
67 Group:          Libraries
68 Obsoletes:      lightdm-libs < 1.7.0-0.6
69
70 %description libs-gobject
71 This package contains a GObject based library for LightDM clients to
72 use to interface with LightDM.
73
74 %package libs-gobject-devel
75 Summary:        Development files for %{name}-gobject
76 Group:          Development/Libraries
77 Group:          Libraries
78 Requires:       %{name}-libs-gobject = %{version}-%{release}
79
80 %description libs-gobject-devel
81 This package contains development files for a GObject based library
82 for LightDM clients to use to interface with LightDM.
83
84 %package libs-qt
85 Summary:        LightDM Qt client library
86 Group:          Libraries
87 Conflicts:      lightdm-libs < 1.7.0-0.6
88
89 %description libs-qt
90 This package contains a Qt based library for LightDM clients to use to
91 interface with LightDM.
92
93 %package libs-qt-devel
94 Summary:        Development files for %{name}-qt
95 Group:          Development/Libraries
96 Requires:       %{name}-libs-qt = %{version}-%{release}
97
98 %description libs-qt-devel
99 This package contains development files for a Qt based library for
100 LightDM clients to use to interface with LightDM.
101
102 %package apidocs
103 Summary:        lightdm API documentation
104 Group:          Documentation
105
106 %description apidocs
107 lightdm API documentation.
108
109 %package upstart
110 Summary:        Upstart job for lightdm
111 Summary(hu.UTF-8):      Upstart támogatás lightdm-hez
112 Group:          Daemons
113 Requires:       %{name} = %{epoch}:%{version}-%{release}
114 Requires:       upstart >= 0.6
115
116 %description upstart
117 Upstart job for lightdm.
118
119 %description upstart -l hu.UTF-8
120 Upstart támogatás lightdm-hez.
121
122 %prep
123 %setup -q
124 %patch0 -p1
125 %patch2 -p1
126
127 %build
128 %{__libtoolize}
129 %{__gtkdocize}
130 %{__aclocal}
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         --disable-silent-rules \
136         --disable-static \
137         --disable-tests \
138         --enable-liblightdm-qt \
139         --with-html-dir=%{_gtkdocdir} \
140         --enable-gtk-doc \
141         --with-greeter-session=lightdm-gtk-greeter \
142         --with-greeter-user=xdm
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 install -d $RPM_BUILD_ROOT/etc/{pam.d,security,init,dbus-1/system.d} \
151         $RPM_BUILD_ROOT/home/services/xdm \
152         $RPM_BUILD_ROOT%{_datadir}/xgreeters \
153         $RPM_BUILD_ROOT%{_datadir}/lightdm/remote-sessions \
154         $RPM_BUILD_ROOT/var/{log,cache}/lightdm
155
156 cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/lightdm
157 touch $RPM_BUILD_ROOT/etc/security/blacklist.lightdm
158 cp -p data/init/%{name}.conf $RPM_BUILD_ROOT/etc/init
159
160 # We don't ship AppAmor
161 rm -rv $RPM_BUILD_ROOT%{_sysconfdir}/apparmor.d
162
163 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{lb,wae}
164
165 %find_lang %{name} --with-gnome
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %pre
171 %groupadd -g 55 -r -f xdm
172 %useradd -u 55 -r -d /home/services/xdm -s /bin/false -c "X Display Manager" -g xdm xdm
173
174 %post   libs-gobject -p /sbin/ldconfig
175 %postun libs-gobject -p /sbin/ldconfig
176
177 %post   libs-qt -p /sbin/ldconfig
178 %postun libs-qt -p /sbin/ldconfig
179
180 %post upstart
181 %upstart_post lightdm
182
183 %postun upstart
184 %upstart_postun lightdm
185
186 if [ "$1" = "0" ]; then
187         %userremove xdm
188         %groupremove xdm
189 fi
190
191 %files -f %{name}.lang
192 %defattr(644,root,root,755)
193 %doc NEWS
194 %dir %{_sysconfdir}/%{name}
195 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.conf
196 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/keys.conf
197 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/users.conf
198 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/lightdm
199 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/lightdm-autologin
200 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/lightdm-greeter
201 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.lightdm
202 /etc/dbus-1/system.d/org.freedesktop.DisplayManager.conf
203 %attr(755,root,root) %{_bindir}/dm-tool
204 %attr(755,root,root) %{_sbindir}/lightdm
205 %dir %{_libdir}/%{name}
206 %attr(755,root,root) %{_libdir}/%{name}/gdmflexiserver
207 %attr(755,root,root) %{_libdir}/%{name}/lightdm-guest-session-wrapper
208 %attr(755,root,root) %{_libdir}/%{name}/lightdm-set-defaults
209 %{_libdir}/girepository-1.0/LightDM-1.typelib
210 %dir %{_datadir}/xgreeters
211 %dir %{_datadir}/%{name}
212 %dir %{_datadir}/%{name}/remote-sessions
213 %{_mandir}/man1/lightdm*
214 %dir %attr(710,root,root) /var/cache/lightdm
215 %dir %attr(710,root,root) /var/log/lightdm
216 %dir %attr(750,xdm,xdm) /home/services/xdm
217
218 %files libs-gobject
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/liblightdm-gobject-1.so.*.*.*
221 %attr(755,root,root) %ghost %{_libdir}/liblightdm-gobject-1.so.0
222
223 %files libs-qt
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_libdir}/liblightdm-qt-3.so.*.*.*
226 %attr(755,root,root) %ghost %{_libdir}/liblightdm-qt-3.so.0
227
228 %files libs-gobject-devel
229 %defattr(644,root,root,755)
230 %{_datadir}/gir-1.0/LightDM-1.gir
231 %{_includedir}/lightdm-gobject-1
232 %{_pkgconfigdir}/liblightdm-gobject-1.pc
233 %{_libdir}/liblightdm-gobject-1.la
234 %attr(755,root,root) %{_libdir}/liblightdm-gobject-1.so
235 # -vala
236 %{_datadir}/vala/vapi/liblightdm-gobject-1.vapi
237
238 %files libs-qt-devel
239 %defattr(644,root,root,755)
240 %{_libdir}/liblightdm-qt-3.la
241 %attr(755,root,root) %{_libdir}/liblightdm-qt-3.so
242 %{_includedir}/lightdm-qt-3
243 %{_pkgconfigdir}/liblightdm-qt-3.pc
244
245 %files apidocs
246 %defattr(644,root,root,755)
247 %{_gtkdocdir}/lightdm-gobject-1
248
249 %files upstart
250 %defattr(644,root,root,755)
251 %config(noreplace) %verify(not md5 mtime size) /etc/init/%{name}.conf
This page took 0.145198 seconds and 3 git commands to generate.