]> git.pld-linux.org Git - packages/libzypp.git/blob - libzypp.spec
- updated to 17.31.9
[packages/libzypp.git] / libzypp.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_with     rpm5            # rpm5 fork instead of rpm.org
5 %bcond_with     zchunk          # zchunk compression
6 #
7 Summary:        Package management library
8 Summary(pl.UTF-8):      Biblioteka do zarządzania pakietami
9 Name:           libzypp
10 Version:        17.31.9
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries
14 #Source0Download: https://github.com/openSUSE/libzypp/tags
15 Source0:        https://github.com/openSUSE/libzypp/archive/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  b21539939f0b885b633914ba00c4e1af
17 Patch0:         %{name}-rpm5.patch
18 Patch1:         %{name}-link.patch
19 Patch2:         %{name}-gpgme-pkgconfig.patch
20 URL:            https://en.opensuse.org/Portal:Libzypp
21 BuildRequires:  boost-devel
22 BuildRequires:  cmake >= 3.1
23 BuildRequires:  curl-devel
24 %{?with_apidocs:BuildRequires:  doxygen}
25 BuildRequires:  expat-devel >= 1.95
26 BuildRequires:  gettext-tools
27 BuildRequires:  glib2-devel >= 2.0
28 BuildRequires:  gpgme-devel
29 BuildRequires:  libproxy-devel
30 BuildRequires:  libsigc++-devel >= 2.0
31 # with helixrepo enabled
32 BuildRequires:  libsolv-devel >= 0.6.8
33 BuildRequires:  libstdc++-devel >= 6:5
34 BuildRequires:  libxml2-devel >= 2.0
35 BuildRequires:  openssl-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  protobuf-devel >= 3.8.0
38 %if %{with rpm5}
39 BuildRequires:  rpm-devel >= 5
40 %else
41 BuildRequires:  rpm-devel >= 1:4.15
42 %endif
43 BuildRequires:  udev-devel
44 BuildRequires:  yaml-cpp-devel
45 %{?with_zchunk:BuildRequires:   zchunk-devel}
46 BuildRequires:  zlib-devel
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 libzypp is the package management library that powers applications
51 like YaST, zypper and the openSUSE/SLE implementation of PackageKit.
52
53 %description -l pl.UTF-8
54 libzypp to biblioteka do zarządzania pakietami wspomagająca aplikacje
55 takie jak YaST, zypper czy implementacja PackageKit wykorzystywana w
56 dystrybucjach openSUSE/SLE.
57
58 %package devel
59 Summary:        Header files for Zypp library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Zypp
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       boost-devel
64 Requires:       curl-devel
65 Requires:       libsolv-devel >= 0.6.8
66 Requires:       libstdc++-devel >= 6:5
67 Requires:       libxml2-devel >= 2.0
68 %if %{with rpm5}
69 Requires:       rpm-devel >= 5
70 %else
71 Requires:       rpm-devel >= 1:4.15
72 %endif
73
74 %description devel
75 Header files for Zypp library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki Zypp.
79
80 %package apidocs
81 Summary:        Zypp API documentation
82 Summary(pl.UTF-8):      Dokumentacja API biblioteki Zypp
83 Group:          Documentation
84
85 %description apidocs
86 API documentation for Zypp library.
87
88 %description apidocs -l pl.UTF-8
89 Dokumentacja API biblioteki Zypp.
90
91 %prep
92 %setup -q
93 %if %{with rpm5}
94 %patch0 -p1
95 %endif
96 %patch1 -p1
97 %patch2 -p1
98
99 %build
100 install -d build
101 cd build
102 # MEDIABACKEND_TESTS require nginx+fcgi+fcgi++
103 %cmake .. \
104         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
105         %{?with_apidocs:-DENABLE_BUILD_DOCS=ON} \
106         -DENABLE_BUILD_TRANS=ON \
107         -DDISABLE_MEDIABACKEND_TESTS=ON \
108         %{?with_zchunk:-DENABLE_ZCHUNK_COMPRESSION=ON}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} -C build install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %{__mv} $RPM_BUILD_ROOT%{_docdir}/packages/libzypp/libzypp/html $RPM_BUILD_ROOT%{_docdir}/libzypp-apidocs
119 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/packages/libzypp/libzypp/libzypp.doxytag
120
121 %find_lang zypp
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files -f zypp.lang
130 %defattr(644,root,root,755)
131 %doc COPYING
132 %dir %{_sysconfdir}/zypp
133 %config(noreplace) %verify(not mtime md5 size) %{_sysconfdir}/zypp/needreboot
134 %config(noreplace) %verify(not mtime md5 size) %{_sysconfdir}/zypp/systemCheck
135 %config(noreplace) %verify(not mtime md5 size) %{_sysconfdir}/zypp/zypp.conf
136 %config(noreplace) %verify(not mtime md5 size) /etc/logrotate.d/zypp-history.lr
137 %attr(755,root,root) %{_bindir}/zypp-CheckAccessDeleted
138 %attr(755,root,root) %{_bindir}/zypp-NameReqPrv
139 %attr(755,root,root) %{_libdir}/libzypp.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libzypp.so.1722
141 %dir %{_libexecdir}/zypp
142 %attr(755,root,root) %{_libexecdir}/zypp/zypp-rpm
143 %{_datadir}/zypp
144 %{_mandir}/man1/zypp-CheckAccessDeleted.1*
145 %{_mandir}/man1/zypp-NameReqPrv.1*
146 %{_mandir}/man5/locks.5*
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/libzypp.so
151 %{_includedir}/zypp
152 %{_includedir}/zypp-core
153 %{_includedir}/zypp-curl
154 %{_includedir}/zypp-media
155 %{_pkgconfigdir}/libzypp.pc
156 %{_datadir}/cmake/Modules/FindZypp.cmake
157 %{_datadir}/cmake/Modules/ZyppCommon.cmake
158
159 %if %{with apidocs}
160 %files apidocs
161 %defattr(644,root,root,755)
162 %{_docdir}/libzypp-apidocs
163 %endif
This page took 0.095054 seconds and 3 git commands to generate.