]> git.pld-linux.org Git - packages/libyubikey.git/blob - libyubikey.spec
d1cf5fd363c8902fe262fe5b8a4c97ec85bcfcbf
[packages/libyubikey.git] / libyubikey.spec
1 %bcond_without  tests
2 #
3 Summary:        C library for decrypting and parsing Yubikey One-time passwords
4 Name:           libyubikey
5 Version:        1.13
6 Release:        1
7 License:        BSD
8 Group:          Development/Libraries
9 Group:          Libraries
10 URL:            http://opensource.yubico.com/yubico-c
11 Source0:        http://opensource.yubico.com/yubico-c/releases/%{name}-%{version}.tar.gz
12 # Source0-md5:  6e84fc1914ab5b609319945c18d45835
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 This package holds a low-level C software development kit for the
17 Yubico authentication device, the Yubikey.
18
19 %package devel
20 Summary:        Development files for libyubikey
21 Group:          Development/Libraries
22 Requires:       %{name} = %{version}-%{release}
23
24 %description devel
25 This package contains the header file needed to develop applications
26 that use libyubikey.
27
28 %prep
29 %setup -q
30
31 %build
32 %configure \
33         --disable-static \
34         --disable-silent-rules \
35
36 %{__make}
37
38 %if %{with tests}
39 export LD_LIBRARY_PATH=$RPM_BUILD_DIR/%{name}-%{version}/.libs
40 %{__make} check
41 %endif
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT \
48         INSTALL="%{__install} -p"
49
50 %clean
51 %{__rm} -rf $RPM_BUILD_ROOT
52
53 %post -p /sbin/ldconfig
54 %postun -p /sbin/ldconfig
55
56 %files
57 %defattr(644,root,root,755)
58 %doc AUTHORS NEWS ChangeLog README
59 %attr(755,root,root) %{_bindir}/modhex
60 %attr(755,root,root) %{_bindir}/ykparse
61 %attr(755,root,root) %{_bindir}/ykgenerate
62 %attr(755,root,root) %ghost %{_libdir}/libyubikey.so.0
63 %attr(755,root,root) %{_libdir}/libyubikey.so.*.*
64 %{_mandir}/man1/ykgenerate.1*
65 %{_mandir}/man1/ykparse.1*
66 %{_mandir}/man1/modhex.1*
67
68 %files devel
69 %defattr(644,root,root,755)
70 %{_includedir}/yubikey.h
71 %attr(755,root,root) %{_libdir}/libyubikey.so
72 %{_libdir}/libyubikey.la
This page took 0.06168 seconds and 2 git commands to generate.