]> git.pld-linux.org Git - packages/libxslt.git/blob - libxslt.spec
- release 2 (by relup.sh)
[packages/libxslt.git] / libxslt.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # don't build python binding
4 %bcond_without  static_libs     # don't build static library
5 %bcond_with     tests           # run test suite
6 #
7 %define         libxml2ver      1:2.6.30
8
9 Summary:        XSLT processor
10 Summary(pl.UTF-8):      Procesor XSLT
11 Summary(pt_BR.UTF-8):   Biblioteca que disponibiliza o sistema XSLT do GNOME
12 Name:           libxslt
13 Version:        1.1.28
14 Release:        2
15 License:        MIT
16 Group:          Libraries
17 #Source0:       http://ftp.gnome.org/pub/GNOME/sources/libxslt/1.1/%{name}-%{version}.tar.bz2
18 Source0:        ftp://xmlsoft.org/libxml2/%{name}-%{version}.tar.gz
19 # Source0-md5:  9667bf6f9310b957254fdcf6596600b7
20 Patch0:         %{name}-m4.patch
21 URL:            http://xmlsoft.org/XSLT/
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake
24 BuildRequires:  libgcrypt-devel >= 1.1.42
25 BuildRequires:  libtool >= 2:2.0
26 BuildRequires:  libxml2-devel >= %{libxml2ver}
27 BuildRequires:  perl-base
28 %if %{with python}
29 BuildRequires:  python
30 BuildRequires:  python-devel
31 BuildRequires:  python-libxml2 >= %{libxml2ver}
32 %endif
33 BuildRequires:  rpm-pythonprov
34 Requires:       libgcrypt >= 1.1.42
35 Requires:       libxml2 >= %{libxml2ver}
36 Obsoletes:      libxslt1
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Library for XSLT processing.
41
42 %description -l pl.UTF-8
43 Biblioteka do przetwarzania XSLT.
44
45 %description -l pt_BR.UTF-8
46 Esta biblioteca C permite a transformação de arquivos XML em outros
47 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
48 transformação dos estilos XSLT. O comando xsltproc é uma interface em
49 linha de comandos para o mecanismo XSLT.
50
51 %package devel
52 Summary:        Header files for libxslt
53 Summary(pl.UTF-8):      Pliki nagłówkowe libxslt
54 Summary(pt_BR.UTF-8):   Bibliotecas, includes, etc. para incluir o mecanismo XSLT do GNOME
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       libgcrypt-devel >= 1.1.42
58 Requires:       libxml2-devel >= %{libxml2ver}
59 Obsoletes:      libxslt1-devel
60
61 %description devel
62 Header files for libxslt - XSLT processor.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe procesora XSLT.
66
67 %description devel -l pt_BR.UTF-8
68 Esta biblioteca C permite a transformação de arquivos XML em outros
69 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
70 transformação dos estilos XSLT.
71
72 %package static
73 Summary:        Static libraries of libxslt
74 Summary(pl.UTF-8):      Biblioteki statyczne libxslt
75 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para incluir o mecanismo XSLT do GNOME
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static libraries of libxslt - XSLT processor.
81
82 %description static -l pl.UTF-8
83 Statyczne biblioteki procesora XSLT.
84
85 %description static -l pt_BR.UTF-8
86 Esta biblioteca C permite a transformação de arquivos XML em outros
87 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
88 transformação dos estilos XSLT. Estas são as bibliotecas em sua versão
89 estática.
90
91 %package progs
92 Summary:        XSLT processor
93 Summary(pl.UTF-8):      Procesor XSLT
94 Group:          Applications/Text
95 Requires:       %{name} = %{version}-%{release}
96 Obsoletes:      libxslt-proc
97
98 %description progs
99 XSLT processor.
100
101 %description progs -l pl.UTF-8
102 Procesor XSLT.
103
104 %package -n python-%{name}
105 Summary:        Python support for libxslt
106 Summary(pl.UTF-8):      Moduły języka Python dla biblioteki libxslt
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       python-libxml2 => %{libxml2ver}
110 %pyrequires_eq  python-modules
111 Obsoletes:      libxslt-python
112
113 %description -n python-%{name}
114 Python support for libxslt.
115
116 %description -n python-%{name} -l pl.UTF-8
117 Moduły języka Python dla biblioteki libxslt.
118
119 %prep
120 %setup -q
121 %patch0 -p0
122
123 %build
124 %{__libtoolize}
125 %{__aclocal}
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         --disable-silent-rules \
131         %{!?with_static_libs:--disable-static} \
132         --with-plugins \
133         %{!?with_python:--without-python}
134 %{__make}
135
136 %{?with_tests:%{__make} -C tests test}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 %if %{with python}
145 # move examples to proper dir
146 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
147 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}/examples/* \
148   $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
149 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}
150
151 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
152 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
153 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{py,la,a}
154 %endif
155
156 # packaged as %doc
157 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc AUTHORS ChangeLog Copyright FEATURES NEWS README TODO
168 %attr(755,root,root) %{_libdir}/libexslt.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libexslt.so.0
170 %attr(755,root,root) %{_libdir}/libxslt.so.*.*.*
171 %attr(755,root,root) %ghost %{_libdir}/libxslt.so.1
172 %dir %{_libdir}/libxslt-plugins
173
174 %files devel
175 %defattr(644,root,root,755)
176 %doc doc/{*.{gif,html},html}
177 %attr(755,root,root) %{_bindir}/xslt-config
178 %attr(755,root,root) %{_libdir}/libexslt.so
179 %attr(755,root,root) %{_libdir}/libxslt.so
180 %{_libdir}/libexslt.la
181 %{_libdir}/libxslt.la
182 %attr(755,root,root) %{_libdir}/xsltConf.sh
183 %{_includedir}/libexslt
184 %{_includedir}/libxslt
185 %{_pkgconfigdir}/libexslt.pc
186 %{_pkgconfigdir}/libxslt.pc
187 %{_aclocaldir}/libxslt.m4
188 %{_mandir}/man3/libexslt.3*
189 %{_mandir}/man3/libxslt.3*
190
191 %if %{with static_libs}
192 %files static
193 %defattr(644,root,root,755)
194 %{_libdir}/libexslt.a
195 %{_libdir}/libxslt.a
196 %endif
197
198 %files progs
199 %defattr(644,root,root,755)
200 %attr(755,root,root) %{_bindir}/xsltproc
201 %{_mandir}/man1/xsltproc.1*
202
203 %if %{with python}
204 %files -n python-%{name}
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{py_sitedir}/libxsltmod.so
207 %{py_sitedir}/libxslt.py[co]
208 %{_examplesdir}/python-%{name}-%{version}
209 %endif
This page took 0.090849 seconds and 3 git commands to generate.