]> git.pld-linux.org Git - packages/libxslt.git/blob - libxslt.spec
08bed8bb0e92b914dfcc67f4717761ce285b6a64
[packages/libxslt.git] / libxslt.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # Python binding
4 %bcond_without  static_libs     # static library
5 %bcond_with     tests           # test suite
6
7 %define         libxml2ver      1:2.6.30
8 Summary:        XSLT processor
9 Summary(pl.UTF-8):      Procesor XSLT
10 Summary(pt_BR.UTF-8):   Biblioteca que disponibiliza o sistema XSLT do GNOME
11 Name:           libxslt
12 Version:        1.1.36
13 Release:        1
14 License:        MIT
15 Group:          Libraries
16 #Source0:       ftp://xmlsoft.org/libxml2/%{name}-%{version}.tar.gz
17 Source0:        https://download.gnome.org/sources/libxslt/1.1/%{name}-%{version}.tar.xz
18 # Source0-md5:  ecf54ae636780d7983dd664b852e3212
19 Patch0:         %{name}-m4.patch
20 Patch1:         LFS.patch
21 Patch2:         %{name}-libs-no-libdir.patch
22 URL:            http://xmlsoft.org/XSLT/
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  automake >= 1:1.15
25 BuildRequires:  libgcrypt-devel >= 1.1.42
26 BuildRequires:  libtool >= 2:2.0
27 BuildRequires:  libxml2-devel >= %{libxml2ver}
28 BuildRequires:  perl-base
29 BuildRequires:  pkgconfig
30 %if %{with python}
31 BuildRequires:  python
32 BuildRequires:  python-devel
33 BuildRequires:  python-libxml2 >= %{libxml2ver}
34 %endif
35 BuildRequires:  rpm-build >= 4.6
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  sed >= 4.0
38 BuildRequires:  tar >= 1:1.22
39 BuildRequires:  xz
40 Requires:       libgcrypt >= 1.1.42
41 Requires:       libxml2 >= %{libxml2ver}
42 Obsoletes:      libxslt1
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Library for XSLT processing.
47
48 %description -l pl.UTF-8
49 Biblioteka do przetwarzania XSLT.
50
51 %description -l pt_BR.UTF-8
52 Esta biblioteca C permite a transformação de arquivos XML em outros
53 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
54 transformação dos estilos XSLT. O comando xsltproc é uma interface em
55 linha de comandos para o mecanismo XSLT.
56
57 %package devel
58 Summary:        Header files for libxslt
59 Summary(pl.UTF-8):      Pliki nagłówkowe libxslt
60 Summary(pt_BR.UTF-8):   Bibliotecas, includes, etc. para incluir o mecanismo XSLT do GNOME
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       libgcrypt-devel >= 1.1.42
64 Requires:       libxml2-devel >= %{libxml2ver}
65 Obsoletes:      libxslt1-devel
66
67 %description devel
68 Header files for libxslt - XSLT processor.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe procesora XSLT.
72
73 %description devel -l pt_BR.UTF-8
74 Esta biblioteca C permite a transformação de arquivos XML em outros
75 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
76 transformação dos estilos XSLT.
77
78 %package static
79 Summary:        Static libraries of libxslt
80 Summary(pl.UTF-8):      Biblioteki statyczne libxslt
81 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para incluir o mecanismo XSLT do GNOME
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static libraries of libxslt - XSLT processor.
87
88 %description static -l pl.UTF-8
89 Statyczne biblioteki procesora XSLT.
90
91 %description static -l pt_BR.UTF-8
92 Esta biblioteca C permite a transformação de arquivos XML em outros
93 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
94 transformação dos estilos XSLT. Estas são as bibliotecas em sua versão
95 estática.
96
97 %package apidocs
98 Summary:        API documentation for libxslt library
99 Summary(pl.UTF-8):      Dokumentacja API bibliotei libxslt
100 Group:          Documentation
101 BuildArch:      noarch
102
103 %description apidocs
104 API documentation for libxslt library.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API bibliotei libxslt.
108
109 %package progs
110 Summary:        XSLT processor
111 Summary(pl.UTF-8):      Procesor XSLT
112 Group:          Applications/Text
113 Requires:       %{name} = %{version}-%{release}
114 Obsoletes:      libxslt-proc
115
116 %description progs
117 XSLT processor.
118
119 %description progs -l pl.UTF-8
120 Procesor XSLT.
121
122 %package -n python-%{name}
123 Summary:        Python support for libxslt
124 Summary(pl.UTF-8):      Moduły języka Python dla biblioteki libxslt
125 Group:          Libraries/Python
126 Requires:       %{name} = %{version}-%{release}
127 Requires:       python-libxml2 => %{libxml2ver}
128 %pyrequires_eq  python-modules
129 Obsoletes:      libxslt-python
130
131 %description -n python-%{name}
132 Python support for libxslt.
133
134 %description -n python-%{name} -l pl.UTF-8
135 Moduły języka Python dla biblioteki libxslt.
136
137 %prep
138 %setup -q
139 %patch0 -p0
140 %patch1 -p1
141 %patch2 -p1
142
143 %{__sed} -i -e 's,\$(datadir)/gtk-doc/html,%{_gtkdocdir},' \
144         doc/devhelp/Makefile.am doc/EXSLT/devhelp/Makefile.am
145
146 %build
147 %{__libtoolize}
148 %{__aclocal}
149 %{__autoconf}
150 %{__autoheader}
151 %{__automake}
152 %configure \
153         ac_cv_header_xlocale_h=no \
154         --disable-silent-rules \
155         %{?with_static_libs:--enable-static} \
156         --with-html-subdir=libxslt \
157         --with-plugins \
158         %{!?with_python:--without-python}
159 %{__make}
160
161 %{?with_tests:%{__make} -C tests test}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 # junk (files to configure libxslt itself, not cmake export files)
170 %{__rm} $RPM_BUILD_ROOT%{_libdir}/cmake/libxslt/{FindGcrypt,libxslt-config}.cmake
171
172 %if %{with python}
173 # move examples to proper dir
174 install -d $RPM_BUILD_ROOT%{_examplesdir}
175 %{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}/python/examples \
176         $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
177 rmdir $RPM_BUILD_ROOT%{_docdir}/%{name}/python
178
179 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
180 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
181 %py_postclean
182 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
183 %if %{with static_libs}
184 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.a
185 %endif
186 %endif
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %post   -p /sbin/ldconfig
192 %postun -p /sbin/ldconfig
193
194 %files
195 %defattr(644,root,root,755)
196 %doc AUTHORS Copyright FEATURES NEWS README TODO
197 %attr(755,root,root) %{_libdir}/libexslt.so.*.*.*
198 %attr(755,root,root) %ghost %{_libdir}/libexslt.so.0
199 %attr(755,root,root) %{_libdir}/libxslt.so.*.*.*
200 %attr(755,root,root) %ghost %{_libdir}/libxslt.so.1
201 %dir %{_libdir}/libxslt-plugins
202
203 %files devel
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_bindir}/xslt-config
206 %attr(755,root,root) %{_libdir}/libexslt.so
207 %attr(755,root,root) %{_libdir}/libxslt.so
208 %{_libdir}/libexslt.la
209 %{_libdir}/libxslt.la
210 %attr(755,root,root) %{_libdir}/xsltConf.sh
211 %{_includedir}/libexslt
212 %{_includedir}/libxslt
213 %{_pkgconfigdir}/libexslt.pc
214 %{_pkgconfigdir}/libxslt.pc
215 %{_aclocaldir}/libxslt.m4
216 %{_mandir}/man3/libexslt.3*
217 %{_mandir}/man3/libxslt.3*
218
219 %if %{with static_libs}
220 %files static
221 %defattr(644,root,root,755)
222 %{_libdir}/libexslt.a
223 %{_libdir}/libxslt.a
224 %endif
225
226 %files apidocs
227 %defattr(644,root,root,755)
228 %{_docdir}/libxslt
229 %{_gtkdocdir}/libexslt
230 %{_gtkdocdir}/libxslt
231
232 %files progs
233 %defattr(644,root,root,755)
234 %attr(755,root,root) %{_bindir}/xsltproc
235 %{_mandir}/man1/xsltproc.1*
236
237 %if %{with python}
238 %files -n python-%{name}
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{py_sitedir}/libxsltmod.so
241 %{py_sitescriptdir}/libxslt.py[co]
242 %{_examplesdir}/python-%{name}-%{version}
243 %endif
This page took 0.107818 seconds and 2 git commands to generate.