]> git.pld-linux.org Git - packages/libxslt.git/blob - libxslt.spec
04e5224f1bab035733a372259112b47b5ed2e2fe
[packages/libxslt.git] / libxslt.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # don't build python binding
4 %bcond_without  static_libs     # don't build static library
5 %bcond_with     tests           # run test suite
6
7 %define         libxml2ver      1:2.6.30
8 Summary:        XSLT processor
9 Summary(pl.UTF-8):      Procesor XSLT
10 Summary(pt_BR.UTF-8):   Biblioteca que disponibiliza o sistema XSLT do GNOME
11 Name:           libxslt
12 Version:        1.1.29
13 Release:        2
14 License:        MIT
15 Group:          Libraries
16 #Source0:       http://ftp.gnome.org/pub/GNOME/sources/libxslt/1.1/%{name}-%{version}.tar.bz2
17 Source0:        ftp://xmlsoft.org/libxml2/%{name}-%{version}.tar.gz
18 # Source0-md5:  a129d3c44c022de3b9dcf6d6f288d72e
19 Patch0:         %{name}-m4.patch
20 Patch1:         LFS.patch
21 Patch2:         %{name}-libs-no-libdir.patch
22 URL:            http://xmlsoft.org/XSLT/
23 BuildRequires:  autoconf >= 2.59
24 BuildRequires:  automake
25 BuildRequires:  libgcrypt-devel >= 1.1.42
26 BuildRequires:  libtool >= 2:2.0
27 BuildRequires:  libxml2-devel >= %{libxml2ver}
28 BuildRequires:  perl-base
29 %if %{with python}
30 BuildRequires:  python
31 BuildRequires:  python-devel
32 BuildRequires:  python-libxml2 >= %{libxml2ver}
33 %endif
34 BuildRequires:  rpm-pythonprov
35 Requires:       libgcrypt >= 1.1.42
36 Requires:       libxml2 >= %{libxml2ver}
37 Obsoletes:      libxslt1
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Library for XSLT processing.
42
43 %description -l pl.UTF-8
44 Biblioteka do przetwarzania XSLT.
45
46 %description -l pt_BR.UTF-8
47 Esta biblioteca C permite a transformação de arquivos XML em outros
48 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
49 transformação dos estilos XSLT. O comando xsltproc é uma interface em
50 linha de comandos para o mecanismo XSLT.
51
52 %package devel
53 Summary:        Header files for libxslt
54 Summary(pl.UTF-8):      Pliki nagłówkowe libxslt
55 Summary(pt_BR.UTF-8):   Bibliotecas, includes, etc. para incluir o mecanismo XSLT do GNOME
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       libgcrypt-devel >= 1.1.42
59 Requires:       libxml2-devel >= %{libxml2ver}
60 Obsoletes:      libxslt1-devel
61
62 %description devel
63 Header files for libxslt - XSLT processor.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe procesora XSLT.
67
68 %description devel -l pt_BR.UTF-8
69 Esta biblioteca C permite a transformação de arquivos XML em outros
70 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
71 transformação dos estilos XSLT.
72
73 %package static
74 Summary:        Static libraries of libxslt
75 Summary(pl.UTF-8):      Biblioteki statyczne libxslt
76 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para incluir o mecanismo XSLT do GNOME
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static libraries of libxslt - XSLT processor.
82
83 %description static -l pl.UTF-8
84 Statyczne biblioteki procesora XSLT.
85
86 %description static -l pt_BR.UTF-8
87 Esta biblioteca C permite a transformação de arquivos XML em outros
88 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
89 transformação dos estilos XSLT. Estas são as bibliotecas em sua versão
90 estática.
91
92 %package progs
93 Summary:        XSLT processor
94 Summary(pl.UTF-8):      Procesor XSLT
95 Group:          Applications/Text
96 Requires:       %{name} = %{version}-%{release}
97 Obsoletes:      libxslt-proc
98
99 %description progs
100 XSLT processor.
101
102 %description progs -l pl.UTF-8
103 Procesor XSLT.
104
105 %package -n python-%{name}
106 Summary:        Python support for libxslt
107 Summary(pl.UTF-8):      Moduły języka Python dla biblioteki libxslt
108 Group:          Libraries/Python
109 Requires:       %{name} = %{version}-%{release}
110 Requires:       python-libxml2 => %{libxml2ver}
111 %pyrequires_eq  python-modules
112 Obsoletes:      libxslt-python
113
114 %description -n python-%{name}
115 Python support for libxslt.
116
117 %description -n python-%{name} -l pl.UTF-8
118 Moduły języka Python dla biblioteki libxslt.
119
120 %prep
121 %setup -q
122 %patch0 -p0
123 %patch1 -p1
124 %patch2 -p1
125
126 %build
127 %{__libtoolize}
128 %{__aclocal}
129 %{__autoconf}
130 %{__autoheader}
131 %{__automake}
132 %configure \
133         --disable-silent-rules \
134         %{!?with_static_libs:--disable-static} \
135         --with-plugins \
136         %{!?with_python:--without-python}
137 %{__make}
138
139 %{?with_tests:%{__make} -C tests test}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %if %{with python}
148 # move examples to proper dir
149 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
150 %{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}/examples/* \
151         $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
152 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}
153
154 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
155 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
156 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.{py,la,a}
157 %endif
158
159 # packaged as %doc
160 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %post   -p /sbin/ldconfig
166 %postun -p /sbin/ldconfig
167
168 %files
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog Copyright FEATURES NEWS README TODO
171 %attr(755,root,root) %{_libdir}/libexslt.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libexslt.so.0
173 %attr(755,root,root) %{_libdir}/libxslt.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libxslt.so.1
175 %dir %{_libdir}/libxslt-plugins
176
177 %files devel
178 %defattr(644,root,root,755)
179 %doc doc/{*.{gif,html},html}
180 %attr(755,root,root) %{_bindir}/xslt-config
181 %attr(755,root,root) %{_libdir}/libexslt.so
182 %attr(755,root,root) %{_libdir}/libxslt.so
183 %{_libdir}/libexslt.la
184 %{_libdir}/libxslt.la
185 %attr(755,root,root) %{_libdir}/xsltConf.sh
186 %{_includedir}/libexslt
187 %{_includedir}/libxslt
188 %{_pkgconfigdir}/libexslt.pc
189 %{_pkgconfigdir}/libxslt.pc
190 %{_aclocaldir}/libxslt.m4
191 %{_mandir}/man3/libexslt.3*
192 %{_mandir}/man3/libxslt.3*
193
194 %if %{with static_libs}
195 %files static
196 %defattr(644,root,root,755)
197 %{_libdir}/libexslt.a
198 %{_libdir}/libxslt.a
199 %endif
200
201 %files progs
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_bindir}/xsltproc
204 %{_mandir}/man1/xsltproc.1*
205
206 %if %{with python}
207 %files -n python-%{name}
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{py_sitedir}/libxsltmod.so
210 %{py_sitedir}/libxslt.py[co]
211 %{_examplesdir}/python-%{name}-%{version}
212 %endif
This page took 0.092597 seconds and 2 git commands to generate.