]> git.pld-linux.org Git - packages/libxml++5.git/blob - libxml++5.spec
- updated to 5.0.0 as libxml++5 (C++17 based, glibmm-free)
[packages/libxml++5.git] / libxml++5.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        C++ interface for working with XML files
6 Summary(pl.UTF-8):      Interfejs C++ do pracy z plikami XML
7 Name:           libxml++5
8 Version:        5.0.0
9 Release:        1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        https://download.gnome.org/sources/libxml++/5.0/libxml++-%{version}.tar.xz
13 # Source0-md5:  4153c04b2215696e8fb3cc1ae9ccdfdf
14 URL:            http://libxmlplusplus.sourceforge.net/
15 BuildRequires:  autoconf >= 2.59
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  doxygen >= 1:1.8.9
18 BuildRequires:  libstdc++-devel >= 6:7
19 BuildRequires:  libtool >= 2:2.2.6
20 BuildRequires:  libxml2-devel >= 1:2.7.7
21 BuildRequires:  mm-common >= 0.9.10
22 BuildRequires:  pkgconfig
23 BuildRequires:  rpmbuild(macros) >= 1.752
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 Requires:       libxml2 >= 1:2.7.7
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 libxml++ is a C++ interface for the libxml XML parser library.
31
32 %description -l pl.UTF-8
33 libxml++ jest interfejsem C++ do biblioteki libxml.
34
35 %package devel
36 Summary:        Header files for libxml++
37 Summary(pl.UTF-8):      Pliki nagłówkowe do libxml++
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       libstdc++-devel >= 6:7
41 Requires:       libxml2-devel >= 1:2.7.7
42
43 %description devel
44 Header files for libxml++.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe do libxml++.
48
49 %package static
50 Summary:        Static libxml++ libraries
51 Summary(pl.UTF-8):      Biblioteka statyczna libxml++
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static libxml++ libraries.
57
58 %description static -l pl.UTF-8
59 Biblioteka statyczna libxml++.
60
61 %package apidocs
62 Summary:        libxml++ API documentation
63 Summary(pl.UTF-8):      Dokumentacja API libxml++
64 Group:          Documentation
65 %{?noarchpackage}
66
67 %description apidocs
68 libxml++ API documentation.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API libxml++.
72
73 %package examples
74 Summary:        libxml++ - example programs
75 Summary(pl.UTF-8):      libxml++ - przykładowe programy
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description examples
80 libxml++ - example programs.
81
82 %description examples -l pl.UTF-8
83 libxml++ - przykładowe programy.
84
85 %prep
86 %setup -q -n libxml++-%{version}
87
88 %build
89 mm-common-prepare --copy --force
90 %{__libtoolize}
91 %{__aclocal} -I build
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         %{?with_static_libs:--enable-static} \
97         --disable-silent-rules
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
108
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libxml++-5.0.la
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS README
120 %attr(755,root,root) %{_libdir}/libxml++-5.0.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libxml++-5.0.so.1
122
123 %files devel
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/libxml++-5.0.so
126 %{_libdir}/libxml++-5.0
127 %{_includedir}/libxml++-5.0
128 %{_pkgconfigdir}/libxml++-5.0.pc
129
130 %if %{with static_libs}
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libxml++-5.0.a
134 %endif
135
136 %files apidocs
137 %defattr(644,root,root,755)
138 %{_datadir}/devhelp/books/libxml++-5.0
139 %{_docdir}/libxml++-5.0
140
141 %files examples
142 %defattr(644,root,root,755)
143 %{_examplesdir}/%{name}-%{version}
This page took 0.037678 seconds and 4 git commands to generate.