]> git.pld-linux.org Git - packages/libwpe.git/blob - libwpe.spec
- build apidocs
[packages/libwpe.git] / libwpe.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4
5 Summary:        General-purpose library for the WPE-flavored port of WebKit
6 Summary(pl.UTF-8):      Ogólna biblioteka do portu WPE biblioteki WebKit
7 Name:           libwpe
8 Version:        1.10.1
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/WebPlatformForEmbedded/libwpe/releases
13 Source0:        https://github.com/WebPlatformForEmbedded/libwpe/releases/download/%{version}/%{name}-%{version}.tar.xz
14 # Source0-md5:  f60fc13b519a66d262afb76c77441870
15 Patch0:         %{name}-libdir.patch
16 URL:            https://wpewebkit.org/
17 BuildRequires:  EGL-devel
18 BuildRequires:  cmake >= 3.0
19 %{?with_apidocs:BuildRequires:  hotdoc}
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  rpmbuild(macros) >= 1.605
22 BuildRequires:  xorg-lib-libxkbcommon-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 General-purpose library developed for the WPE-flavored port of WebKit.
27
28 %description -l pl.UTF-8
29 Ogólna biblioteka do portu WPE biblioteki WebKit.
30
31 %package devel
32 Summary:        Header files for WPE library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki WPE
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       EGL-devel
37 Requires:       xorg-lib-libxkbcommon-devel
38
39 %description devel
40 Header files for WPE library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki WPE.
44
45 %package apidocs
46 Summary:        API documentation for WPE library
47 Summary(pl.UTF-8):      Dokumentacja API biblioteki WPE
48 Group:          Documentation
49
50 %description apidocs
51 API documentation for WPE library.
52
53 %description apidocs -l pl.UTF-8
54 Dokumentacja API biblioteki WPE.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59
60 %build
61 install -d build
62 cd build
63 %cmake .. \
64         %{?with_apidocs:-DBUILD_DOCS=ON}
65
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} -C build install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc COPYING NEWS
83 %attr(755,root,root) %{_libdir}/libwpe-1.0.so.*.*.*
84 %attr(755,root,root) %ghost %{_libdir}/libwpe-1.0.so.1
85
86 %files devel
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_libdir}/libwpe-1.0.so
89 %{_includedir}/wpe-1.0
90 %{_pkgconfigdir}/wpe-1.0.pc
91
92 %if %{with apidocs}
93 %files apidocs
94 %defattr(644,root,root,755)
95 %doc build/Documentation/html/*
96 %endif
This page took 0.156508 seconds and 3 git commands to generate.